commops
MINUTES

#fedora-meeting: Fedora CommOps (2016-08-16)

Meeting started by jflory7 at 15:59:03 UTC (full logs).

Meeting summary

  1. Agenda (jflory7, 15:59:16)
    1. https://fedoraproject.org/wiki/Meeting:CommOps_2016-08-16 (jflory7, 15:59:23)
    2. (1) Roll Call / Q&A (jflory7, 15:59:28)
    3. (2) Announcements (jflory7, 15:59:38)
    4. (3) Action items from last meeting (jflory7, 15:59:43)
    5. (4) Tickets (jflory7, 15:59:50)
    6. (5) Wiki Gardening (jflory7, 15:59:55)
    7. (6) Community Blog (jflory7, 16:00:02)
    8. (7) Release Schedule (jflory7, 16:00:07)
    9. (8) Open Floor (jflory7, 16:00:12)

  2. Roll Call / Q&A (jflory7, 16:00:23)
    1. Name; Timezone; Sub-projects/Interest Areas (jflory7, 16:00:24)
    2. Justin W. Flory; UTC-4; CommOps, Marketing / Magazine, Ambassadors, Diversity Team, and more (jflory7, 16:00:44)
    3. Sachin S. Kamath ; UTC +5.30; GSoC, CommOps, Metrics, etc (skamath, 16:01:09)
    4. Michael Downey; UTC -7:00; GSoC, commops, marketing, diversity, you-name-it (downey, 16:02:04)
    5. Huiren Woo; UTC+8; CommOps, Ambassadors, Marketing (GIANT_CRAB, 16:02:08)
    6. Trishna Guha; UTC +5:30; Cloud, CommOps, Infrastructure (trishnag, 16:04:57)
    7. Tummala Dhanvi; UTC +5.30; CommOps, docs, security, * (c0mrad3, 16:07:24)
    8. Dhanesh B. Sabane, UTC +5:30, CommOps, ML, Kernel, RPM Packaging (dhanesh95, 16:07:28)

  3. Announcements (jflory7, 16:08:29)
    1. === New metrics brainstorming wiki page === (jflory7, 16:08:35)
    2. https://fedoraproject.org/wiki/CommOps/Metrics_Ideas (jflory7, 16:08:40)
    3. bee2502 has started working on generating some ideas on community metric generation. Check out the wiki page with more information on metric collection with regards to discussion at the CommOps Flock workshop there. (jflory7, 16:08:47)
    4. HELP: Feel free to add some of your own ideas, thoughts, or wishes for metrics to this page too! (jflory7, 16:09:01)
    5. === "Docs Project update from Flock 2016" === (jflory7, 16:09:07)
    6. https://communityblog.fedoraproject.org/docs-project-update-flock-2016/ (jflory7, 16:09:14)
    7. On jflory7's "must read list of 2016" - very informative post about the state of the Fedora Docs team and adds a lot of insight into the issues they are facing and how they plan to overcome them. If you haven't been following the Docs team and want to see what's up in a single post, this is a good one to read. (jflory7, 16:09:24)
    8. === "Women in technology: Fedora campus presence" === (jflory7, 16:09:34)
    9. https://communityblog.fedoraproject.org/women-technology-fedora-campus-presence/ (jflory7, 16:09:39)
    10. Outreach efforts towards women are ongoing in local Indian communities. Read this brief report to see what is getting started by a2batic and sumantrom. (jflory7, 16:09:47)
    11. === "Żegnajcie! Fedora Flock 2016 in words" === (jflory7, 16:10:24)
    12. https://blog.justinwflory.com/2016/08/fedora-flock-2016/ (jflory7, 16:10:24)
    13. jflory7's event report on Flock 2016. There's a section dedicated to the Fedora CommOps workshop and feedback related to the workshop. It may be worth a read for anyone interested in the workshop and what kinds of results we got out of holding it. (jflory7, 16:10:34)
    14. Sayan Chowdhury;UTC+5:30; Infrastructure, Cloud, CommOps, Marketing, Ambassadors etc. (sayan, 16:11:12)
    15. https://pagure.io/fedora-diversity/issue/12 (skamath, 16:14:44)

  4. Action items from last meeting (jflory7, 16:15:28)
    1. https://meetbot.fedoraproject.org/fedora-meeting/2016-08-09/commops.2016-08-09-16.02.html (jflory7, 16:15:34)
    2. How This Works: We look at past #action items from the last meeting for quick follow-up. If a task is completed, we move on to the next one. If it isn't, we get an update and re-action it if needed. If no status, we'll try to get a quick update and move forward. (jflory7, 16:15:43)
    3. === [INCOMPLETE] jflory7 Write a promo on the CommBlog about the ultimate women's Fedora t-shirt === (jflory7, 16:17:22)
    4. ACTION: downey Edit original UnixStickers shirt article to include links / mentions of the women's sizes / editions too (jflory7, 16:17:46)
    5. === [INCOMPLETE] skamath file a ticket on fedmsg repo for the mailman bug === (jflory7, 16:17:59)
    6. ACTION: skamath file a ticket on fedmsg repo for the mailman bug (jflory7, 16:18:04)
    7. === [IN PROGRESS] jflory7 Work with bee2502 on writing a report / update on the Flock 2016 CommOps workshop === (jflory7, 16:18:10)
    8. ACTION: jflory7 Work with bee2502 on writing a report / update on the Flock 2016 CommOps workshop (jflory7, 16:18:21)
    9. jflory7 and bee2502 did some parsing of info on Saturday from the workshop, but there's still a little more to do - jflory7 needs to start a draft in the CommBlog next (jflory7, 16:18:27)
    10. === [IN PROGRESS] jflory7 Review emails for pending posts on the CommBlog === (jflory7, 16:18:34)
    11. ACTION: jflory7 Review emails for pending posts on the CommBlog (jflory7, 16:18:40)
    12. This is getting done every week, but there's a consistent amount of more coming in each week for new posts and authors, which is awesome. :) (jflory7, 16:18:49)
    13. === [IN PROGRESS] jflory7 bee2502 Take workshop feedback and parse it into more accessible data (e.g. tickets / commits / CommBlog posts / metrics / etc.) === (jflory7, 16:18:59)
    14. ACTION: jflory7 bee2502 Take workshop feedback and parse it into more accessible data (e.g. tickets / commits / CommBlog posts / metrics / etc.) (jflory7, 16:19:09)
    15. jflory7 and bee2502 did some parsing of info on Saturday from the workshop, but there's still a little more to do - jflory7 needs to start a draft in the CommBlog next (jflory7, 16:19:15)
    16. === [INCOMPLETE] jflory7 File tickets for Python SIG, add feedback for Ambassadors from workshop === (jflory7, 16:19:27)
    17. ACTION: jflory7 File tickets for Python SIG, add feedback for Ambassadors from workshop (jflory7, 16:19:39)
    18. === [COMPLETE] jflory7 Close ticket#80 === (jflory7, 16:19:45)
    19. https://fedorahosted.org/fedora-commops/ticket/80 (jflory7, 16:20:30)
    20. === [COMPLETE] jflory7 Follow up with nardasev ASAP on whether this one is still good to publish post-Flock === (jflory7, 16:20:44)
    21. https://lists.fedoraproject.org/archives/list/commops@lists.fedoraproject.org/thread/ORM4TLBC562D6N6SDQNFFJAASV44E34V/ (jflory7, 16:20:51)
    22. === [INCOMPLETE] jflory7 Update guide for writing a new article based on what's actually happening in 2016 now === (jflory7, 16:20:58)
    23. ACTION: jflory7 Update guide for writing a new article based on what's actually happening in 2016 now (jflory7, 16:21:05)

  5. Tickets (jflory7, 16:22:06)
    1. https://fedorahosted.org/fedora-commops/report/9 (jflory7, 16:22:11)
    2. === Ticket #81 === (jflory7, 16:22:32)
    3. "Migrating to Pagure" (jflory7, 16:22:41)
    4. https://fedorahosted.org/fedora-commops/ticket/81 (jflory7, 16:22:45)
    5. It is now possible for us to migrate from Trac to Pagure (the importer tool was recently completed by cverna). A staging repo of what the import looks like exists on the Pagure staging instance. Since we now have the tooling, we should set a hard date for migrating the entire Trac over to Pagure and begin retiring it. Rough timeline detailed in ticket. (jflory7, 16:22:51)
    6. https://stg.pagure.io/stg-fedora-commops/issues (jflory7, 16:22:57)
    7. IDEA: Migration date: Mon, 2016 Aug 29? +1/0/-1? (jflory7, 16:23:03)
    8. AGREED: CommOps Trac will migrate to Pagure on 2016-08-29 - more details to come soon, watch mailing list for info (jflory7, 16:26:33)
    9. === Ticket #78 === (jflory7, 16:26:45)
    10. "Automating a check-in to evaluate activity of members" (jflory7, 16:26:51)
    11. https://fedorahosted.org/fedora-commops/ticket/78 (jflory7, 16:27:02)
    12. Two ways to do it: Infra-style with a manual post sent monthly, or could use Fedocal to automate this once a month as check-in calendar event to query members on regular, consistent basis. Non-responders would be removed from the FAS group hypothetically. Need to discuss implementation and if this is something we want to do. (jflory7, 16:27:07)
    13. IDEA: Would this be necessary for active members to also complete every month? Is it better to separate into two "groups" - apprentices and regular members? (jflory7, 16:27:13)
    14. IDEA: Blatantly removing people is the wrong approach: it will be demotivating and isolate people from wanting to contribute (jflory7, 16:35:26)
    15. IDEA: If any kind of consistent follow-up is to be done, it really should be automated so it will always be consistent (jflory7, 16:35:43)
    16. IDEA: Start in a beginner group, then move to an "alumni" group for contributors who are consistent and active (i.e. they no longer have to do the regular check-in) (jflory7, 16:36:21)
    17. IDEA: A single ping is easy to miss and it could cause someone still interested to be left out (jflory7, 16:36:37)
    18. IDEA: Responding to one email may not be the best gauge of activity / contributions, so makes it difficult to use as a tool to evaluate merits (jflory7, 16:37:06)
    19. IDEA: Every team could have "three big things" an active person does, follow up on them around a 3-month interval, judge inactivity on those criteria (jflory7, 16:37:56)
    20. IDEA: Automated tools don't flag some for removal, but just review / follow-up (jflory7, 16:38:22)
    21. IDEA: Instead of removing contributors, "retire" them - could de-provision by removing from group, but note them somewhere along with their contributions, kind of like a wall of fame sort of idea (jflory7, 16:40:24)
    22. https://gist.github.com/robbyoconnor/376099ee735985fede7e6c14e072db7c (jflory7, 16:40:29)
    23. ACTION: jflory7 Sort through ideas on reviewing old contributor discussion, form proposals in the ticket, share at next meeting (jflory7, 16:42:03)
    24. AGREED: Lots of ideas and discussion on this ticket - jflory7 will sort through these ideas, try turning them into separate proposals, and then we can vote on them at the next meeting (jflory7, 16:42:39)
    25. === Ticket #10 === (jflory7, 16:44:09)
    26. "CommOps vFAD 2016" (jflory7, 16:44:15)
    27. https://fedorahosted.org/fedora-commops/ticket/10 (jflory7, 16:44:19)
    28. Based on Flock outcome, likely reasonable to begin planning out our own FAD event. Can opt for an in-person FAD at first, and if necessary, fall back to virtual event. Would be held in 2017 (after February / March when budget for next fiscal year allocated). First steps would be for defining purpose and matching up to outcomes and results that align with Fedora mission. We can start now by using mattdm's logic model template and (jflory7, 16:44:26)
    29. ...identifying key areas for us to focus on as team. (jflory7, 16:44:36)
    30. https://pagure.io/FedoraLogicModelTemplate (jflory7, 16:44:41)
    31. ACTION: jflory7 Remove Ticket #10 from meeting agenda, collaborate with bee2502 on sorting through feedback / ideas from Flock (jflory7, 16:47:28)
    32. === Ticket #70 === (jflory7, 16:49:39)
    33. "FOSS Student Pack" (jflory7, 16:49:45)
    34. https://fedorahosted.org/fedora-commops/ticket/70 (jflory7, 16:49:50)
    35. Key thing to get out of this is less on physical / costly items, more on providing resources / tools to point people towards contributing to open source and subsequently Fedora, e.g. IRC client, bouncer service, development tools, software in Fedora, etc.) (jflory7, 16:49:56)
    36. IDEA: Key to the gate: FAS account (guide to register and what a FAS account gives you access to) (jflory7, 16:50:55)
    37. IDEA: Java IDE: Eclipse (jflory7, 16:51:00)
    38. IDEA: IRC client: HexChat (IRC beginner guide, how to use HexChat, etc.) (jflory7, 16:51:07)
    39. IDEA: Photo editing: DarkTable (what it does, guides for using it, etc.) (jflory7, 16:51:14)
    40. IDEA: Creating Fedora USB media: Whatever the preferred tool now is for creating media correctly and with stability (Fedora Media Writer?) (jflory7, 16:51:20)
    41. IDEA: IRCCloud temporary membership / full account as part of the starter pack? [Warning: This would be a relationship we would have to actively maintain] (jflory7, 16:54:55)
    42. IDEA: Starting small by identifying the "Fedora Essentials 101" for what a student would need for Linux / FOSS (jflory7, 16:58:22)
    43. HELP: What tool helped you get started with Linux and FOSS? What made Fedora so great for you? What could we offer students to help introduce to FOSS, Linux, and then Fedora? Please add your ideas and thoughts to the ticket so we can start building a first edition of the pack! (jflory7, 17:01:18)
    44. === Tickets #34 === (jflory7, 17:02:58)
    45. #34: "[Onboarding Series] [MASTER TICKET] Creating sub-project on-boarding badge series" (jflory7, 17:03:13)
    46. https://fedorahosted.org/fedora-commops/ticket/34 (jflory7, 17:03:18)
    47. Infrastructure ticket put on hold while current blocking issues are resolved. More detail in the ticket. For now, we need to decide and focus on a new sub-project / team to focus on. jflory7 would like to propose the Python SIG as a team that is in need of some assistance and help. Having difficulties on-boarding new members effectively. Need to find ways for communicating this better and how to make it simpler for getting involved. See (jflory7, 17:03:25)
    48. ...rough notes for Flock as a primer on this one. (jflory7, 17:03:33)
    49. https://etherpad.gnome.org/p/flock-2016-commops-workshop (jflory7, 17:03:39)
    50. IDEA: Target focusing on Python SIG as next team to assist? +1/0/-1? (jflory7, 17:05:01)
    51. AGREED: Will focus on Python SIG next for helping with on-boarding process - jflory7 to file the ticket for them soon (jflory7, 17:08:05)

  6. Wiki Gardening (jflory7, 17:08:50)
    1. ACTION: commops New members, make sure you add your timezone / interests on CommOps wiki [ https://fedoraproject.org/wiki/CommOps ] (jflory7, 17:08:56)

  7. Community Blog (jflory7, 17:12:12)
    1. How This Works: There is a quick blast of information about what was published in the past week with some metrics, followed by posts that are being drafted. After the information blast, the floor is opened for any Community Blog-related discussion. Here we go! (jflory7, 17:12:23)
    2. === This Week in CommBlog === (jflory7, 17:15:26)
    3. (1) "Women in technology: Fedora campus presence" (jflory7, 17:15:32)
    4. https://communityblog.fedoraproject.org/women-technology-fedora-campus-presence/ (jflory7, 17:15:39)
    5. Total Views (Aug. 12 - Aug. 16): 178 (jflory7, 17:15:45)
    6. https://communityblog.fedoraproject.org/wp-admin/admin.php?page=stats&view=post&post=2039 (jflory7, 17:15:50)
    7. (2) "Heroes of Fedora 23 bonus: Test Days" (jflory7, 17:15:57)
    8. https://communityblog.fedoraproject.org/heroes-fedora-23-bonus-test-days/ (jflory7, 17:16:05)
    9. Total Views (Aug. 14 - Aug. 16): 30 (jflory7, 17:16:12)
    10. https://communityblog.fedoraproject.org/wp-admin/admin.php?page=stats&view=post&post=2070 (jflory7, 17:16:17)
    11. (3) "Docs Project update from Flock 2016" (jflory7, 17:16:29)
    12. https://communityblog.fedoraproject.org/docs-project-update-flock-2016/ (jflory7, 17:16:35)
    13. Total Views (Aug. 15 - Aug. 16): 138 (jflory7, 17:16:54)
    14. https://communityblog.fedoraproject.org/wp-admin/admin.php?page=stats&view=post&post=2082 (jflory7, 17:17:04)
    15. === Coming Up in CommBlog === (jflory7, 17:17:10)
    16. (1) "FOSS wave: Bhopal, Madhya Pradesh, India" (scheduled: 2016-08-18, 8:15 UTC) (jflory7, 17:17:20)
    17. https://communityblog.fedoraproject.org/?p=2096&preview=1&_ppp=2944783363 (jflory7, 17:17:26)
    18. (2) "List of Flock blogs and more" (jflory7, 17:17:32)
    19. https://communityblog.fedoraproject.org/?p=2185&preview=1&_ppp=37e727fbf1 (jflory7, 17:17:38)
    20. Ready to publish, but pending feedback from cwickert for final review (jflory7, 17:18:16)
    21. (3) "Heroes of Fedora (HoF) - F24 Alpha" (jflory7, 17:18:27)
    22. https://communityblog.fedoraproject.org/?p=2091&preview=1&_ppp=38236c1722 (jflory7, 17:18:33)
    23. (4) "Heroes of Fedora (HoF) – F24 Beta" (jflory7, 17:18:38)
    24. https://communityblog.fedoraproject.org/?p=2142&preview=true (jflory7, 17:18:45)
    25. (5) "FOSS Wave Delhi , IN" (jflory7, 17:18:54)
    26. https://communityblog.fedoraproject.org/?p=2145&preview=1&_ppp=6f751ef7ee (jflory7, 17:19:00)
    27. (6) "Onboarding Kickoff - Fedora QA, Bhopal" (jflory7, 17:19:07)
    28. https://communityblog.fedoraproject.org/?p=2188&preview=1&_ppp=3836cca259 (jflory7, 17:19:13)
    29. (7) "Heroes of Fedora (HoF) - Fedora 24 Final" (jflory7, 17:19:19)
    30. https://communityblog.fedoraproject.org/?p=2184&preview=1&_ppp=a7f8ba6bd1 (jflory7, 17:19:26)
    31. (8) "Python 3 porting: 50% done in Rawhide" (jflory7, 17:19:31)
    32. https://communityblog.fedoraproject.org/?p=2141&preview=1&_ppp=dff4da09a5 (jflory7, 17:19:38)
    33. (9) "Event Report: WWFS-FWD'2016, Kolkata" (jflory7, 17:19:48)
    34. https://communityblog.fedoraproject.org/?p=2046&preview=1&_ppp=e00cffc625 (jflory7, 17:19:54)
    35. (10) "Fedora 24 Release Party in Singapore!" (jflory7, 17:19:59)
    36. https://communityblog.fedoraproject.org/?p=2010&preview=1&_ppp=3eef8bef67 (jflory7, 17:20:05)
    37. (11) "Modularity Infrastructure Design" (jflory7, 17:20:13)
    38. https://communityblog.fedoraproject.org/?p=2154&preview=1&_ppp=9d83efdef2 (jflory7, 17:20:18)

  8. Open Floor (jflory7, 17:23:16)


Meeting ended at 17:30:47 UTC (full logs).

Action items

  1. downey Edit original UnixStickers shirt article to include links / mentions of the women's sizes / editions too
  2. skamath file a ticket on fedmsg repo for the mailman bug
  3. jflory7 Work with bee2502 on writing a report / update on the Flock 2016 CommOps workshop
  4. jflory7 Review emails for pending posts on the CommBlog
  5. jflory7 bee2502 Take workshop feedback and parse it into more accessible data (e.g. tickets / commits / CommBlog posts / metrics / etc.)
  6. jflory7 File tickets for Python SIG, add feedback for Ambassadors from workshop
  7. jflory7 Update guide for writing a new article based on what's actually happening in 2016 now
  8. jflory7 Sort through ideas on reviewing old contributor discussion, form proposals in the ticket, share at next meeting
  9. jflory7 Remove Ticket #10 from meeting agenda, collaborate with bee2502 on sorting through feedback / ideas from Flock
  10. commops New members, make sure you add your timezone / interests on CommOps wiki [ https://fedoraproject.org/wiki/CommOps ]


Action items, by person

  1. commops
    1. commops New members, make sure you add your timezone / interests on CommOps wiki [ https://fedoraproject.org/wiki/CommOps ]
  2. downey
    1. downey Edit original UnixStickers shirt article to include links / mentions of the women's sizes / editions too
  3. jflory7
    1. jflory7 Work with bee2502 on writing a report / update on the Flock 2016 CommOps workshop
    2. jflory7 Review emails for pending posts on the CommBlog
    3. jflory7 bee2502 Take workshop feedback and parse it into more accessible data (e.g. tickets / commits / CommBlog posts / metrics / etc.)
    4. jflory7 File tickets for Python SIG, add feedback for Ambassadors from workshop
    5. jflory7 Update guide for writing a new article based on what's actually happening in 2016 now
    6. jflory7 Sort through ideas on reviewing old contributor discussion, form proposals in the ticket, share at next meeting
    7. jflory7 Remove Ticket #10 from meeting agenda, collaborate with bee2502 on sorting through feedback / ideas from Flock
  4. skamath
    1. skamath file a ticket on fedmsg repo for the mailman bug


People present (lines said)

  1. jflory7 (366)
  2. tatica (42)
  3. downey (38)
  4. zodbot (32)
  5. GIANT_CRAB (29)
  6. skamath (29)
  7. mailga (19)
  8. r0bby (10)
  9. dhanesh95 (7)
  10. trishnag (4)
  11. a2batic (4)
  12. sayan (4)
  13. c0mrad3 (2)
  14. misc (2)
  15. landim (1)
  16. commops (0)


Generated by MeetBot 0.1.4.