workstation
MINUTES

#fedora-meeting-2: Workstation WG (2020-10-27)

Meeting started by cmurf at 17:35:23 UTC (full logs).

Meeting summary

  1. Rollcall (cmurf, 17:35:54)
    1. present: mclasen, aday, mcatanzaro, kalev, otaylor, tpopela, jens, neal, langdon, cmurf (cmurf, 17:35:55)
    2. regrets wg members: (cmurf, 17:35:57)
    3. present guests: James (cmurf, 17:35:59)

  2. Approve 20 October minutes (cmurf, 17:36:01)
    1. https://meetbot.fedoraproject.org/fedora-meeting-2/2020-10-21/workstation.2020-10-21-15.18.log.html (cmurf, 17:36:03)
    2. Minutes are approved (cmurf, 17:36:05)

  3. Announcements (cmurf, 17:36:07)
    1. F33 release is 30 minutes away (cmurf, 17:36:09)
    2. aday wants to do F33 release retrospective discussion in future (cmurf, 17:36:11)
    3. US election next week, do we hold meeting as usual? Yes, most of us will be here. (cmurf, 17:36:13)

  4. Follow-ups and status reports (cmurf, 17:36:15)
  5. F34 planning (cmurf, 17:36:17)
    1. F34 milestone issues: https://pagure.io/fedora-workstation/issues?status=Open&milestone=Fedora+34 (cmurf, 17:36:19)
    2. Issues with no milestone: https://pagure.io/fedora-workstation/issues?status=Open&milestone=none&close_status= (cmurf, 17:36:21)
    3. WG examines the list of issues tagged for F34 (cmurf, 17:36:23)
    4. Neal discusses btrfs full-disk encryption, goal for F34 (cmurf, 17:36:25)
    5. Neal asks tpopela about progress on removing Chrome's dependency on atd. atd is already removed from F34 (fedora-workstation#183) (cmurf, 17:36:27)
    6. ACTION: tpopela to work with Chrome upstream to remove atd dependency. (cmurf, 17:36:29)
    7. Neal wants to rename fedora-workstation-repos package to something generic so it can be used in desktop spins. (cmurf, 17:36:31)
    8. Matthias asks about generic camera app, is it a wishlist or something that actually exists? aday and Neal reply that it already exists. (cmurf, 17:36:33)
    9. aday asks how to handle apps that currently depend on Cheese; this is something we need to think about. (cmurf, 17:36:35)
    10. Langdon asks what's wrong with Cheese? aday wants photo booth to be less kooky, fewer fun effects. (cmurf, 17:36:37)
    11. aday wants to make progress on fedora-workstation#105 (install fedora-workstation-repositories by default) and fedora-workstation#108 (filtered view of flathub) (cmurf, 17:36:39)
    12. topela asks about systemd-oomd, which will be included in systemd 247. Neal suggests that we stick with earlyoom for F34, unless systemd developers request otherwise. (cmurf, 17:36:41)
    13. WG examines the list of issues not tagged for F34 (cmurf, 17:36:43)
    14. Neal provides status update on fedora-workstation#161 (btrfs disk integration). Development work stalled (cmurf, 17:36:45)
    15. tpopela mentions H.264 support in Firefox (fedora-workstation#126). mstransky has been working on this. Neal says Firefox 81 should use OpenH264 directly instead of via ffmpeg, so this should be fixed. Michael suggests we should test Firefox and confirm it actually works before closing the issue. (cmurf, 17:36:47)
    16. Neal discusses automatically installing OpenH264 (fedora-workstation#84). This still needs more work (possibly in gnome-initial-setup) (cmurf, 17:36:49)
    17. WG discusses btrfs documentation for how to rescue corrupted filesystem (fedora-workstation#157). Neal says this is WIP. (cmurf, 17:36:51)
    18. Neal says btrfs upstream is also fixing btrfs dependency on system page size. (cmurf, 17:36:53)
    19. ABRT: Michael says status is not good, and probably not likely to improve. (cmurf, 17:36:55)
    20. Neal mentions debuginfod. Local retracing should no longer require installing debug RPMs anymore. ABRT developers are planning to work on this. (cmurf, 17:36:57)
    21. Michael proposes to move some btrfs issues to the btrfs tracker. (cmurf, 17:36:59)
    22. ACTION: Michael to move the issues (cmurf, 17:37:01)
    23. aday asks about fedora-workstation#125 (guidelines for preinstalled and nonremovable apps). (cmurf, 17:37:03)
    24. ACTION: aday to prepare guidelines. (cmurf, 17:37:05)
    25. Neal suggests we close fedora-workstation#124 (anaconda: no more hub). Michael closes the issue. (cmurf, 17:37:07)
    26. Neal asks do we replace PulseAudio with pipewire in F34? Kalev says that's a question for Wim. tpopela says Wim is planning on F35, not F34. Neal says Fedora Jam will use it in F34 anyway. (cmurf, 17:37:09)
    27. ACTION: Neal to discuss with Wim. (cmurf, 17:37:11)
    28. James mentions gnome-software downloading entire F33 runtime when installing dconf-editor is unexpected. (This is related to fedora-workstation#187.) (cmurf, 17:37:13)

  6. Open Floor (cmurf, 17:37:15)
    1. WG discusses timezones and DST. Remember meeting time is pinned to US Eastern time. (cmurf, 17:37:17)


Meeting ended at 17:37:30 UTC (full logs).

Action items

  1. tpopela to work with Chrome upstream to remove atd dependency.
  2. Michael to move the issues
  3. aday to prepare guidelines.
  4. Neal to discuss with Wim.


Action items, by person

  1. aday
    1. aday to prepare guidelines.
  2. UNASSIGNED
    1. tpopela to work with Chrome upstream to remove atd dependency.
    2. Michael to move the issues
    3. Neal to discuss with Wim.


People present (lines said)

  1. cmurf (47)
  2. zodbot (7)
  3. aday (0)


Generated by MeetBot 0.1.4.