workstation
LOGS
17:35:23 <cmurf> #startmeeting Workstation WG (2020-10-27)
17:35:23 <zodbot> Meeting started Wed Oct 28 17:35:23 2020 UTC.
17:35:23 <zodbot> This meeting is logged and archived in a public location.
17:35:23 <zodbot> The chair is cmurf. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:35:23 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
17:35:23 <zodbot> The meeting name has been set to 'workstation_wg_(2020-10-27)'
17:35:25 <cmurf> #meetingname workstation
17:35:25 <zodbot> The meeting name has been set to 'workstation'
17:35:27 <cmurf> #chair aday
17:35:27 <zodbot> Current chairs: aday cmurf
17:35:54 <cmurf> #topic Rollcall
17:35:55 <cmurf> #info present: mclasen, aday, mcatanzaro, kalev, otaylor, tpopela, jens, neal, langdon, cmurf
17:35:57 <cmurf> #info regrets wg members:
17:35:59 <cmurf> #info present guests: James
17:36:01 <cmurf> #topic Approve 20 October minutes
17:36:03 <cmurf> #link https://meetbot.fedoraproject.org/fedora-meeting-2/2020-10-21/workstation.2020-10-21-15.18.log.html
17:36:05 <cmurf> #info Minutes are approved
17:36:07 <cmurf> #topic Announcements
17:36:09 <cmurf> #info F33 release is 30 minutes away
17:36:11 <cmurf> #info aday wants to do F33 release retrospective discussion in future
17:36:13 <cmurf> #info US election next week, do we hold meeting as usual? Yes, most of us will be here.
17:36:15 <cmurf> #topic Follow-ups and status reports
17:36:17 <cmurf> #topic F34 planning
17:36:19 <cmurf> #link F34 milestone issues: https://pagure.io/fedora-workstation/issues?status=Open&milestone=Fedora+34
17:36:21 <cmurf> #link Issues with no milestone: https://pagure.io/fedora-workstation/issues?status=Open&milestone=none&close_status=
17:36:23 <cmurf> #info WG examines the list of issues tagged for F34
17:36:25 <cmurf> #info Neal discusses btrfs full-disk encryption, goal for F34
17:36:27 <cmurf> #info Neal asks tpopela about progress on removing Chrome's dependency on atd. atd is already removed from F34 (fedora-workstation#183)
17:36:29 <cmurf> #action tpopela to work with Chrome upstream to remove atd dependency.
17:36:31 <cmurf> #info Neal wants to rename fedora-workstation-repos package to something generic so it can be used in desktop spins.
17:36:33 <cmurf> #info Matthias asks about generic camera app, is it a wishlist or something that actually exists? aday and Neal reply that it already exists.
17:36:35 <cmurf> #info aday asks how to handle apps that currently depend on Cheese; this is something we need to think about.
17:36:37 <cmurf> #info Langdon asks what's wrong with Cheese? aday wants photo booth to be less kooky, fewer fun effects.
17:36:39 <cmurf> #info aday wants to make progress on fedora-workstation#105 (install fedora-workstation-repositories by default) and fedora-workstation#108 (filtered view of flathub)
17:36:41 <cmurf> #info topela asks about systemd-oomd, which will be included in systemd 247. Neal suggests that we stick with earlyoom for F34, unless systemd developers request otherwise.
17:36:43 <cmurf> #info WG examines the list of issues not tagged for F34
17:36:45 <cmurf> #info Neal provides status update on fedora-workstation#161 (btrfs disk integration). Development work stalled
17:36:47 <cmurf> #info tpopela mentions H.264 support in Firefox (fedora-workstation#126). mstransky has been working on this. Neal says Firefox 81 should use OpenH264 directly instead of via ffmpeg, so this should be fixed. Michael suggests we should test Firefox and confirm it actually works before closing the issue.
17:36:49 <cmurf> #info Neal discusses automatically installing OpenH264 (fedora-workstation#84). This still needs more work (possibly in gnome-initial-setup)
17:36:51 <cmurf> #info WG discusses btrfs documentation for how to rescue corrupted filesystem (fedora-workstation#157). Neal says this is WIP.
17:36:53 <cmurf> #info Neal says btrfs upstream is also fixing btrfs dependency on system page size.
17:36:55 <cmurf> #info ABRT: Michael says status is not good, and probably not likely to improve.
17:36:57 <cmurf> #info Neal mentions debuginfod. Local retracing should no longer require installing debug RPMs anymore. ABRT developers are planning to work on this.
17:36:59 <cmurf> #info Michael proposes to move some btrfs issues to the btrfs tracker.
17:37:01 <cmurf> #action Michael to move the issues
17:37:03 <cmurf> #info aday asks about fedora-workstation#125 (guidelines for preinstalled and nonremovable apps).
17:37:05 <cmurf> #action aday to prepare guidelines.
17:37:07 <cmurf> #info Neal suggests we close fedora-workstation#124 (anaconda: no more hub). Michael closes the issue.
17:37:09 <cmurf> #info Neal asks do we replace PulseAudio with pipewire in F34? Kalev says that's a question for Wim. tpopela says Wim is planning on F35, not F34. Neal says Fedora Jam will use it in F34 anyway.
17:37:11 <cmurf> #action Neal to discuss with Wim.
17:37:13 <cmurf> #info James mentions gnome-software downloading entire F33 runtime when installing dconf-editor is unexpected. (This is related to fedora-workstation#187.)
17:37:15 <cmurf> #topic Open Floor
17:37:17 <cmurf> #info WG discusses timezones and DST. Remember meeting time is pinned to US Eastern time.
17:37:30 <cmurf> #endmeeting