council
MINUTES

#fedora-meeting-1: Fedora Council February 2023 Hackfest

Meeting started by bcotton at 21:05:10 UTC (full logs).

Meeting summary

    1. This is a readout of the Fedora Council’s private in-person meeting in Frankfurt, DE 7–9 February 2023 (bcotton, 21:05:21)
    2. Members present: mattdm jflory7 bcotton dcantrell siddharthvipul1 sumantrom t0xic0der bookwar (bcotton, 21:05:28)

  1. Code of Conduct (bcotton, 21:05:32)
    1. AGREED: Our code of conduct is under the CC BY 4.0 license (+8,0,-0) (bcotton, 21:05:38)
    2. AGREED: Marie Nordin is a member of the Code of Conduct committee due to her role as a Code of Conduct specialist and her experience with the Fedora community (+8,0,-0) (bcotton, 21:05:44)
    3. AGREED: The supplemental Code of Conduct documentation is ready for the policy change policy process. (bcotton, 21:05:52)
    4. ACTION: mattdm to begin the policy change process for the Code of Conduct supplemental documentation (bcotton, 21:05:59)

  2. Fedora Council Charter (bcotton, 21:06:04)
    1. ACTION: mattdm to add content about private meetings and time expectations to Council docs (bcotton, 21:06:10)
    2. AGREED: The Fedora Community Action and Impact Coordinator (FCAIC) is renamed to Fedora Community Architect (+8,0,-0) (bcotton, 21:06:23)
    3. AGREED: We are renaming “Objectives” to “Community Initiatives” to improve clarity. (+8,0,-0) (bcotton, 21:06:24)
    4. https://pagure.io/Fedora-Council/council-docs/pull-request/171 (bcotton, 21:06:24)
    5. ACTION: mattdm to draft a Community Blog post explaining the change in title from Objectives to Community Initiatives (e.g. why did the Council make this decision and what does it mean for new Community Initiatives?) (bcotton, 21:06:24)
    6. AGREED: We will add an executive sponsor (existing Council member) role for Community Initiatives. (+8,0,-0) (bcotton, 21:06:31)
    7. We have consensus to remove the full/auxiliary member distinction. (bcotton, 21:06:38)
    8. ACTION: mattdm to start the process for removing the auxiliary member distinction (bcotton, 21:06:38)
    9. AGREED: We are renaming the “Diversity & Inclusion Team Representative” role to “Diversity, Equity, and Inclusion Advisor” (+8,0,-0) (bcotton, 21:06:46)
    10. https://pagure.io/Fedora-Council/council-docs/pull-request/168 (bcotton, 21:06:46)
    11. ACTION: sumantrom to draft a new opening paragraph for elected representatives to change “he or she” to “they” and to clarify wording to indicate that the Council is an active body (bcotton, 21:06:53)
    12. ACTION: dcantrell to review the Engineering representative section for accuracy and propose necessary changes (bcotton, 21:06:58)

  3. Fedora tooling (bcotton, 21:07:04)
    1. We discussed Packit and the source-git model (bcotton, 21:07:13)
    2. Consensus is that we need to say “we allow source-git type repositories” and let Packit be the implementation detail. (bcotton, 21:07:13)
    3. bookwar or the Packit team will file a ticket in the Council repo (bcotton, 21:07:13)
    4. We discussed GitLab. We are working with GitLab to see if Red Hat can pay them to host an open source version for our use. (bcotton, 21:07:19)
    5. Using GitLab.com has issues with user namespaces and provides non-FOSS features, which is a concern for some in the community (bcotton, 21:07:19)
    6. We discussed moving more of our asynchronous communication to Discussion. (bcotton, 21:07:40)
    7. The planned order of moving: (bcotton, 21:07:41)
    8. 1. Change proposals/discussion (bcotton, 21:07:41)
    9. 2. FESCo tickets (bcotton, 21:07:41)
    10. 3. Introductions (bcotton, 21:07:53)
    11. 4. Packaging (bcotton, 21:07:54)
    12. 5. Automated messages (bcotton, 21:07:54)
    13. ACTION: mattdm to propose moving Change proposals to Discussion (bcotton, 21:07:54)
    14. AGREED: We will ask Fedora Infrastructure to stop creating new mailing lists (+7,0,-0) (bcotton, 21:07:54)
    15. ACTION: sumantrom to generate a list of mailing lists, including usage categorization (e.g. announcements, discussion, etc) (bcotton, 21:07:54)
    16. https://pagure.io/Fedora-Council/tickets/issue/434 (bcotton, 21:07:54)
    17. ACTION: mattdm to create a “Council scratchpad” workflow category in docs (bcotton, 21:08:08)
    18. AGREED: We will retire AskNot in favor of a static page that’s easier to keep up-to-date (+7,1,0) (bcotton, 21:08:12)
    19. ACTION: bcotton to create a PR for the static page (bcotton, 21:08:13)
    20. Prior to acting on this, the Docs team independently decided to adopt the application (bcotton, 21:08:13)
    21. AGREED: We will mark Easyfix as deprecated with a planned shutoff date to coincide with the F38 release (+8,0,-0) (bcotton, 21:08:17)
    22. ACTION: t0xic0der to request deprecation notice for Easyfix (bcotton, 21:08:17)

  4. Council meetings (bcotton, 21:08:22)
    1. AGREED: We will move to a weekly half hour meeting model (+8,0,0) (bcotton, 21:08:30)
    2. ACTION: bcotton to send out a WhenIsGood (bcotton, 21:08:30)
    3. AGREED: We will keep the video meetings on the current schedule (+8,0,0) (bcotton, 21:08:36)

  5. Strategic Plan (bcotton, 21:08:40)
    1. Plan timeline (bcotton, 21:08:54)
    2. Matthew’s goal is to have 1–2 posts a week on Discussion about the impacts in the strategy through April, at which point the Council will vote on the strategy. (bcotton, 21:08:54)
    3. In May–June, we want to find two people per outcome: 1 person to lead, 1 Council member as executive sponsor (bcotton, 21:08:55)
    4. Finalize plan for presentation at Flock in early August (bcotton, 21:08:55)
    5. We spent a lot of time discussing the 18 objectives in the strategic plan logic model (bcotton, 21:09:02)
    6. https://discussion.fedoraproject.org/t/fedora-project-strategy-2028-february-march-planning-work-and-roadmap-til-flock/43618 (bcotton, 21:09:02)


Meeting ended at 21:09:04 UTC (full logs).

Action items

  1. mattdm to begin the policy change process for the Code of Conduct supplemental documentation
  2. mattdm to add content about private meetings and time expectations to Council docs
  3. mattdm to draft a Community Blog post explaining the change in title from Objectives to Community Initiatives (e.g. why did the Council make this decision and what does it mean for new Community Initiatives?)
  4. mattdm to start the process for removing the auxiliary member distinction
  5. sumantrom to draft a new opening paragraph for elected representatives to change “he or she” to “they” and to clarify wording to indicate that the Council is an active body
  6. dcantrell to review the Engineering representative section for accuracy and propose necessary changes
  7. mattdm to propose moving Change proposals to Discussion
  8. sumantrom to generate a list of mailing lists, including usage categorization (e.g. announcements, discussion, etc)
  9. mattdm to create a “Council scratchpad” workflow category in docs
  10. bcotton to create a PR for the static page
  11. t0xic0der to request deprecation notice for Easyfix
  12. bcotton to send out a WhenIsGood


Action items, by person

  1. bcotton
    1. bcotton to create a PR for the static page
    2. bcotton to send out a WhenIsGood
  2. UNASSIGNED
    1. mattdm to begin the policy change process for the Code of Conduct supplemental documentation
    2. mattdm to add content about private meetings and time expectations to Council docs
    3. mattdm to draft a Community Blog post explaining the change in title from Objectives to Community Initiatives (e.g. why did the Council make this decision and what does it mean for new Community Initiatives?)
    4. mattdm to start the process for removing the auxiliary member distinction
    5. sumantrom to draft a new opening paragraph for elected representatives to change “he or she” to “they” and to clarify wording to indicate that the Council is an active body
    6. dcantrell to review the Engineering representative section for accuracy and propose necessary changes
    7. mattdm to propose moving Change proposals to Discussion
    8. sumantrom to generate a list of mailing lists, including usage categorization (e.g. announcements, discussion, etc)
    9. mattdm to create a “Council scratchpad” workflow category in docs
    10. t0xic0der to request deprecation notice for Easyfix


People present (lines said)

  1. bcotton (57)
  2. zodbot (6)


Generated by MeetBot 0.4.