f36-blocker-review
MINUTES

#fedora-blocker-review: F36-blocker-review

Meeting started by adamw at 16:00:09 UTC (full logs).

Meeting summary

  1. Roll Call (adamw, 16:00:18)
  2. Introduction (adamw, 16:05:36)
    1. Our purpose in this meeting is to review proposed blocker and nice-to-have bugs and decide whether to accept them, and to monitor the progress of fixing existing accepted blocker and nice-to-have bugs. (adamw, 16:05:42)
    2. We'll be following the process outlined at: (adamw, 16:05:45)
    3. https://fedoraproject.org/wiki/QA:SOP_Blocker_Bug_Meeting (adamw, 16:05:48)
    4. The bugs up for review today are available at: (adamw, 16:05:50)
    5. http://qa.fedoraproject.org/blockerbugs/current (adamw, 16:05:53)
    6. The criteria for release blocking bugs can be found at: (adamw, 16:05:55)
    7. https://fedoraproject.org/wiki/Basic_Release_Criteria (adamw, 16:05:58)
    8. https://fedoraproject.org/wiki/Fedora_36_Beta_Release_Criteria (adamw, 16:06:01)
    9. https://fedoraproject.org/wiki/Fedora_36_Final_Release_Criteria (adamw, 16:06:03)
    10. for Final, we have: (adamw, 16:06:27)
    11. 4 Proposed Blockers (adamw, 16:06:34)
    12. 7 Accepted Blockers (adamw, 16:06:37)
    13. 2 Proposed Freeze Exceptions (adamw, 16:06:40)
    14. 2 Accepted Freeze Exceptions (adamw, 16:06:43)
    15. coremodule will secretarialize (adamw, 16:07:09)

  3. Proposed Final blockers (adamw, 16:07:19)
  4. (2069164) Most buttons on the GNOME virtual keyboard don't work (adamw, 16:07:24)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=2069164 (adamw, 16:07:27)
    2. https://pagure.io/fedora-qa/blocker-review/issue/693 (adamw, 16:07:30)
    3. Proposed Blocker, gnome-shell, NEW (adamw, 16:07:33)
    4. AGREED: 2069164 - AcceptedBlocker (Final) - this is accepted as a conditional violation of "A system installed with a release-blocking desktop must boot to a log in screen where it is possible to log in to a working desktop", in cases where use of the OSK is necessary due to lack of a physical keyboard, or accessibility requirements (adamw, 16:27:12)

  5. (2066717) [abrt] gvfs: type_class_init_Wm(): gvfsd-dav killed by SIGABRT (adamw, 16:27:49)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=2066717 (adamw, 16:27:54)
    2. https://pagure.io/fedora-qa/blocker-review/issue/685 (adamw, 16:27:58)
    3. Proposed Blocker, gvfs, MODIFIED (adamw, 16:28:02)
    4. Ticket vote: FinalBlocker (+0,1,-2) (kparal, -catanzaro, -nielsenb) (adamw, 16:28:04)
    5. AGREED: 2066717 - RejectedBlocker (Final) AcceptedFreezeException (Final) - we agreed this goes beyond 'basic functionality', but does seem worth granting an FE to try and make sure the feature works on the live image (adamw, 16:35:22)

  6. (2063156) Workstation Live is frozen in a VM with QXL video driver (Virtio works OK) (adamw, 16:36:00)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=2063156 (adamw, 16:36:04)
    2. https://pagure.io/fedora-qa/blocker-review/issue/656 (adamw, 16:36:08)
    3. Proposed Blocker, mutter, NEW (adamw, 16:36:11)
    4. Ticket vote: FinalBlocker (+0,0,-1) (-nielsenb) (adamw, 16:36:18)
    5. Ticket vote: FinalFreezeException (+1,0,-0) (+nielsenb) (adamw, 16:36:22)
    6. AGREED: 2063156 - AcceptedBlocker (Final) - this is accepted as a conditional violation of Basic criterion "A system installed with a release-blocking desktop must boot to a log in screen where it is possible to log in to a working desktop...", when running on a default F35 or earlier virt-manager VM and hitting the bug (adamw, 16:44:10)

  7. (2067151) Basic graphics mode broken for KDE (BIOS/UEFI) and GNOME (UEFI+X11) (adamw, 16:44:21)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=2067151 (adamw, 16:44:25)
    2. https://pagure.io/fedora-qa/blocker-review/issue/687 (adamw, 16:44:27)
    3. Proposed Blocker, xorg-x11-server, NEW (adamw, 16:44:32)
    4. Ticket vote: FinalBlocker (+2,0,-0) (+imsedgar, +nielsenb) (adamw, 16:44:35)
    5. AGREED: 2067151 - AcceptedBlocker (Final) - this is accepted as a clear violation of Final criterion "The generic video driver option...must function as intended (launching the installer or desktop and attempting to use a generic driver), and there must be no bugs that clearly prevent the installer or desktop from being reached in this configuration on all systems or on wide classes of hardware" (adamw, 16:50:54)

  8. Proposed Final freeze exception issues (adamw, 16:51:09)
  9. (2069039) After F35 -> F36 upgrade spell checking doesn't work in Weechat (adamw, 16:51:14)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=2069039 (adamw, 16:51:17)
    2. https://pagure.io/fedora-qa/blocker-review/issue/692 (adamw, 16:51:20)
    3. Proposed Freeze Exceptions, enchant, NEW (adamw, 16:51:25)
    4. https://paste.centos.org/view/593805c5 (adamw, 16:55:58)
    5. AGREED: 2069039 - AcceptedFreezeException (Final) - we're not 100% sure anything on media uses enchant, but the dependency list is very long so it seems like a good bet, and the fix is pretty clear and safe (just have it support the new location for hunspell dictionaries) (adamw, 16:59:21)

  10. (2063410) Printer setting: can't scroll media size list (adamw, 16:59:29)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=2063410 (adamw, 16:59:34)
    2. https://pagure.io/fedora-qa/blocker-review/issue/659 (adamw, 16:59:36)
    3. Proposed Freeze Exceptions, gnome-control-center, NEW (adamw, 16:59:39)
    4. Ticket vote: FinalFreezeException (+3,0,-1) (+geraldosimiao, +catanzaro, +imsedgar, -nielsenb) (adamw, 16:59:42)
    5. https://gitlab.gnome.org/GNOME/gnome-control-center/-/merge_requests/1268/diffs does indeed look a bit more radical than something i'd want to take during a freeze (adamw, 17:00:57)
    6. AGREED: 2063410 - RejectedFreezeException (Final) - we'd sort of like to take this as it does affect printing from the Workstation live, but the fix looks like a bit too much major surgery to be comfortable during a freeze, and we suspect the practical impact is not too big as commonly-used sizes are likely to be near the top of the list (adamw, 17:07:58)

  11. Accepted Final Blockers (adamw, 17:08:26)
    1. in this section of the meeting we are checking in on progress with fixes, not voting (unless there seems to be clear reason to re-consider accepted status) (adamw, 17:08:59)

  12. (2068015) [abrt] gnome-connections: _mid_memalign(): gnome-connections killed by SIGSEGV (adamw, 17:09:24)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=2068015 (adamw, 17:09:26)
    2. https://pagure.io/fedora-qa/blocker-review/issue/688 (adamw, 17:09:28)
    3. Accepted Blocker, gnome-connections, NEW (adamw, 17:09:30)
    4. this is fairly recently discovered, no apparent movement on a fix yet (adamw, 17:10:22)
    5. ACTION: adamw to ping kparal to file an upstream report (adamw, 17:10:28)

  13. (2049849) Windows with bitlocker enabled can't be booted, needs to use bootnext instead of chainloader (adamw, 17:10:37)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=2049849 (adamw, 17:10:41)
    2. https://pagure.io/fedora-qa/blocker-review/issue/597 (adamw, 17:10:45)
    3. Accepted Blocker, grub2, NEW (adamw, 17:10:48)
    4. back in February, rharwood wrote: "I recommend either changing the criteria or deferring" (adamw, 17:11:58)
    5. AGREED: QA (adamw) and devel (cmurf), plus bcotton, agreed this should be waived to F37 as a difficult-to-fix blocker, but there was no releng representation so the decision cannot be finalized (adamw, 17:25:50)
    6. ACTION: adamw to get signoff from releng and complete waiving this to F37 (adamw, 17:26:05)

  14. (2043335) gtk_widget_measure: assertion 'for_size >= -1' failed (adamw, 17:26:45)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=2043335 (adamw, 17:26:47)
    2. https://pagure.io/fedora-qa/blocker-review/issue/613 (adamw, 17:26:51)
    3. Accepted Blocker, gtk4, VERIFIED (adamw, 17:26:54)
    4. this was marked VERIFIED with the RC megaupdate, we will close it (adamw, 17:28:20)

  15. (2049849) Windows with bitlocker enabled can't be booted, needs to use bootnext instead of chainloader (adamw, 17:30:51)
    1. circling back to this one as releng showed up (adamw, 17:30:58)
    2. AGREED: with votes from adamw, cmurf, bcotton, nirik and mboddu, this is waived due to grub developers stating it is not possible to fix during this release cycle. during F37 cycle we will evaluate whether to adjust the release criterion (adamw, 17:32:38)

  16. (2062660) The input string via Input Method isn't renderred properly at the search box on Activities (adamw, 17:33:09)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=2062660 (adamw, 17:33:10)
    2. https://pagure.io/fedora-qa/blocker-review/issue/676 (adamw, 17:33:13)
    3. Accepted Blocker, mutter, ASSIGNED (adamw, 17:33:17)
    4. upstream has done some debugging of this at https://gitlab.gnome.org/GNOME/mutter/-/issues/2188 , seems stalled since a week ago (adamw, 17:34:16)
    5. ACTION: adamw to ping garnacho on current status (adamw, 17:34:37)

  17. (2056927) Require authselect for use in scriptlets (adamw, 17:35:22)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=2056927 (adamw, 17:35:24)
    2. https://pagure.io/fedora-qa/blocker-review/issue/622 (adamw, 17:35:27)
    3. Accepted Blocker, nss-mdns, ON_QA (adamw, 17:35:30)
    4. update was pushed stable, but fix isn't yet verified, we need to verify it (adamw, 17:36:12)

  18. (2057563) The About button sends Discover into loop and the application stops responding. (adamw, 17:40:18)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=2057563 (adamw, 17:40:22)
    2. https://pagure.io/fedora-qa/blocker-review/issue/627 (adamw, 17:40:25)
    3. Accepted Blocker, plasma-discover, NEW (adamw, 17:40:29)
    4. this is reported upstream, but upstream dev (nate graham) had trouble reproducing (adamw, 17:41:36)
    5. ben pinged the report three days ago, so I guess we'll see if that gets us anywhere (adamw, 17:41:52)

  19. (2066703) tracker-extract-3 killed by SIGSYS (adamw, 17:43:47)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=2066703 (adamw, 17:43:50)
    2. https://pagure.io/fedora-qa/blocker-review/issue/684 (adamw, 17:43:53)
    3. Accepted Blocker, tracker-miners, NEW (adamw, 17:43:57)
    4. this probably needs an upstream report (adamw, 17:46:32)
    5. garnacho says https://gitlab.gnome.org/GNOME/tracker-miners/-/merge_requests/386 should fix this (adamw, 17:48:34)

  20. Open Floor (adamw, 17:50:05)


Meeting ended at 17:53:57 UTC (full logs).

Action items

  1. adamw to ping kparal to file an upstream report
  2. adamw to get signoff from releng and complete waiving this to F37
  3. adamw to ping garnacho on current status


Action items, by person

  1. adamw
    1. adamw to ping kparal to file an upstream report
    2. adamw to get signoff from releng and complete waiving this to F37
    3. adamw to ping garnacho on current status
  2. kparal
    1. adamw to ping kparal to file an upstream report


People present (lines said)

  1. adamw (186)
  2. cmurf (34)
  3. zodbot (15)
  4. bcotton (15)
  5. lruzicka (10)
  6. Eighth_Doctor (10)
  7. geraldosimiao (9)
  8. Southern_Gentlem (9)
  9. coremodule (8)
  10. mboddu (5)
  11. kparal (4)
  12. OnuralpSezer[m] (2)
  13. nirik (2)
  14. mclasen (1)
  15. OnuralpSezer[m]1 (1)


Generated by MeetBot 0.4.