f26-blocker-review
MINUTES

#fedora-blocker-review: F26-blocker-review

Meeting started by adamw at 18:01:13 UTC (full logs).

Meeting summary

  1. Roll Call (adamw, 18:01:13)
    1. coremodule will secretarialize (adamw, 18:03:38)

  2. Introduction (adamw, 18:06:30)
    1. Our purpose in this meeting is to review proposed blocker and nice-to-have bugs and decide whether to accept them, and to monitor the progress of fixing existing accepted blocker and nice-to-have bugs. (adamw, 18:06:31)
    2. We'll be following the process outlined at: (adamw, 18:06:32)
    3. https://fedoraproject.org/wiki/QA:SOP_Blocker_Bug_Meeting (adamw, 18:06:34)
    4. The bugs up for review today are available at: (adamw, 18:06:36)
    5. http://qa.fedoraproject.org/blockerbugs/current (adamw, 18:06:38)
    6. The criteria for release blocking bugs can be found at: (adamw, 18:06:40)
    7. https://fedoraproject.org/wiki/Fedora_26_Alpha_Release_Criteria (adamw, 18:06:42)
    8. https://fedoraproject.org/wiki/Fedora_26_Beta_Release_Criteria (adamw, 18:06:44)
    9. https://fedoraproject.org/wiki/Fedora_26_Final_Release_Criteria (adamw, 18:06:46)
    10. 3 Proposed Blockers (Alpha) (adamw, 18:07:16)
    11. 2 Proposed Blockers (Beta) (adamw, 18:07:26)
    12. 3 Proposed Blockers (Final) (adamw, 18:07:35)

  3. (1412750) Multiple services in recent Rawhide fail to start with: Failed at step USER spawning (executable): Permission denied (adamw, 18:07:49)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1412750 (adamw, 18:07:50)
    2. Proposed Blocker, selinux-policy, MODIFIED (adamw, 18:07:50)
    3. AGREED: 1412750 - AcceptedBlocker (Alpha) - violates "Unless explicitly specified otherwise, after system installation the Cockpit web management interface must be running and accessible on its default port (9090)" and probably other criteria (adamw, 18:14:21)

  4. (1419946) "agetty: can not connect on UNIX socket" on tty1 after boot, have to use tty2 to log in after 3.13.1-236 update (adamw, 18:14:29)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1419946 (adamw, 18:14:29)
    2. Proposed Blocker, selinux-policy, MODIFIED (adamw, 18:14:29)
    3. AGREED: 1419946 - RejectedBlocker (Alpha) AcceptedBlocker (Beta) - this is agreed to be a violation of "The installer must be able to complete an installation using the serial console interface." combined with "A system installed without a graphical package set must boot to a working login prompt without any unintended user intervention" (adamw, 18:27:15)

  5. (1420753) "systemd-udevd.service: Failed at step ADDRESS_FAMILIES spawning" for PowerPC (adamw, 18:27:50)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1420753 (adamw, 18:27:51)
    2. Proposed Blocker, systemd, NEW (adamw, 18:27:51)
    3. AGREED: 1420753 - RejectedBlocker AcceptedFreezeException (Alpha) - on current information this doesn't affect either release-blocking arch (x86_64 or armhfp) so cannot block Alpha, but it is accepted as a freeze exception issue as a major bug for non-blocking arches. we also suggest it could go to the PrioritizedBug process. (adamw, 18:38:21)
    4. that's it for Alpha blockers (adamw, 18:38:48)

  6. (1376638) rescue mode cannot mount a default Fedora install (adamw, 18:38:58)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1376638 (adamw, 18:38:58)
    2. Proposed Blocker, anaconda, ASSIGNED (adamw, 18:38:58)
    3. AGREED: 1376638 - AcceptedBlocker (Beta) - since latest known status is this still frequently fails, it's accepted as a Beta blocker as a violation of "The rescue mode of the installer must start successfully and be able to detect and mount any installation performed according to the applicable criteria, and provide a shell with access to utilities capable of performing typical recovery operations." (adamw, 18:43:15)

  7. (1414391) single partition disks not visible in custom partitioning dialog (adamw, 18:43:21)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1414391 (adamw, 18:43:21)
    2. Proposed Blocker, anaconda, NEW (adamw, 18:43:22)
    3. AGREED: 1414391 - AcceptedBlocker (Beta) - seems like a clear violation of "When using the custom partitioning flow, the installer must be able to: ... Correctly interpret, and modify as described below, any disk with a valid ms-dos or gpt disk label and partition table containing ext4 partitions ..." (adamw, 18:48:26)
    4. that's all for Beta, onto Final! (adamw, 18:48:38)

  8. (1340203) goa-daemon not stopped on logout, and gnome-keyring unusable on next log in (adamw, 18:48:47)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1340203 (adamw, 18:48:47)
    2. Proposed Blocker, gnome-online-accounts, NEW (adamw, 18:48:47)
    3. AGREED: 1340203 - punt (delay decision) - it's a bit difficult to get a feel from the bug report for exactly how common this problem is. we'd like to ask the devs for a concise summary of how big a problem it is before we vote (adamw, 19:02:48)

  9. (1405539) changing the default keyboard layout changes also disk decryption in plymouth, but only after kernel update, long after (adamw, 19:03:03)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1405539 (adamw, 19:03:03)
    2. Proposed Blocker, plymouth, NEW (adamw, 19:03:03)
    3. ACTION: kohane to ask i18n/l10n/desktop teams for input on https://bugzilla.redhat.com/show_bug.cgi?id=1405539 (adamw, 19:32:13)
    4. AGREED: 1405539 - punt (delay decision) - once again we found it really hard to come to a decision on this. we agreed to ask for input from g11n and desktop teams to see what they think (adamw, 19:35:43)

  10. (1392161) SELinux is preventing (ostnamed) from 'mounton' accesses on the directory /proc/irq. (adamw, 19:35:54)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1392161 (adamw, 19:35:54)
    2. Proposed Blocker, selinux-policy, MODIFIED (adamw, 19:35:54)
    3. AGREED: 1392161 - AcceptedBlocker (Final) - clear violation of "There must be no SELinux denial notifications or crash notifications on boot of or during installation from a release-blocking live image, or at first login after a default install of a release-blocking desktop." (adamw, 19:39:23)
    4. that's all the proposed blockers, folks (adamw, 19:40:10)

  11. Open floor (adamw, 19:40:12)


Meeting ended at 19:47:34 UTC (full logs).

Action items

  1. kohane to ask i18n/l10n/desktop teams for input on https://bugzilla.redhat.com/show_bug.cgi?id=1405539


People present (lines said)

  1. adamw (235)
  2. kparal (78)
  3. Kohane (72)
  4. Southern_Gentlem (40)
  5. roshi (35)
  6. sgallagh (29)
  7. pschindl_ (20)
  8. pwhalen (17)
  9. zodbot (14)
  10. coremodule (7)
  11. cmurf (2)
  12. satellit (1)


Generated by MeetBot 0.1.4.