f26-blocker-review
LOGS
18:01:13 <adamw> #startmeeting F26-blocker-review
18:01:13 <zodbot> Meeting started Mon Feb 13 18:01:13 2017 UTC.  The chair is adamw. Information about MeetBot at http://wiki.debian.org/MeetBot.
18:01:13 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
18:01:13 <zodbot> The meeting name has been set to 'f26-blocker-review'
18:01:13 <adamw> #meetingname F26-blocker-review
18:01:13 <zodbot> The meeting name has been set to 'f26-blocker-review'
18:01:13 <adamw> #topic Roll Call
18:01:25 <Kohane> Hi
18:01:30 <Kohane> .fas lailah
18:01:31 <zodbot> Kohane: lailah 'Sylvia Sánchez' <BHKohane@gmail.com>
18:01:37 <adamw> who's around for exciting blocker meeting  fun? :)
18:01:39 <adamw> hi sylvia!
18:01:40 * kparal is here
18:01:49 <Kohane> Hi Adam!
18:02:02 * coremodule is here, ready for secretarialization duties.
18:03:38 <adamw> #info coremodule will secretarialize
18:03:41 <adamw> #chair coremodule
18:03:41 <zodbot> Current chairs: adamw coremodule
18:03:54 * pschindl_ is here
18:04:27 <roshi> .hello
18:04:27 <zodbot> roshi: (hello <an alias, 1 argument>) -- Alias for "hellomynameis $1".
18:04:30 <roshi> .hello roshi
18:04:31 <zodbot> roshi: roshi 'Mike Ruckman' <mruckman@redhat.com>
18:04:33 <adamw> hi roshi, pschindl
18:04:38 <adamw> #chair pschindl_ roshi
18:04:38 <zodbot> Current chairs: adamw coremodule pschindl_ roshi
18:06:10 <adamw> looks like we've got a decent turnout
18:06:19 <adamw> let's have some exciting boilerplate!
18:06:30 <adamw> everyone loves boilerplate.
18:06:30 <adamw> #topic Introduction
18:06:30 <adamw> Why are we here?
18:06:31 <adamw> #info Our purpose in this meeting is to review proposed blocker and nice-to-have bugs and decide whether to accept them, and to monitor the progress of fixing existing accepted blocker and nice-to-have bugs.
18:06:32 <adamw> #info We'll be following the process outlined at:
18:06:34 <adamw> #link https://fedoraproject.org/wiki/QA:SOP_Blocker_Bug_Meeting
18:06:36 <adamw> #info The bugs up for review today are available at:
18:06:38 <adamw> #link http://qa.fedoraproject.org/blockerbugs/current
18:06:40 <adamw> #info The criteria for release blocking bugs can be found at:
18:06:42 <adamw> #link https://fedoraproject.org/wiki/Fedora_26_Alpha_Release_Criteria
18:06:44 <adamw> #link https://fedoraproject.org/wiki/Fedora_26_Beta_Release_Criteria
18:06:46 <adamw> #link https://fedoraproject.org/wiki/Fedora_26_Final_Release_Criteria
18:07:12 <adamw> we have:
18:07:16 <adamw> #info 3 Proposed Blockers (Alpha)
18:07:26 <adamw> #info 2 Proposed Blockers (Beta)
18:07:35 <adamw> #info 3 Proposed Blockers (Final)
18:07:41 <adamw> so let's start right in on the Alpha proposals
18:07:49 <adamw> #topic (1412750) Multiple services in recent Rawhide fail to start with: Failed at step USER spawning (executable): Permission denied
18:07:50 <adamw> #link https://bugzilla.redhat.com/show_bug.cgi?id=1412750
18:07:50 <adamw> #info Proposed Blocker, selinux-policy, MODIFIED
18:08:41 * satellit listening
18:09:09 * Kohane reading
18:09:53 * pwhalen is here
18:09:53 <coremodule> Does this just break cockpit or does it break other things as well?
18:09:55 <kparal> +1
18:09:59 <roshi> +1
18:10:09 <adamw> coremodule: several other services too
18:10:18 <adamw> i'm still +1 on this one, for the record
18:10:22 <pwhalen> +1
18:10:27 <adamw> haven't really been able to tell if the fix works yet what with all the other breakage
18:10:51 <cmurf> +1
18:10:53 <Kohane> +1
18:10:54 <sgallagh> +1
18:10:59 <sgallagh> (sorry I'm late)
18:11:31 <coremodule> +1
18:11:41 <pschindl_> +1
18:12:17 <Southern_Gentlem> +1
18:13:20 <adamw> sorry, phone call
18:13:39 <adamw> proposed #agreed 1412750 - AcceptedBlocker (Alpha) - violates "Unless explicitly specified otherwise, after system installation the Cockpit web management interface must be running and accessible on its default port (9090)" and probably other criteria
18:13:52 <coremodule> ack
18:13:53 <pwhalen> ack
18:13:55 <Kohane> ack
18:14:21 <adamw> #agreed 1412750 - AcceptedBlocker (Alpha) - violates "Unless explicitly specified otherwise, after system installation the Cockpit web management interface must be running and accessible on its default port (9090)" and probably other criteria
18:14:29 <adamw> #topic (1419946) "agetty: can not connect on UNIX socket" on tty1 after boot, have to use tty2 to log in after 3.13.1-236 update
18:14:29 <adamw> #link https://bugzilla.redhat.com/show_bug.cgi?id=1419946
18:14:29 <adamw> #info Proposed Blocker, selinux-policy, MODIFIED
18:15:04 <cmurf> I'm +1
18:15:08 <coremodule> +1
18:15:15 <pwhalen> +1
18:15:25 <kparal> +1
18:15:36 <sgallagh> +1
18:15:37 <Kohane> It says fixed on the bottom...?
18:15:39 <Southern_Gentlem> +1
18:15:49 <Kohane> +1 anyway
18:15:53 <adamw> Kohane: it's modified
18:15:58 <roshi> +1
18:15:59 <Kohane> Ah
18:16:00 <adamw> we haven't had a compose with the fix yet so can't be sure if it's fixed
18:16:02 <Southern_Gentlem> would tty1 be where x is in fedora?
18:16:08 <Kohane> adamw: thanks
18:16:13 <adamw> Southern_Gentlem: well, yeah, but this doesn't actually stop X (or Wayland) starting
18:16:16 <sgallagh> Kohane: MODIFIED means that a fix went to the upstream policy, but hasn't made it to Fedora ytet
18:16:17 <adamw> Southern_Gentlem: it's specific to agetty
18:16:32 <adamw> Southern_Gentlem: but the 'no serial logins' case seems blockerish
18:16:58 <pwhalen> updating to selinux-policy-3.13.1-239 fixes it, serial console works
18:17:04 <adamw> you know...i don't think this actually strictly violates the alpha criteria
18:17:05 <Southern_Gentlem> +1
18:17:08 <adamw> but i dunno how hard i want to argue it.
18:17:34 <sgallagh> adamw: What about pwhalen's criterion?
18:17:57 <adamw> sgallagh: i wrote that, it means "you have to be able to login on at least one VT".
18:18:03 <adamw> it wasn't really supposed to be about serial console logins.
18:18:04 <sgallagh> It specifically refers to non-graphical logins
18:18:06 <pwhalen> I grabbed what looked reasonable. its a remote system so the default login is serial console
18:19:05 <adamw> for Beta we have "The installer must be able to complete an installation using the serial console interface.", which you could argue should also mean you can log in that way
18:19:05 <Kohane> If there's a fix on the way, shouldn't we wait until it reaches Fedora and then see if it's a blocker or not?
18:19:08 <adamw> but i don't think there's anything for alpha
18:19:17 <adamw> Kohane: no, that's the exact opposite way to how the process works :)
18:19:30 <Kohane> Oh, sorry
18:19:50 <Southern_Gentlem> keep moving before we talk ourselves into a hole
18:20:06 <adamw> i can just go with the vote, i guess, though it seems to be establishing new policy.
18:20:42 <sgallagh> adamw: Can you still log in with a local keyboard and screen?
18:20:42 <adamw> proposed #agreed 1419946 - AcceptedBlocker (Alpha) - this was considered a violation of the criterion "A system installed without a graphical package set must boot to a state where it is possible to log in through at least one of the default virtual consoles", apparently in relation to serial console login.
18:20:45 <adamw> sgallagh: yes.
18:20:47 <sgallagh> I didn't get that from the ticket
18:21:05 <adamw> sgallagh: the description says "have to use tty2 to log in after 3.13.1-236 update"
18:21:16 <adamw> which pretty clearly implies that one *can* login on tty2. :)
18:21:30 <sgallagh> Ah, hmm.
18:21:35 <sgallagh> Sorry, I misunderstood the problem.
18:21:35 <roshi> yeah, I suppose that's true
18:21:50 <sgallagh> If you can login on tty2, I'm actually switching to -1
18:21:59 <sgallagh> (at least for Alpha)
18:22:22 <adamw> i think it's worth considering whether we should block on serial console login for alpha, but i don't think it's easy to argue we currently *do*. :)
18:22:33 <roshi> lol, true
18:22:38 <Kohane> So you can't login on tty1 but you're still able to login on tty2. Is this right?
18:22:45 <adamw> Kohane: yes.
18:22:49 <adamw> (or 3, 4, 5 or 6, i think).
18:22:54 <Southern_Gentlem> -1
18:22:55 <pwhalen> on a remote system, you can't login. you cant change tty's
18:23:01 <Kohane> Then I don't think is a blocker really
18:23:08 <Kohane> You're still able to login
18:23:14 <Kohane> -1
18:23:29 <sgallagh> pwhalen: I'
18:23:30 <Kohane> I understood something different, I guess I missed something.
18:23:34 <sgallagh> I'm comfortable with Beta Blocker
18:23:39 <Kohane> yes
18:23:39 <sgallagh> On the installer criterion
18:23:45 <adamw> yeah, i'll go +1 beta
18:23:55 <adamw> and i'm open to a proposal that alpha should cover remote login
18:24:17 <sgallagh> adamw: That's specifically serial console, or ssh as well?
18:24:24 <adamw> undecided
18:24:27 <adamw> let's paint the bikeshed later :P
18:24:31 <sgallagh> agreed
18:24:38 <roshi> works for me
18:24:53 <sgallagh> (Reminder: if anyone wants this to be a blocker REALLY badly, feel free to petition FESCo for their override)
18:24:53 <adamw> so, new proposal
18:24:58 <Southern_Gentlem> -1 Alpha +1 beta
18:25:01 <sgallagh> (Alpha blocker, I mean)
18:25:29 <pwhalen> I wont be able to do a large portion of arm testing without serial logins
18:25:49 <adamw> proposed #agreed 1419946 - AcceptedBlocker (Beta) - this is agreed to be a violation of "The installer must be able to complete an installation using the serial console interface." combined with "A system installed without a graphical package set must boot to a working login prompt without any unintended user intervention"
18:25:54 <sgallagh> pwhalen: Not marking it a blocker doesn't prevent anyone from fixing it.
18:25:58 <adamw> pwhalen: in practice it's being fixed anyhow
18:26:03 <pwhalen> its fixed
18:26:06 <pwhalen> right
18:26:07 <adamw> we're not in freeze, it doesn't need blocker/fe status to get in
18:26:19 <adamw> so there's no urgent need to rewrite alpha rules on the fly
18:26:24 <pwhalen> sure.
18:26:28 <adamw> but please do go ahead and make a proposal to change them if you think it makes sense
18:26:28 <sgallagh> ack
18:26:37 <Southern_Gentlem> ack
18:26:38 <Kohane> ack
18:26:44 <adamw> as things stand, though, they're quite clearly written to only require serial console to work at beta
18:26:53 <adamw> #agreed 1419946 - AcceptedBlocker (Beta) - this is agreed to be a violation of "The installer must be able to complete an installation using the serial console interface." combined with "A system installed without a graphical package set must boot to a working login prompt without any unintended user intervention"
18:27:02 <adamw> #undo
18:27:02 <zodbot> Removing item from minutes: AGREED by adamw at 18:26:53 : 1419946 - AcceptedBlocker (Beta) - this is agreed to be a violation of "The installer must be able to complete an installation using the serial console interface." combined with "A system installed without a graphical package set must boot to a working login prompt without any unintended user intervention"
18:27:15 <adamw> #agreed 1419946 - RejectedBlocker (Alpha) AcceptedBlocker (Beta) - this is agreed to be a violation of "The installer must be able to complete an installation using the serial console interface." combined with "A system installed without a graphical package set must boot to a working login prompt without any unintended user intervention"
18:27:36 <sgallagh> adamw: Also, it may be a moot point to revise the criterion, as Alpha is supposedly going away in F27 :)
18:27:41 <adamw> well, true =)
18:27:50 <adamw> though we may have 'rawhide acceptance criteria' or something, i guess.
18:27:50 <adamw> #topic (1420753) "systemd-udevd.service: Failed at step ADDRESS_FAMILIES spawning" for PowerPC
18:27:51 <adamw> #link https://bugzilla.redhat.com/show_bug.cgi?id=1420753
18:27:51 <adamw> #info Proposed Blocker, systemd, NEW
18:28:08 <adamw> ppc isn't a release blocking arch, is it?
18:28:20 <Southern_Gentlem> -1
18:28:33 <kparal> nope
18:28:41 <pschindl_> -1
18:28:54 <roshi> -1 since it's PowerPC
18:28:58 <sgallagh> We're sure this only affects PPC64?
18:29:04 <kparal> we can convert this to FE if it makes sense
18:29:20 <adamw> sgallagh: seems pretty clear from the discussion.
18:29:31 <sgallagh> Zbigniew's reply suggests "non-AMD64 arches"...
18:29:45 <adamw> the openQA tests before compose started failing had lots of problems, but not this one.
18:29:47 <adamw> hmm, point.
18:30:47 <adamw> do we know if it affects armhpf? pwhalen?
18:31:09 <Southern_Gentlem> i think we punt for more info
18:31:49 <adamw> i'd be more inclined to -1 with option to revote if it affects armhpf
18:31:57 <adamw> afaik, only x86_64 and armhfp are current release blocking arches
18:32:17 <Kohane> Okay, then -1
18:32:28 <Southern_Gentlem> thats why lets punt for now
18:33:06 <pwhalen> adamw, I havent seen it
18:33:23 <adamw> meh, i just don't want the work of voting on it again later. :P disregarding gentlem's earlier -1, i count -4
18:33:28 <adamw> anyone else want to change to punt? or else we'll go with -1
18:33:30 <sgallagh> -1
18:33:55 <sgallagh> Can we suggest that they propose it as a Prioritized Bug?
18:34:04 <sgallagh> (Because obviously it's a real issue)
18:34:08 <adamw> sure
18:34:22 <adamw> oh, i can be +1 FE too
18:34:25 <adamw> any other FE votes?
18:34:54 <Southern_Gentlem> +fe
18:34:56 <kparal> +1 fe
18:35:11 <pwhalen> +1 fe
18:35:44 <Southern_Gentlem> -1 +fe
18:35:44 <pschindl_> +1 FE
18:35:49 <sgallagh> I'm -1 FE for anything having to do with systemd, honestly
18:35:52 <sgallagh> Too much risk
18:35:53 <Southern_Gentlem> +1 fe rather
18:36:14 <adamw> proposed #agreed 1420753 - RejectedBlocker AcceptedFreezeException (Alpha) - on current information this doesn't affect either release-blocking arch (x86_64 or armhfp) so cannot block Alpha, but it is accepted as a freeze exception issue as a major bug for non-blocking arches. we also suggest it could go to the PrioritizedBug process.
18:36:44 <adamw> sgallagh: hmm, point. i'm +1 on the basis we request a backport of the fix, not a new systemd release build.
18:36:51 <adamw> (if it goes in after freeze)
18:37:06 <pschindl_> ack
18:37:12 <roshi> ack
18:37:14 <Kohane> ack
18:38:21 <adamw> #agreed 1420753 - RejectedBlocker AcceptedFreezeException (Alpha) - on current information this doesn't affect either release-blocking arch (x86_64 or armhfp) so cannot block Alpha, but it is accepted as a freeze exception issue as a major bug for non-blocking arches. we also suggest it could go to the PrioritizedBug process.
18:38:33 <adamw> coremodule: can you note the 'backport not new systemd release' thing in the comment?
18:38:45 <coremodule> Sure! Got it.
18:38:48 <adamw> #info that's it for Alpha blockers
18:38:50 <adamw> going onto Beta
18:38:58 <adamw> #topic (1376638) rescue mode cannot mount a default Fedora install
18:38:58 <adamw> #link https://bugzilla.redhat.com/show_bug.cgi?id=1376638
18:38:58 <adamw> #info Proposed Blocker, anaconda, ASSIGNED
18:39:30 * Kohane has to rush a moment, BRB sorry
18:39:36 <adamw> the last status i had on this was it would *sometimes* work but still most often fail
18:39:39 <adamw> might be a race
18:39:42 <adamw> Kohane: npnp
18:39:48 <adamw> don't know status lately with all the other breakage
18:40:04 <roshi> +1, seems clear
18:40:36 <kparal> +1
18:40:40 <Southern_Gentlem> +1
18:40:43 <pschindl_> +1
18:42:11 <adamw> proposed #agreed 1376638 - AcceptedBlocker (Beta) - since latest known status is this still frequently fails, it's accepted as a Beta blocker as a violation of "The rescue mode of the installer must start successfully and be able to detect and mount any installation performed according to the applicable criteria, and provide a shell with access to utilities capable of performing typical recovery operations."
18:42:18 <pwhalen> +1
18:42:26 <pwhalen> ack
18:42:32 <kparal> ack
18:42:33 <roshi> ack
18:42:36 <Southern_Gentlem> ack
18:43:15 <adamw> #agreed 1376638 - AcceptedBlocker (Beta) - since latest known status is this still frequently fails, it's accepted as a Beta blocker as a violation of "The rescue mode of the installer must start successfully and be able to detect and mount any installation performed according to the applicable criteria, and provide a shell with access to utilities capable of performing typical recovery operations."
18:43:21 <adamw> #topic (1414391) single partition disks not visible in custom partitioning dialog
18:43:21 <adamw> #link https://bugzilla.redhat.com/show_bug.cgi?id=1414391
18:43:22 <adamw> #info Proposed Blocker, anaconda, NEW
18:44:50 <adamw> seems to hit the criterion
18:44:51 <adamw> so +1
18:45:12 <pschindl_> +1
18:45:14 <Southern_Gentlem> +1
18:45:24 <kparal> +1
18:45:25 * Kohane still reading
18:45:30 <roshi> +1
18:45:39 <Kohane> +1
18:46:21 <pwhalen> +1
18:46:48 <adamw> proposed #agreed 1414391 - AcceptedBlocker (Beta) - seems like a clear violation of "When using the custom partitioning flow, the installer must be able to: ... Correctly interpret, and modify as described below, any disk with a valid ms-dos or gpt disk label and partition table containing ext4 partitions ..."
18:47:01 <roshi> ack
18:47:06 <Kohane> ack
18:47:19 <Southern_Gentlem> ack
18:47:26 <pwhalen> ack
18:48:05 <pschindl_> ack
18:48:26 <adamw> #agreed 1414391 - AcceptedBlocker (Beta) - seems like a clear violation of "When using the custom partitioning flow, the installer must be able to: ... Correctly interpret, and modify as described below, any disk with a valid ms-dos or gpt disk label and partition table containing ext4 partitions ..."
18:48:38 <adamw> #info that's all for Beta, onto Final!
18:48:47 <adamw> #topic (1340203) goa-daemon not stopped on logout, and gnome-keyring unusable on next log in
18:48:47 <adamw> #link https://bugzilla.redhat.com/show_bug.cgi?id=1340203
18:48:47 <adamw> #info Proposed Blocker, gnome-online-accounts, NEW
18:50:42 <adamw> hum, not sure about this.
18:51:28 <kparal> +1 final
18:51:29 <adamw> i think i'd be -1 blocker on this. the mechanism basically works. i don't think a possibility of it stopping working on a logout/login cycle is enough to block release, particularly since the bug exists in current releases.
18:51:49 * adamw narrows eyes
18:51:53 <kparal> if keyring breaks on logging out, I think it violates our criteria
18:52:11 <adamw> i don't think it's that straightforward.
18:52:13 <Kohane> adamw: it doesn't happen to me
18:52:19 <adamw> yeah, doesn't happen to me either.
18:52:31 <adamw> from a quick scan, it sounds like it's a race-y / ordering-y systemd thing.
18:52:38 <adamw> and it seems to have been around for a while.
18:52:40 <pschindl_> I've seen it few times (on rawhide).
18:53:06 <adamw> i may have seen it happen once or twice and dismissed it as some weird passing thing, in fact. but it clearly doesn't happen to everyone every time they log out, i don't think.
18:53:14 <kparal> I think we should not distinguish "clean" login and repeated login, that doesn't make sense to me
18:53:15 <roshi> I'm -.5 on this
18:53:22 <Southern_Gentlem> i can see as the crit is written that it could be a blocker
18:53:24 <kparal> however, if this is a race, I can see -1 here
18:53:42 <adamw> kparal: that's why i said 'a possibility of it stopping working'.
18:53:46 <adamw> i.e., it doesn't always happen.
18:53:59 <kparal> alright
18:54:16 <adamw> do read it yourself and confirm, though, i just scanned the report
18:54:19 * adamw reads more closely
18:54:20 <kparal> I didn't manage to read it all
18:54:22 <pschindl_> I'm -1 as it doesn't happen allways. But I'm +1 because when it happens it is really annoying
18:54:27 <pschindl_> +1 FE
18:54:37 <Kohane> I think it's serious bug but I'm not sure if it's  *that*  serious to mark it as blocker. I can't decide....
18:54:40 <kparal> pschindl_: do you have an estimate how often it happens?
18:55:33 * Southern_Gentlem is going to go test real fast
18:55:42 <pschindl_> I'm not sure. I doen't reboot or logout too much so I can't estimate it
18:56:18 <pschindl_> It's not everytime.
18:56:26 * Kohane does a quick test and comes back, just to check it still doesn't happen in her laptop
18:56:48 <adamw> the upstream bug does have quite a few dupes
18:56:57 <kparal> ok then, if it is not every time, I guess I'm not +1
18:56:59 <adamw> hum. i think i might change my vote to 'punt and ask devs for a clear summary of how bad this is'
18:57:20 <kparal> sounds good
18:58:41 <Kohane> Okay, I just checked. It doesn't happen to me.
18:59:04 <Southern_Gentlem> Kohane, and you are running gnome correct
18:59:19 <Kohane> yes,
18:59:30 <Kohane> It's Workstation, with no other desktops installed.
19:00:16 <Southern_Gentlem> i am agreeing with adamw  i think punt till we can get more info
19:00:22 <Southern_Gentlem> +1 punt
19:00:34 <roshi> wfm
19:00:53 <adamw> pschindl, punt OK for you?
19:01:03 <pschindl_> adamw: yes
19:01:07 <pschindl_> +1 punt
19:01:13 <Kohane> yes, +1 punt
19:01:35 <roshi> +1 punt
19:01:43 <adamw> proposed #agreed 1340203 - punt (delay decision) - it's a bit difficult to get a feel from the bug report for exactly how common this problem is. we'd like to ask the devs for a concise summary of how big a problem it is before we vote
19:01:52 <roshi> ack
19:01:55 <Southern_Gentlem> ack
19:02:07 <Kohane> ack
19:02:43 <pschindl_> ack
19:02:48 <adamw> #agreed 1340203 - punt (delay decision) - it's a bit difficult to get a feel from the bug report for exactly how common this problem is. we'd like to ask the devs for a concise summary of how big a problem it is before we vote
19:03:03 <adamw> #topic (1405539) changing the default keyboard layout changes also disk decryption in plymouth, but only after kernel update, long after
19:03:03 <adamw> #link https://bugzilla.redhat.com/show_bug.cgi?id=1405539
19:03:03 <adamw> #info Proposed Blocker, plymouth, NEW
19:03:28 <adamw> so we kinda argued about this one a bit and punted it last time
19:03:32 <kparal> one would hope this fixes itself during the past 3 weeks, right? :)
19:03:33 <adamw> did anyone get any significant new info?
19:04:29 <kparal> no new info. but I guess I'm tired of fighting serious gnome bugs when gnome devs don't really care
19:04:56 <kparal> so, when thinking about this, I guess we should split this into two parts. how serious it is and how many users it affects, and decide based on that
19:04:59 <adamw> i know we found lots of problems with fixing it. like plymouth can't really draw a keyboard layout indicator on the screen because it has no concept of glyphs. and also, knowing which 'console layout' is active for 'switched console layouts' is either difficult or outright impossible, because of how they really work.
19:05:54 <kparal> well I wasn't really talking about "the ultimate fix", but about minimizing the likelihood that this happens to a user (without being warned)
19:06:00 <kparal> that's not that difficult
19:06:12 <kparal> that's all this bug was about
19:06:34 <Southern_Gentlem> so when a new kernel is installed so dracut is ran correct
19:06:59 <kparal> so, about seriousness, I think this is very serious, because it is basically "device bricked" for ordinary users
19:07:14 <Southern_Gentlem> which is nt correct because it happens long time afterwards
19:07:32 <adamw> well, even just running dracut right away doesn't really 'fix the problem'
19:07:35 <kparal> how many users this affects: those with encrypted disks & multiple user accounts & changing their default keyboard layout
19:07:36 <adamw> they might still not reboot for a long time
19:08:14 <kparal> adamw: I don't follow
19:08:24 <adamw> say you change the layout, then don't reboot for two weeks
19:08:33 <adamw> maybe you forget about it then too
19:08:36 <adamw> i dunno, i guess it's not as bad.
19:08:49 <adamw> you don't have the gap where it keeps being the old layout then, i guess.
19:08:53 <kparal> ok, yeah, it might not be obvious if you don't reboot for a long time
19:09:46 <kparal> so I guess I'd decide this based on the number of affected users, see above
19:09:56 <kparal> which we might only guesstimate, of course
19:10:05 <adamw> you know, i start to think the only valid 'solution' for this is something like android where you can only use numbers. and you get an onscreen keyboard. :P
19:10:26 <adamw> but yeah, there's definitely stuff that could be done to make it less bad.
19:10:40 <kparal> I think saying "this might break your disk encryption password" in a dialog is also a valid "solution"
19:11:40 <roshi> +1 to the warning, in any case
19:11:45 <roshi> if we could make that happen
19:11:53 <adamw> having a warning, and running dracut right away, might both help
19:11:57 <kparal> damn, I was wrong. not multiple accounts, not a single account
19:12:07 <kparal> argh
19:12:10 <kparal> so, once again:
19:12:19 <kparal> how many users this affects: those with encrypted disks & single user account & changing their default keyboard layout
19:12:39 <roshi> that drops the number of people affected down by a bunch
19:12:42 <roshi> IMo at elast
19:12:44 <roshi> least
19:12:50 <kparal> I guess it's mostly corporate users
19:12:54 * roshi swears he could type at one time in his life
19:12:55 <adamw> roshi: hum? i'd kinda guess it'd be the other way
19:12:58 <Kohane> kparal: so it affects to those who have only one account as well?
19:13:00 <kparal> not sure how many ordinary users encrypt their disks
19:13:03 <adamw> single user account seems like a more common case than multiple
19:13:06 <adamw> is there a button to apply the settings systemwide, when there are multiple accounts?
19:13:12 <roshi> but not changing keyboard layouts
19:13:16 <adamw> Kohane: it's more likely to affect them
19:13:17 <kparal> adamw: yes
19:13:20 <adamw> oh, and the account has to be an admin
19:13:23 <roshi> if anything is a "set and forget" I'd think it'd be the layout
19:13:24 <adamw> Kohane: the difference is this:
19:13:25 <Kohane> Oh...
19:13:31 <kparal> if you have a single user account, it's usually admin :)
19:13:38 <Kohane> Yes, I know
19:13:47 <Kohane> I have my laptop that way, haha
19:13:49 <adamw> when there are multiple accounts, and a single user changes a setting like this in GNOME, the change is only applied to that user's account by default
19:13:57 <kparal> if you have multiple accounts, you need to use "login screen" button first to indicate it's a system-wide change
19:14:05 <adamw> if you have a single user account and that user is an admin, then when you make a change like this in GNOME, GNOME automatically applies the change systemwide
19:14:38 <adamw> kparal: right, but then of course the label on that button is a lie...so you *could* still hit this and not know what's going on if there are multiple accounts, it just requires an extra step...
19:14:56 <kparal> yes, just decreases the likelihood
19:15:02 <kparal> but you can still hit it, sure
19:15:53 <adamw> so i guess i'm pulled a few different ways here. i suspect this still doesn't ultimately hit *that* many people. but on the other hand, if you do hit it and not know what's going on, it's really bad. but on the gripping hand, i'm always kinda reluctant to take bugs without clear solutions as blockers
19:16:31 * adamw dreams of the day someone acknowledges his 'gripping hand' references
19:16:46 <kparal> sorry, not me
19:16:49 <adamw> =)
19:16:50 <Kohane> adamw: LOL
19:17:35 <kparal> so, how frequent is "encrypted & single user & change layout" use case, what do you think?
19:17:59 <adamw> i'd be guessing as much as you, quite honestly
19:18:26 <kparal> it's already a prioritized bug, which might not mean much
19:18:46 <adamw> it means top men are on it
19:18:48 <adamw> TOP. MEN.
19:19:16 <Kohane> Well...  changing keyboard layout isn't weird, isn't it?  But I'm guessing as well.
19:19:25 <kparal> honestly I'm pretty pissed that there seems to be no will to add at least a warning label. but if people think it does not affect too large audience, I'm not going to fight for this
19:19:39 <adamw> Kohane: it's not that weird, but i mean, there isn't a *lot* of call for doing it. you don't usually just suddenly go get a keyboard with a different layout.
19:19:55 <kparal> keyboard layouts are very frequent in non-us countries
19:19:58 <roshi> I've only changed my layout after install to test something, but have no idea if others change layouts for funzies
19:20:01 <kparal> non english speaking, rather
19:20:01 <adamw> kparal: i really honestly don't know. i don't follow the forums as much as i used to
19:20:17 <adamw> kparal: well sure, but usually, you pick the right one at install time.
19:20:23 <Kohane> I have 3 different layouts and permanently switch between them, Am I rare then?
19:20:25 <adamw> i think?
19:20:42 <adamw> Kohane: i'd say you're in a minority, but more importantly, do you change which one is the *default*?
19:20:46 <kparal> adamw: not really, because on some layouts some characters are either missing or very hard to type
19:20:50 <adamw> just switching layout at run time doesn't cause this bug to happen
19:20:59 <adamw> you have to go into the GNOME preferences and change the order of the layouts there
19:21:03 <roshi> yeah, it's a changing the default
19:21:22 <kparal> right, but having multiple layouts makes it more likely that you go and change the default
19:21:26 <adamw> kparal: i'd figure the normal case there would be just to add another layout and do switching, not change the default. but i'm entirely guessing at that point
19:21:30 <adamw> sure, it does make it more likely
19:21:45 <Kohane> adamw:  I don't know which one is the default, they are too many. I just looked and it's 4 not 3  (0_0)
19:22:27 <adamw> Kohane: the one at the top of the list in the GNOME preferences is 'the default' so far as GNOME is concerned, IIRC. if you change which one is at the top of the order, GNOME will make an effort to make that layout your console layout (the one used on VTs and during boot)
19:22:38 <kparal> as I say, I'm not going to fight this :) it's true that having multiple layouts doesn't mean you go and adjust the default one
19:23:15 <adamw> kparal: i kinda feel like ultimately it comes down to just making a flat out guess about how common this is. because i really have no good evidence
19:23:22 <Kohane> I agree with kparal that there should be a warning
19:23:57 <kparal> anybody wants to guess if this affects a reasonable portion of our userbase?
19:24:09 <adamw> i'd really rather not, but if it comes down to it, we'll have to :P
19:24:25 <Kohane> I think it's a reasonable portion of the userbase but I don't know how large is.
19:25:05 <kparal> sigh. let's do automation. it's easier
19:25:06 <Kohane> I did change the default a couple of time because my laptop has a weird US keyboard. But I gave up in the process.
19:25:25 <Kohane> a couple of times *
19:25:52 <adamw> we could ask i18n / l10n groups i guess?
19:25:59 <adamw> they might have a better chance at making a reasonable guess
19:26:09 <Kohane> yes, it could be
19:26:43 <kparal> we also can ping workstation wg
19:26:46 <adamw> sure
19:26:48 <roshi> +1 to asking the i18n/l10n groups
19:26:51 <adamw> let's make it SEP
19:26:51 <adamw> :P
19:26:56 <kparal> and discuss this bug again in a week :)
19:27:06 * kparal loves SEPs
19:27:12 <Kohane> xD
19:27:58 <kparal> adamw: have you just volunteered to ping those groups, or should I?
19:28:20 <adamw> proposed #agreed 1405539 - punt (delay decision) - once again we found it really hard to come to a decision on this. we agreed to ask for input from g11n and desktop teams to see what they think
19:28:22 <adamw> kparal: either way
19:28:48 <kparal> do you know how to best reach i18n/l10n?
19:29:43 <Southern_Gentlem> +1
19:30:15 <roshi> ack
19:30:16 <adamw> kparal: they have mailing lists, i think.
19:30:21 <adamw> there's at least an i18n list
19:30:21 <kparal> I have this inexplicable feeling that workstation wg doesn't like me, not sure why. but the g11n people don't know me yet, so that should be fine...
19:30:52 <adamw> oh, workstation people don't like anyone, it's nothing personal :P
19:30:56 <Kohane> kparal: want me to try?
19:31:01 <Kohane> LOL
19:31:16 <Kohane> They won't like me either?
19:31:18 <kparal> Kohane: if you want to volunteer, sure, no problem with me :)
19:31:23 <pschindl_> ack
19:31:38 <Southern_Gentlem> ack
19:31:46 <kparal> adamw: that explains a lot :)
19:31:49 <Kohane> kparal: yes, I'm volunteering
19:31:55 <kparal> Kohane: great, thanks
19:32:04 <kparal> Kohane++
19:32:13 <adamw> #action kohane to ask i18n/l10n/desktop teams for input on https://bugzilla.redhat.com/show_bug.cgi?id=1405539
19:32:14 <kparal> seems I'm out of cookies
19:32:17 <adamw> thanks kohane
19:32:20 <adamw> kohane++
19:32:24 <Kohane> Welcome
19:32:25 <adamw> or zodbot isn't here
19:32:29 <adamw> wiat, he is.
19:32:30 <adamw> then i dunno.
19:32:34 <adamw> aaanyho
19:32:38 <adamw> one more bug to go!
19:32:42 <Kohane> LOL
19:32:48 <adamw> #topic (1392161) SELinux is preventing (ostnamed) from 'mounton' accesses on the directory /proc/irq.
19:32:48 <adamw> #link https://bugzilla.redhat.com/show_bug.cgi?id=1392161
19:32:48 <adamw> #info Proposed Blocker, selinux-policy, MODIFIED
19:32:50 <adamw> jeez, this one?
19:33:00 <adamw> oh yeah, more in the topic of 'probably fixed but can't tell yet'
19:33:04 * kparal will ack anything that has selinux in it
19:33:05 <Kohane> I want my cookies...  :'(
19:33:28 * Kohane trying to read...
19:33:32 <adamw> i'll have to go figure out if this is fixed yet once we have a non-disastrous compose, but i'm definitely +1 on it being a blocker.
19:34:05 <kparal> +1
19:34:14 <kparal> (because it's selinux)
19:34:21 <Southern_Gentlem> +
19:34:24 <Southern_Gentlem> 1
19:34:25 <Kohane> +1
19:34:54 <pschindl_> Did I miss something or there was no #agreed on the previous bug?
19:35:05 <pschindl_> +1
19:35:15 <adamw> oh dangit
19:35:18 <adamw> you are quite correct
19:35:26 <adamw> choo choo! all aboard the undo train
19:35:28 <Kohane> pschindl_: No agreed
19:35:30 <adamw> #undo
19:35:30 <zodbot> Removing item from minutes: INFO by adamw at 19:32:48 : Proposed Blocker, selinux-policy, MODIFIED
19:35:32 <adamw> #undo
19:35:32 <zodbot> Removing item from minutes: <MeetBot.items.Link object at 0x3e68e50>
19:35:38 <adamw> #undo
19:35:38 <zodbot> Removing item from minutes: <MeetBot.items.Topic object at 0x38f93750>
19:35:43 <adamw> #agreed 1405539 - punt (delay decision) - once again we found it really hard to come to a decision on this. we agreed to ask for input from g11n and desktop teams to see what they think
19:35:54 <adamw> #topic (1392161) SELinux is preventing (ostnamed) from 'mounton' accesses on the directory /proc/irq.
19:35:54 <adamw> #link https://bugzilla.redhat.com/show_bug.cgi?id=1392161
19:35:54 <adamw> #info Proposed Blocker, selinux-policy, MODIFIED
19:35:58 <adamw> there we go.
19:36:04 <pschindl_> Still +1 :)
19:36:32 <adamw> proposed #agreed 1392161 - AcceptedBlocker (Final) - clear violation of "There must be no SELinux denial notifications or crash notifications on boot of or during installation from a release-blocking live image, or at first login after a default install of a release-blocking desktop."
19:36:38 <kparal> ack
19:36:47 <Southern_Gentlem> ack
19:36:49 <roshi> +1
19:36:50 <Kohane> ack
19:36:51 <roshi> ack
19:37:25 <Kohane> adamw: what happened to the last #action? Undo as well?
19:37:59 <kparal> that should still be there
19:38:14 <kparal> adamw is our undo master
19:38:42 <Kohane> yes, haha
19:38:54 <Southern_Gentlem> Kohane++
19:39:19 <adamw> yeah, the action should be ok
19:39:23 <adamw> #agreed 1392161 - AcceptedBlocker (Final) - clear violation of "There must be no SELinux denial notifications or crash notifications on boot of or during installation from a release-blocking live image, or at first login after a default install of a release-blocking desktop."
19:39:40 <adamw> although we never actually follow up on blocker meeting action items, really...at least they show up in the minutes
19:39:54 <adamw> maybe we should add a 'previous meeting follow-up' bit to blocker meetings
19:40:00 <adamw> you know, they're not long enough yet, after all
19:40:07 <roshi> I coulda swore there was one...
19:40:10 <adamw> #info that's all the proposed blockers, folks
19:40:12 <adamw> #topic Open floor
19:40:16 * roshi has nothing
19:40:27 <adamw> we could do accepted blockers, but meh, it's late in europe
19:40:35 <adamw> and it's a public holiday here and i didn't sleep much
19:40:35 <adamw> :P
19:40:41 <Kohane> Late?
19:40:47 <roshi> and we haven't even branched F26 yet - there's no need :p
19:40:54 <Southern_Gentlem> update on 1340203 when we get a chance  (clen install using the updated work iso created user login and ssh to the host  exit and logiut  and same user cannot login, reboot required for user to login
19:40:55 <kparal> 9pm here
19:41:08 <Kohane> It's 19:40 UTC
19:41:15 <Kohane> That's me
19:41:17 <adamw> Kohane: late for people who work office hours!
19:41:23 <Kohane> Ah...
19:41:31 * roshi ambles off to find some more coffee...
19:41:31 <adamw> they're czech, they have a constitutional right to be in a bar by now
19:41:47 <Kohane> adamw: LMAO
19:41:53 <kparal> social state, you know
19:42:07 <adamw> thanks for sticking around, folks
19:42:16 <adamw> see you next time, same bat-channel
19:42:22 * adamw sets fuse
19:42:22 <Kohane> haha
19:42:24 <kparal> thanks adamw
19:42:32 <Kohane> adamw++
19:42:34 <Southern_Gentlem> update on 1340203 when we get a chance  (clen install using the updated work iso created user login and ssh to the host  exit and logiut  and same user cannot login, reboot required for user to login
19:42:36 <coremodule> Thanks for doing the heavy lifting adamw
19:42:49 <adamw> Southern_Gentlem: sorry, i can't parse that.
19:43:07 <Kohane> Why no cookies for adamw??  I'm pretty sure I still have some.
19:43:09 <adamw> Southern_Gentlem: i don't know that what you're describing has anything to do with that bug?
19:43:13 <adamw> Kohane: try 'adamwill++'
19:43:19 <Southern_Gentlem> .bug 1340203
19:43:19 <zodbot> Southern_Gentlem: Bug 1340203 – goa-daemon not stopped on logout, and gnome-keyring unusable on next log in - https://bugzilla.redhat.com/1340203
19:43:22 <Kohane> adamwill++
19:43:43 <kparal> zodbot seems to be ignoring us here
19:43:47 <Southern_Gentlem> created a Workstation VM
19:43:53 <Kohane> ye!
19:44:05 <Kohane> But it's not the first time....
19:44:17 <Southern_Gentlem> login as user, ssh to host, log out on ssh, then logout of VM
19:44:29 <Southern_Gentlem> user cannot log back in without rebooting
19:44:35 <Kohane> Yes. And?
19:44:49 <kparal> might be a different issue, but definitely is an interesting one
19:45:22 <Southern_Gentlem> where should i look in the logs to see if its a gonome-keyring or what issue
19:45:31 <adamw> Southern_Gentlem: journal, I guess.
19:45:38 <kparal> Southern_Gentlem: file a bug with 'journalctl -b' attached, I'd say
19:45:48 <kparal> yeah, or compare the logs first
19:45:54 <kparal> with the info in the bug
19:46:21 <Southern_Gentlem> ok i can make it happen consistantly
19:47:30 <adamw> welp, seems like we're done with blocker business
19:47:32 <adamw> thanks again folks!
19:47:34 <adamw> #endmeeting