ansible_core_meeting
MINUTES

#ansible-meeting: Ansible Core Meeting

Meeting started by abadger1999 at 19:05:15 UTC (full logs).

Meeting summary

    1. Agenda: https://github.com/ansible/community/issues/220 (abadger1999, 19:05:35)

  1. Allow implementing stdout/stdin params for command modules: https://github.com/ansible/community/issues/220#issuecomment-320049755 (abadger1999, 19:06:23)
    1. https://github.com/ansible/ansible/pull/27335 (jtanner, 19:10:40)
    2. jimi|ansible, nitzmahone, alikins, abadger1999, jtanner, sdoran: all basically for it, bcoca mildly opposed. We've agreed to take a PR (abadger1999, 19:18:23)
    3. ACTION: abadger1999 to search for the outtanding PRs on this feature and coordinate until something is merged. (abadger1999, 19:18:43)
    4. jimi|ansible requests that the parameter be named data rather than stdin. (abadger1999, 19:19:26)

  2. Backwards incompatible policy for status=preview modules: https://github.com/ansible/community/issues/220#issuecomment-321596159 (abadger1999, 19:21:10)
    1. Proposal For community modules marked status=preview, leave it up to the maintainer whether to change params, whether to have deprecation period, etc. (abadger1999, 19:24:27)
    2. Proposal For community modules marked status=preview, leave it up to the maintainer whether to change params, whether to have deprecation period, etc. But params must stay compatible within a minor release series (example: all 2.4.x releases). Incompatible changes must be documented (abadger1999, 19:27:20)
    3. ACTION: abadger1999 to open a docs PR to get this documented in the module guidelines. (abadger1999, 19:43:21)

  3. Add more modules for command/shell warning: https://github.com/ansible/ansible/pull/25089 (abadger1999, 19:44:08)
    1. http://docs.ansible.com/ansible/latest/dev_guide/developing_modules_documenting.html#fields <= is part, we just dont have it all in 1, we have 'no features in minor releases also' (bcoca, 19:44:50)
    2. Not in favor of expanding the list of commands that get a warning to use a module instead. (abadger1999, 19:49:22)
    3. may talk about a config to toggle it or dynamically generating the list of (commands => modules) later. (abadger1999, 19:50:27)

  4. Moving url documentation to doc fragments, removing some params from the url argspec: https://github.com/ansible/ansible/pull/27738 (abadger1999, 19:53:19)
    1. change can't be made as written due to compatibility. Propose to dag that we discuss and implement a new urls apis or at the least a new, parallel url_arg_spec. (abadger1999, 20:02:20)

  5. Open floor (abadger1999, 20:03:17)


Meeting ended at 20:06:03 UTC (full logs).

Action items

  1. abadger1999 to search for the outtanding PRs on this feature and coordinate until something is merged.
  2. abadger1999 to open a docs PR to get this documented in the module guidelines.


Action items, by person

  1. abadger1999
    1. abadger1999 to search for the outtanding PRs on this feature and coordinate until something is merged.
    2. abadger1999 to open a docs PR to get this documented in the module guidelines.


People present (lines said)

  1. abadger1999 (90)
  2. bcoca (48)
  3. nitzmahone (23)
  4. kustodian (15)
  5. jimi|ansible (13)
  6. sdoran (11)
  7. misc (11)
  8. alikins (7)
  9. mikedlr (7)
  10. zodbot (5)
  11. jtanner (5)
  12. newswangerd (1)
  13. dag (0)


Generated by MeetBot 0.1.4.