ansible_pr_review_day
MINUTES

#ansible-community: Ansible PR review day

Meeting started by gundalow at 14:00:20 UTC (full logs).

Meeting summary

    1. What's this all about https://github.com/ansible/community/issues/407 (gundalow, 14:05:33)
    2. If you are new to the Ansible Community I invite you to review the Code of Conduct https://docs.ansible.com/ansible/latest/community/code_of_conduct.html (gundalow, 14:06:30)
    3. This is the first PR review day since we've had the collections in place (gundalow, 14:06:51)

  1. community.general (gundalow, 14:09:03)
    1. We will start with https://github.com/ansible-collections/community.general/pulls?q=is%3Apr+is%3Aopen+sort%3Acreated-asc (oldest PR first) (gundalow, 14:09:49)
    2. https://github.com/ansible-collections/community.general/pull/52 Add check_and_failed option to pacemaker_cluster module (gundalow, 14:10:08)
    3. https://github.com/ansible-collections/community.general/pull/53 Add pacemaker_resource module for managing cluster resources (gundalow, 14:15:22)
    4. https://github.com/ansible-collections/community.general/pull/85 [WIP] Refactor github* modules,Added tests for github_deploy_key (gundalow, 14:18:06)
    5. https://github.com/ansible-collections/community.general/pull/90 Add Thycotic DevOps Secrets Vault lookup plugin (gundalow, 14:27:45)
    6. https://github.com/ansible-collections/community.general/pull/91 Add the Thycotic Secret Server lookup plugin. (gundalow, 14:39:48)
    7. https://github.com/ansible-collections/community.general/pull/129 parted: Allow passing negative numbers to specify partition boundary relative to disk end (gundalow, 14:47:49)
    8. https://github.com/ansible-collections/community.general/pull/129/files#r441609961 (BhavyaM, 14:56:16)
    9. https://github.com/ansible-collections/community.general/pull/137 filesystem.py: fix xfs growfs (gundalow, 15:04:52)
    10. https://github.com/ansible-collections/community.general/pull/145 Add inventory alicloud_ecs (gundalow, 15:12:20)
    11. https://github.com/ansible-collections/community.general/pull/153 Return correct values when running yarn in check mode (gundalow, 15:13:06)
    12. https://github.com/ansible-collections/community.general/pull/169 (acozine, 15:49:24)
    13. https://github.com/ansible-collections/community.general/pull/175 add EfficientIP Device Manager dynamic inventory (gundalow, 16:04:51)
    14. ACTION: if 175 gets merged update BOTMETA to add to remote_management label & maintainers (gundalow, 16:06:00)
    15. https://www.efficientip.com/products/ (acozine, 16:13:10)
    16. https://github.com/ansible-collections/community.general/pull/209 cpanm: Honor version operators (gundalow, 16:17:46)
    17. ACTION: gundalow chase status of NIOS collection. Direct current PRs in c.general to new location (gundalow, 16:20:41)
    18. https://github.com/ansible-collections/community.general/pull/216 lxc_container: fix the type of the 'container_config' parameter (gundalow, 16:28:38)
    19. ACTION: rerun CI on c.general 216 (gundalow, 17:33:25)
    20. https://github.com/ansible-collections/community.general/pull/250 Handle negative integer values in osx_defaults (gundalow, 17:46:10)
    21. https://github.com/ansible-collections/community.general/pull/263 New merge lists plugin from a given key (gundalow, 17:48:17)
    22. https://github.com/ansible-collections/community.general/pull/267 Fixed flatpak module to accept a list of names to install/uninstall (gundalow, 17:54:41)


Meeting ended at 18:07:01 UTC (full logs).

Action items

  1. if 175 gets merged update BOTMETA to add to remote_management label & maintainers
  2. gundalow chase status of NIOS collection. Direct current PRs in c.general to new location
  3. rerun CI on c.general 216


Action items, by person

  1. gundalow
    1. gundalow chase status of NIOS collection. Direct current PRs in c.general to new location
  2. UNASSIGNED
    1. if 175 gets merged update BOTMETA to add to remote_management label & maintainers
    2. rerun CI on c.general 216


People present (lines said)

  1. gundalow (120)
  2. felixfontein (99)
  3. acozine (75)
  4. samccann (38)
  5. maxamillion (21)
  6. BhavyaM (14)
  7. zodbot (12)
  8. mattclay (11)
  9. bcoca (5)
  10. jtanner (3)
  11. gregdek (3)
  12. dennis_effa (3)
  13. shertel (2)
  14. resmo (2)
  15. cybette (2)


Generated by MeetBot 0.1.4.