gluster-meeting
MINUTES

#gluster-meeting Meeting

Meeting started by kshlm at 12:01:19 UTC (full logs).

Meeting summary

  1. Roll call (kshlm, 12:03:18)
  2. Last weeks AIs (kshlm, 12:06:19)
  3. kshlm to check back with misc on the new jenkins slaves (kshlm, 12:06:49)
  4. ndevos send out a reminder to the maintainers about more actively enforcing backports of bugfixes (kshlm, 12:08:01)
    1. ACTION: ndevos send out a reminder to the maintainers about more actively enforcing backports of bugfixes (kshlm, 12:09:19)

  5. raghu to call for volunteers and help from maintainers for doing backports listed by rwareing to 3.6.7 (kshlm, 12:09:40)
    1. ACTION: raghu to call for volunteers and help from maintainers for doing backports listed by rwareing to 3.6.7 (kshlm, 12:10:51)

  6. hagarth to post a tracking page on gluster.org for 3.8 by next week's meeting (kshlm, 12:11:14)
    1. ACTION: hagarth to post a tracking page on gluster.org for 3.8 by next week's meeting (kshlm, 12:12:22)

  7. rafi to setup a doodle poll for bug triage meeting (kshlm, 12:13:17)
    1. ACTION: rafi1 to setup a doodle poll for bug triage meeting (kshlm, 12:14:32)

  8. rastar and msvbhat to publish a test exit criterion for major/minor releases on gluster.org (kshlm, 12:14:53)
    1. ACTION: rastar and msvbhat to publish a test exit criterion for major/minor releases on gluster.org (kshlm, 12:16:20)

  9. jdarcy to send monthly update for NSR (kshlm, 12:16:33)
    1. ACTION: jdarcy to send monthly update for NSR (kshlm, 12:18:15)

  10. samikshan to send status on Gluster Eventing (kshlm, 12:18:45)
    1. ACTION: samikshan to send status on Gluster Eventing (kshlm, 12:19:14)

  11. atinm to put up the GlusterD 2.0 design doc by end of next week (kshlm, 12:19:36)
    1. ACTION: atinm/kshlm to put up the GlusterD 2.0 design doc by end of next week (kshlm, 12:20:57)

  12. more eyes needed on http://review.gluster.org/#/c/12321/ (kshlm, 12:21:25)
    1. The patch Shyam's experimental xlator change. (kshlm, 12:22:26)

  13. kshlm & csim to set up faux/pseudo user email for gerrit, bugzilla, github (kshlm, 12:24:16)
    1. ACTION: kshlm & csim to set up faux/pseudo user email for gerrit, bugzilla, github (kshlm, 12:25:23)

  14. atinm to send a mail to Manu asking his help on 3.6 BSD smoke failures (kshlm, 12:25:57)
    1. http://www.gluster.org/pipermail/gluster-devel/2015-November/thread.html#47085 (atinm, 12:29:04)
    2. http://www.gluster.org/pipermail/gluster-devel/2015-November/thread.html#47085 (kshlm, 12:29:20)
    3. ACTION: Need to decide if fixing BSD testing for release-3.6 is worth it. (kshlm, 12:33:37)

  15. raghu to send a note in ML to ignore BSD failures (kshlm, 12:33:55)
    1. https://www.gluster.org/pipermail/gluster-devel/2015-November/047082.html (kshlm, 12:35:38)

  16. GlusterFS 3.7 (kshlm, 12:36:14)
    1. 3.7.6 released (kshlm, 12:36:46)
    2. release-announcement https://www.gluster.org/pipermail/gluster-devel/2015-November/047152.html (kshlm, 12:37:33)
    3. https://bugzilla.redhat.com/show_bug.cgi?id=1279240 (rastar, 12:38:31)
    4. ACTION: rastar to close the glusterfs-3.7.6 tracker (kshlm, 12:40:20)

  17. Need release-manager for glusterfs-3.7.7 (kshlm, 12:40:55)
    1. ACTION: rastar Will call for volunteers for 3.7.7 release-manager (kshlm, 12:43:50)

  18. GlusterFS 3.6 (kshlm, 12:44:05)
    1. 3.6.7 on track for release on 20-Nov (kshlm, 12:45:19)

  19. GlusterFS 3.5 (kshlm, 12:47:29)
  20. GlusterFS-3.8/GlusterFS-4.0 (kshlm, 12:51:58)
    1. https://drive.google.com/file/d/0B_1LWY0UTlNiQTI0ZU9hWDJGdEk/view?usp=sharing (atinm, 12:57:24)
    2. DHT-2.0 hangout was held. More details at http://www.gluster.org/pipermail/gluster-devel/2015-November/047098.html (kshlm, 12:58:09)

  21. Open floor (kshlm, 12:58:21)
  22. Should  we have an LTS release? There is a community user who is currently  running 3.6 in production. They plan to use it long past its expected  EOL. They would like to see a LTS release, along the lines of, e.g., Ubuntu LTS. (kshlm, 12:59:04)
    1. http://www.gluster.org/community/documentation/index.php/Life_Cycle (JoeJulian, 13:04:28)
    2. ACTION: amye to get on top of disucssion on long-term releases. (kshlm, 13:08:30)

  23. Gartner is reporting that Gluster doesn't have a very active community, e.g. compared to Ceph. (kshlm, 13:08:59)
    1. AGREED: We should have regular review-triages to review community fixes. (kshlm, 13:15:32)
    2. ACTION: Need to discuss how we do review-triages (kshlm, 13:18:06)

  24. somewhat  related to the above, with all the new work going on for 4.0. We need  to make it a requirement that all new code get clean Coverity, cppcheck,  clang analyse, and valgrind runs before merging. (kshlm, 13:18:13)


Meeting ended at 13:21:32 UTC (full logs).

Action items

  1. ndevos send out a reminder to the maintainers about more actively enforcing backports of bugfixes
  2. raghu to call for volunteers and help from maintainers for doing backports listed by rwareing to 3.6.7
  3. hagarth to post a tracking page on gluster.org for 3.8 by next week's meeting
  4. rafi1 to setup a doodle poll for bug triage meeting
  5. rastar and msvbhat to publish a test exit criterion for major/minor releases on gluster.org
  6. jdarcy to send monthly update for NSR
  7. samikshan to send status on Gluster Eventing
  8. atinm/kshlm to put up the GlusterD 2.0 design doc by end of next week
  9. kshlm & csim to set up faux/pseudo user email for gerrit, bugzilla, github
  10. Need to decide if fixing BSD testing for release-3.6 is worth it.
  11. rastar to close the glusterfs-3.7.6 tracker
  12. rastar Will call for volunteers for 3.7.7 release-manager
  13. amye to get on top of disucssion on long-term releases.
  14. Need to discuss how we do review-triages


Action items, by person

  1. atinm
    1. atinm/kshlm to put up the GlusterD 2.0 design doc by end of next week
  2. jdarcy
    1. jdarcy to send monthly update for NSR
  3. kshlm
    1. atinm/kshlm to put up the GlusterD 2.0 design doc by end of next week
    2. kshlm & csim to set up faux/pseudo user email for gerrit, bugzilla, github
  4. msvbhat
    1. rastar and msvbhat to publish a test exit criterion for major/minor releases on gluster.org
  5. ndevos
    1. ndevos send out a reminder to the maintainers about more actively enforcing backports of bugfixes
  6. raghu
    1. raghu to call for volunteers and help from maintainers for doing backports listed by rwareing to 3.6.7
  7. rastar
    1. rastar and msvbhat to publish a test exit criterion for major/minor releases on gluster.org
    2. rastar to close the glusterfs-3.7.6 tracker
    3. rastar Will call for volunteers for 3.7.7 release-manager
  8. UNASSIGNED
    1. hagarth to post a tracking page on gluster.org for 3.8 by next week's meeting
    2. rafi1 to setup a doodle poll for bug triage meeting
    3. samikshan to send status on Gluster Eventing
    4. Need to decide if fixing BSD testing for release-3.6 is worth it.
    5. amye to get on top of disucssion on long-term releases.
    6. Need to discuss how we do review-triages


People present (lines said)

  1. kshlm (173)
  2. atinm (31)
  3. kkeithley (31)
  4. rastar (17)
  5. jdarcy (13)
  6. Humble (12)
  7. raghu (10)
  8. JoeJulian (4)
  9. obnox (3)
  10. ndevos (3)
  11. overclk_ (3)
  12. bluenemo (2)
  13. rjoseph (2)
  14. zodbot (2)
  15. msvbhat (1)
  16. asengupt (1)
  17. jiffin (1)


Generated by MeetBot 0.1.4.