gluster-meeting
LOGS
12:01:19 <kshlm> #startmeeting
12:01:19 <zodbot> Meeting started Wed Nov 18 12:01:19 2015 UTC.  The chair is kshlm. Information about MeetBot at http://wiki.debian.org/MeetBot.
12:01:19 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
12:01:47 <kshlm> Welcome everyone to the weekly Gluster community meeting.
12:02:00 <kshlm> Today's agenda is available at https://public.pad.fsfe.org/p/gluster-community-meetings as always.
12:02:13 <kshlm> I'll appreciate if someone could set it as the topic.
12:03:14 <kshlm> Let's have a roll-call
12:03:18 <kshlm> #topic Roll call
12:03:20 * atinm is here
12:03:26 * obnox is here
12:03:29 <rjoseph> rjoseph is here
12:03:31 * msvbhat is present
12:03:36 * rjoseph is here
12:03:44 * Humble is here
12:03:56 * raghu is here
12:04:14 <kshlm> I'll wait 1 more minute for people to show up.
12:04:46 * overclk_ is here
12:05:33 * jdarcy isn't.
12:05:36 <bluenemo> hi
12:05:55 <kshlm> Hey bluenemo. Welcome to the meeting.
12:06:04 * jiffin is here
12:06:13 <kshlm> Okay, enough waiting. Let's have the meeting.
12:06:19 <kshlm> #topic Last weeks AIs
12:06:20 <bluenemo> I'm not new anymore to gluster installation and now run one in production. nice to be here :)
12:06:49 <kshlm> #topic kshlm to check back with misc on the new jenkins slaves
12:07:16 * rastar joins now
12:07:39 <kshlm> I've asked csim to publish the salt-configs he's using for the slave, so I can help with it.
12:07:51 <kshlm> I'll continue working with him on this.
12:08:01 <kshlm> #topic ndevos send out a reminder to the maintainers about more actively enforcing backports of bugfixes
12:08:16 <kshlm> ndevos, You around?
12:08:33 <ndevos> kshlm: just leaving now, and no, I didnt do that AI :-/
12:08:36 <kshlm> I've not seen this reminder (or at-least don't remember seeing it).
12:08:44 <Humble> bluenemo, cool :)
12:08:47 <kshlm> ndevos, carry it forward?
12:09:06 <ndevos> kshlm: yeah, I'm practising the backport bit and making sure its documented well
12:09:16 <kshlm> ndevos, cool
12:09:19 <kshlm> #action ndevos send out a reminder to the maintainers about more actively enforcing backports of bugfixes
12:09:40 <kshlm> #topic raghu to call for volunteers and help from maintainers for doing backports listed by rwareing to 3.6.7
12:09:56 * ndevos drops off the internetz
12:09:57 <kshlm> raghu, I've not seen this mail.
12:10:19 <raghu> kshlm: can we please carry forward this AI to next week?
12:10:44 * asengupt is here
12:10:45 <kshlm> raghu, cool. Will you be here next week though?
12:10:51 <kshlm> #action raghu to call for volunteers and help from maintainers for doing backports listed by rwareing to 3.6.7
12:10:55 <raghu> kshlm: yes
12:11:14 <kshlm> #topic hagarth to post a tracking page on gluster.org for 3.8 by next week's meeting
12:11:17 <kshlm> raghu, cool
12:11:32 <kshlm> hagarth isn't here.
12:12:06 <kshlm> He was probably too busy the last couple of weeks to do this.
12:12:11 <jdarcy> It's a little early for him now, and what with jet lag etc.   ;)
12:12:18 <kshlm> Carrying this forward as well.
12:12:22 <kshlm> #action hagarth to post a tracking page on gluster.org for 3.8 by next week's meeting
12:13:09 <kshlm> jdarcy, He did have 2 weeks since the last meeting to do it. But he's been really busy.
12:13:17 <kshlm> #topic rafi to setup a doodle poll for bug triage meeting
12:13:31 <kshlm> rafi1, ?
12:14:23 <kshlm> He isn't around. Carrying this forward as well.
12:14:32 <kshlm> #action rafi1 to setup a doodle poll for bug triage meeting
12:14:53 <kshlm> #topic rastar and msvbhat to publish a test exit criterion for major/minor releases on gluster.org
12:15:17 <kshlm> rastar, msvbhat, your turn
12:15:32 <rastar> we had the design talk last week
12:15:40 <rastar> I am still preparing the doc
12:15:47 <rastar> will send it by tomorrow
12:16:10 <kshlm> rastar, thanks. I'll keep this AI open.
12:16:20 <kshlm> #action rastar and msvbhat to publish a test exit criterion for major/minor releases on gluster.org
12:16:33 <kshlm> #topic jdarcy to send monthly update for NSR
12:16:49 <jdarcy> Um, yeah, I guess I didn't do that.  <hangs head>
12:17:09 <kshlm> Well, you were presenting at LISA last week.
12:17:13 <jdarcy> I'll do it after we sync up (after this meeting).
12:17:22 <kshlm> jdarcy, Cool.
12:17:30 <kshlm> Shall I keep the AI?
12:17:39 <obnox> jdarcy: too occupied with running?... ;-)
12:17:51 <atinm> obnox, :)
12:17:53 <jdarcy> Yeah, that's it.  ;)
12:18:04 <jdarcy> Yes, might as well keep the AI for now.
12:18:12 <kshlm> jdarcy, thanks.
12:18:15 <kshlm> #action jdarcy to send monthly update for NSR
12:18:45 <kshlm> #topic samikshan to send status on Gluster Eventing
12:19:04 <kshlm> I don't see samikshan around.
12:19:10 <kshlm> I'll carry this forward.
12:19:14 <kshlm> #action samikshan to send status on Gluster Eventing
12:19:18 <atinm> kshlm, I'll ask samikshan to send it
12:19:36 <kshlm> #topic atinm to put up the GlusterD 2.0 design doc by end of next week
12:20:10 <kshlm> We're in the process of finishing the document.
12:20:21 <atinm> kshlm, well, me & kshlm are still working on this, the holidays in India haven't helped much to keep up the same space
12:20:38 <atinm> We expect it to be up for review by end of this week
12:20:42 <kshlm> Yup.
12:20:53 <atinm> s/space/pace
12:20:57 <kshlm> #action atinm/kshlm to put up the GlusterD 2.0 design doc by end of next week
12:21:25 <kshlm> #topic more eyes needed on http://review.gluster.org/#/c/12321/
12:22:02 <kshlm> This is Shyams experimental xlators patch.
12:22:04 <atinm> kshlm, I believe now this patch is mergable
12:22:20 <overclk_> kshlm: the patch has got couple of +1s..
12:22:26 <kshlm> #info The patch Shyam's experimental  xlator change.
12:22:46 <kshlm> overclk_, Yes. I see that. Does it require any more reviews?
12:23:00 <atinm> jdarcy, would you want to have a final look at it and merge this patch?
12:23:09 <overclk_> kshlm: If noone else has any other objection, it should be good to go..
12:23:16 <jdarcy> Doesn't need any more reviews now.  ;)
12:23:37 <kshlm> jdarcy, overclk_, thanks
12:24:03 <kshlm> This was our first non-carry forwarded AI this week
12:24:16 <kshlm> #topic kshlm & csim to set up faux/pseudo user email for gerrit, bugzilla, github
12:24:18 <jdarcy> Should we add an action item to retire more action items?
12:25:00 <kshlm> This wasn't done. The mailing list discussion just fizzled off.
12:25:08 <kshlm> I'll carry this forward as well.
12:25:23 <kshlm> #action kshlm & csim to set up faux/pseudo user email for gerrit, bugzilla, github
12:25:36 <kshlm> jdarcy, We should!
12:25:57 <kshlm> #topic atinm to send a mail to Manu asking his help on 3.6 BSD smoke failures
12:26:06 <kshlm> atinm, Any updates?
12:26:16 <atinm> kshlm, I did that
12:26:23 * atinm is looking for the mail thread
12:26:26 <kshlm> atinm, and?
12:26:55 <kshlm> I think we weren't supposed to be running BSD tests for 3.6.
12:27:11 <kshlm> The test-infra changes weren't backported to 3.6 IIRC.
12:27:15 <atinm> Manu confirmed that we are still not considering bsd smoke votes as lot of backports are missing from 3.6 branch related to netbsd fixes
12:27:34 <kshlm> atinm, Thanks.
12:27:37 <atinm> so we can continue to merge the patches in 3.6 ignoring freebsd smoke failures
12:27:59 <atinm> however the question remains open whether we'd spend effort backporting all those fixes in 3.6
12:28:21 <kshlm> atinm, was this discussion happening?
12:28:27 <kshlm> In the mail thread I mean.
12:29:04 <atinm> http://www.gluster.org/pipermail/gluster-devel/2015-November/thread.html#47085
12:29:20 <kshlm> #info http://www.gluster.org/pipermail/gluster-devel/2015-November/thread.html#47085
12:29:48 <atinm> Post this I haven't followed up on this
12:29:58 <kshlm> Do you want to follow up?
12:29:58 <jdarcy> FWIW, I've also run into at least one problem that exists only on NetBSD 7 (not 6).  We need to get on top of NetBSD stuff or it's only going to keep getting worse and obstructing more patches.
12:30:18 <kshlm> jdarcy, Is this for 3.6 or later?
12:30:25 <jdarcy> kshlm: On master.
12:31:15 <kshlm> jdarcy, then I suppose the tests on master are working.
12:31:33 <jdarcy> Mostly, yes.
12:31:44 <kshlm> The trouble was with 3.6 requiring a lot of backports to get the netbsd tests to work.
12:32:01 <kshlm> atinm, Do you want to continue this discussion?
12:32:44 <atinm> kshlm, I would urge for someone else to volunteer if possible
12:32:53 * kshlm thinks the next AI can be closed as well. Seeing as it was raghu's mail thread where atinm started the discussion.
12:33:14 <kshlm> atinm, I'll add an open ai then.
12:33:35 <atinm> kshlm, sure
12:33:37 <kshlm> #action Need to decide if fixing BSD testing for release-3.6 is worth it.
12:33:55 <kshlm> #topic raghu to send a note in ML to ignore BSD failures
12:34:19 <kshlm> raghu, This is done I suppose.
12:34:43 <raghu> kshlm: yes. I have started a mail thread about it
12:35:02 <kshlm> raghu, is this it https://www.gluster.org/pipermail/gluster-devel/2015-November/047082.html
12:35:29 <raghu> kshlm: yes
12:35:34 <kshlm> Thank you.
12:35:38 <kshlm> #info https://www.gluster.org/pipermail/gluster-devel/2015-November/047082.html
12:35:58 <kshlm> We are done with last weeks AIs.
12:36:08 <kshlm> On to the releases.
12:36:14 <kshlm> #topic GlusterFS 3.7
12:36:24 <kshlm> rastar, You're time to shine.
12:36:33 <rastar> Glusterfs 3.7.6 was released!
12:36:33 <kshlm> s/You're/Your/
12:36:46 <kshlm> #info 3.7.6 released
12:36:49 <rastar> A total of 57 bugs fixed
12:36:59 <rastar> Most of them from tiering
12:37:15 <rastar> It is getting into good state
12:37:33 <kshlm> #info release-announcement https://www.gluster.org/pipermail/gluster-devel/2015-November/047152.html
12:37:38 <kshlm> rastar, Awesome!
12:37:38 <rastar> We need some one to volunteer for next release
12:37:55 <rastar> I won't available in first week of next month
12:37:57 <kshlm> Thanks for bringing this up.
12:38:07 <kshlm> So any volunteers?
12:38:12 <rastar> I have created tracker for 3.7.7
12:38:16 <Humble> rastar, can u please send the release note patch to glusterdocs ?
12:38:17 <kkeithley> the 3.7.6 tracker BZ needs to be closed!
12:38:31 <rastar> https://bugzilla.redhat.com/show_bug.cgi?id=1279240
12:38:52 <rastar> Humble: Oh!, I sent it in glusterfs/docs
12:39:07 <rastar> Humble: will send in glusterfsdocs too
12:39:16 <rastar> and kkeithley thanks! forgot to do that.
12:39:16 <kshlm> rastar, kkeithley is right. You're work isn't done yet.
12:39:18 <Humble> rastar++ thanks !!!
12:39:47 <kkeithley> I'd have closed it, but didn't want to step on anyone's toes
12:39:52 <kkeithley> ;-)
12:40:01 <rastar> kkeithley: :)
12:40:20 <kshlm> #action rastar to close the glusterfs-3.7.6 tracker
12:40:28 <kshlm> rastar, you now have an AI.
12:40:44 <kshlm> Back to the topic of volunteers.
12:40:55 <kshlm> #topic Need release-manager for glusterfs-3.7.7
12:41:05 <kshlm> So anyone willing to do this?
12:41:43 <kshlm> Any of the maintainers should be able to do this.
12:42:14 <atinm> kshlm, probably people can think about it for another week and get back by next week's meeting? we can carry forward this action item
12:42:27 <kshlm> I'll carry this forward.
12:42:44 <kshlm> atinm, Willing to send out a call for volunteers?
12:43:09 <kshlm> Or I think rastar better do it, he's the current manager.
12:43:19 <rastar> kshlm: sure
12:43:26 <atinm> rastar, thanks ;)
12:43:50 <kshlm> #action rastar Will call for volunteers for 3.7.7 release-manager
12:44:05 <kshlm> #topic GlusterFS 3.6
12:44:11 <kshlm> raghu,
12:44:22 <raghu> I will be doing 3.6.7 on 20th
12:44:34 <raghu> I have merged some patches.
12:44:56 <kshlm> I don't suppose that list includes the ones suggested by rwareing?
12:45:07 <atinm> raghu, there were couple of patches from glusterd where you wanted my acks
12:45:07 <raghu> kshlm: nope
12:45:16 <atinm> raghu, acks are available now
12:45:19 <raghu> atinm: yes. I have merged them
12:45:19 <kshlm> #info 3.6.7 on track for release on 20-Nov
12:45:28 <atinm> raghu, awesome, thanks
12:45:44 <kkeithley> I will be calling for volunteers to do packages.
12:46:01 <kkeithley> fair warning
12:46:26 <kkeithley> ugh, Friday. I'll be on PTO
12:46:50 <kshlm> kkeithley, You should be okay there. 3.7.6 packaging was done by the volunteers.
12:47:02 <kshlm> raghu, anything else to add?
12:47:22 <raghu> kshlm: nope
12:47:26 <kshlm> Thanks.
12:47:29 <kshlm> #topic GlusterFS 3.5
12:47:47 <kshlm> ndevos isn't around.
12:48:08 <kshlm> We're still waiting to do a 3.5.7 release.
12:48:28 <kshlm> I don't think anyone has something to add here.
12:48:51 <kkeithley> haven't seen any commits to release-3.5 since Nov 9
12:49:10 <kshlm> release-3.5 is pretty stable then.
12:49:28 <kkeithley> or nobody is doing (or asking for) backports
12:50:06 <kshlm> kkeithley, release-3.5 is pretty stable then. ;-)
12:50:11 <kkeithley> I have a feeling that we don't have a good, accountable way to ask for backports.
12:50:24 <Humble> kkeithley, u r correct
12:50:59 <kshlm> Let's have a seperate discussion on this later.
12:51:54 <Humble> we should have a better workflow on this.. yeah, lets discuss it later
12:51:58 <kshlm> #topic GlusterFS-3.8/GlusterFS-4.0
12:52:17 <kshlm> Clubbing these two together because of the time remaining.
12:52:25 <kshlm> Any updates?
12:53:01 <atinm> From GlusterD 2.0 we have got some reviews on the basic ReST APIs
12:53:10 <atinm> design doc is in progress
12:53:23 <kkeithley> sorry, I'm slow. 3.5.6 was released on 2015-09-18. There have been four commits since then: 2015-09-28, 2015-10-12, 2015-10-26, and 2015-11-09.  We should/could have a 3.5 release any time
12:53:50 <atinm> We'd be also starting the design/discussion on txn framework pretty soon
12:54:10 <atinm> over to other initiative owners for their updates
12:54:13 <kshlm> atinm, Thanks for that update.
12:54:54 <kshlm> jdarcy, "work continues"?
12:55:21 <kshlm> I'll take that as a yes.
12:55:26 <jdarcy> Pretty much.  I've made a bunch of progress on the journal stuff.
12:55:41 <kshlm> Thanks jdarcy.
12:55:50 <kshlm> We don't have hagarth for 3.8 updates.
12:55:52 <atinm> kshlm, DHT 2 had done a hang out session on their progress as well
12:55:53 <jdarcy> Apparently Avra got pulled in to some snapshot stuff, so was mostly unavailable for 4.0 work.
12:56:11 <kshlm> atinm, Cool. I forgot about that.
12:56:25 <kshlm> Do we have a recorded video of that?
12:56:46 <atinm> we do
12:57:00 <kshlm> Link?
12:57:24 <atinm> https://drive.google.com/file/d/0B_1LWY0UTlNiQTI0ZU9hWDJGdEk/view?usp=sharing
12:57:38 <kshlm> Huh this was a bluejeans meeting!?
12:57:41 <atinm> Rather all the details are here : http://www.gluster.org/pipermail/gluster-devel/2015-November/047098.html
12:58:09 <kshlm> #info DHT-2.0 hangout was held. More details at  http://www.gluster.org/pipermail/gluster-devel/2015-November/047098.html
12:58:17 <kshlm> Onto Open floor
12:58:21 <kshlm> #topic Open floor
12:58:43 * atinm is switching to another meeting
12:58:56 <kshlm> Lots of topics here.
12:59:04 <kshlm> #topic Should  we have an LTS release? There is a community user who is currently  running 3.6 in production. They plan to use it long past its expected  EOL. They would like to see a LTS release, along the lines of, e.g., Ubuntu LTS.
12:59:20 <kshlm> Who added this?
12:59:32 <kkeithley> me. probably a question for Amye and the board as much as anything
13:00:00 <kkeithley> but maybe other people have an opinion?
13:00:00 <kshlm> So what do we need to do?
13:00:26 <kkeithley> does anyone think it's a bad idea? If so, why?
13:00:54 <kshlm> How long would this release need to be supported?
13:00:57 <kkeithley> And even if it's a good idea it doesn't necessarily mean it will happen, but we ought to have the discussion
13:01:49 <kshlm> Going by our current release cycle, we support a release branch for ~2 years.
13:01:55 <Humble> kkeithley, do they want support in terms of bug fixes ?
13:02:02 <kshlm> How much longer would the LTS need to be supported?
13:02:14 * obnox off for another meeting
13:02:39 <kkeithley> the point is that it would be actively maintained. The extra duration is something to be determined.
13:02:52 <kkeithley> actively maintained == bug fixes
13:03:21 <JoeJulian> I proposed that once. Got no traction.
13:04:12 <kshlm> kkeithley, would get this discussion started with the board?
13:04:22 <kkeithley> okay, well, I brought it up. I think the ball is in Amye's court now.
13:04:28 <JoeJulian> http://www.gluster.org/community/documentation/index.php/Life_Cycle
13:05:59 <kshlm> JoeJulian, That was quite a while back!
13:06:20 <JoeJulian> I was chuckling at 4.0 being on the horizon back then.
13:07:30 <kshlm> kkeithley, so we need to get Amye to reply back on this?
13:07:42 <kkeithley> yes
13:07:51 <kshlm> kkeithley, Okay.
13:08:08 <kshlm> Adding an AI on Amye then. I'll ping her after the meeting.
13:08:30 <kshlm> #action amye to get on top of disucssion on long-term releases.
13:08:54 <kshlm> Next topic!
13:08:59 <kshlm> #topic Gartner is reporting that Gluster doesn't have a very active community, e.g. compared to Ceph.
13:09:25 <kkeithley> that chart showing stable (critical and security fixes into 2017 for 3.4 makes me.... laugh. and cry)
13:09:54 <kshlm> kkeithley, :)
13:10:00 <kshlm> So what do we do about this?
13:10:01 <kkeithley> yes, that's me again. ;-)
13:10:35 <Humble> kkeithley, can u share the reference ? :)
13:10:37 <kkeithley> dunno.  I just want to make people aware of it.  If you go through all the reviews there are some fixes from the community that have languised for over a year
13:10:56 <kkeithley> I'll see if I can get a pointer to it from Sayan
13:11:06 <Humble> oh..ok. nw :)
13:11:10 <kkeithley> languished
13:12:43 <kshlm> I propose we have regular meetings to checkout these sorts of reviews, along the lines of bug-triages.
13:12:58 <kkeithley> It's a rare thing when people actually send patches. We should reward them. Not punish them by ignoring them.
13:13:20 <kshlm> The bug-triage meetings have helped a lot IMO.
13:13:30 <kshlm> kkeithley, Agree with that.
13:14:02 <kkeithley> yes, +1 for bug triage. If we don't spend the whole hour on bugs, maybe we can triage reviews too in the same meeting.
13:14:21 <Humble> also we need to be responsive in irc channels
13:14:27 <kshlm> That would be nice.
13:14:45 <JoeJulian> +1
13:14:49 <Humble> kkeithley, first of all we need participation
13:14:51 <Humble> :)
13:15:03 <kshlm> So we agree on having review-triages?
13:15:32 <kshlm> #agree We should have regular review-triages to review community fixes.
13:15:47 <kkeithley> I like the idea, although I'm reluctant to suggest yet-another-meeting-that-will-take-an-hour-of-people's-time.
13:16:08 <kshlm> We could do this as you suggested along with the bug-triages.
13:16:09 <kkeithley> another-hour
13:16:56 <kshlm> Let's get the details on how we do this, worked out after this meeting.
13:17:07 <kshlm> We're 1 minutes overtime.
13:17:26 <kkeithley> sure
13:17:35 <kshlm> s/1/15/
13:18:06 <kshlm> #action Need to discuss how we do review-triages
13:18:13 <kshlm> #topic somewhat  related to the above, with all the new work going on for 4.0. We need  to make it a requirement that all new code get clean Coverity, cppcheck,  clang analyse, and valgrind runs before merging.
13:18:18 <kshlm> kkeithley, you again?
13:18:22 <kkeithley> yup
13:18:31 <kkeithley> we can defer to next week if you want
13:19:24 <kkeithley> since we're long past the hour
13:19:45 <kshlm> kkeithley, Okay. Cool.
13:20:07 <kshlm> Let's also have take the next topic over to next week.
13:20:23 <kshlm> Thanks for attending todays meeting everyone.
13:20:35 <kshlm> And a reminder to everyone
13:21:03 <kshlm> Please add your selves in the Gluster attendance of events: https://public.pad.fsfe.org/p/gluster-events etherpad if you're attending any conferences.
13:21:17 <kshlm> And put (even minor) interesting topics on https://public.pad.fsfe.org/p/gluster-weekly-news
13:21:29 <kshlm> Thanks again.
13:21:32 <kshlm> #endmeeting