fedora-meeting
MINUTES

#fedora-meeting Meeting

Meeting started by quaid at 14:02:45 UTC (full logs).

Meeting summary

  1. Summer Coding 2010 - opening moments ... (quaid, 14:03:31)
    1. https://fedoraproject.org/wiki/Summer_Coding_SIG#Agenda (quaid, 14:04:11)

  2. Questions to cover in review of messaging index. (quaid, 14:10:27)
  3. Message page review - https://fedoraproject.org/wiki/Summer_Coding_2010_plan (quaid, 14:20:01)
    1. https://fedoraproject.org/wiki/Summer_Coding_2010_plan (Southern_Gentlem, 14:27:54)
    2. ACTION: see if we can include an LWN subscription for students (quaid, 14:29:14)
    3. ACTION: Students need to know that we won't know how much money per student for a few weeks; it has to do with strength of proposals and size of funding pool. (quaid, 14:31:00)
    4. ACTION: fix link to ideas in plan page (quaid, 14:32:03)
    5. ACTION: add section to student messaging that better covers the value to My Future of FOSS contributions (quaid, 14:38:32)
    6. http://fedoraproject.org/wiki/SummerOfCode (Southern_Gentlem, 14:38:37)
    7. ACTION: student messaging needs to cover that FOSS contrib is accessible to all, not just scary super genii (quaid, 14:39:26)
    8. ACTION: [[SummerOfCode]] goes to a page [[Summer coding]] that should be merged in to [[Summer Coding SIG]] and then both made a redirect to that page. (quaid, 14:41:02)
    9. ACTION: ASAP student messaging needs to address that our program this year isn't going to cover all their needs with the same certainty that GSoC or an internship does; we're like GSoC first year, but less budget. (quaid, 14:43:29)
    10. ACTION: students need to know we're planning on doing this again in the future, so if the first round doesn't fit them, they should come back next year (and maybe help us patch the program in the meantime). (mchua, 14:45:19)
    11. ACTION: make sure student messaging is reassuring and certain - "this scaffolding *will* be built, and stable enough for you to climb upon." (mchua, 14:50:01)
    12. https://fedoraproject.org/wiki/Summer_Coding_2010_plan#Mentors_-_what (quaid, 14:51:22)
    13. https://fedoraproject.org/wiki/Summer_Coding_2010_plan#Sponsoring_orgs_-_what (quaid, 14:51:34)
    14. ACTION: reach students via professors and other mentor-type people when possible (mchua, 14:52:58)
    15. https://fedoraproject.org/wiki/Summer_Coding_2010_timeline (quaid, 14:54:05)
    16. ACTION: make sure mentor understands their time commitment needed - and whether communications with the student will be push or pull from their side (mchua, 14:54:10)
    17. https://fedoraproject.org/wiki/Summer_Coding_2010 (quaid, 14:55:57)
    18. ACTION: make sure mentor is confident about the reliability of student - either by knowing the student or trusting the person responsible for keeping everyone on track during the summer (in GSoC, that's the project admin). (mchua, 14:58:57)
    19. http://meetbot.fedoraproject.org/fedora-meeting/2010-04-07/fedora-meeting.2010-04-07-14.02.log.txt (quaid, 15:02:52)
    20. https://fedoraproject.org/wiki/Summer_Coding_2010_plan#Sponsoring_organizations (quaid, 15:03:32)
    21. ACTION: make sure mentors know what they'll get from it ("reliable contributor help for N weeks"? access to certain resources to help with project planning? learn-how-to-manage?) (mchua, 15:04:47)
    22. https://fedoraproject.org/wiki/Summer_Coding_2010_plan#Sub-projects (quaid, 15:08:44)
    23. ACTION: Create new "You are an academic" section for [[Summer Coding 2010]] based on new messaging (quaid, 15:15:43)

  4. Message page review - https://fedoraproject.org/wiki/Category:Summer_Coding_2010_ideas (quaid, 15:22:23)
  5. Page review - https://fedoraproject.org/wiki/Summer_Coding_2010_schedule (quaid, 15:32:29)
    1. https://fedoraproject.org/wiki/Summer_Coding_2010_timeline (quaid, 15:38:47)
    2. ACTION: adjust schedule to open idea window to 14 April and proposals to 21 April (quaid, 15:41:53)
    3. ACTION: reannounce idea update to devel hannels (quaid, 15:42:19)
    4. ACTION: student messaging - make it clear we are doing the best schedule on this notice, but keep tuned for updates in this year -- we may add proposal and work rounds to accomodate other school schedules, etc. (quaid, 15:43:41)

  6. Page review (last one) - https://fedoraproject.org/wiki/Summer_Coding_2010_student_application (quaid, 15:44:05)
    1. https://fedoraproject.org/wiki/Communication_for_Summer_Coding_2010 (quaid, 15:44:39)
    2. https://fedoraproject.org/wiki/How_to_create_an_idea_page_for_Summer_Coding (quaid, 15:44:46)
    3. https://fedoraproject.org/wiki/Category:Summer_Coding_2010 (quaid, 15:44:58)
    4. https://fedoraproject.org/wiki/Summer_Coding_2010_timeline (quaid, 15:45:10)
    5. ACTION: fix sub-sectioning of student app to put all on same level (quaid, 15:49:26)
    6. ACTION: make language about preferred language less certain - we may be able to, etc. (quaid, 15:50:03)
    7. ACTION: == About your project == needs to specify a link back to an idea page, if it exists, plus any discussions with mentor(s) (quaid, 15:50:57)
    8. ACTION: == About your project == should specify in point 3 they need a mentor fully aware of why and supportive if code is not "mostly working" by mid-term; it can be OK if it's not mostly working as long as it is not a surprise to the mentor and there is a plan between mentor and student to rectify. (quaid, 15:53:45)
    9. ACTION: == You and the community == Trick question in #2 and #3? our plan includes clued mentor, but maybe good to hear student's thoughts, kind of scary question. Also, we are requiring blogging, so we should say, "In addition to the required at-least 2x/week blog post, how else do you plan on keeping the community informed ...? example, test days, etc." (quaid, 15:55:44)
    10. ACTION: == Misc... == Expand on development environment; include that we want them to engage with the community early and often. (quaid, 15:56:20)
    11. ACTION: can we make it more clear how to use talk pages and watch preferences? is there a canonical how-to page? if not, write it and reference. (quaid, 15:57:22)


Meeting ended at 15:59:54 UTC (full logs).

Action items

  1. see if we can include an LWN subscription for students
  2. Students need to know that we won't know how much money per student for a few weeks; it has to do with strength of proposals and size of funding pool.
  3. fix link to ideas in plan page
  4. add section to student messaging that better covers the value to My Future of FOSS contributions
  5. student messaging needs to cover that FOSS contrib is accessible to all, not just scary super genii
  6. [[SummerOfCode]] goes to a page [[Summer coding]] that should be merged in to [[Summer Coding SIG]] and then both made a redirect to that page.
  7. ASAP student messaging needs to address that our program this year isn't going to cover all their needs with the same certainty that GSoC or an internship does; we're like GSoC first year, but less budget.
  8. students need to know we're planning on doing this again in the future, so if the first round doesn't fit them, they should come back next year (and maybe help us patch the program in the meantime).
  9. make sure student messaging is reassuring and certain - "this scaffolding *will* be built, and stable enough for you to climb upon."
  10. reach students via professors and other mentor-type people when possible
  11. make sure mentor understands their time commitment needed - and whether communications with the student will be push or pull from their side
  12. make sure mentor is confident about the reliability of student - either by knowing the student or trusting the person responsible for keeping everyone on track during the summer (in GSoC, that's the project admin).
  13. make sure mentors know what they'll get from it ("reliable contributor help for N weeks"? access to certain resources to help with project planning? learn-how-to-manage?)
  14. Create new "You are an academic" section for [[Summer Coding 2010]] based on new messaging
  15. adjust schedule to open idea window to 14 April and proposals to 21 April
  16. reannounce idea update to devel hannels
  17. student messaging - make it clear we are doing the best schedule on this notice, but keep tuned for updates in this year -- we may add proposal and work rounds to accomodate other school schedules, etc.
  18. fix sub-sectioning of student app to put all on same level
  19. make language about preferred language less certain - we may be able to, etc.
  20. == About your project == needs to specify a link back to an idea page, if it exists, plus any discussions with mentor(s)
  21. == About your project == should specify in point 3 they need a mentor fully aware of why and supportive if code is not "mostly working" by mid-term; it can be OK if it's not mostly working as long as it is not a surprise to the mentor and there is a plan between mentor and student to rectify.
  22. == You and the community == Trick question in #2 and #3? our plan includes clued mentor, but maybe good to hear student's thoughts, kind of scary question. Also, we are requiring blogging, so we should say, "In addition to the required at-least 2x/week blog post, how else do you plan on keeping the community informed ...? example, test days, etc."
  23. == Misc... == Expand on development environment; include that we want them to engage with the community early and often.
  24. can we make it more clear how to use talk pages and watch preferences? is there a canonical how-to page? if not, write it and reference.


People present (lines said)

  1. quaid (188)
  2. mchua (76)
  3. dgilmore (19)
  4. jreznik (10)
  5. rvokal (8)
  6. Southern_Gentlem (5)
  7. skvidal (4)
  8. dash123 (3)
  9. zodbot (3)
  10. maploin (1)
  11. sankarshan (1)


Generated by MeetBot 0.1.4.