fedora-meeting
LOGS
14:02:45 <quaid> #startmeeting
14:02:46 <zodbot> Meeting started Wed Apr  7 14:02:45 2010 UTC.  The chair is quaid. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:02:47 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
14:03:31 <quaid> #topic Summer Coding 2010 - opening moments ...
14:04:11 <quaid> #link https://fedoraproject.org/wiki/Summer_Coding_SIG#Agenda
14:05:22 <quaid> Cool, we have a special beat in FWN for a few weeks.
14:06:11 <quaid> who is here for the Summer Coding SIG meeting?
14:06:26 * dgilmore 
14:07:50 <quaid> ok, we'll wait another few moments ...
14:07:53 * maploin says hi!
14:08:04 * sankarshan is lurking
14:10:27 <quaid> #topic Questions to cover in review of messaging index.
14:11:17 <quaid> what I am interested in for this meeting and beyond is a check of the messaging material, then unleash people to start spreading the word to various audiences.
14:11:33 <quaid> #  Does it make sense for the target audience?
14:11:34 <quaid> # Is it complete?
14:11:34 <quaid> # Is it too much?
14:11:34 <quaid> # What needs fixing?
14:11:39 <quaid> any other questions we should be asking?
14:12:12 <quaid> then we can go over each page in the list (ref. agenda) and make actions for each still to do on that page.
14:12:46 <quaid> each action is codeworded for ASAP or TRAC, depending on if it's critical path for releasing the message today or an overall program task we need to get in the tracker.
14:14:12 * mchua looks up
14:14:20 <mchua> gah! Sorry. Was in the wrong meeting channel (#fedora-meeting-1).
14:14:38 <quaid> mchua: anything you want to add to the questions we ponder?
14:14:59 <mchua> quaid: Not at the moment.
14:15:11 <quaid> to answer mchua from the other channel
14:15:22 <quaid> 1. we finish this meeting with actions to do ASAP
14:15:31 <quaid> 2. we do those actions ASAP, within the next few hours
14:15:37 <quaid> 3. we unleash the message on the world
14:15:51 <quaid> so, yeah, we can tell students realsoon
14:16:30 <mchua> w00t.
14:16:55 <dgilmore> quaid: do we have an idea how many students we can accomodate?
14:17:29 <quaid> "it depends"
14:17:41 <quaid> first, on how much we want to slice up our pool of moment
14:17:43 <quaid> money
14:17:59 <quaid> right that the pool is holding $5k from CommArch
14:18:18 <quaid> so we could take 10 students but pay them $500
14:18:30 <quaid> otoh, we could take one student doing something really great for the whole thing
14:18:33 <quaid> etc.
14:18:43 <quaid> so strength of proposals has more to do with how many students we try to take.
14:19:15 <dgilmore> ok
14:19:34 <quaid> here, let's move and see how this is addressed in the messages to audiences.
14:20:01 <quaid> #topic Message page review - https://fedoraproject.org/wiki/Summer_Coding_2010_plan
14:20:20 <quaid> ok, so I'll do a new topic per-page with actions therein to try to organize as we go.
14:20:26 * mchua is a bit concerned about the $500 number - how many students will actually be able to work for that amount of money?
14:20:32 <mchua> but that's offtopic, so... um... moving on.
14:20:55 <mchua> However, that's something that's important for students that they'll want to find out. "How much will I get paid?" Survival for the summmer depends on that often.
14:21:01 <quaid> mchua: how many students might do it anyway and $500 is a sweetener?
14:21:12 <mchua> quaid: Are we expecting full-time work from them?
14:21:17 <quaid> maybe the project is proportionally smaller
14:21:42 <mchua> quaid: If they're going to do it anyway, I don't know if $500 is going to make that much difference. I worry that we narrow our pool considerably by depending on students who (1) don't need income and (2) have free time and (3) want to use that to get started in FOSS.
14:21:53 <quaid> one of the challenges with GSoC is the disproportionate value of the pay
14:21:59 <quaid> some people, that's barely enough to cover a summer
14:22:09 <quaid> some people, it feeds them and their family for a big chunk of the year
14:22:20 <mchua> One thing about GSoC is that it gives you "permission" to be a newbie but dive in feet-first for an extended period of time - for some, it's a way to say "okay, *this* summer I get involved in FOSS."
14:22:36 <mchua> Some people don't have life situations that allow them to pick it up slowly, as a hobby, the way many of us did.
14:22:38 <mchua> That's a privilege we can't assume.
14:22:42 <quaid> mchua: how much of your perspective is "college student from US or Europe"?
14:22:56 <mchua> quaid: Well, all of my perspective is "recently a college kid from the US."
14:23:20 <mchua> I know that in the Philippines, for example, $500 would be more than enough to live on for a summer... but if I have the skills to code, I'm going to go for something that earns me a *lot* more than $500.
14:23:29 * dgilmore was a college student in OZ 8 years ago
14:23:38 <quaid> what I'm saying is ... we can't go in with a fixed value on how we split the pool if we i) don't know the pool size and ii) don't know the value of the proposals
14:23:53 <quaid> e.g. if we get two strong, part-time proposals, then split the pool 50/50 and go on, right?
14:23:57 <mchua> Yeah, sorry - I diverted the conversation... we can come back to this later.
14:24:07 * mchua still has her "starving student" hat on.
14:24:34 <quaid> that's not a problem, but I don't know how to apply that _globally_
14:24:36 <rvokal> quaid: EU and US won't differ much .. (just FYI)
14:25:12 <quaid> rvokal: ok, so we know what 2+ billion people are likely to expect ... :)
14:25:27 <rvokal> :-)
14:25:59 * quaid points at /topic
14:26:03 <quaid> so that plan page
14:26:14 <quaid> was first written up by myself, mel, and I forget who else was in gobby that day
14:26:35 <quaid> it tries to say what we are going to say to each audience and which venues we'll use.
14:26:43 <quaid> I've been over it so many times it makes my eyes glaze
14:26:48 <quaid> does anything jump out for you all?
14:27:54 <Southern_Gentlem> https://fedoraproject.org/wiki/Summer_Coding_2010_plan
14:27:59 <quaid> yep
14:28:37 <dgilmore> quaid: do we have any lwn subs left?
14:28:43 <quaid> hmm, don't think any of the "flyers for events" will work out, no events in time
14:28:48 <dgilmore> It might be nice to give one to each student
14:28:57 <quaid> dgilmore: unsure
14:29:14 <quaid> #action see if we can include an LWN subscription for students
14:29:40 <dgilmore> ill gladly give up mine for a student
14:29:48 <dgilmore> i can get covered by Red Hats
14:30:18 <quaid> ok, yeah, I use RHTs so there may be others we an recapture that way
14:31:00 <quaid> #action Students need to know that we won't know how much money per student for a few weeks; it has to do with strength of proposals and size of funding pool.
14:31:01 <dgilmore> anyway i thought that could be a perk,  and another insight into the OSS world
14:31:50 * mchua puts the "starving student" hat back on and reads through https://fedoraproject.org/wiki/Summer_Coding_2010_plan#Students_-_what
14:32:03 <quaid> #action fix link to ideas in plan page
14:32:11 <dgilmore> the page looks pretty good to me, do we have Campus Ambassadors relationships with many schools?
14:32:15 * mchua will dump questions in here. *flood!*
14:32:21 <mchua> "What's JBoss/Fedora?"
14:32:25 <Southern_Gentlem> dgilmore,  just getting started
14:32:28 <rvokal> quaid: do we really want to fund all projects or just pick the best ones?
14:32:34 <mchua> "What is this? Is it an internship? Why shoudl I care?"
14:33:00 <rvokal> quaid: I mean starting several projects in parallel and than pick those which will get funded
14:33:24 <mchua> "People who stay around and do good work are noticed - but how good a guarantee is this that I'll be able to have some sort of future in this space... and I don't even know what this space is, I've never done FOSS before, I don't know if I'll actually want to stay and work here."
14:33:48 <mchua> "Will this look good on my resume to other employers? What if I want to maybe work for $big_proprietary_software_company when I graduate, because my friends who do that can pay off their student loans?"
14:34:18 <mchua> "The best ideas are student generated - but I don't have context into this world, how can I possibly figure out what to work on? I don't know what this means!"
14:34:36 <dgilmore> mchua: the answer to does this look good on my resume depends entirely on the employer
14:34:54 <mchua> "Am I good enough to work on this? I don't know how this works... don't you have to be some sort of supergenius to work on open source? The only person I know who uses Linux is the scary smart dude who never leaves his room..."
14:34:55 <quaid> rvokal: only pick best ones
14:35:07 <quaid> rvokal: it's going to be up to the mentors, largely, what gets funded.
14:35:24 <quaid> mchua: don't dump, turn in to #actions please
14:35:25 <rvokal> mchua: and since most of the big emplyoess are looking at FOSS it's always good to have it on CV ..
14:35:32 <rvokal> quaid: k
14:35:43 <mchua> "Fedora may be a place to work through integrating ideas with other upstream projects - uh oh, wait, there are *more* people I don't know that I have to figure this out with? I have to write a paper tonight and I also have to apply to 2 other jobs because I *really* need money this summer to stay in school..."
14:36:04 <mchua> rvokal: Oh, I agree - but how do we give students that same sense of certainty?
14:36:35 * mchua is deliberately trying to push the edge with her questions here - these aren't too far off from what I was thinking even 3 summers ago before I really got into FOSS contribution.
14:36:47 <rvokal> mchua: do we have to? I prefer students smart enough to realize that this is their chance to get some praxis during their studies
14:36:51 <mchua> And I know I'm not the only one who had/has these sorts of questions and concerns.
14:37:02 <quaid> mchua: we are not going to be able to provide a program that is useful to all starving students; we may be limited and  have to rely upon people who have the privilege; if it can't be helped, it can't.
14:37:09 <quaid> if we raise $100K in the next few days, great!
14:37:12 <quaid> if not ...
14:37:48 <mchua> rvokal: Those students are the ones who're already likely to be contributors, imo. If we're trying to use this to reach folks we might not otherwise, we may have to stretch a little farther. Some of 'em turn into very helpful contributors if they're just given the chance to start.
14:37:54 * mchua hopes she's an example of that.
14:38:32 <Southern_Gentlem> this page needs updated to point to the 2010 stuff
14:38:32 <quaid> #action add section to student messaging that better covers the value to My Future of FOSS contributions
14:38:37 <Southern_Gentlem> http://fedoraproject.org/wiki/SummerOfCode
14:38:50 <mchua> quaid: Point taken. I'm trying to figure out how to make simple tweaks to our messaging to make it reach more folks without relying on massive amounts of $ or giant overhauls or whatnot.
14:38:57 <quaid> Southern_Gentlem: go ahead and make a pointer please
14:39:11 * mchua opens up talk page and tries to scribble
14:39:25 <Southern_Gentlem> quaid,  where should it point is not clear at this point
14:39:26 <quaid> #action student messaging needs to cover that FOSS contrib is accessible to all, not just scary super genii
14:40:14 <quaid> Southern_Gentlem: weird, it goes to a page that should be merged in to [[Summer Coding SIG]] and then both made a redirect to that page.
14:41:02 <quaid> #action [[SummerOfCode]] goes to a page [[Summer coding]] that should be merged in to [[Summer Coding SIG]] and then both made a redirect to that page.
14:41:14 <quaid> mchua: where are you scribbling?
14:41:45 <quaid> mchua: can we instead create #action items here so we can have a big easy list to knock out after the meeting?
14:42:08 <mchua> quaid: yessir.
14:42:10 * mchua stops scribbling
14:43:29 <quaid> #action ASAP student messaging needs to address that our program this year isn't going to cover all their needs with the same certainty that GSoC or an internship does; we're like GSoC first year, but less budget.
14:44:59 <skvidal> quaid: how much less budget?
14:45:19 <mchua> #action students need to know we're planning on doing this again in the future, so if the first round doesn't fit them, they should come back next year (and maybe help us patch the program in the meantime).
14:45:32 * mchua is assuming we /are/ shooting for this to be more than a 1-year thing.
14:46:16 <dgilmore> skvidal: $5k total?
14:46:45 <quaid> ok, stop
14:46:51 <skvidal> dgilmore: for all students?
14:46:54 <quaid> stop
14:47:05 * skvidal stops
14:47:08 * dgilmore is stopped
14:47:15 <quaid> first, we are raising money, that's what the sponsor messaging is about
14:47:27 * skvidal wasn't trying to be disruptive - sorry if it was taken that way
14:47:28 <quaid> second, we have raised _at_least_ $5k from RHT so far
14:47:50 <quaid> third, we have not decided how to split the money since we don't have ideas or proposals to evaluate; that's going to end up in the mentors hands largely
14:48:06 <quaid> skvidal: just wanted to keep from throwing out incorrect info at this stage :)
14:48:20 <quaid> mchua: yeah, more than one year
14:48:45 <quaid> ok, I'm concerned that we are only just through one group of messaging
14:48:50 <quaid> and have a bunch more to go
14:48:56 <quaid> not sure who can go beyond the hour ...
14:49:04 * mchua can go for another 45m.
14:49:20 <quaid> but is there anything else we need to make sure we say to students
14:49:33 <quaid> if so, make an #action and note which audience it is for
14:50:01 <mchua> #action make sure student messaging is reassuring and certain - "this scaffolding *will* be built, and stable enough for you to climb upon."
14:50:30 <mchua> (as opposed to "uh, we don't know! maybe! stuff! wanna help us hack this plane while it's flying?" - which is exciting, but only after you trust that Stuff Will Work Out for the summer. ;)
14:50:36 * mchua done
14:50:51 <quaid> skvidal, dgilmore et al I think we're going to need to take budget discussion to the list and work out the approach.
14:51:14 <quaid> any reviews for the mentor messaging?
14:51:22 <quaid> #link https://fedoraproject.org/wiki/Summer_Coding_2010_plan#Mentors_-_what
14:51:32 <quaid> and sponsoring
14:51:34 <quaid> #link https://fedoraproject.org/wiki/Summer_Coding_2010_plan#Sponsoring_orgs_-_what
14:51:46 <quaid> those are the two crucial ones at this stage I think
14:52:37 * mchua looking
14:52:58 <mchua> #action reach students via professors and other mentor-type people when possible
14:53:05 * mchua swaps brain into "mentor" mode
14:53:22 <mchua> mentors: we are targeting people already within the fedora/jboss community, right?
14:53:30 <quaid> yes
14:53:32 <mchua> so we don't have to explain why FOSS is awesome or what those projects are and whatnot.
14:53:36 <mchua> Ok. just making sure.
14:53:40 <quaid> although if a uni has a mentor, that might work too
14:53:44 <dgilmore> quaid: what is the proposed timeline?
14:53:48 <quaid> no, mentor does not need mentoring :)
14:54:05 <quaid> #link https://fedoraproject.org/wiki/Summer_Coding_2010_timeline
14:54:10 <mchua> #action make sure mentor understands their time commitment needed - and whether communications with the student will be push or pull from their side
14:54:15 * mchua not sure how to phrase that
14:54:20 <dgilmore> quaid: and can we look at support SOC at different times of year for both hemispheres?
14:54:35 <mchua> basically "am I supposed to be around and the student will ping me," or "do I have to constantly be on top of my mentee to make sure they're doing stuff?"
14:54:44 <quaid> dgilmore: definitely
14:54:55 <dgilmore> quaid: we need to link the timeline to the summer coding plan
14:54:55 <quaid> dgilmore: in fact, a year round program is a great idea
14:55:11 <rvokal> quaid: good question, does to SOC has to be time limited? can't we have it as continuos thing even during school year?
14:55:27 <quaid> dgilmore: note that the plan is for _us_
14:55:40 <dgilmore> I know when i was a student i couldnt have done SOC because i was busy with school  since it was during term for me
14:55:41 <quaid> dgilmore: the schedule is transcluded in each audience  section here:
14:55:57 <quaid> #link https://fedoraproject.org/wiki/Summer_Coding_2010
14:56:18 <quaid> let's talk about ongoing FSC on list
14:56:29 <quaid> summer-coding@lists.fp.o that is
14:56:50 <quaid> our CommArch team has already talked about it, but I never brought it forward as an idea to the SIG
14:58:08 * mchua trying really hard to remember to bring convo to summer-coding channel/list
14:58:16 <mchua> poke me if I slip up :)
14:58:57 <mchua> #action make sure mentor is confident about the reliability of student - either by knowing the student or trusting the person responsible for keeping everyone on track during the summer (in GSoC, that's the project admin).
14:58:57 <quaid> oh, wow
14:59:02 <mchua> hm?
14:59:05 <quaid> I just realized I started this meeting an hour early :)
14:59:11 <quaid> I did it on local clock
14:59:29 <mchua> ...I thought it was right on time. But maybe *my* clock is off.
14:59:49 <mchua> ...okay, yes, I have the wrong meeting time too. Um.
14:59:50 * mchua fixes
14:59:59 <quaid> we set it to UTC not EDT
15:00:17 <quaid> ok, top of the hour review of where we are ...
15:00:43 <quaid> currently looking at the plan page, that we use in writing out the messaging to [[Summer Coding 2010]]
15:00:53 <quaid> in particular, looking at mentor and sponsor messaging
15:01:23 * jreznik is late... yes, it was one hour early :)
15:01:51 <quaid> jreznik: yeah, I got it stuck in my local brain on local time :)
15:01:57 <quaid> no worries
15:02:12 <jreznik> np, I'll read summary
15:02:52 <quaid> #link http://meetbot.fedoraproject.org/fedora-meeting/2010-04-07/fedora-meeting.2010-04-07-14.02.log.txt
15:02:56 <quaid> that's the ongoing log
15:03:29 <quaid> jreznik: so this is relevant for you I think :
15:03:32 <quaid> https://fedoraproject.org/wiki/Summer_Coding_2010_plan#Sponsoring_organizations
15:03:57 <quaid> that is what we are telling sponsors (funders), examples being Red Hat, our partners, etc.
15:04:13 * quaid also thinks some schools fall in there, depending
15:04:46 * dgilmore thinks it would be cool for schools to give class credit for SOC work
15:04:47 <mchua> #action make sure mentors know what they'll get from it ("reliable contributor help for N weeks"? access to certain resources to help with project planning? learn-how-to-manage?)
15:04:52 <mchua> dgilmore: +1
15:05:08 <mchua> quaid: yeah, where do profs at schools who want to support their students in doing FOSS work, but who aren't involved in a project enough to be a code mentor, fall in?
15:05:34 <jreznik> dgilmore: nice idea!
15:05:37 <mchua> The closest i can think of is the role of a project admin for GSoC - administrative oversight, checking in with people and clearing nontech blockers, making sure communications are flowing, etc
15:06:40 <dgilmore> jreznik: that could be a good incentive to do it
15:06:46 <quaid> mchua: sponsor
15:07:01 <quaid> I mean, they have to have _something_ to bring to the game
15:08:17 <jreznik> quaid: we usually bring people - mentors, not money (or not a lot of money)
15:08:26 <jreznik> opposite to ms way :)
15:08:36 <quaid> ok, anything for sub-projects
15:08:44 <quaid> #link https://fedoraproject.org/wiki/Summer_Coding_2010_plan#Sub-projects
15:09:56 <jreznik> is it really necessary to split it to sub projects?
15:10:47 <mchua> quaid: they have plenty to bring to the table; it may not be funding, though.
15:10:56 <mchua> quaid: funding in the academic world is slow, and right now it's *way* too late to ask for summer funding
15:11:22 <mchua> quaid: but they have students, they can make sure the students are reliable, they can provide institutional support and the "this is really a real thing to the school you go to!" cred that dgilmore mentioned
15:11:45 <quaid> jreznik: how do you mean?
15:12:00 <mchua> (not necessarily formal academic credit, at least not for this year - but having something be "institutionally supported" makes a difference to students in terms of how an internship looks.)
15:12:22 <quaid> the reason for talking with sub-projects (e.g. RHQ, etc.) is typically there is a connection of student<=>mentor+sub-project
15:12:32 <jreznik> ok
15:12:40 <quaid> mchua: yes, and is that addressed?
15:12:46 <quaid> do we do a separate message for academics?
15:13:07 <jreznik> quaid: so mentor is partially contact person to (sub)project
15:14:25 <mchua> quaid: Um... well, if I'm a professor from, say, TOS, it's not clear to me what category I fall into.
15:14:32 <quaid> jreznik: yes
15:14:50 <mchua> quaid: or rather, "how do I know I'm supposed to be a sponsor?"
15:14:54 <quaid> mchua: do we want to expand sponsors to cover or add a new messaging section?
15:14:58 <quaid> ok
15:15:17 <quaid> mchua: can you add a new section for academics to the plan page?
15:15:43 <quaid> #action Create new "You are an academic" section for [[Summer Coding 2010]] based on new messaging
15:15:50 <mchua> the breakdown I have in my mind is students = labor, mentors = expertise, sponsors = money and time (for oversight/overhead).
15:15:58 <mchua> so based on that, academics == sponsors, from the not-money side
15:15:59 <mchua> usually
15:16:11 <mchua> quaid: Ok - I can expand the "sponsors" section to work for that, if nothing else.
15:20:21 <quaid> mchua: let's add a new section
15:20:31 <quaid> as you said, how does an academic know we think of them as sponsors?
15:20:50 <quaid> and in fact, maybe this is a new category in the model we haven't considered because Google left it out
15:21:04 <quaid> ok, I'm ready to move on from the plan
15:21:08 <quaid> (that was a big page)
15:21:15 * mchua too
15:22:23 <quaid> #topic Message page review - https://fedoraproject.org/wiki/Category:Summer_Coding_2010_ideas
15:22:27 * quaid is going in order
15:23:07 <quaid> I know I made it appear complicated, but if we actually get ideas and proposals :) we need them as stand-alone wiki pages to use Talk properly
15:25:49 <mchua> quaid: I know you were redoing the swimchart I quickly filmed up... do we need to modify that any in order to take into account our New And More Different model?
15:26:13 <mchua> do we have a couple concrete use cases (Matt Jadud's student project at Allegheny) that we can ask to work through the process as examples, basically right away?
15:31:18 <quaid> mchua: yeah, we'll adapt that model a bit I think
15:31:38 <quaid> ok, I like the ideas page
15:32:18 * quaid skips around the list a little
15:32:29 <quaid> #topic Page review - https://fedoraproject.org/wiki/Summer_Coding_2010_schedule
15:32:36 <quaid> any comments on the schedule
15:32:55 <quaid> mchua and I worked that out yesterday
15:33:36 <quaid> I picked Fri. for ideas page so students have a full week for proposals
15:33:39 <quaid> which is still pretty short
15:36:37 <dash123> quaid: I think another weekend for students to submit applications won't hurt will it? I mean extending student application deadline to 18th.
15:37:02 <jreznik> I'll ask our people to prepare some proposals
15:38:44 <quaid> dash123: we could even go a bit longer ...
15:38:47 <quaid> https://fedoraproject.org/wiki/Summer_Coding_2010_timeline
15:38:51 <quaid> that has the raw calendars
15:39:31 <quaid> we could extend proposals due to 21 April?
15:39:49 <quaid> we could also extend ideas due to Monday 12 April or even next Wed.
15:39:57 <quaid> if we think it's Ok to have this stuff in parallel
15:40:28 <jreznik> quaid: +1 to extend
15:41:21 <quaid> yeah, this was all from making sure mentors had a good week to do the hard work of deciding by 30 April.
15:41:53 <quaid> #action adjust schedule to open idea window to 14 April and proposals to 21 April
15:41:58 <mchua> quaid: possible to have 2 rounds of deadlines? that way people who need to know early and can hustle can know early, but we accomodate latecomers who can also accomodate knowing later.
15:42:19 <quaid> #action reannounce idea update to devel hannels
15:42:27 * mchua has to jet.
15:42:37 <quaid> mchua: not sure because it was from our discussion
15:42:44 <quaid> about being all dialed by mid-May
15:42:46 * mchua nods
15:42:54 <quaid> but I know there are different schedules, etc.
15:43:41 <quaid> #action student messaging - make it clear we are doing the best schedule on this notice, but keep tuned for updates in this year -- we may add proposal and work rounds to accomodate other school schedules, etc.
15:44:05 <quaid> #topic Page review (last one) - https://fedoraproject.org/wiki/Summer_Coding_2010_student_application
15:44:22 <quaid> there are a few more pages in the agenda, but I don't think they matter as much
15:44:32 <quaid> but for those who want to look at them, the pages I am going to skip reviewing today are:
15:44:39 <quaid> #link https://fedoraproject.org/wiki/Communication_for_Summer_Coding_2010
15:44:46 <quaid> #link https://fedoraproject.org/wiki/How_to_create_an_idea_page_for_Summer_Coding
15:44:58 <quaid> #link https://fedoraproject.org/wiki/Category:Summer_Coding_2010
15:45:10 <quaid> #link https://fedoraproject.org/wiki/Summer_Coding_2010_timeline
15:45:29 <quaid> the latter, the timeline page, may have breakdowns by audience, so we can transclude them to other useful locationks
15:45:41 <quaid> for now, when people look at the schedule, they see the whole thing.
15:46:12 * quaid notes the timeline includes deliverables by audience that we used to inform the schedule
15:46:34 <quaid> ok, that student application was mainly written by mchua for Sugar Labs GSoC
15:46:48 <quaid> I remixed it (thanks CC BY!) for us
15:49:26 <quaid> #action fix sub-sectioning of student app to put all on same level
15:50:03 <quaid> #action make language about preferred language less certain - we may be able to, etc.
15:50:57 <quaid> #action == About your project == needs to specify a link back to an idea page, if it exists, plus any discussions with mentor(s)
15:52:53 <quaid> #action == About your project == should specify in point 3 they need a mentor fully aware of why and supportive in code is not "mostly working" by mid-term.
15:53:08 <quaid> #undo
15:53:08 <zodbot> Removing item from minutes: <MeetBot.items.Action object at 0x2b03b07638d0>
15:53:45 <quaid> #action == About your project == should specify in point 3 they need a mentor fully aware of why and supportive if code is not "mostly working" by mid-term; it can be OK if it's not mostly working as long as it is not a surprise to the mentor and there is a plan between mentor and student to rectify.
15:55:44 <quaid> #action == You and the community == Trick question in #2 and #3? our plan includes clued mentor, but maybe good to hear student's thoughts, kind of scary question. Also, we are requiring blogging, so we should say, "In addition to the required at-least 2x/week blog post, how else do you plan on keeping the community informed ...? example, test days, etc."
15:56:20 <quaid> #action == Misc... == Expand on development environment; include that we want them to engage with the community early and often.
15:57:22 <quaid> #action can we make it more clear how to use talk pages and watch preferences?  is there a canonical how-to page? if not, write it and reference.
15:57:42 <quaid> ok, I'm done with my review of the student application
15:57:51 <quaid> and we're almost at the final minute
15:57:59 <quaid> I'm closing the meeting in 1 minute
15:58:10 <quaid> if there is further discussion, #fedora-summer-coding
15:58:43 <quaid> dash123: thanks again for the rubysoc etc. analysis, hope you don't mind that I forwarded it to the list with only your irc nick for attribution
15:59:02 <dash123> ah...not a problem :)
15:59:14 * quaid realizes he doesn't know what dash123's actual person name is :)
15:59:40 * dash123 loves being anonymous
15:59:40 <quaid> or if I do, I forgot ;)
15:59:45 <quaid> rock on :)
15:59:49 * quaid won't break that bubble
15:59:52 <quaid> and on that note ...
15:59:54 <quaid> #endmeeting