f19beta-blocker-review-7
MINUTES

#fedora-blocker-review: f19beta-blocker-review-7

Meeting started by tflink at 16:07:28 UTC (full logs).

Meeting summary

  1. Roll Call (tflink, 16:07:28)
  2. Introduction (tflink, 16:18:02)
    1. Our purpose in this meeting is to review proposed blocker and nice-to-have bugs and decide whether to accept them, and to monitor the progress of fixing existing accepted blocker and nice-to-have bugs. (tflink, 16:18:55)
    2. We'll be following the process outlined at: (tflink, 16:18:59)
    3. https://fedoraproject.org/wiki/QA:SOP_Blocker_Bug_Meeting (tflink, 16:19:00)
    4. The bugs up for review today are available at: (tflink, 16:19:05)
    5. http://qa.fedoraproject.org/blockerbugs/current (tflink, 16:19:05)
    6. The criteria for release blocking bugs can be found at: (tflink, 16:19:10)
    7. https://fedoraproject.org/wiki/Fedora_19_Beta_Release_Criteria (tflink, 16:19:10)
    8. https://fedoraproject.org/wiki/Fedora_19_Alpha_Release_Criteria (tflink, 16:19:13)
    9. Up for review today, we have: (tflink, 16:19:16)
    10. 5 Proposed Blockers (tflink, 16:19:22)
    11. 3 Accepted Blockers (tflink, 16:19:23)
    12. 12 Proposed Freeze Exceptions (tflink, 16:19:23)
    13. 9 Accepted Freeze Exceptions (tflink, 16:19:23)

  3. (963952) Failure to connect to wired ethernet on reboots (tflink, 16:20:55)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=963952 (tflink, 16:20:55)
    2. Proposed Blocker, anaconda, POST (tflink, 16:20:55)
    3. AGREED: 963952 - RejectedBlocker RejectedFreezeException - This doesn't violate any F19 beta release requirements and it's getting too close to release to be taking changes like this as FE. Rejected as blocker and FreezeException for F19 beta (tflink, 16:26:08)

  4. (964069) Anaconda creates native partition in text mode if LVM or btrfs is selected (tflink, 16:26:30)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=964069 (tflink, 16:26:33)
    2. Proposed Blocker, anaconda, MODIFIED (tflink, 16:26:35)
    3. https://bugzilla.redhat.com/show_bug.cgi?id=964069#c11 was my shot at the criteria (adamw, 16:30:46)
    4. AGREED: 964069 - AcceptedBlocker - Violates the following F19 beta release criterion for text installs: "When using the guided partitioning flow, the installer must be able to ... complete an installation using any combination of disk configuration options it allows the user to select" (tflink, 16:34:25)

  5. (963810) Could not get update details: Error Type: <type 'exceptions.UnicodeDecodeError'> (tflink, 16:34:31)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=963810 (tflink, 16:34:34)
    2. Proposed Blocker, PackageKit, MODIFIED (tflink, 16:34:36)
    3. AGREED: 963810 - AcceptedBlocker - Violates the following F19 alpha release criterion when updates with UTF-8 specific characters are available: "The installed system must be able to download and install updates with yum and with the default graphical package manager in all release-blocking desktops." (tflink, 16:41:35)

  6. (963361) pesign currently does not align signature list entries, which will cause shim to fail on newer firmware. (tflink, 16:41:47)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=963361 (tflink, 16:41:51)
    2. Proposed Blocker, pesign, NEW (tflink, 16:41:53)
    3. AGREED: 963361 - RejectedBlocker - This doesn't seem to affect enough machines (newer OVMF which is not supported, unknown number of newer firmwares) and disabling secure boot is an acceptable workaround for beta. Thus, this bug is rejected as a blocker for F19 beta (tflink, 16:49:28)

  7. (965101) QXL driver crashes in KVM (i386) (tflink, 16:49:51)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=965101 (tflink, 16:49:51)
    2. Proposed Blocker, xorg-x11-drv-qxl, NEW (tflink, 16:49:51)
    3. https://bugzilla.redhat.com/show_bug.cgi?id=965101#c3 (tflink, 16:52:57)
    4. https://fedoraproject.org/wiki/QA:Testcase_Install_to_Current_KVM (dan408, 17:03:46)
    5. AGREED: 965101 - RejectedBlocker RejectedFreezeException - While this is a paritial violation of the F19 beta release criterion, it is limited to 32 bit guests, has workarounds (use Cirrus or 64 bit guest) and could reasonably be fixed with an update in most cases. (tflink, 17:08:13)

  8. (962006) Crash when installing a specific btrfs layout with a kickstart (tflink, 17:08:56)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=962006 (tflink, 17:08:59)
    2. Proposed Freeze Exceptions, anaconda, NEW (tflink, 17:09:02)
    3. https://bugzilla.redhat.com/show_bug.cgi?id=962006#c10 (adamw, 17:11:07)
    4. still unclear whether this is user error or not (tflink, 17:11:09)
    5. https://bugzilla.redhat.com/show_bug.cgi?id=962006#c10 (tflink, 17:11:30)

  9. (963958) dialog-warning-symbolic.svg (used as the 'warning triangle' emblem in anaconda) is now grey; if anaconda wants the old orange one, anaconda should ship it (tflink, 17:12:01)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=963958 (tflink, 17:12:05)
    2. Proposed Freeze Exceptions, anaconda, NEW (tflink, 17:12:08)
    3. AGREED: 963958 - AcceptedFreezeException - This makes warnings on the hub very non-obvious and a fix would be nice but certainly not required. A tested fix would be considered past F19 beta freeze (tflink, 17:17:34)

  10. (963841) update logo on login screen. (tflink, 17:17:39)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=963841 (tflink, 17:17:39)
    2. Proposed Freeze Exceptions, gdm, ON_QA (tflink, 17:17:39)
    3. AGREED: 963841 - RejectedFreezeException - The logo we have now doesn't pose any legal issues and this could be fixed with an update post-release since gdm doesn't normally show up on livecds. (tflink, 17:23:33)

  11. (961140) g-i-s lets you create a user with no password, but if you do, transition from g-i-s to user session fails and g-i-s re-runs on reboot (tflink, 17:23:51)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=961140 (tflink, 17:23:54)
    2. Proposed Freeze Exceptions, gnome-initial-setup, ON_QA (tflink, 17:23:56)
    3. this needs more investigation before pulling in, but accepted for now (tflink, 17:34:05)
    4. http://pkgs.fedoraproject.org/cgit/gnome-initial-setup.git/commit/?h=f19 (tflink, 17:34:28)
    5. AGREED: 961140 - AcceptedFreezeException - This is a pretty nasty bug to hit if you don't add a password to the user in g-i-e, a tested fix would be considered past F19 beta freeze. (tflink, 17:36:29)

  12. (928659) gnome-initial-setup should logout existing user when changing desktop locale (tflink, 17:36:45)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=928659 (tflink, 17:36:48)
    2. Proposed Freeze Exceptions, gnome-initial-setup, NEW (tflink, 17:36:50)
    3. AGREED: 928659 - RejectedFreezeException - While unfortunate, this is not a severe issue and can be worked around by logging out or restarting after g-i-s runs. (tflink, 17:49:09)

  13. (964828) On EFI: F18 is rendered unbootable after installing F19 (tflink, 17:49:18)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=964828 (tflink, 17:49:21)
    2. Proposed Freeze Exceptions, grub2, NEW (tflink, 17:49:24)
    3. AGREED: 964828 - RejectedFreezeException - This is too much of a corner case to justify taking grub changes for this late in the beta cycle. Documentation via CommonBugs is acceptable for Beta (tflink, 17:56:14)

  14. (963098) Left/Right cursor key does not work in the initial conversion state (tflink, 17:56:22)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=963098 (tflink, 17:56:24)
    2. Proposed Freeze Exceptions, libkkc, ON_QA (tflink, 17:56:27)
    3. AGREED: 963098 - AcceptedFreezeException - This interferes with IME text input on the live images which can't be fixed with updated. The already proposed fix is isolated and would be considered past F19 beta freeze once tested. (tflink, 18:09:14)

  15. (963238) SELinux is preventing lightdm from 'create', 'write', and 'rename' accesses on the file .dmrc.RANDOM (tflink, 18:09:18)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=963238 (tflink, 18:09:21)
    2. Proposed Freeze Exceptions, lightdm, ON_QA (tflink, 18:09:23)
    3. AGREED: 963238 - AcceptedFreezeException - It appears that the functionality causing the AVC warnings (~/.dmrc) is not used much anymore and can be safely dropped. A tested fix would be considered past F19 beta freeze. (tflink, 18:21:53)

  16. (961446) Review Request: c2esp - CUPS driver for Kodak AiO printers (tflink, 18:21:57)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=961446 (tflink, 18:22:00)
    2. Proposed Freeze Exceptions, Package Review, NEW (tflink, 18:22:03)
    3. AGREED: 961446 - RejectedFreezeException - This package is not reviewed yet, nor would it be on the DVD. Thus, any FE designation would not affect the package and the bug is rejected as a Freeze Exception for F19 beta (tflink, 18:25:16)

  17. (963359) Shim should provide a mechanism for \EFI\BOOT\BOOTX64.EFI as a fallback on fixed media. (tflink, 18:25:20)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=963359 (tflink, 18:25:23)
    2. Proposed Freeze Exceptions, shim, NEW (tflink, 18:25:26)
    3. AGREED: 963359 - RejectedFreezeException - While this would be a useful recovery feature, it isn't required and it's too close to go/no-go to be taking shim features past freeze (tflink, 18:31:27)

  18. (927564) F19 release-name “Schrödinger’s Cat” shown as "SchrA¶dingerâÇÖs Cat" on the linux console (tflink, 18:31:37)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=927564 (tflink, 18:31:40)
    2. Proposed Freeze Exceptions, systemd, ASSIGNED (tflink, 18:31:42)
    3. AGREED: 927564 - RejectedFreezeException - While this does look bad, the currently proposed fixes require changes to vital system components and are not appropriate for Freeze Exceptions. (tflink, 18:37:11)

  19. (958787) X error "AddScreen/ScreenInit failed for gpu driver 0 -1" on iMac12,2 with F19 Beta TC3 when starting GDM (tflink, 18:37:36)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=958787 (tflink, 18:37:39)
    2. Proposed Freeze Exceptions, xorg-x11-server, NEW (tflink, 18:37:41)
    3. AGREED: 958787 - RejectedFreezeException - This bug is not clear enough to determine what the fix is at this point and seems to affect a limited subset of hardware. (tflink, 18:41:49)

  20. (964965) gdm should require it's own deps to function. (tflink, 18:41:57)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=964965 (tflink, 18:41:57)
    2. Proposed Freeze Exception, gdm, NEW (tflink, 18:41:57)
    3. AGREED: 964965 - AcceptedFreezeException - This doesn't require any major changes to gdm, just ensuring that its required packages will be pulled in @ build and use time. A tested fix that does not involve touching gdm code or adding packages to the desktop spin would be considered past F19 beta freeze (tflink, 18:45:37)

  21. Open Floor (tflink, 18:52:23)


Meeting ended at 18:58:59 UTC (full logs).

Action items

  1. (none)


People present (lines said)

  1. tflink (280)
  2. adamw (197)
  3. dan408 (147)
  4. nirik (44)
  5. jreznik (21)
  6. brunowolff (20)
  7. zodbot (12)
  8. Viking-Ice (6)
  9. satellit_e (6)


Generated by MeetBot 0.1.4.