f19beta-blocker-review-7
LOGS
16:07:28 <tflink> #startmeeting f19beta-blocker-review-7
16:07:28 <zodbot> Meeting started Mon May 20 16:07:28 2013 UTC.  The chair is tflink. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:07:28 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
16:07:28 <tflink> #meetingname f19beta-blocker-review-7
16:07:28 <tflink> #topic Roll Call
16:07:28 <zodbot> The meeting name has been set to 'f19beta-blocker-review-7'
16:07:35 <adamw> then bring it back again.
16:09:13 * satellit_e still here
16:09:36 <tflink> anyone else here for some blocker review fun?
16:10:26 <adamw> YAY FUN
16:10:35 <adamw> nirik: you there?
16:10:42 <nirik> yeah, looking at bz tho.
16:10:46 <tflink> a lot of proposed FEs materialized since the last meeting
16:12:14 <adamw> we should start charging for FEs
16:12:19 <adamw> money goes to the project colada fund
16:14:35 <tflink> sounds good to me
16:14:38 <adamw> hi jreznik
16:14:45 <Viking-Ice> what's going to sponsor project mojito?
16:15:02 <tflink> Viking-Ice: what's project mojito?
16:15:14 <brunowolff> I'm going to go away for a bit over an hour. If the fun is still going on when I get back, I'll participate.
16:15:32 * jreznik is here :) but you know, it's #jollaloveday - going to watch live stream!
16:15:43 <tflink> brunowolff: ok, hopefully it won't be too bad but I suspect it'll be more than an hour
16:16:29 <adamw> tflink: it sounds like project colada but with an inferior drink :)
16:16:30 <dan408> hi
16:16:32 <tflink> do we have enough people?
16:16:32 <dan408> im here
16:16:35 <dan408> you can start now
16:16:42 <adamw> whew
16:16:48 <tflink> #chair adamw
16:16:48 <zodbot> Current chairs: adamw tflink
16:16:56 <Viking-Ice> tflink, you did not get the memo about project mojito and bora bora
16:16:58 <Viking-Ice> ;)
16:17:03 <dan408> you dont have to give me a chair
16:17:04 <tflink> any volunteers for secretary duty?
16:17:04 <dan408> it's cool
16:17:29 <tflink> Viking-Ice: I did not but it sounds like something worthwhile
16:17:36 <tflink> #nochair dan408
16:17:42 <tflink> :)
16:17:55 <tflink> anyhow, time for some boilerplate
16:17:57 <adamw> tflink: i'll do it
16:18:02 <tflink> #topic Introduction
16:18:06 <dan408> .fire tflink
16:18:06 <Viking-Ice> tflink, escape plan for those nasty bugs that eluded us and the angry lynchmob that follows
16:18:06 <tflink> adamw: thanks
16:18:06 <zodbot> adamw fires tflink
16:18:07 <Viking-Ice> ;)
16:18:17 <tflink> wow, twice in 15 minutes
16:18:32 <dan408> he mad
16:18:34 <adamw> i didn't even  notice i was doing it that time
16:18:50 <tflink> Viking-Ice: sounds like a wise plan :)
16:18:55 <tflink> Why are we here?
16:18:55 <tflink> #info Our purpose in this meeting is to review proposed blocker and nice-to-have bugs and decide whether to accept them, and to monitor the progress of fixing existing accepted blocker and nice-to-have bugs.
16:18:59 <tflink> #info We'll be following the process outlined at:
16:19:00 <tflink> #link https://fedoraproject.org/wiki/QA:SOP_Blocker_Bug_Meeting
16:19:05 <tflink> #info The bugs up for review today are available at:
16:19:05 <tflink> #link http://qa.fedoraproject.org/blockerbugs/current
16:19:10 <tflink> #info The criteria for release blocking bugs can be found at:
16:19:10 <tflink> #link https://fedoraproject.org/wiki/Fedora_19_Beta_Release_Criteria
16:19:13 <tflink> #link https://fedoraproject.org/wiki/Fedora_19_Alpha_Release_Criteria
16:19:16 <tflink> #info Up for review today, we have:
16:19:22 <tflink> #info 5 Proposed Blockers
16:19:23 <tflink> #info 3 Accepted Blockers
16:19:23 <tflink> #info 12 Proposed Freeze Exceptions
16:19:23 <tflink> #info 9 Accepted Freeze Exceptions
16:19:24 <adamw> Viking-Ice: I thought that's what the hidden tunnels were for
16:20:09 <tflink> if there are no objections, we'll start with the proposed blockers
16:20:48 <dan408> +1
16:20:55 <tflink> #topic (963952) Failure to connect to wired ethernet on reboots
16:20:55 <tflink> #link https://bugzilla.redhat.com/show_bug.cgi?id=963952
16:20:55 <tflink> #info Proposed Blocker, anaconda, POST
16:21:09 <dan408> +1
16:21:35 <adamw> -1
16:21:49 <adamw> this doesn't hit any of the criteria, and it's easy enough to tweak.
16:21:53 <dan408> +1 FE
16:22:51 <adamw> anyone else?
16:22:57 * tflink should buy some bz devs a beer for showing state changes inline with comments
16:22:58 * dan408 actually looks at the bug
16:23:04 <adamw> we're getting close to go/no-go now so i'm kinda inclined to tighten down on FEs
16:23:07 <adamw> dan408: :D
16:23:24 <dan408> this was reported on TC4
16:23:28 <tflink> yeah -1/-1
16:23:36 <dan408> i would would ask the bug reporter to try it again with RC2
16:23:37 <dan408> -1
16:24:26 <dan408> anaconda keeps changing
16:24:40 <dan408> i did find it rather annoying that i had to check "auto connect" on my primary device
16:24:41 <adamw> dan408: it's not necessary, we know precisely the current state
16:24:56 <dan408> ok
16:24:58 <dan408> moving on
16:25:00 <adamw> yeah, i think it'd be okay to tweak this after beta and test it during final validation, just don't want to break beta
16:25:01 <tflink> proposed #agreed 963952 - RejectedBlocker RejectedFreezeException - This doesn't violate any F19 beta release requirements and it's getting too close to release to be taking changes like this as FE. Rejected as blocker and FreezeException for F19 beta
16:25:05 <adamw> ack
16:25:08 <dan408> ack
16:26:08 <tflink> #agreed 963952 - RejectedBlocker RejectedFreezeException - This doesn't violate any F19 beta release requirements and it's getting too close to release to be taking changes like this as FE. Rejected as blocker and FreezeException for F19 beta
16:26:22 <tflink> hrm, we seem to have lost a viking and a jreznik
16:26:30 <tflink> #topic (964069) Anaconda creates native partition in text mode if LVM or btrfs is selected
16:26:33 <tflink> #link https://bugzilla.redhat.com/show_bug.cgi?id=964069
16:26:35 <tflink> #info Proposed Blocker, anaconda, MODIFIED
16:26:47 <dan408> +1
16:27:39 <tflink> I thought that text mode didn't block release
16:27:51 <dan408> partitioning does
16:28:09 <adamw> tflink: it's arguable, it's not clear in the criteria really
16:28:11 <tflink> I didn't think that anything in text mode blocked beta
16:28:16 <Viking-Ice> +1 blocker
16:28:18 <adamw> tflink: text mode is required to 'work' at alpha
16:28:28 <adamw> the question of how we interpret that is somewhat open, we haven't settled it
16:28:44 <tflink> suggestions on criteria to cite?
16:28:46 <dan408> Installation interfaces
16:28:46 <dan408> When using the dedicated installer images, the installer must be able to complete an installation using the text, graphical and VNC installation interfaces.
16:28:49 <adamw> now admittedly half my motivation for nominating this was just as an excuse to do rc3, and we don't need an excuse any more as we have the PK bug
16:28:56 <adamw> tflink: i provided that in the last comment
16:29:07 <dan408> Disk layouts
16:29:08 <dan408> The installer must be able to complete an installation to a single disk using automatic partitioning.
16:29:09 <adamw> i'd be okay with just FE for this, but it does seem like a good fix to get in beta
16:29:45 <jreznik> sorry guys, I'm back - I had a phone call
16:29:52 <dan408> i think we all need to go over the criterion in general
16:29:56 <dan408> except viking-ice
16:30:17 * satellit_e wish lives had a network spoke...
16:30:46 <adamw> https://bugzilla.redhat.com/show_bug.cgi?id=964069#c11 was my shot at the criteria
16:30:51 <tflink> proposed #agreed 964069 - AcceptedBlocker - Violates the following F19 beta release criterion for text installs: "When using the guided partitioning flow, the installer must be able to ... complete an installation using any combination of disk configuration options it allows the user to select"
16:31:09 <adamw> ack, sure.
16:31:15 <dan408> ack
16:31:15 <jreznik> able to ... complete?
16:31:37 <tflink> adamw: suggestions for improvement?
16:31:47 <adamw> tflink: no suggestions
16:32:06 <dan408> brb must go to a lame meeting
16:32:14 <dan408> 20 mins tops
16:32:21 <tflink> any other ack/nak/patch?
16:32:58 <adamw> Viking-Ice: ack or nack?
16:34:25 <tflink> #agreed 964069 - AcceptedBlocker - Violates the following F19 beta release criterion for text installs: "When using the guided partitioning flow, the installer must be able to ... complete an installation using any combination of disk configuration options it allows the user to select"
16:34:31 <tflink> #topic (963810) Could not get update details: Error Type: <type 'exceptions.UnicodeDecodeError'>
16:34:34 <tflink> #link https://bugzilla.redhat.com/show_bug.cgi?id=963810
16:34:36 <tflink> #info Proposed Blocker, PackageKit, MODIFIED
16:35:41 <adamw> this seems pretty no-brainer
16:36:09 <adamw> update issues are always a bit tricky as they usually depend on the contents of an update, but in this case there's clearly a serious bug in PK that we really ought to fix, we can't just say 'oh we'll change the update not to have a TM in it'
16:37:34 <tflink> yeah, +1
16:38:35 <tflink> other votes?
16:38:54 <adamw> nirik: pokey
16:39:06 <adamw> jreznik: we're on https://bugzilla.redhat.com/show_bug.cgi?id=963810
16:39:11 <nirik> hum.
16:39:15 * nirik reads up
16:39:36 <jreznik> thanks adamw
16:39:44 <nirik> +1
16:40:01 <jreznik> bad internet connection, can't read it :(
16:40:02 <nirik> looks like a blocker to me.
16:40:31 <tflink> proposed #agreed 963810 - AcceptedBlocker - Violates the following F19 alpha release criterion when updates with UTF-8 specific characters are available: "The installed system must be able to download and install updates with yum and with the default graphical package manager in all release-blocking desktops."
16:40:40 <jreznik> hughsie is going to be in brno this week, so I can follow up with him personally
16:41:16 <adamw> it's already MODIFIED
16:41:26 <adamw> ack
16:41:26 <nirik> ack
16:41:30 <jreznik> ack
16:41:35 <tflink> #agreed 963810 - AcceptedBlocker - Violates the following F19 alpha release criterion when updates with UTF-8 specific characters are available: "The installed system must be able to download and install updates with yum and with the default graphical package manager in all release-blocking desktops."
16:41:47 <tflink> #topic (963361) pesign currently does not align signature list entries, which will cause shim to fail on newer firmware.
16:41:51 <tflink> #link https://bugzilla.redhat.com/show_bug.cgi?id=963361
16:41:53 <tflink> #info Proposed Blocker, pesign, NEW
16:42:48 <tflink> -1 blocker for beta, I think
16:42:52 <nirik> yeah, def +1 FE... but not sure on blocker since we don't know how many machines this affects.
16:43:19 <dan408> back
16:43:33 <tflink> although messing with shim this close to release doesn't seem like the wisest thing ever
16:45:01 <dan408> +1 FE
16:45:32 <tflink> for the record, it's already accepted as FE
16:45:39 <tflink> we're looking for blocker votes
16:45:42 <adamw> right, so just a question whether we block on it
16:45:46 <adamw> i guess i'd shade -1 blocker
16:45:51 <dan408> -1 blocker
16:45:54 <adamw> but i know pjones wanted to get it in so i'll make sure he knows the deadlines
16:45:55 * nirik leans toward -1 as well.
16:47:17 <tflink> proposed #agreed 963361 - RejectedBlocker - This doesn't seem to affect enough machines (newer OVMF which is not supported, unknown number of newer firmwares) and is thus rejected as a blocker for F19 beta
16:48:04 <dan408> ack
16:48:11 <nirik> ack
16:48:16 <tflink> actually, I have a patch
16:48:37 * adamw waits for patch
16:48:58 <tflink> proposed #agreed 963361 - RejectedBlocker - This doesn't seem to affect enough machines (newer OVMF which is not supported, unknown number of newer firmwares) and disabling secure boot is an acceptable workaround for beta. Thus, this bug is rejected as a blocker for F19 beta
16:49:03 <dan408> ack
16:49:11 <tflink> change was in workaround
16:49:16 <adamw> ack
16:49:18 <tflink> emphasis on "for beta"
16:49:18 <nirik> ack
16:49:28 <tflink> #agreed 963361 - RejectedBlocker - This doesn't seem to affect enough machines (newer OVMF which is not supported, unknown number of newer firmwares) and disabling secure boot is an acceptable workaround for beta. Thus, this bug is rejected as a blocker for F19 beta
16:49:51 <tflink> #topic (965101) QXL driver crashes in KVM (i386)
16:49:51 <tflink> #link https://bugzilla.redhat.com/show_bug.cgi?id=965101
16:49:51 <tflink> #info Proposed Blocker, xorg-x11-drv-qxl, NEW
16:50:30 <dan408> -1
16:50:38 <tflink> I thought that the default driver was QXL for recent installs
16:50:57 <tflink> VNC/Cirrus was only if you've been upgrading since ~ F15
16:51:03 <nirik> it's also only 32bit it seems?
16:51:04 <dan408> this is defined nowhere in the criterion
16:51:06 * nirik hasn't hit it here.
16:51:31 <nirik> tflink: yeah, mine have been getting qxl I am pretty sure.
16:52:04 <tflink> I wonder if kparal hit it as well
16:52:06 <adamw> yes, qxl is default as long as you installed kinda recently.
16:52:26 * dan408 is wondering why this is proposed when it's not in the criterion
16:52:41 <adamw> it'd be under the virt criteria
16:52:42 * dan408 wonders if he's missing something
16:52:47 <tflink> dan408: the cited criterion isn't good enough?
16:52:57 <tflink> https://bugzilla.redhat.com/show_bug.cgi?id=965101#c3
16:53:04 <adamw> so it sounds quite bad, but thinking logically about it, we don't really support virt on i686 systems
16:53:15 <adamw> you pretty much need to have x86_64 for kvm to actually work
16:53:19 <tflink> which is i386?
16:53:23 <adamw> so this isn't as bad as it sounds
16:53:25 <adamw> yes, same deal - 32-bit
16:53:30 <tflink> the guest or the host?
16:53:37 <dan408> +1 FE
16:53:54 <tflink> adamw: the host is x86_64, the guest is i386
16:54:29 <nirik> yeah, I misread that too. the first comment makes it sound like everything is 32bit
16:54:49 <adamw> tflink: yes, but my point is, if you have an x86_64 host there isn't much reason to use an i386 guest
16:54:57 <adamw> so there is always a simple workaround for this: use an x86_64 guest
16:54:59 <tflink> adamw: why not?
16:55:00 <nirik> well, less memory use I guess.
16:55:06 <adamw> tflink: why?
16:55:06 <dan408> personally i'd like to see better support for running fedora as a guest with different virtualizers
16:55:18 <dan408> EOF
16:55:21 <tflink> adamw: memory usage, i386-only apps
16:55:49 <nirik> but yeah, this is borderline for blocker... since we can workaround for now by just doing a 64bit.
16:56:08 <nirik> so, I guess I am -1 blocker (document workaround) +1 FE (if the fix is very self contained/etc)
16:56:08 <dan408> so +1 FE ?
16:56:35 * adamw just checking he's right about 32-bit virt hosts not being supported
16:56:50 <tflink> adamw: how is that related to this bug, though?
16:57:11 <tflink> this has nothing to do with an i386 virt host
16:57:34 <adamw> tflink: I don't think 32-bit hosts can host 64-bit guests
16:57:38 * nirik nods at tflink
16:57:38 <dan408> .fire adamw
16:57:41 <zodbot> adamw fires adamw
16:57:46 <nirik> adamw: this is a 64bit host.
16:57:49 <tflink> adamw: still not following you
16:57:55 <adamw> so if we support 32-bit hosts, this becomes an important case. at least, assuming 32-bit on 32-bit is broken too, and not just 32-bit on 64-bit
16:58:09 <tflink> oh, that's what you were getting at
16:58:11 <adamw> nirik: i was assuming the same bug would affect a 32-bit guest on a 32-bit host, though i suppose that may not be the case.
16:58:22 <nirik> yeah, not sure it would.
16:58:44 <nirik> perhaps we punt and ask for testing on more combos?
16:59:12 <tflink> I only see one definite hit on this, too
16:59:15 <dan408> +1 to punt
16:59:18 * jreznik is back, rereading
16:59:20 <dan408> also -1 block +1 FE
16:59:21 <tflink> I assume kparal hit it, though
16:59:40 <adamw> it says 'reproduced on two systems' iirc
17:01:07 <tflink> I'm a little unclear where we are on votes
17:01:18 * dan408 taps foot
17:01:23 <adamw> i guess i'm -1 blocker, possibly +1 fe
17:01:29 <adamw> <bhavna> adamw, dallan: KVM is only supported on 6.4-bit
17:01:30 <dan408> +1 fe
17:01:36 <tflink> does cirrus work with shell?
17:01:40 <adamw> so, everyone break out your 6.4 bit systems
17:01:45 <adamw> tflink: last I checked...kinda.
17:01:58 <adamw> actually, better than it used to.
17:02:08 <dan408> i'll test it if needed it
17:02:17 <dan408> i dont think this should block
17:02:23 <tflink> then -1/+0 on this
17:03:00 <tflink> if you're installing in a VM, it seems reasonable to expect users to update
17:03:02 <jreznik> -1 blocker, not sure it's worth FE now
17:03:15 <tflink> if you can't update, using cirrus is an acceptable workaround
17:03:40 <tflink> so, -1/-.5 from me
17:03:46 <dan408> #link https://fedoraproject.org/wiki/QA:Testcase_Install_to_Current_KVM
17:03:52 <tflink> is everyone still +1 FE?
17:03:56 <dan408> yes
17:03:57 <adamw> i don't mind -1 fe.
17:03:58 <dan408> +1 fe
17:04:07 * dan408 is +1 for moving on
17:04:09 <adamw> heh
17:04:53 <tflink> it looks like we're more +1 FE than -1
17:05:13 <dan408> i dont see anything wrong with a +1 FE
17:05:18 <nirik> I suppose if we have good workarounds, I'm ok with -1 /-1 for beta...
17:05:27 <nirik> we don't have to take the fix if it's too scary.
17:05:39 <tflink> dan408: destabilizing the release right before go/no-go mostly
17:05:48 <tflink> the potential to, rather
17:05:53 <dan408> it can always get unpushed
17:06:03 <tflink> dan408: not really
17:06:09 <dan408> okay
17:06:12 <dan408> -1/-1
17:06:25 <adamw> dan408: it _can_ do, but if we do a build and include it and it turns out to explode things, it costs us time to respin without it
17:06:54 <nirik> all the retesting is a drag
17:07:27 <tflink> proposed #agreed 965101 - RejectedBlocker RejectedFreezeException - While this is a paritial violation of the F19 beta release criterion, it is limited to 32 bit guests, has workarounds (use Cirrus or 64 bit guest) and could reasonably be fixed with an update in most cases.
17:07:42 <dan408> i think they broke gnome-icon-theme
17:07:49 <nirik> ack
17:08:04 <jreznik> ack
17:08:04 <adamw> ack
17:08:13 <tflink> #agreed 965101 - RejectedBlocker RejectedFreezeException - While this is a paritial violation of the F19 beta release criterion, it is limited to 32 bit guests, has workarounds (use Cirrus or 64 bit guest) and could reasonably be fixed with an update in most cases.
17:08:26 <tflink> OK, that's all of the blockers on my list
17:08:35 <tflink> moving on to the proposed FEs
17:08:56 <tflink> #topic (962006) Crash when installing a specific btrfs layout with a kickstart
17:08:59 <tflink> #link https://bugzilla.redhat.com/show_bug.cgi?id=962006
17:09:02 <tflink> #info Proposed Freeze Exceptions, anaconda, NEW
17:09:19 <dan408> +1 blocker
17:09:30 <dan408> or +1 FE
17:09:36 <dan408> since it's not proposed as a blocker
17:10:19 <adamw> actually this seems like it may be user error
17:10:20 <tflink> oh, this is already accepted
17:10:27 <adamw> tflink: see the note from the last meeting.
17:10:33 <tflink> yeah, I just read it
17:10:55 <tflink> so, skip for today
17:11:05 <dan408> i might have a new FE/possible blocker for gnome
17:11:07 <adamw> https://bugzilla.redhat.com/show_bug.cgi?id=962006#c10
17:11:09 <tflink> #info still unclear whether this is user error or not
17:11:22 <adamw> if dlehman doesn't get back soon i'll just close the bug
17:11:30 <tflink> #link https://bugzilla.redhat.com/show_bug.cgi?id=962006#c10
17:11:33 <dan408> brb bio break
17:12:01 <tflink> #topic (963958) dialog-warning-symbolic.svg (used as the 'warning triangle' emblem in anaconda) is now grey; if anaconda wants the old orange one, anaconda should ship it
17:12:05 <tflink> #link https://bugzilla.redhat.com/show_bug.cgi?id=963958
17:12:08 <tflink> #info Proposed Freeze Exceptions, anaconda, NEW
17:13:09 <adamw> this looks kinda janky and a fix would be pretty safe
17:13:16 <adamw> but it's not the end of the world
17:13:29 <tflink> it took me a sec to see where the grey issue was
17:13:58 <adamw> i think it takes a second because your eyes just don't see the triangle any more :)
17:14:06 <tflink> yeah, exactly
17:14:14 <adamw> so it's not great, but no-one's gonna die.
17:14:27 <tflink> it seems safe enough
17:14:31 <tflink> +1 FE
17:14:41 <adamw> +1 from me
17:15:06 <nirik> +1 FE
17:16:05 <dan408> +1 FE
17:16:08 <tflink> proposed #agreed 963958 - AcceptedFreezeException - This makes warnings on the hub very non-obvious and a fix would be nice but certainly not required. A tested fix would be considered past F19 beta freeze
17:16:23 <adamw> ack
17:16:45 <dan408> ack
17:17:32 <nirik> ack
17:17:34 <tflink> #agreed 963958 - AcceptedFreezeException - This makes warnings on the hub very non-obvious and a fix would be nice but certainly not required. A tested fix would be considered past F19 beta freeze
17:17:39 <tflink> #topic (963841) update logo on login screen.
17:17:39 <tflink> #link https://bugzilla.redhat.com/show_bug.cgi?id=963841
17:17:39 <tflink> #info Proposed Freeze Exceptions, gdm, ON_QA
17:17:51 <tflink> what else changed in that gdm update?
17:18:05 <tflink> my first thought is -1 when I see FE and gdm together
17:18:23 <adamw> nothing, but at the same time, the change itself is almost invisible...
17:18:39 <dan408> nothing changed
17:18:41 <adamw> all you have to do is A/B the two files mentioned
17:18:55 <dan408> -1
17:19:04 <dan408> purely cosmetic
17:19:12 <adamw> so yeah, i guess i'd be -1 now i noticed that, and let the artwork people sort out what the hell is going on for final
17:20:06 * nirik doesn't think this is worth a FE...
17:20:21 <dan408> 3 -1's
17:20:49 <tflink> are we -1ing the update or the idea of a fix to the bug in question
17:21:06 <dan408> we are -1ing the FE
17:21:15 <tflink> dan408: that's a non-answer
17:21:17 <dan408> it does not fix a bug
17:21:22 <dan408> it is a cosmetic change to gdm
17:21:42 <nirik> I think they can change it to whatever they like after freeze?
17:21:48 <dan408> yes.
17:21:49 * adamw throws https://bugzilla.redhat.com/show_bug.cgi?id=964965 on the proposed FE pile
17:21:52 <adamw> nirik: right
17:21:58 <tflink> true, gdm doesn't show up on lives either
17:22:05 <adamw> tflink: i guess i'm -1ing the idea of changing this at this point
17:22:15 * nirik nods to adamw.
17:22:17 <adamw> what we have right now looks okay and doesn't violate any TM guidelines or anything afaik
17:22:35 <dan408> +1 FE
17:22:39 <adamw> and the fact that the current proposed change is so...odd seems to suggest people are not all on the same page about what they want
17:22:43 <adamw> so i'm saying 'let them figure it out for final'
17:23:11 <tflink> proposed #agreed 963841 - RejectedFreezeException - The logo we have now doesn't pose any legal issues and this could be fixed with an update post-release since gdm doesn't normally show up on livecds.
17:23:12 <dan408> +1 FE on 964965 -1 on 963841
17:23:20 <dan408> ack
17:23:25 <adamw> ack
17:23:26 <nirik> ack
17:23:33 <tflink> #agreed 963841 - RejectedFreezeException - The logo we have now doesn't pose any legal issues and this could be fixed with an update post-release since gdm doesn't normally show up on livecds.
17:23:39 <adamw> if you install from the live cd you'll see the 'old' gdm at least once, but eh.
17:23:51 <tflink> #topic (961140) g-i-s lets you create a user with no password, but if you do, transition from g-i-s to user session fails and g-i-s re-runs on reboot
17:23:54 <tflink> #link https://bugzilla.redhat.com/show_bug.cgi?id=961140
17:23:56 <tflink> #info Proposed Freeze Exceptions, gnome-initial-setup, ON_QA
17:24:11 <tflink> adamw: if you install from dvds, you'll probably see it once as well
17:24:18 <dan408> can we just completely block i-s
17:24:40 * satellit_e +1
17:24:41 <tflink> wait, it allows blank passwords but not "too simple" ones?
17:24:42 * nirik is +1 FE on this one, sounds like something people could hit and just looks bad.
17:25:10 <adamw> tflink: yes. i don't know why.
17:25:20 <adamw> and yeah, +1, the bug is pretty icky if you hit it.
17:26:13 <tflink> what was the fix?
17:26:54 * satellit_e may be needed for OEM install
17:28:14 <adamw> the fix is to do it properly
17:28:24 <adamw> so it still lets you create a user with no password, it just works now (allegedly, i haven't checked)
17:28:29 <tflink> yeah, just wondering what else might have snuck in
17:28:32 <tflink> but it's a patch
17:28:36 <tflink> not a new tarball
17:30:01 <tflink> did we pull in the fix for https://bugzilla.redhat.com/show_bug.cgi?id=928645 ?
17:30:22 <tflink> the git commits indicate that the update includes a fix for that
17:31:19 <adamw> i'm checking what g-i-s was in rc2
17:31:40 <tflink> if it was 0.10-2, it had the 928645 fix in it
17:31:55 <tflink> I don't see an update for that, though
17:32:02 <dan408> im about to propose after some further investigation and openfloor
17:32:43 <adamw> goddamnit, my loop mount is hanging
17:33:26 <tflink> proposed #agreed 961140 - AcceptedFreezeException - This is a pretty nasty bug to hit if you don't add a password to the user in g-i-e, a tested fix would be considered past F19 beta freeze.
17:33:37 <adamw> ack for now
17:33:46 <adamw> i can check on what we had in rc2 and how big the proposed change is later
17:33:55 <nirik> ack
17:34:05 <tflink> #info this needs more investigation before pulling in, but accepted for now
17:34:19 <tflink> adamw: if we went from -2 to -3, it's a one-liner
17:34:28 <tflink> http://pkgs.fedoraproject.org/cgit/gnome-initial-setup.git/commit/?h=f19
17:34:56 <tflink> not sure about the no-release to -2, though
17:34:57 <adamw> yeah
17:35:01 <tflink> I see 3 patches in -2
17:35:02 <adamw> that's what i need to check on
17:35:07 <adamw> i think we may have had -1 in rc2
17:35:11 <adamw> the patches are all kinda useful, but...
17:35:17 <adamw> anyhow, i'll check it out before the rc3 request.
17:35:31 <tflink> as far as I can tell, there was no update for -2
17:36:29 <tflink> #agreed 961140 - AcceptedFreezeException - This is a pretty nasty bug to hit if you don't add a password to the user in g-i-e, a tested fix would be considered past F19 beta freeze.
17:36:45 <tflink> #topic (928659) gnome-initial-setup should logout existing user when changing desktop locale
17:36:48 <tflink> #link https://bugzilla.redhat.com/show_bug.cgi?id=928659
17:36:50 <tflink> #info Proposed Freeze Exceptions, gnome-initial-setup, NEW
17:37:43 <adamw> if they'd got a fix for this in last week then sure, but it seems a bit late now
17:37:49 <adamw> this one's much less severe than the last
17:37:56 <adamw> more of a polish thing
17:38:22 <tflink> yeah, I'm probably -1 on this
17:38:24 <tflink> for beta
17:38:36 <tflink> would be more +1 for final
17:38:55 <adamw> yeah, that's to worry about for the future though.
17:39:10 <tflink> yep
17:39:15 <tflink> other votes?
17:40:03 <dan408> +1 final
17:40:41 <adamw> we don't need to vote on final status now
17:40:48 <adamw> dan408: what's your vote for beta FE?
17:41:09 <dan408> sure +1
17:42:23 <tflink> so we're -1/+1 ATM
17:42:42 <adamw> what?
17:42:44 <adamw> this is a proposed FE
17:42:48 <adamw> there's no X/Y
17:42:55 <adamw> you're either -1 to beta FE or +1
17:42:58 <adamw> we're not voting on final
17:43:07 <adamw> i'm -1 to beta fe
17:43:16 <tflink> adamw: if you have a better format for displaying votes, go for it
17:43:24 <tflink> now we-re -2/+1
17:43:34 <adamw> ohhh, sorry, i misread
17:43:42 <adamw> :)
17:43:44 <adamw> .fire adamw
17:43:44 <zodbot> adamw fires adamw
17:44:09 <tflink> nirik, jreznik: any votes?
17:44:28 * nirik reads up
17:45:10 <nirik> -1
17:45:12 <tflink> proposed #agreed 928659 - RejectedFreezeException - While unfortunate, this is not a severe issue and can be worked around by logging out or restarting after g-i-s runs.
17:45:47 <adamw> ack
17:46:14 <jreznik> ack, sorry for avoiding g-i-s related discussion :)
17:48:29 <tflink> jreznik: so it was on purpose?
17:49:09 <tflink> #agreed 928659 - RejectedFreezeException - While unfortunate, this is not a severe issue and can be worked around by logging out or restarting after g-i-s runs.
17:49:18 <tflink> #topic (964828) On EFI: F18 is rendered unbootable after installing F19
17:49:21 <tflink> #link https://bugzilla.redhat.com/show_bug.cgi?id=964828
17:49:24 <tflink> #info Proposed Freeze Exceptions, grub2, NEW
17:50:20 <tflink> that's weird, why is grub2 ignoring efi?
17:50:50 <adamw> this whole area just isn't very well tested/covered yet, really
17:51:47 <tflink> I'm not sure about a grub FE change right now
17:51:56 <brunowolff> I'm a bit leery of changing stuff there without much room to rebuild after a bad change.
17:51:59 <tflink> it would depend on the fix, I suppose
17:52:21 <tflink> this seems a bit too corner-casey to be changing grub for this close to go/no-go
17:52:35 <tflink> +1 commonbugs, though
17:52:48 <adamw> it'd be kinda nice to have this covered for testing, is the only thing
17:52:56 <adamw> but yeah, destabilizing is a worry too
17:53:24 <tflink> -1 FE, +1 doc - if someone is installing F19 beta alongside F18, they can probably figure out how to muck with grub.cfg
17:53:35 <nirik> ditto what tflink said.
17:53:55 <adamw> i won't fight that
17:55:05 <tflink> proposed #agreed 964828 - RejectedFreezeException - This is too much of a corner case to justify taking grub changes for this late in the beta cycle. Documentation via CommonBugs is acceptable for Beta
17:55:19 <adamw> ack
17:55:44 <brunowolff> ack
17:56:14 <tflink> #agreed 964828 - RejectedFreezeException - This is too much of a corner case to justify taking grub changes for this late in the beta cycle. Documentation via CommonBugs is acceptable for Beta
17:56:22 <tflink> #topic (963098) Left/Right cursor key does not work in the initial conversion state
17:56:24 <tflink> #link https://bugzilla.redhat.com/show_bug.cgi?id=963098
17:56:27 <tflink> #info Proposed Freeze Exceptions, libkkc, ON_QA
17:56:56 <tflink> I'm having trouble understanding what the bug is here
17:57:31 <tflink> is it trying to edit text in the japanese ime before rendering/converting?
17:58:11 <tflink> that's what it sounds like, to me
17:58:36 <adamw> no, it's *after* rendering/converting
17:58:49 <adamw> you type your string, hit enter to accept the rendering of it, then you can't move the cursor within the text you just input
17:59:01 <adamw> i have the updated libkkc here and I just tested that it's working
17:59:11 <adamw> and this fix would be isolated to japanese users so we can't break anything else
17:59:12 <adamw> so i guess +1
17:59:25 <tflink> can you use japanese on the lives?
17:59:32 <tflink> w/o installing, I mean
17:59:43 <adamw> uh, not sure. lemme check
18:00:22 <tflink> I'm probably +1 on this, though. it's isolated and is kind of impolite even if it is mostly fixable with an update
18:01:41 <tflink> with an emphasis on the isolation
18:02:01 <brunowolff> Does this affect anaconda installs?
18:02:34 <tflink> during the install? not sure
18:03:34 <tflink> can you use an ime during install?
18:03:49 <dan408> hi
18:03:52 <jreznik> if it could be updated, I'll be less supportive of that
18:04:34 <adamw> just checking
18:04:47 <adamw> tflink: non-live install, no, anaconda does not have ibus support at present
18:04:53 <brunowolff> If it ends up not affecting the lives we produce or installing with the install disk, I'd rather just have this be an update at this point.
18:04:54 <tflink> jreznik: I don't think it would interfere with updates, no
18:05:15 <tflink> I think it's mostly an annoyance
18:05:30 <tflink> if it's on the lives, I'm ok with +1
18:05:32 <adamw> you can indeed use KKC on the live image
18:05:36 <adamw> and RC2 has teh bug
18:05:39 <tflink> +1
18:05:47 <brunowolff> Then I'm +1 FE.
18:05:50 <adamw> so yeah, +1
18:06:24 <jreznik> ok, +1
18:07:02 <dan408> +1
18:07:04 <tflink> proposed #agreed 963098 - AcceptedFreezeException - This interferes with IME text input on the live images which can't be fixed with updated. The already proposed fix is isolated and would be considered past F19 beta freeze once tested.
18:07:32 <brunowolff> ack
18:08:11 <adamw> ack
18:09:14 <tflink> #agreed 963098 - AcceptedFreezeException - This interferes with IME text input on the live images which can't be fixed with updated. The already proposed fix is isolated and would be considered past F19 beta freeze once tested.
18:09:18 <tflink> #topic (963238) SELinux is preventing lightdm from 'create', 'write', and 'rename' accesses on the file .dmrc.RANDOM
18:09:21 <tflink> #link https://bugzilla.redhat.com/show_bug.cgi?id=963238
18:09:23 <tflink> #info Proposed Freeze Exceptions, lightdm, ON_QA
18:10:25 <tflink> which spin does this break and how?
18:10:29 <dan408> +! blocker
18:10:31 <dan408> +1 blocker
18:10:38 <dan408> it's not just spins
18:10:48 <dan408> this blocks any DE that uses lightdm
18:10:53 <dan408> err affects
18:11:00 <adamw> none of those are release blocking desktops, though.
18:11:00 <tflink> what is the effect?
18:11:02 <dan408> mate, cinnamon (which is switching to lightdm)
18:11:08 <dan408> everytime you login you get an selinux alert
18:11:09 <brunowolff> If it isn't KDE or Gnome, that makes it FE, not blocker.
18:11:15 <tflink> does it block login?
18:11:15 <adamw> and I don't know that this bug actually stops lightdm working, it just throws an alert
18:11:21 <dan408> KDE is probably affected too
18:11:25 <adamw> no, KDE uses KDM.
18:11:27 <dan408> i believe KDE was switching to lightdm
18:11:29 <tflink> if it's just an alert, I'm OK with -1
18:11:32 <adamw> it's still on KDM atm
18:11:38 <dan408> no this has been going on for 3 months
18:11:42 <nirik> it's just a notice on Xfce at least.
18:11:46 <dan408> i dont understand what the heold up
18:11:48 <adamw> this would be +1 final FE by policy, beta fe is up to our discretion
18:11:52 <nirik> I noted it in my desktop tests for Xfce. ;)
18:12:18 <dan408> this would really look bad for anyone trying out MATE or XFCE or even LXDE
18:12:21 <dan408> as a beta
18:12:21 <nirik> this is on the wrong component, IMHO
18:12:25 <adamw> since it only affects non-blocking desktops i'd probably defer to the non-blocking desktop owners in deciding whether to take it, but the two we have here seem to be voting in opposite directions :)
18:12:27 <dan408> "Oh yay another selinux alert"
18:12:32 * satellit_e sugar is switched to it also on my latest remix
18:12:35 <nirik> it should be moved to selinux-policy
18:12:49 <tflink> the fix is in lightdb, though
18:12:55 <tflink> er, lightdm
18:13:00 <adamw> nirik: it originally was, and was intentionally moved
18:13:01 <dan408> .bug 963238
18:13:05 <zodbot> dan408: Bug 963238 SELinux is preventing lightdm from 'create', 'write', and 'rename' accesses on the file .dmrc.RANDOM - https://bugzilla.redhat.com/show_bug.cgi?id=963238
18:13:12 <nirik> oh, I see. re-reading
18:13:19 <tflink> the fix was to drop functionality from lightdm
18:13:49 <nirik> got it. Sure, I'd be +1 to FE on this...
18:14:03 <adamw> given the nature of the change being safe and restricted to non-blocking desktops i could probably go with a +1
18:14:04 <dan408> no this isn't the same bug
18:14:11 <adamw> dan408: same as what?
18:14:16 <dan408> sec
18:14:25 <tflink> what is the relationship between kdm and lightdm?
18:14:30 <dan408> nothing
18:14:33 <adamw> they're both DMs
18:15:01 <adamw> this ~/.dmrc file appears to have been something that was like a DM-independent config file in the past or something
18:15:05 <tflink> ok, wasn't sure since c#16 references kdm behavior WRT ~/.dmrc
18:15:09 <adamw> so if you write something to it, all DMs should respect that, whatever it is
18:15:10 <nirik> yes, it was used in the past.
18:15:29 <adamw> i think c#16 is saying that only lightdm and kdm even bother doing anything with dmrc any more, and accountsservice has kinda superseded it, so let's just drop it
18:15:42 <dan408> i guess it is the same bug
18:15:43 <adamw> though i don't know if anyone has tested xdm. or cares about xdm at all in any way.
18:15:45 <dan408> reassigned to lightdm
18:15:47 <dan408> +1 FE
18:16:01 * nirik doesn't think anyone cares about xdm anymore. ;)
18:16:11 <tflink> it sounds like we're mostly +1 on this?
18:16:17 <adamw> personally i only care about whatever DMs our important spins use, which is gdm, kdm, lightdm.
18:16:21 <adamw> yeah, I think so.
18:16:31 <dan408> please +1 this FE
18:16:36 <adamw> so if all three of those speak AccountsService, then dropping .dmrc seems appropriate.
18:17:43 <tflink> I'm still not a fan of taking FEs for AVC warnings this late, but won't fight it
18:18:05 <dan408> this has been a long time bug
18:18:35 <tflink> dan408: that's not good enough for FE
18:18:52 <dan408> .bug 922958
18:18:57 <zodbot> dan408: Bug 922958 SELinux is preventing /usr/sbin/lightdm from 'create' accesses on the file .dmrc.T5D7TW. - https://bugzilla.redhat.com/show_bug.cgi?id=922958
18:19:08 <dan408> never voted on
18:19:11 <dan408> never rejected nor accepted
18:19:34 <tflink> proposed #agreed 963238 - AcceptedFreezeException - It appears that the functionality causing the AVC warnings (~/.dmrc) is not used much anymore and can be safely dropped. A tested fix would be considered past F19 beta freeze.
18:19:51 <tflink> dan408: which is orthagonal to the discussion here
18:19:53 <dan408> ack
18:20:01 <tflink> FE != todo list
18:20:09 <dan408> .fire tflink
18:20:09 <zodbot> adamw fires tflink
18:20:11 <adamw> ack
18:21:52 <brunowolff> ack
18:21:53 <tflink> #agreed 963238 - AcceptedFreezeException - It appears that the functionality causing the AVC warnings (~/.dmrc) is not used much anymore and can be safely dropped. A tested fix would be considered past F19 beta freeze.
18:21:57 <tflink> #topic (961446) Review Request: c2esp - CUPS driver for Kodak AiO printers
18:22:00 <tflink> #link https://bugzilla.redhat.com/show_bug.cgi?id=961446
18:22:03 <tflink> #info Proposed Freeze Exceptions, Package Review, NEW
18:22:09 <dan408> -1 FE
18:22:34 <tflink> is this on the dvd?
18:23:02 <dan408> unspecificed
18:23:13 <brunowolff> -1 FE in any case. This can be fixed in an update.
18:23:15 <tflink> an unassigned reveiw request?
18:23:19 <tflink> -1 FE
18:23:20 <adamw> yeah, easy -1.
18:23:24 <jreznik> -1
18:24:24 <tflink> proposed #agreed 961446 - RejectedFreezeException - This package is not reviewed yet, nor would it be on the DVD. Thus, any FE designation would not affect the package and the bug is rejected as a Freeze Exception for F19 beta
18:24:30 <dan408> ack
18:24:42 <jreznik> ack
18:25:14 <adamw> ack
18:25:16 <tflink> #agreed 961446 - RejectedFreezeException - This package is not reviewed yet, nor would it be on the DVD. Thus, any FE designation would not affect the package and the bug is rejected as a Freeze Exception for F19 beta
18:25:20 <tflink> #topic (963359) Shim should provide a mechanism for \EFI\BOOT\BOOTX64.EFI as a fallback on fixed media.
18:25:23 <tflink> #link https://bugzilla.redhat.com/show_bug.cgi?id=963359
18:25:26 <tflink> #info Proposed Freeze Exceptions, shim, NEW
18:26:06 <adamw> pjones asked for this one, though i was kinda hoping he'd have it done earlier
18:26:13 <adamw> it seems to be getting somewhat late at this point
18:27:00 <tflink> yeah, I'm probably -1 on this
18:27:04 <tflink> er, -1
18:27:14 <tflink> we've been getting along fine without this AFAIK
18:27:15 <dan408> -1
18:27:30 <adamw> tflink: well, there are cases which will break without the change, but they're not super common
18:27:35 <brunowolff> -1 unless there is a slip
18:27:39 <adamw> it's if you manage to nerf your EFI boot manager or you move an install, basically
18:27:43 <tflink> adamw: that wouldn't have broken in F18?
18:27:51 <dan408> move it to final
18:27:54 <tflink> yeah, and there are ways to work around this
18:27:56 <dan408> brunowolff: sent you a pm
18:28:00 <tflink> I've done it :)
18:28:18 <adamw> pjones says he's unlikely to have a fix for this in time for beta anyway.
18:28:28 <adamw> tflink: sure, they'd be broken in 18 too.
18:29:34 <jreznik> if there would be no fix for beta, slip it for final
18:30:18 <tflink> proposed #agreed 963359 - RejectedFreezeException - While this would be a useful recovery feature, it isn't required and it's too close to go/no-go to be taking shim features past freeze
18:30:22 <tflink> ack/nak/patch?
18:30:54 <adamw> ack
18:31:09 <dan408> ack
18:31:16 <jreznik> ack
18:31:26 <dan408> i dont have much time left
18:31:27 <tflink> #agreed 963359 - RejectedFreezeException - While this would be a useful recovery feature, it isn't required and it's too close to go/no-go to be taking shim features past freeze
18:31:31 <dan408> but im going to add this as an FE
18:31:37 <tflink> #topic (927564) F19 release-name “Schrödinger’s Cat” shown as "SchrA¶dingerâÇÖs Cat" on the  linux console
18:31:40 <tflink> #link https://bugzilla.redhat.com/show_bug.cgi?id=927564
18:31:42 <tflink> #info Proposed Freeze Exceptions, systemd, ASSIGNED
18:31:44 <dan408> +1 FE
18:32:27 <adamw> i have not been keeping up with this bug
18:32:39 <adamw> what needs to get fixed now?
18:32:50 <tflink> font on command line
18:32:55 <dan408> self explanatory
18:32:59 <adamw> i mean, what change is needed now
18:33:03 <tflink> so, a change to grub cfg
18:33:08 <adamw> since at my last count we'd done like five fixes for this already
18:33:14 <tflink> at least that's how I'm reading it
18:33:25 <tflink> if they want to change grub defaults, I'm a strong -1
18:33:41 <dan408> this should actually be a release blocker
18:33:46 <adamw> why?
18:33:48 <brunowolff> This is a pretty minor issue for beta. The fix can wait.
18:33:55 <dan408> it's kind of ridiculous
18:33:57 <adamw> (that 'why' was for dan)
18:34:03 <adamw> 'kind of ridiculous' isn't in the criteria
18:34:09 <dan408> oh
18:34:10 <dan408> ok
18:34:10 <adamw> who does it benefit for us to delay the beta release to fix this?
18:34:21 <dan408> our image
18:34:26 <adamw> it's a beta
18:34:36 <dan408> a nice polished beta would be NTH
18:34:46 <adamw> yes, but a beta that works is also nice
18:34:55 <tflink> I see -1/+1 explicitly, brunowolff sounds -1, so -2/+1 I think
18:34:55 <dan408> anyways
18:35:06 <adamw> hence throwing shit at key components at the last minute to fix entirely superficial bugs isn't recommended
18:35:28 <dan408> anyways i have a few minutes before i must go, may i have a minute of your time?
18:35:29 <adamw> i'm -1 at least until we see precisely what someone wants to change for this; it sounds like no-one's really sure what's still broken any how
18:35:34 <dan408> sorry to side track the meeting
18:35:49 <tflink> -3/+1
18:35:53 <dan408> im -1
18:35:54 <dan408> -4
18:36:45 <tflink> proposed #agreed 927564 - RejectedFreezeException - While this does look bad, the currently proposed fixes require changes to vital system components and are not appropriate for Freeze Exceptions.
18:36:56 <adamw> ack
18:37:01 <dan408> ack
18:37:11 <tflink> #agreed 927564 - RejectedFreezeException - While this does look bad, the currently proposed fixes require changes to vital system components and are not appropriate for Freeze Exceptions.
18:37:19 <brunowolff> ack
18:37:32 * tflink wants to get through everything before we hit the 3 hr time limit
18:37:36 <tflink> #topic (958787) X error "AddScreen/ScreenInit failed for gpu driver 0 -1" on iMac12,2 with F19 Beta TC3 when starting GDM
18:37:39 <tflink> #link https://bugzilla.redhat.com/show_bug.cgi?id=958787
18:37:41 <tflink> #info Proposed Freeze Exceptions, xorg-x11-server, NEW
18:38:05 <tflink> still waiting for input from devs
18:38:27 <adamw> yeah, i'm -1 now since it's not clear enough
18:38:47 <tflink> At this point, I'd be -1 on any xorg fixes at this point if the only affected systems are apple hw
18:40:25 <tflink> proposed #agreed  958787 - RejectedFreezeException - This bug is not clear enough to determine what the fix is at this point and seems to affect a limited subset of hardware.
18:40:46 <brunowolff> I'm not seeing any scope on the fix, nor an indication that a large number of people are affected. It seems pretty late to accept this, given the unknowns.
18:40:52 <brunowolff> ack
18:41:22 <tflink> other ack/nak/patch?
18:41:22 <jreznik> ack
18:41:41 <tflink> I'd really to avoid a continuation tomorrow
18:41:49 <adamw> ack
18:41:49 <tflink> #agreed  958787 - RejectedFreezeException - This bug is not clear enough to determine what the fix is at this point and seems to affect a limited subset of hardware.
18:41:57 <tflink> #topic (964965) gdm should require it's own deps to function.
18:41:57 <tflink> #link https://bugzilla.redhat.com/show_bug.cgi?id=964965
18:41:57 <tflink> #info Proposed Freeze Exception, gdm, NEW
18:42:08 <tflink> it sounds like this is breaking soas right now
18:42:14 <adamw> yeah, seems to be.
18:42:20 <adamw> i'm planning to investigate and fix this today
18:42:29 <adamw> the planned fix is only to add requirements to the GDM package, so it should be safe
18:42:46 <adamw> i suppose it could affect the size of spins that include GDM, but it shouldn't affect the desktop spin as, obviously, that already has the needed packages or it wouldn't work.
18:42:49 <tflink> if the fix is to add the required packages to the gdm package, I'd be OK with it
18:43:22 <brunowolff> Is this going to put any spins oversize?
18:43:23 <adamw> so let's say we won't take a fix that involves touching the gdm code or adds any packages to the desktop spin.
18:43:41 <tflink> proposed #agreed 964965 - AcceptedFreezeException - This doesn't require any major changes to gdm, just ensuring that its required packages will be pulled in @ build and use time.
18:43:41 <jreznik> and does not mean oversizing of any spins
18:43:41 <brunowolff> That sounds good.
18:43:58 <adamw> brunowolff: sugar has quite a lot of space below its target so I don't think so
18:44:10 <adamw> sugar is 632MB atm, target 700MB
18:44:14 <tflink> proposed #agreed 964965 - AcceptedFreezeException - This doesn't require any major changes to gdm, just ensuring that its required packages will be pulled in @ build and use time. A tested fix that does not involve touching gdm code or adding packages to the desktop spin would be considered past F19 beta freeze
18:44:29 <adamw> ack
18:44:30 <brunowolff> I was more worried about an optional dependency messing up the desktop spin. You covered that with your caveats.
18:44:43 <adamw> yeah, i'll make sure i test it before i submit anything
18:44:50 <adamw> i'll do a desktop live build and verify it doesn't add any packages
18:44:57 <brunowolff> ack
18:44:59 <jreznik> ok, thanks
18:45:07 * jreznik is out of battery now :(
18:45:26 * satellit_e FYI I just built a remix of Soas and it boots used the gdm missing files + a few others
18:45:37 <tflink> #agreed 964965 - AcceptedFreezeException - This doesn't require any major changes to gdm, just ensuring that its required packages will be pulled in @ build and use time. A tested fix that does not involve touching gdm code or adding packages to the desktop spin would be considered past F19 beta freeze
18:46:01 <tflink> it looks like all the accepted blockers are either VERIFIED or ON_QA
18:46:13 <tflink> any objections to skipping them for today?
18:46:30 <adamw> no, but dan wanted to add a proposed FE
18:46:44 <tflink> dan408: bzid?
18:46:45 <adamw> he suggested https://bugzilla.redhat.com/show_bug.cgi?id=964638 , but the actual bug he's concerned about may not be that bug
18:47:17 <adamw> the actual bug he's concerned about is http://i.imgur.com/epaGfX8.png
18:47:23 <tflink> the firefox, it crashed :(
18:47:28 <adamw> wrong/generic icons used on MATE spin
18:47:32 <adamw> (in anaconda)
18:48:08 <adamw> i thought it may be the same as https://bugzilla.redhat.com/show_bug.cgi?id=964019 - which is a case of crappy icons showing up in the KDE live image in anaconda - but it may not be
18:48:17 <adamw> i think we may need to investigate some more here before proposing anything
18:48:28 <tflink> leave it for wednesday, then?
18:49:33 <adamw> yeah, or do it in-bug
18:50:22 <dan408> .bug 964019
18:50:26 <zodbot> dan408: Bug 964019 Ugly icons when running from KDE live images - https://bugzilla.redhat.com/show_bug.cgi?id=964019
18:50:33 <dan408> err
18:50:35 <dan408> sorry
18:50:45 <dan408> .bug 964638
18:50:50 <zodbot> dan408: Bug 964638 Since some days, alert boxes are presented with black and white icons only - https://bugzilla.redhat.com/show_bug.cgi?id=964638
18:51:00 <dan408> gnome-icon-theme was updated recently
18:51:01 <adamw> yeah, as I said, i don't think 964638 is causing this
18:51:03 <adamw> though I don't know what is
18:51:08 <dan408> i asked the reporter to downgrade to gnome-icon-itheme
18:51:10 <dan408> no change
18:51:18 <dan408> i'll look into it further when i have time
18:51:25 <dan408> i just wanted to get it on the agenda
18:51:34 <dan408> i actually have to run to a doctor's appointment
18:51:44 <dan408> adamw is dling the latest compose and will look into it
18:52:14 <tflink> I believe that's all for today, then
18:52:23 <tflink> #topic Open Floor
18:52:28 <dan408> thanks
18:52:31 <dan408> see y'all later
18:53:23 <tflink> anything else that should be covered in meeting today?
18:53:41 <brunowolff> I need to leave now. I'll try to come by on Wednesday.
18:54:01 <adamw> er, we did https://bugzilla.redhat.com/show_bug.cgi?id=964352 , right?
18:54:12 <adamw> or did we not?
18:54:35 <adamw> oh, we did https://bugzilla.redhat.com/show_bug.cgi?id=963810 .
18:55:15 <tflink> I don't think so
18:55:34 <adamw> 964352 was basically the same as 963810, but it got re-opened to make apper handle the PK crash more gracefully
18:55:37 <adamw> i've dropped the blocker nomination
18:56:04 <tflink> ok
18:56:53 <tflink> if there's nothing else, I'll set the fuse for [0,5] minutes
18:58:47 <tflink> Thanks for coming, everyone!
18:58:55 * tflink will send out minutes shortly
18:58:59 <tflink> #endmeeting