check-in_20170111
LOGS
09:15:11 <nishanth> #startmeeting check-in_20170111
09:15:12 <zodbot> Meeting started Wed Jan 11 09:15:11 2017 UTC.  The chair is nishanth. Information about MeetBot at http://wiki.debian.org/MeetBot.
09:15:12 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
09:15:12 <zodbot> The meeting name has been set to 'check-in_20170111'
09:15:30 <nishanth> #topic anmol's updates
09:17:26 <nishanth> #accept good progress on reviews
09:18:19 <nishanth> #info anmol is working on incorporating review comments
09:19:03 <nishanth> #action k4n0 to review monitoring patches
09:19:33 <nishanth> #topic dahorak's updates
09:19:44 <dahorak> itHub Link: https://github.com/Tendrl/usmqe-tests/pull/24 Change usm_host_config parameter to usm_inventory
09:19:44 <dahorak> Review and possible impact examination.
09:19:44 <dahorak> Otherwise tasks unrelated to Tendrl.
09:21:14 <nishanth> #info dahorak working on https://github.com/Tendrl/usmqe-tests/pull/24
09:21:35 <nishanth> #topic fbalak 's updates
09:22:15 <fbalak> Issue: https://github.com/Tendrl/usmqe-tests/pull/6 - finishing pull request
09:22:21 <fbalak> Status: good
09:23:01 <nishanth> ok
09:23:27 <nishanth> #info fbalak working on  https://github.com/Tendrl/usmqe-tests/pull/6
09:23:36 <nishanth> thanks for the updates
09:23:53 <nishanth> #topic gowtham's updates
09:24:17 <gowtham> Adding Network details in hardware inventory
09:24:28 <gowtham> new changes told by mrugesh
09:24:39 <gowtham> spc file: https://github.com/Tendrl/specifications/pull/19 - updated new change with this spec
09:25:02 <gowtham> spec aproved by rohan and shubhendu and darshan
09:25:17 <gowtham> need mrugesh review for this
09:25:36 <gowtham> Logging implementation
09:26:01 <gowtham> https://github.com/Tendrl/specifications/pull/94
09:26:13 <gowtham> needs mrugesh review for this also
09:26:37 <nishanth> #action brainfunked to review  https://github.com/Tendrl/specifications/pull/19,  https://github.com/Tendrl/specifications/pull/94
09:26:51 <nishanth> gowtham, logging impl is done?
09:26:52 <gowtham> status: blocked because of review required from brainfunked
09:27:32 <gowtham> nishanth, no still brainfunked is not replied for anmols suggestion
09:28:05 <nishanth> gowtham, we will get that sorted out today
09:28:16 <gowtham> nishanth, ok
09:28:30 <nishanth> gowtham, can you setup a meeting talk about this?
09:28:47 <gowtham> nishanth, i have already sent request to brainfunked to give suggestion in github and slack
09:28:55 <gowtham> nishanth, ok
09:30:27 <nishanth> #info gowtham is blocked on reviews, will setup a call to sort this out
09:30:37 <nishanth> gowtham, thanks for the updates
09:30:56 <nishanth> #topic kaverma's updates
09:31:00 <kaverma> yesterday i was on sick leave.
09:31:00 <kaverma> form today morning , i was reviewing neha's PRs (https://github.com/Tendrl/tendrl_frontend/pull/91 - related to unit testing).
09:31:01 <kaverma> and also i recorded the demo for "import cluster workflow" (https://bluejeans.com/s/yRC9D/) , sent mail for the same .
09:31:01 <kaverma> "import cluster workflow from UI" is done with assumed mocked data as we had discussed with mrugesh and anup.
09:31:02 <kaverma> i want some clear clarification on below mentioned point for import cluster from backend-team -
09:31:04 <kaverma> 1) Are we going to consider bootstrap node while importing cluster or it will auto detect all clusters which suppose to be import.
09:31:07 <kaverma> 2) i need proper response format for import cluster for both GET and POST request.
09:33:17 <kaverma> end
09:34:11 <nishanth> kaverma, we need to discuss this off-line. I know that UX designs are done based on bootstrap node. Let us discuss off-line and sort this out today
09:34:35 <nishanth> kaverma, any other thing you are working on?
09:35:02 <kaverma> no . so can i schedule one meeting for same ?
09:35:28 <nishanth> kaverma, please go ahead and  do that
09:35:39 <kaverma> nishanth, sure
09:36:38 <nishanth> #info kaverma require some clarifications on import flow, will schedule a discussion for the same
09:36:59 <nishanth> #info kaverma also doing some code reviews
09:37:20 <nishanth> thanks for the updates
09:38:13 <nishanth> #topic ltrilety's updates
09:38:37 <ltrilety> #info ltrilety is working on https://github.com/Tendrl/usmqe-tests/issues/10
09:39:31 <ltrilety> #action ltrilety is creating a simple log in test, as of now for old skyring (tendrl has no authentication yet)
09:39:36 <ltrilety> that's all
09:39:47 <nishanth> ok
09:39:54 <nishanth> thanks for the updates
09:40:19 <nishanth> #topic mbukatov's updates
09:40:35 <mbukatov> #info finished pull request with proposed fix for Tendrl/alterting#/24
09:40:43 <mbukatov> #link https://github.com/Tendrl/alerting/pull/25
09:40:50 <mbukatov> #info rechecked tendrl-api issue which was previously blocking qe
09:40:57 <mbukatov> #link https://github.com/Tendrl/tendrl-api/issues/31
09:41:04 <mbukatov> #info Tendrl/tendrl-api#31 no longer blocks testing
09:41:12 <mbukatov> #info checked names of systemd service files, filed 2 new issues
09:41:18 <mbukatov> #link https://github.com/Tendrl/gluster-integration/issues/107
09:41:26 <mbukatov> #link https://github.com/Tendrl/ceph-integration/issues/77
09:41:33 <mbukatov> #info check of remaining minor packaging issues done by fbalak
09:41:41 <mbukatov> #info suggested removal of tendrl-site repo
09:41:48 <mbukatov> #link https://github.com/Tendrl/tendrl-site/issues/5
09:41:51 <mbukatov> that's all
09:43:25 <nishanth> mbukatov, ok, can you make the tox related changes to other repos as well?
09:44:01 <mbukatov> nishanth: I plan to do that after the pull request is discussed and merged into the alterting repo
09:44:24 <nishanth> mbukatov, alright, make sense
09:45:05 <nishanth> thanks for the updates
09:45:29 <nishanth> #topic mkudlej's updates
09:45:30 <mkudlej> nishanth: hi, I've done review of https://github.com/Tendrl/usmqe-tests/pull/6 and I'm still working on https://github.com/Tendrl/usmqe-tests/issues/9. That's all.
09:46:01 <nishanth> #info mkudlej reviewed  https://github.com/Tendrl/usmqe-tests/pull/6
09:46:18 <nishanth> #info mkudlej working on n https://github.com/Tendrl/usmqe-tests/issues/9
09:46:27 <nishanth> thanks for the update
09:47:02 <nishanth> #topic ndarshan's updates
09:47:06 <ndarshan> Spec:
09:47:06 <ndarshan> Introduce Flows tied to objects (https://github.com/Tendrl/specifications/issues/34)
09:47:06 <ndarshan> Issues:
09:47:06 <ndarshan> https://github.com/Tendrl/ceph_integration/issues/66
09:47:06 <ndarshan> https://github.com/Tendrl/gluster_integration/issues/95
09:47:06 <ndarshan> https://github.com/Tendrl/common/issues/94
09:47:08 <ndarshan> PRs:
09:47:10 <ndarshan> https://github.com/Tendrl/gluster_integration/pull/96  --> Merged
09:47:12 <ndarshan> https://github.com/Tendrl/ceph_integration/pull/67  -->  Merged
09:47:14 <ndarshan> Summary:
09:47:16 <ndarshan> Introduce Flows tied to object ---> completed from backend. Anoop working on API changes
09:47:18 <ndarshan> ---------------------------------
09:47:20 <ndarshan> ISSUES Fixed:
09:47:22 <ndarshan> https://github.com/Tendrl/node-agent/pull/129 ---> merged
09:47:24 <ndarshan> https://github.com/Tendrl/commons/pull/98 ---> merged
09:47:26 <ndarshan> ---------------------------------
09:47:28 <ndarshan> started working on node_agent tagging and job routing.
09:49:14 <nishanth> #accept ndarshan's PRs(https://github.com/Tendrl/gluster_integration/pull/96 , https://github.com/Tendrl/ceph_integration/pull/67, https://github.com/Tendrl/node-agent/pull/129, https://github.com/Tendrl/commons/pull/98) got merged upstream
09:50:28 <nishanth> ndarshan, Introduce Flows tied to objects --> what stage it is in?
09:51:08 <nishanth> #info ndarshan started working on tag based job routing
09:51:30 <ndarshan> nishanth, Backend side its complete, noopq is working on API layer
09:52:02 <nishanth> ndarshan, reviews done?
09:52:36 <ndarshan> nishanth, not blocked on reviews....however
09:54:11 <ndarshan> I am working on an issue related to invoking integration processes as service during import cluster...for which I need to make use of service utils.....but getting config in common is undergoing some change...am waiting for that change to go in
09:55:01 <nishanth> ndarshan, ok
09:55:24 <ndarshan> k4n0 is working on streamlining the use of config, once that's completed will continue with this issue
09:56:14 <nishanth> # ndarshan is also working on https://github.com/Tendrl/specifications/issues/34, completed from backend. Anoop working on API changes
09:56:20 <nishanth> Thanks for the updates
09:56:35 <nishanth> #topic neha's updates
09:57:12 <neha> sent updated PR for file share test after incorporating kaverma's comments - https://github.com/Tendrl/tendrl_frontend/pull/91
09:57:45 <neha> will start working on https://github.com/Tendrl/tendrl_frontend/issues/64 once kaverma commits his code to repo
09:57:49 <neha> end
09:59:06 <Shu6h3ndu> k4n0, I have travis issues for https://github.com/Tendrl/gluster-integration/pull/106 and https://github.com/Tendrl/node-agent/pull/123
09:59:28 <Shu6h3ndu> k4n0, but for https://github.com/Tendrl/node-agent/pull/123 we need to merge the spec PR first https://github.com/Tendrl/specifications/pull/104
09:59:34 <nishanth> #accept neha incorporated review comments on  https://github.com/Tendrl/tendrl_frontend/pull/91
09:59:37 <k4n0> Shu6h3ndu, ack
09:59:57 <nishanth> #info neha will start working on  https://github.com/Tendrl/tendrl_frontend/issues/64
10:00:16 <nishanth> Thanks for the updates
10:00:42 <nishanth> #topic noopq's updates
10:01:00 <noopq> nishanth, I am working on the new definitions file
10:01:14 <noopq> which ndarshan had provided
10:01:30 <noopq> the hierarchy of the objects has changed to what it was before
10:01:47 <noopq> so I am fixing that
10:01:52 <noopq> nothing else
10:02:06 <nishanth> #noopq is working on https://github.com/Tendrl/specifications/issues/34
10:02:31 <nishanth> noopq, kaverma require some info regarding the import from you?
10:02:43 <noopq> nishanth, ok
10:02:46 <nishanth> noopq, can you provide that info to him?
10:03:00 <nishanth> noopq, thanks
10:03:03 <noopq> nishanth, yes, if he tells me what the issue is :)
10:03:34 <kaverma> nishanth, i scheduled one call at @4:30pm . will discuss over there
10:03:39 <kaverma> ^^anup
10:03:50 <nishanth> kaverma, okay thanks
10:04:17 <nishanth> #topic shu6h3ndu's updates
10:04:39 <Shu6h3ndu> sure
10:04:46 <Shu6h3ndu> https://github.com/Tendrl/commons/pull/99 is merged
10:04:47 <Shu6h3ndu> Sent a spec PR https://github.com/Tendrl/specifications/pull/117 - review required
10:04:47 <Shu6h3ndu> Sent https://github.com/Tendrl/gluster-integration/pull/106 for fixing an issue - under review
10:04:47 <Shu6h3ndu> Rohan reviewed https://github.com/Tendrl/node-agent/pull/123. Comments incorporated
10:04:47 <Shu6h3ndu> Working on rework for https://github.com/Tendrl/gluster_integration/pull/62 - pre post atoms for volume opretaions
10:04:52 <Shu6h3ndu> Will continue working on https://github.com/Tendrl/specifications/pull/117
10:05:05 <Shu6h3ndu> Rohan to merge spec PR https://github.com/Tendrl/specifications/pull/104 - multi node_ids in job
10:05:06 <Shu6h3ndu> Mrugesh to review and close https://github.com/Tendrl/specifications/pull/98 - pool util monitoring
10:05:06 <Shu6h3ndu> Anup, Roahn and Nishanth to review the spec PR https://github.com/Tendrl/specifications/pull/93 - pool utilization in cluster sync
10:05:06 <Shu6h3ndu> Rohan to review https://github.com/Tendrl/gluster_integration/pull/63
10:05:36 <Shu6h3ndu> end
10:06:30 <Shu6h3ndu> I would check the reviews pending on me today sometime
10:07:17 <nishanth> #accept  https://github.com/Tendrl/commons/pull/99 merged upstream
10:08:56 <nishanth> #action k4n0, brainfunked, nishanth to review  https://github.com/Tendrl/specifications/pull/117, https://github.com/Tendrl/gluster-integration/pull/106 ,  https://github.com/Tendrl/node-agent/pull/123
10:09:25 <nishanth> #action k4n0 to merge https://github.com/Tendrl/specifications/pull/104
10:09:53 <nishanth> #action noopq, nishanth, k4n0 to review  https://github.com/Tendrl/specifications/pull/93
10:10:17 <nishanth> #action k4n0 to review  https://github.com/Tendrl/gluster_integration/pull/63
10:10:37 <nishanth> thanks for the updates
10:10:49 <nishanth> #topic t1m1's updates
10:11:21 <t1m1> Working on nightly builds for Tendrl and building hwinfo package
10:11:21 <t1m1> A) hwinfo package build:
10:11:21 <t1m1> Found the list of build dependencies.
10:11:21 <t1m1> Facing few issues with hwinfo
10:11:21 <t1m1> fixing them by building the sub dependency ( libx86emu-1.1-22.1.2.x86_64 ) first
10:11:22 <t1m1> Planning to send a patch to build hwinfo today late night
10:11:24 <t1m1> B) Auto Build (Pickup latest source and build the package, Enable automatic build):
10:11:26 <t1m1> 1) Package → tendrl-api:-
10:11:28 <t1m1> https://copr.fedorainfracloud.org/coprs/tendrl/tendrl/package/tendrl-api/
10:11:30 <t1m1> Done changes in tendrl-api to automatically pickup latest source from
10:11:32 <t1m1> the github repo and build on a user trigger (so that anyone can fire a build if they want a build from latest source from master branch) Also created the webhook to initiate the auto build for this package.
10:11:35 <t1m1> Webhook URL for GitHub : https://copr.fedorainfracloud.org/webhooks/github/10793/c58347dd-89a0-45ae-b274-c5dc7ef470db/
10:11:38 <t1m1> 2) Package → tendrl-common:-
10:11:40 <t1m1> facing issues during auto build. It only build for fedora-24
10:11:44 <t1m1> https://copr.fedorainfracloud.org/coprs/tendrl/tendrl/build/498362/
10:11:46 <t1m1> failed for epel-7-x86_64
10:11:48 <t1m1> debuging the issues → http://copr-dist-git.fedorainfracloud.org/per-task-logs/498362-epel7.log
10:11:50 <t1m1> I will be thankful if anyone can help identify the issue
10:11:52 <t1m1> 3) Package → tendrl-ceph-integration:
10:11:54 <t1m1> enable build system to pickup latest source from github master branch and build the package
10:11:56 <t1m1> Build passes only for fedora-23 and fedora-25
10:11:58 <t1m1> https://copr.fedorainfracloud.org/coprs/tendrl/tendrl/build/498346/
10:12:00 <t1m1> debuging the issue for chroot epel-7-x86_64: (srpm build error)
10:12:02 <t1m1> http://copr-dist-git.fedorainfracloud.org/per-task-logs/498346-epel7.log
10:12:04 <t1m1> will be taking tendrl-gluster-integration and other packages once I complete the above issues
10:12:06 <t1m1> Currently building libx86emu:
10:12:08 <t1m1> https://copr.fedorainfracloud.org/coprs/tendrl/tendrl/package/libx86emu/
10:14:40 <nishanth> #info t1m1 started working on building hwinfo. There are some dependant packages which needs to built as well( libx86emu). Planning to work on the same and send a patch late evening
10:15:00 <nishanth> #accept enabled auto builds for tendrl-api
10:15:46 <nishanth> #info some issues encountered in enabling the auto builds for other packages, working on the same
10:16:06 <nishanth> t1m1, any ETA for completing the auto builds?
10:16:40 <t1m1> nishanth, currently i am planning to complete hwinfo package build today
10:17:08 <t1m1> it looks like the auto build for all the remaining packages will take 2-3 days time
10:17:10 <t1m1> max
10:17:42 <nishanth> t1m1, there are some spec changes to be done to enable auto builds?
10:17:52 <t1m1> nishanth, yes
10:18:17 <nishanth> t1m1, please work on that on priority along with hwinfo
10:18:24 <nishanth> thanks for the updates
10:18:29 <t1m1> nishanth, also we have to configure our github to keep the created webhoos for every project
10:18:35 <t1m1> webhooks
10:19:08 <t1m1> its a very simple configuration, only an administrator can do it
10:19:32 <nishanth> t1m1, I suggest. first we will complete with manual trigger and start looking at webhooks
10:19:36 <nishanth> make sense?
10:19:43 <t1m1> nishanth, yes, got it!
10:20:53 <nishanth> #topic nishanth's updates
10:21:17 <nishanth> #info completed a bunch of pending reviews
10:22:02 <nishanth> #info started working on https://github.com/Tendrl/specifications/issues/112
10:23:08 <nishanth> #endmeeting