teachingopensource
LOGS
17:49:00 <mchua> #startmeeting
17:49:00 <zodbot> Meeting started Thu Sep  2 17:49:00 2010 UTC.  The chair is mchua. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:49:00 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
17:49:02 <mchua> #chair micadeyeye
17:49:02 <zodbot> Current chairs: mchua micadeyeye
17:49:06 <mchua> #topic Agenda
17:49:21 <micadeyeye> i am very much around.
17:49:27 <mchua> Since this is our first big chance to catch up, it might take longer, I'm hoping we'll be able to check in at least once a week between now and the POSSE and those check-ins should be very short (<30 minutes).
17:49:49 <micadeyeye> great.
17:49:55 <mchua> micadeyeye: If this time works for you every Tuesday, that might actually work out well (just to put one suggestion out there).
17:49:58 <mchua> So, things I have on my list to talk about
17:50:04 <mchua> #info * Curriculum status
17:50:10 <mchua> #info * Staffing and travel logistics status
17:50:13 <mchua> #info * Budget status
17:50:18 <mchua> #info * Enrollment/recruitment status
17:50:29 <mchua> #info * Visitors and guest lecturers status
17:50:34 <mchua> #info * PR status
17:50:40 <mchua> micadeyeye: Anything else you have to add? I may be forgetting things. :)
17:50:53 <micadeyeye> i can't think of one.
17:51:16 <mchua> Okay, let's go through them then.
17:51:20 <mchua> #topic Curriculum status
17:51:50 <mchua> #note The most important thing to note is that we're *definitely* on - this POSSE is a go, so at this point anything more we can pull into it is a *very* good thing. :)
17:52:06 <mchua> #link http://teachingopensource.org/index.php/POSSE_South_Africa#Topic_Schedule
17:52:24 <micadeyeye> great.
17:52:26 <mchua> micadeyeye: ^ That's the general outline for the week - basically, curriculum's becoming set, Jan and I will be talking about it in the coming weeks and pushing notes to the wiki and the TOS list.
17:52:42 <mchua> That's all I had about it, but if you had any specific questions/concerns about curriculum you want to bring up now, I'd like to hear them.
17:52:58 <mchua> (if you don't have questions now, we'll keep checking in every week so you can always bring them up later as they come up :)
17:53:32 <micadeyeye> we are good with the curriculum. i took a look at it sometime ago.
17:53:35 <mchua> Okay, cool!
17:53:37 <mchua> Thanks.
17:53:39 <mchua> Moving on, then.
17:53:50 <micadeyeye> And if there is any, i will let you know.
17:53:56 <mchua> (let me know if I'm going too fast or too slow or anything comes up that you want to talk about, btw)
17:53:59 * mchua nods
17:54:11 <mchua> thanks, micadeyeye. You've been an amazing organizer and very patient, and I totally appreciate this.
17:54:22 <micadeyeye> you are welcome.
17:54:23 <mchua> and I'm looking forward to you teaching your own POSSEs in Africa next year. :)
17:54:26 <mchua> Okay, next!
17:54:30 <mchua> #topic Staffing and travel logistics status
17:54:38 <mchua> #info Instructors confirmed: Mel Chua and Jan Wildeboer
17:54:40 * micadeyeye my dream
17:54:58 <mchua> #info Tech guru - we have somebody, will confirm availability and travel details and then announce
17:55:17 <mchua> micadeyeye: The local folks you were talking with - I'd like to find some way for them to get involved if they're still interested.
17:55:23 <mchua> They're welcome to visit anytime and talk about the things they do, and help out.
17:55:32 <mchua> We can't pay them, but we can at least buy them lunch or dinner. :)
17:55:47 <micadeyeye> okay. i will contact them.
17:55:58 <mchua> The tricky thing is that we needed someone who could be there all week, and who is a very active participant in the global Fedora community.
17:56:31 <mchua> So we ended up having to fly someone from outside South Africa in - but if we do this right, the students of the professors who attend this POSSE will be able to be tech gurus a year from now.
17:56:37 <micadeyeye> but you must be referring to stefano. the guy you mentioned that it would be great to have him around.
17:56:54 <mchua> micadeyeye: Yep, if you could follow up with him and let him know he's welcome anytime that would be great!
17:57:18 <micadeyeye> he said tue-thur.
17:57:21 <mchua> We're going to be working in the Fedora community all week, and iirc he's a Debian fellow, so maybe coming on Thursday so we can look at the differences between the projects would be good.
17:57:25 * micadeyeye checks my mail.
17:57:50 <mchua> micadeyeye: Hrm, what if we asked Stefano to come Thursday afternoon to talk about the topics he described, then join us Thursday night for dinner?
17:58:05 <micadeyeye> no problem.
17:59:08 <micadeyeye> * The Debian / Ubuntu communities: Getting involved, where to find
17:59:08 <micadeyeye> help
17:59:08 <micadeyeye> * Packaging for Debian (Ubuntu is the same) - this is an enormous topic,
17:59:11 <micadeyeye> but I can cover some of it.
17:59:13 <micadeyeye> * Python Packaging in Debian (an area of expertise for me)
17:59:17 * mchua nods
17:59:19 <micadeyeye> * Getting things fixed in Debian / Ubuntu.
17:59:30 <mchua> I think that's a great Thursday afternoon topic.
17:59:51 <micadeyeye> you think he could talk about those things in a day/few hours. right?
17:59:57 <micadeyeye> cool.
18:00:33 <mchua> micadeyeye: Yes - I think we won't have time to get into detail on the packaging, but an overview of the getting-involved stuff for other distros (and other projects in general) and getting things fixed, using packaging as examples that he's done for getting involved himself, would be nice.
18:01:07 <micadeyeye> cool.
18:02:02 <micadeyeye> i will give him an update.
18:02:07 <mchua> micadeyeye: I still need to make hotel bookings for me and Jan and the tech guru, but you sent me the info for that, so I think I'm all set.
18:02:20 <mchua> And I'll figure out transportation for us too unless you have recommendations for how to get there from the airport. :)
18:02:27 <mchua> Thanks for looking into the hotel, btw!
18:02:41 <mchua> (Are all the attendees local, or will some of them have the same travel/flight/hotel questions?)
18:03:11 <micadeyeye> i could work on that. btw, i could come fetch you guys.
18:03:32 <micadeyeye> one or two will be coming from Nigeria.
18:04:16 <mchua> Oh, great!
18:04:25 <mchua> Okay, so I need to make sure we have a mailing list set up so people can start sharing those notes.
18:04:36 <mchua> #action mchua ask ctyler to set up a posse-southafrica mailing list
18:04:37 <micadeyeye> i guess you can retrieve the mail i sent regarding the accommodation.
18:04:43 * mchua nods, I'll post that on the attendees page
18:04:49 <mchua> #action mchua update attendees page with hotel information
18:05:24 <mchua> Okay - that's everything on staffing from my side... we're set with instructors, tech guru should be confirmed by this time next week, and you'll be following up on local folks who want to visit, I think that's it.
18:05:28 <mchua> micadeyeye: did I miss anything on this topic?
18:05:46 <micadeyeye> another developer, Antoine, will be joining us in one of the evening.
18:06:16 <micadeyeye> evenings*
18:06:49 <micadeyeye> we also have one attendee from a neighbouring school.
18:07:05 <mchua> #note Stefano probably visiting (Thursday afternoon?) and can talk about getting-involved in Debian/Ubuntu
18:07:15 <mchua> #note Antoine another prospective visitor
18:07:16 <micadeyeye> nope. i think that's fine too.
18:07:33 <mchua> Okay, cool - on both Stefano and Antoine, it'd be good to get them in the loop on the POSSE mailing list when ctyler gets it up.
18:07:48 <mchua> So they can start meeting people ahead of time, we can get a better picture of when they'll be coming and what they'll be doing, etc.
18:07:56 <mchua> We tend to do POSSE scheduling pretty organically. :)
18:07:59 <mchua> Okay, next topic!
18:08:00 * mchua looks
18:08:15 <mchua> #topic Budget status
18:09:21 <mchua> #link http://teachingopensource.org/index.php/POSSE_South_Africa_Planning#Budget
18:10:14 <mchua> #info Right now our estimate is at $5200 of budget, not counting hotels and expenses. This is definitely an overestimate.
18:12:02 <micadeyeye> mchua: are we using Stefano as the tech guru?
18:12:48 <micadeyeye> or you will be coming with one. I was thinking only Jan and you will be coming.
18:12:52 <mchua> micadeyeye: No, we needed someone who works within Fedora and who is available all week.
18:12:57 <mchua> So we'll have 3 hotel rooms.
18:13:03 * mchua quickly runs a few more numbers on the budget
18:13:40 <micadeyeye> That means 3 of you will be coming.
18:13:54 <mchua> Yes.
18:14:04 <micadeyeye> Great.
18:14:54 <mchua> micadeyeye: Budget-wise - can the department pay for Thursday night's dinner?
18:15:23 <mchua> It's looking really tight on our end because we have to fly instructors in from so far away to seed the POSSE (which is why I'm really looking forward to having POSSE alumni in Africa, so you folks can teach more local ones next year).
18:15:25 <micadeyeye> my dean said that the dept would do so.
18:15:42 <mchua> Okay, awesome. We can have dinner anywhere you want, it doesn't have to be fancy.
18:15:46 <micadeyeye> but, it would be great if we could have an alternative plan.
18:16:05 <micadeyeye> i need to pitch them on it again.
18:16:08 <mchua> But plan for attendees + instructors (3) + some local FOSS guests you'd like to invite, like Stefano and Antoine, maybe 5 of them.
18:16:49 <micadeyeye> okay, i will do that.
18:17:11 <mchua> The reality of the budgeting from my side, though, is that I talked with Max the other day and we have an absolute cap of $7k USD here because we've got to make sure we have enough to run other POSSEs this year.
18:17:20 <micadeyeye> #note Thursday dinner: confirm with the dean/hod
18:17:42 <mchua> #note CPUT will sponsor Thursday's dinner (need to confirm)
18:18:04 <mchua> I'm hoping that we'll go under on plane flights and hotel so we'll have a little extra room for things just in case.
18:19:08 <micadeyeye> that would be great.
18:19:38 <mchua> #action mchua book remaining travel and hotel for instructors so we know how much budget we have left
18:20:10 <mchua> micadeyeye: Any other thoughts on budget? It's not something I'm worried about, it's just something I'm keeping an eye on to make sure we don't go over (since it looks like we'll be cutting it close).
18:20:38 <micadeyeye> btw, we have always got a restricted access to the Internet here. what ports would you want opened? i could only think of the ftp,irc, and ssh?
18:21:07 <mchua> micadeyeye: We actually have that listed somewhere, let me check
18:21:27 <micadeyeye> yes, i don't want to forget.
18:21:39 <micadeyeye> am good with the budget.
18:21:41 <mchua> #link http://teachingopensource.org/index.php/HOWTO_plan_a_POSSE#Find_space
18:21:52 <mchua> #info need ports 80 (web), 23 (ssh), and 6667 (IRC) open
18:21:55 <mchua> ftp wouldn't hurt, too
18:22:35 <mchua> Okay, moving on to the next topic...
18:22:50 <mchua> #topic Enrollment/recruitment status
18:22:56 <mchua> micadeyeye: This one's my big question for you. :)
18:23:07 <micadeyeye> okay
18:23:15 <mchua> #link http://teachingopensource.org/index.php/POSSE_South_Africa#Professors
18:23:42 <mchua> micadeyeye: The thing that would make life easiest for myself and Jan is for the list of professors there to be...
18:24:11 <mchua> 0) Filled with good people - I trust your judgement, so if you think someone's application shows they'd be a good participant, just tell them they're in.
18:24:36 <micadeyeye> i get that.
18:24:39 <mchua> 1) Having as many excellent attendees as possible - we can take a maximum of 25 (somewhere around 12-18 is probably ideal)
18:25:21 <mchua> 2) And to have the answers to the 10 questions at http://teachingopensource.org/index.php/POSSE#How_do_I_apply.3F for each person before you add them to the list on that wiki page
18:25:41 <mchua> (that will help Jan and myself see who's coming so we can figure out specific examples and people to introduce those individual professors to when they arrive.)
18:26:28 <mchua> micadeyeye: If we can have the list of attendees, along with the answers to those 10 questions for each of them, by September 24, we'll be all set.
18:26:44 <micadeyeye> Would want my colleagues and me to do the same?
18:27:05 <mchua> I'll keep asking what the status of enrollment is every time we meet, but it sounds right now like we have 6 attendees (I think I have applications from a few of them).
18:27:24 <micadeyeye> i think we both got the applications of the last two attendees.
18:27:50 <micadeyeye> okay, i ask my colleagues to do the same.
18:27:57 <mchua> micadeyeye: answer the 10 questions? Yes, please - one of the things I want to do is to send everyone's answers to questions #4-#8 to the POSSE's mailing list so everyone will know a little about everyone else who is coming.
18:30:08 <mchua> micadeyeye: I think we can do it this way - you can use http://teachingopensource.org/index.php/POSSE_South_Africa#Professors to keep track of your list of who's coming, and when I get their application info from you I'll update the POSSE South Africa mailing list (which ctyler still has to make) by subscribing them to it.
18:30:19 <mchua> And then every time we meet we can compare your list and my list and make sure they're the same.
18:30:23 <mchua> How does that sound?
18:31:02 <micadeyeye> yes.
18:32:01 <mchua> #note Michael will keep track of his list of attendees on http://teachingopensource.org/index.php/POSSE_South_Africa#Professors, and when Mel gets their application info she will subscribe them to the posse-southafrica mailing list, and every meeting we'll make sure the two lists are the same.
18:32:12 <mchua> micadeyeye: Ok - is there anything else we can do to help you recruit more people?
18:32:25 <mchua> or anything we can do to help with getting attendees in general?
18:32:42 <micadeyeye> i will let know when i think of one.
18:32:51 <mchua> #note Deadline for final attendee list: Friday, September 24 at the end of the day, Michael's timezone
18:33:01 <micadeyeye> but i have been trying to get as many people as possible.
18:33:02 <mchua> micadeyeye: Ok - and if I find anything/anyone I'll point them to you.
18:33:06 * mchua nods
18:33:10 <mchua> The list looks great so far for being so early on!
18:33:31 <mchua> The challenging part of getting professors for this workshop, I've found, is that they have to be there for the entire week, all day (except Friday which is a half-day)
18:33:52 <micadeyeye> we should have a poster.
18:34:19 <micadeyeye> a poster that could be used for all POSSEs.
18:34:33 <micadeyeye> it would be great for future POSSEs.
18:35:01 <mchua> micadeyeye: Okay - I know quaid made a flyer and a handout this summer, I'll make sure you get that.
18:35:07 <mchua> #action mchua get micadeyeye a recruitment poster for POSSE
18:35:21 <micadeyeye> I have been emailing colleagues at other institution and referring them to the site. but i hardly get response.
18:35:45 <micadeyeye> great.
18:36:31 * mchua nods - it's usually that way, ask 10 people and get 1 yes, maybe.
18:37:18 <mchua> micadeyeye: so for next week let's see if I can get answers to the application questions for everyone on the list at http://teachingopensource.org/index.php/POSSE_South_Africa#Professors and get everyone on the mailing list (which I'll make sure gets set up).
18:37:34 <mchua> micadeyeye: I'll check and see whose answers I have and email you the list so you know who else I need the info from.
18:37:43 <mchua> #action mchua email micadeyeye the list of applications she's already gotten
18:37:56 <micadeyeye> okay, but i think i have them.
18:38:03 * micadeyeye checks his email.
18:38:05 <mchua> micadeyeye: Anything else on attendee recruitment? There's some work to be done here but you're doing a great job and I think we'll be all right. :)
18:38:21 <mchua> micadeyeye: I think we both have them, yep.
18:38:30 * mchua will also check in on this again next week
18:38:44 <mchua> Only 2 more things to talk about today, we're almost done :)
18:38:47 <mchua> next meeting should be shorter
18:39:29 <micadeyeye> great.
18:40:57 <mchua> micadeyeye: Okay, almost done! Next topic.
18:41:03 <mchua> jadudm: Hey there, just wrapping up and will be with you in a moment. :)
18:41:14 <mchua> #topic Visitors and guest lecturers status
18:41:15 * jadudm joins the queue
18:41:45 <mchua> micadeyeye: actually, we covered this in the "instructors" section so I think we're all good... but let's get the visitors you're thinking about on the small POSSE South Africa mailing list so they can coordinate their visit too.
18:41:59 <mchua> #action mchua get micadeyeye admin privs on posse-southafrica list so he can add visitors to the list
18:42:02 <micadeyeye> yes, we did.
18:42:18 <mchua> micadeyeye: That's all I had for this right now, anything else?
18:42:24 <mchua> The last thing we had on the table was PR.
18:43:17 <mchua> #topic PR
18:43:24 <mchua> micadeyeye: If you want to do some PR for your university around this, we (Red Hat) would love to support it. I'm going to try to get a few journalists to come down and see if they want to do a story on POSSE and the professors attending it, get you some coverage and attention.
18:43:31 <mchua> We could also, for instance, do a joint press release.
18:43:50 <mchua> micadeyeye: Basically, Red Hat's PR folks have been asking me how they can help, and so I wanted to pass that question on to you.
18:43:53 <micadeyeye> that would be great.
18:44:00 <mchua> #idea Joint press release
18:44:08 <mchua> #idea get reporters to come and cover the event
18:44:13 <micadeyeye> Are they in Cape Town?
18:44:44 <mchua> micadeyeye: I don't know if the student newspaper at CPUT would be interested in covering this too, or if you have any publications/outlets you usually put this sort of event in, but you let us know where you'd like to go with that and we'll do our best to help.
18:44:54 <mchua> micadeyeye: Red Hat's PR folks are mostly in Raleigh with me, but they know reporters from all over the world.
18:45:06 <micadeyeye> okay.
18:45:29 <mchua> micadeyeye: And similarly, I think they're looking for publications that Red Hat usually announces stuff to, and I'll let you know if they come to me with any specific "we're planning on sending this out to these people" things.
18:45:33 <micadeyeye> The university site should have it on its homepage in the next few days.
18:45:35 * mchua nods
18:45:36 <mchua> Awesome.
18:45:41 <micadeyeye> i sent the news to them.
18:45:55 <mchua> #note CPUT's site should have the POSSE event on its homepage in the next few days
18:46:16 <mchua> micadeyeye: Okay - I think Kara (from RH PR) wanted to take a first crack at drafting a press release so I'll ask her about that and send you a draft if she's got one.
18:46:24 <mchua> #action mchua followup with Kara on draft of press release
18:46:35 <mchua> micadeyeye: and then you can take it your university PR folks and we can hook them up with Kara to do a joint push.
18:46:51 <mchua> And I'll let you know about reporters as soon as I hear anything, I'm guessing they'll want to interview or get a quote from you too. :)
18:47:03 <micadeyeye> no problem.
18:47:17 <mchua> micadeyeye: That's all I had on PR thoughts... anything else we can help with?
18:47:27 <mchua> Or anything else re: the POSSE in general you'd like to talk about?
18:47:34 <mchua> micadeyeye: (oh - next week, Tuesday, this time? Is that okay?)
18:47:35 <micadeyeye> i was thinking of recording the event.
18:47:52 <micadeyeye> like we did at FSOSS '09.
18:47:54 <mchua> micadeyeye: Yes, that would be great! We'd need permission from all the attendees, right?
18:48:03 <micadeyeye> i just some of the equipments.
18:48:53 <micadeyeye> i was thinking of capturing the screen of your laptops and using a wireless mic for the audio.
18:49:04 <mchua> micadeyeye: Does the university have a film department or some cameras you could borrow, maybe some film students who'd like practice doing documentary style work?
18:49:24 <mchua> micadeyeye: Oh! We won't have slides or anything like that... it's very hands-on, Jan and I will mostly be going around helping individuals with their projects, rather than lecturing.
18:49:29 <mchua> Not sure if that changes anything.
18:49:36 <micadeyeye> i will discuss it with my colleagues in the film and video department.
18:50:05 <micadeyeye> okay.
18:50:57 <micadeyeye> that will be all.
18:51:20 <mchua> micadeyeye: Ok - I can also ask the film folks here at Red Hat if I can borrow some of their cameras to bring down, if you like, but it might make sense to talk with your colleagues first so I don't bring electronics if I don't have to. :)
18:51:32 <mchua> micadeyeye: Okay, thanks! This time, next week Tuesday?
18:51:51 <micadeyeye> nope.
18:51:57 <micadeyeye> i thought Thursday.
18:52:22 <micadeyeye> i will be attending a conf, and will most likely be returning late.
18:52:40 * mchua looks at Thursday schedule
18:52:45 <mchua> I may be on a plane then.
18:52:53 <micadeyeye> really.
18:53:00 <mchua> micadeyeye: Would earlier on Thursday work? I've got a flight at 1pm.
18:53:08 <micadeyeye> yes.
18:53:11 <mchua> But 10am my time - 4pm your time, for instance, would be fine.
18:53:20 <micadeyeye> sure.
18:53:44 <mchua> #agreed 10am (Raleigh) 4pm (Cape Town) next Thursday is our next meeting
18:53:49 <mchua> micadeyeye: That's all I had for today - thanks Michael!
18:53:55 <micadeyeye> you are welcome
18:54:00 <mchua> Are you all set until next week?
18:54:16 <micadeyeye> yes, i am.
18:54:17 <mchua> (future meetings should be shorter, really - we just had a lot of context to start up on this time.)
18:54:20 <mchua> Okay, awesome.
18:54:26 <mchua> I'll see you Thursday, then. And lots of emails in between that. :)
18:54:31 * mchua will mail logs to the list
18:54:33 * mchua waves
18:54:36 <mchua> #endmeeting