rdo_meeting_-_2019-04-17
LOGS
15:01:26 <ykarel> #startmeeting RDO meeting - 2019-04-17
15:01:26 <zodbot> Meeting started Wed Apr 17 15:01:26 2019 UTC.
15:01:26 <zodbot> This meeting is logged and archived in a public location.
15:01:26 <zodbot> The chair is ykarel. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:01:26 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
15:01:26 <zodbot> The meeting name has been set to 'rdo_meeting_-_2019-04-17'
15:01:27 <openstack> Meeting started Wed Apr 17 15:01:26 2019 UTC and is due to finish in 60 minutes.  The chair is ykarel. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:01:28 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:01:30 <openstack> The meeting name has been set to 'rdo_meeting___2019_04_17'
15:01:47 <ykarel> Please add last minute topics to agenda: https://etherpad.openstack.org/p/RDO-Meeting
15:03:19 <mjturek> o/
15:03:52 <fmount> o/
15:03:56 <ykarel> #topic roll call
15:04:04 <ykarel> #chair fmount mjturek
15:04:04 <zodbot> Current chairs: fmount mjturek ykarel
15:04:05 <openstack> Current chairs: fmount mjturek ykarel
15:04:38 <amoralej> o/
15:05:01 <fultonj> o/
15:05:04 <baha> o/
15:05:19 <ykarel> #chair amoralej fultonj baha
15:05:19 <zodbot> Current chairs: amoralej baha fmount fultonj mjturek ykarel
15:05:20 <openstack> Current chairs: amoralej baha fmount fultonj mjturek ykarel
15:05:21 <PagliaccisCloud> \o
15:05:27 <ykarel> #chair PagliaccisCloud
15:05:27 <zodbot> Current chairs: PagliaccisCloud amoralej baha fmount fultonj mjturek ykarel
15:05:28 <openstack> Current chairs: PagliaccisCloud amoralej baha fmount fultonj mjturek ykarel
15:05:44 <ykarel> let's start with the topics
15:05:47 <ykarel> #topic [mjturek | baha ] Patch to move to tripleo-ci playbooks
15:05:56 <mjturek> thanks ykarel
15:06:07 <mjturek> so we have a patch that seems a bit stalled
15:06:32 <mjturek> it would migrate our job to the upstream tripleoci playbooks for container builds
15:06:41 <ykarel> #link https://review.rdoproject.org/r/#/c/20031/
15:06:44 <mjturek> it would still not push, so it's low risk
15:07:02 <mjturek> but we'd like to see it merge soon so we can start debugging
15:07:12 <mjturek> (though we're hoping it won't need much of that)
15:07:55 <mjturek> are there any concerns we could help alleviate to get this one moving again?
15:10:14 <ykarel> mjturek, so ^^ patch needs some changes atleast due to recent changes in openstack-infra/tripleo-ci
15:10:51 <mjturek> ykarel ah has your patch merged
15:10:57 <ykarel> mjturek, https://review.openstack.org/#/c/652027/ patch merged recently and it moved playbooks to release
15:10:59 <ykarel> mjturek, yes
15:11:12 <ykarel> s/release/role
15:11:22 <mjturek> ykarel got it, alright we'll fix that today
15:11:47 <ykarel> okk
15:11:55 <mjturek> thanks ykarel
15:13:26 <ykarel> anything else on these, we move to next topic?
15:14:04 <mjturek> I'm good!
15:14:09 <ykarel> okk
15:14:47 <rdogerrit> rdo-trunk created openstack/cloudkitty-distgit rpm-master: openstack-cloudkitty: failed to build 46a54ad  https://review.rdoproject.org/r/20280
15:14:48 <ykarel> #action mjturek to fix https://review.rdoproject.org/r/#/c/20031/ as per recent changes in openstack-infra/tripleo-ci
15:14:58 <ykarel> #topic [fmount | fultonj ] Nautilus and Stein
15:15:20 <fmount> ykarel: as you know to move forward with Nautilus + Stein + Ansible 2.7 we need to merge some patches on tht/tripleo-{common,quickstart}
15:15:45 <fmount> but as prereq we need to have packages on 14.x availble
15:15:51 <fmount> *available
15:15:52 <ykarel> also need ceph release/builds and ceph-nautilus rpm
15:15:59 <fmount> ykarel: sure ^
15:16:48 <fmount> question is I'm not sure it's a good idea to merge https://review.openstack.org/#/c/652959
15:17:44 <amoralej> fmount, not there
15:17:48 <fmount> this was born just to show that having 14.x packages (and not mixed with 12.x) CI jobs pass
15:17:58 <amoralej> that should be specific to the releases using nautilus
15:18:11 <amoralej> and need to merge it together with the containers updates
15:18:54 <fmount> amoralej: if you take a look at the dependency chain
15:19:14 <fmount> we have https://review.openstack.org/#/c/651286
15:19:25 <fultonj> i think fmount and i are blocked at getting the packages we need from CBS
15:19:46 <amoralej> fmount, that's fine
15:20:08 <amoralej> but i think we shouldn't update the default in the role
15:20:12 <amoralej> well
15:20:17 <amoralej> the repo will not be confiured
15:20:22 <amoralej> in the rest or releases, right?
15:20:25 <amoralej> that's what you mean?
15:20:49 <fmount> I think we need to have builds of ceph nautilus here: http://mirror.centos.org/centos/7/extras/x86_64/Packages/
15:21:15 <rdogerrit> Merged rdoinfo master: Promote CBS tags update for rocky-testing  https://review.rdoproject.org/r/20266
15:21:32 <fmount> that makes them available for the rest of the components using ceph
15:21:46 <fmount> ykarel: is it correct? ^
15:21:52 <amoralej> fmount, no no in the extras
15:22:03 <amoralej> wdym about "builds of ceph nautilus there?"
15:22:26 <fmount> I mean build of ceph-release
15:23:10 <amoralej> yes
15:23:12 <amoralej> we need it there
15:24:45 <fmount> after that we need to start merging the chain described here: https://etherpad.openstack.org/p/tripleo-integration-squad-status
15:25:30 <ykarel> fmount, is there some ETA when will ceph-release rpm will publish?
15:25:36 <ykarel> who is taking care of it
15:25:48 <fmount> amoralej: consider ceph-ansible as per 239 will work with v2 only (we'll remove the hack after the patch will come)
15:26:00 <amoralej> ack
15:26:01 <fmount> ykarel: I don't know, maybe fultonj can answer
15:26:23 <amoralej> i guess gfidente takes care of it?
15:26:59 <fmount> and for scenario004 we have at least the glance_store patch (so we can easily test later switching GlanceBackend to swift)
15:27:44 <fmount> amoralej: not sure, he can do that but maybe I can ping someone from cbs team
15:27:55 <amoralej> ok
15:28:47 <ykarel> fmount, ack,
15:28:48 <fultonj> sorry i don't know
15:29:03 <fultonj> AFAICT we need help from the CBS team right?
15:29:06 <ykarel> #action fmount fultonj to discuss and get ceph-release nautilus rpm in centos-extras repo
15:29:28 <amoralej> normally sig team creates and tag the packages
15:30:02 <amoralej> https://cbs.centos.org/koji/packageinfo?packageID=6621
15:30:04 <fmount> amoralej: ykarel looking at the dependency list we have on the etherpad, do you see any constraints on start merging patches?
15:30:09 <fultonj> ktdreyer: gfidente is out until next week. any chance you can help us with ^ ?
15:31:03 <ykarel> amoralej, how we do that for cloudsig, i now we have spec at https://github.com/rdo-infra/centos-release-openstack/blob/rocky-rdo/centos-release-openstack.spec
15:31:16 <ykarel> but who tags that, we ?
15:31:23 <ykarel> build and tag
15:31:25 <amoralej> no, storagesig
15:31:35 <ykarel> i meant for CloudSig
15:31:45 <ykarel> centos-release-openstack-rocky etc
15:31:46 <amoralej> for cloudsig we do it
15:32:08 <ykarel> okk, and after tagging, inclusion in extras is automatic, right?
15:32:17 <amoralej> yes
15:32:23 <amoralej> or we ping in centos-devel
15:32:32 <ykarel> ack, similar should be with StorageSIG
15:33:32 <amoralej> i guess so
15:33:41 <ykarel> fmount, re. question in merging, for some changes centos-release rpm is needed
15:34:15 <fmount> ykarel: ack, so it's the first step ^
15:34:49 <ykarel> fmount, yes, that should clear the path
15:35:20 <amoralej> fultonj, i'll be on pto tomorrow and friday and ykarel on friday
15:35:30 <amoralej> so i guess it'll be hard to get it done this week
15:35:40 <fultonj> amoralej: ok
15:35:55 <fultonj> i'll be out mon/friday too and fmount
15:36:14 <fmount> I'll be out on mon
15:36:17 <fultonj> do we know what needs to happen?
15:36:25 <fultonj> is it storagesig?
15:37:27 <amoralej> fultonj, you mean for the release package?
15:37:41 <fultonj> i think we want to accomplish this: "get ceph-release nautilus rpm in centos-extras repo"
15:37:49 <amoralej> for that
15:37:50 <fultonj> i don't have any idea how to get that done or who could help ^
15:38:16 <fultonj> i think gfidente would know but he's away
15:38:28 <amoralej> but wait
15:38:32 <ykarel> from history ktdreyer did for luminous
15:38:32 <amoralej> there is a package in https://cbs.centos.org/koji/packageinfo?packageID=7290
15:38:38 <amoralej> and it's tagged
15:38:55 <ykarel> hmm tags are there
15:39:01 <fultonj> i think ktdreyer could help
15:39:01 <ykarel> seems recently added
15:39:07 <fultonj> i think he has in the past
15:39:37 <fmount> amoralej: we'll ping ktdreyer to get rpm in extras repo
15:39:38 <ykarel> tags are there since 9th April
15:40:15 <ykarel> fultonj, good to ask in #centos-devel what need to be done to move this forward
15:40:41 <ykarel> tags are there so just need some action from centos guys
15:40:48 <amoralej> it was tagged on apr 9th
15:40:52 <amoralej> by gfidente
15:40:54 <ykarel> hmm
15:41:01 <amoralej> they are taking time to push lastly
15:41:11 <amoralej> i think becaus of the distgits migration
15:42:11 <amoralej> i just asked in #centos-devel to the guy managing extras repo
15:42:53 <fmount> amoralej: thanks, I see
15:44:42 <amoralej> btw, https://review.openstack.org/#/c/651337/ is getting merge
15:45:17 <fmount> amoralej: I see, so we can test scenario004 changin backend
15:45:23 <ykarel> cool ^^
15:45:35 <ykarel> we would need that in stein as well
15:45:45 <ykarel> and releases as well or pin in RDO
15:45:48 <amoralej> ykarel, yes i'll propose cherry-pick as soon as it lands
15:45:57 <ykarel> okk
15:45:57 <fmount> amoralej: from the tests we made (and looking at the patch) I expect scenario004 will work
15:46:05 <amoralej> yeah, me too
15:46:15 <amoralej> that should unblock puppet stuff too
15:46:23 <fmount> amoralej: agree ^
15:46:43 <amoralej> so we are slowly moving on
15:46:46 <ykarel> fmount, if you want you can test scenario004 with that glance-store with depends-on before it merges
15:46:53 <ykarel> later we need more hacks
15:47:15 <fmount> ykarel: sure, it's a good idea
15:48:08 <fmount> so the path is clear
15:48:35 <fmount> fultonj: do you have any other questions?
15:49:03 <fmount> we can move and continue cbs question on #centos-devel
15:49:03 <ykarel> yes seeing the current state we should be good by next week
15:49:26 <fultonj> ok, thanks fmount ykarel amoralej
15:49:44 <ykarel> ok let's move
15:50:36 <ykarel> amoralej, please also check nautilus change in RDO https://review.rdoproject.org/r/#/c/20157/
15:50:49 <ykarel> i think we can change both stein/train as done in quickstart
15:51:22 <ykarel> or any issue we change both together?
15:51:58 <amoralej> ykarel, i decided to hold on until we have fixed issues
15:52:03 <amoralej> but yeah, i can check
15:52:13 <ykarel> okk let's move
15:52:22 <ykarel> so no more topic
15:52:28 <ykarel> #topic Open Discussion
15:52:43 <ykarel> please bring any topic that was not in Agends
15:53:50 <rdogerrit> rdo-trunk created openstack/ironic-distgit rpm-master: openstack-ironic: failed to build a03e55f  https://review.rdoproject.org/r/20281
15:55:44 <ykarel> seems no topic, let;s move as we are running out of time
15:55:55 <ykarel> #topic chair for next meeting
15:56:10 <ykarel> any volunteer?
15:56:45 <amoralej> ykarel, i can take it
15:56:53 <ykarel> Okk Thanks
15:56:59 <ykarel> #action amoralej to chair next week
15:57:43 <ykarel> ok Thanks everyone, let's close meeting
15:57:48 <ykarel> #endmeeting