rdo_meeting_-_2019-01-30
LOGS
15:00:44 <amoralej> #startmeeting RDO meeting - 2019-01-30
15:00:44 <zodbot> Meeting started Wed Jan 30 15:00:44 2019 UTC.
15:00:44 <zodbot> This meeting is logged and archived in a public location.
15:00:44 <zodbot> The chair is amoralej. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:44 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
15:00:44 <zodbot> The meeting name has been set to 'rdo_meeting_-_2019-01-30'
15:00:46 <openstack> Meeting started Wed Jan 30 15:00:43 2019 UTC and is due to finish in 60 minutes.  The chair is amoralej. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:47 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:00:49 <openstack> The meeting name has been set to 'rdo_meeting___2019_01_30'
15:00:53 <amoralej> #topic roll call
15:01:28 <jpena> o/
15:01:36 <amoralej> #chair jpena
15:01:36 <zodbot> Current chairs: amoralej jpena
15:01:37 <openstack> Current chairs: amoralej jpena
15:02:06 <number80> o/
15:02:37 <ykarel> o/
15:02:52 <amoralej> #chair ykarel number80
15:02:52 <zodbot> Current chairs: amoralej jpena number80 ykarel
15:02:54 <openstack> Current chairs: amoralej jpena number80 ykarel
15:05:21 <amoralej> let's start
15:05:42 <amoralej> #topic Updates on removal of python2-* from Fedora 30 by EOM
15:05:52 <amoralej> who owns this topic?
15:06:11 <amoralej> it's almost end of month...
15:06:44 <number80> Well, there's this page: https://etherpad.openstack.org/p/fedora_py2_removal_tickets
15:06:49 <mjturek> o/
15:06:58 <number80> I triaged tickets to see what we need to do
15:07:15 <amoralej> #chair mjturek
15:07:15 <zodbot> Current chairs: amoralej jpena mjturek number80 ykarel
15:07:16 <openstack> Current chairs: amoralej jpena mjturek number80 ykarel
15:07:17 <number80> but there'll need to merge spec files at some point
15:08:46 <amoralej> wow, that's a lot of packages....
15:09:13 <PagliaccisCloud> \o
15:09:14 <number80> Yep, triaging them
15:09:21 <amoralej> number80, i see that some of those bz are already closed
15:09:28 <amoralej> #chair PagliaccisCloud
15:09:28 <zodbot> Current chairs: PagliaccisCloud amoralej jpena mjturek number80 ykarel
15:09:28 <number80> original tracker had 1228 which makes bzapi fail ...
15:09:29 <openstack> Current chairs: PagliaccisCloud amoralej jpena mjturek number80 ykarel
15:09:30 <number80> Yep
15:09:43 <number80> The hard part will be merging back those changes
15:10:06 <number80> And it will likely be a manual merge to avoid regressions
15:10:20 <amoralej> sorry, why merging back?
15:10:22 <ykarel> number80, u mean merging back to stable branches o
15:10:22 <amoralej> i'm lost
15:10:46 <number80> amoralej: spec files have diverged between RDO and Fedora
15:11:25 <amoralej> my understanding was that we'll merge diverging patches by now
15:11:26 <number80> That was the blocker for automating the part :(
15:11:34 <amoralej> and at stein ga
15:11:40 <number80> Yup
15:11:41 <amoralej> we'll re-import from rdo
15:11:49 <amoralej> as they will be py3 only
15:12:12 <number80> The thing is we need to ensure that we don't break upgrade path at least
15:13:08 <amoralej> that means adding obsolete/provides to python2- in python3- packages?
15:13:21 <amoralej> we did it in some packages in py3 conversion
15:13:39 <number80> Yep, if fedora and rdo specs differed too much
15:13:40 <amoralej> to ensure upgrade path for packages including binaries
15:13:55 <amoralej> yeah, it's gonna be tricky
15:14:09 <amoralej> but short-term we need to merge fixes in fedora distgit as-is, right?
15:15:21 <number80> Could be an option
15:15:55 <rdogerrit> Sorin Sbarnea proposed rdo-infra/ci-config master: Added initial pre-commit use for linters (bashate)  https://review.rdoproject.org/r/18518
15:15:58 <amoralej> what were you thinking?
15:16:04 <amoralej> maybe there is a better one
15:16:16 <number80> Just to say that full automation is not easy (at least without a full set of CI to test package upgrade path and other things)
15:16:35 <amoralej> yeah
15:17:41 <number80> (That's all I have to say)
15:18:06 <ykarel> number80, what i got is tomorrow is last day to finish this, what will happen if we didn't finish it, or we are hopefull to finish by tomorrow
15:18:33 <amoralej> number80, i see that some packages as castellan is in the list but the bz is closed https://bugzilla.redhat.com/show_bug.cgi?id=1640769
15:18:34 <openstack> bugzilla.redhat.com bug 1640769 in python-castellan "python-castellan: Remove (sub)packages from Fedora 30+: python2-castellan" [Unspecified,Closed: rawhide] - Assigned to mhroncok
15:18:41 <amoralej> i understand that's already fixed
15:18:48 <number80> amoralej: yeah, it's not updated yet
15:18:56 <amoralej> ok
15:19:41 * number80 had higher priority assignments to finish before the end of the month
15:19:57 <amoralej> ok got it
15:20:09 <amoralej> i think first step should be to update the list
15:21:44 <amoralej> then, start pushing patches as fast as we can
15:21:56 <amoralej> we can distribute packages among openstack-sig members
15:22:51 <number80> yup
15:23:08 <ykarel> amoralej, but tomorrow is last day or not?
15:23:17 <ykarel> that's my concern
15:23:19 <amoralej> according to topic name, yes
15:23:29 <amoralej> right number80?
15:23:30 <ykarel> yup
15:24:07 <amoralej> i guess we'll need some more time, but we need to move fast
15:26:00 <number80> Yep
15:26:12 <number80> but i guess this should be fine
15:26:27 <amoralej> ok, let's try to update the list after the meeting and then distribute packages
15:26:34 <amoralej> i'm not sure how many are still missing
15:26:38 <amoralej> i know some are fixed
15:26:51 <ykarel> yup i too saw some fixed ones
15:27:22 <number80> Not much but this is an estimated guess
15:27:57 <amoralej> number80, your script checks if the ticket is closed?
15:29:41 <number80> Nope, bzapi fail if you make too much calls (there's 1228 tickets in the tracker)
15:29:56 <amoralej> ok
15:30:29 <amoralej> ok, then we'll have to check manually
15:31:47 <ykarel> amoralej, may be we can check for python2- packages in http://ftp.riken.jp/Linux/fedora/development/rawhide/Everything/x86_64/os/Packages/
15:31:55 <amoralej> #action ykarel,amoralej review the list of missing python3 converts in fedora
15:32:00 <amoralej> ykarel, ^ is that ok?
15:32:19 <ykarel> amoralej, okk for me
15:32:24 <amoralej> #action openstack-sig members to distribute missing   packages and push fixes
15:32:37 <ykarel> can give some time today, and rest tomorrow morning
15:32:44 <amoralej> it'd be great to have it done by next meeting i'd say
15:33:01 <amoralej> i don't think we'll be able to fix all of them but tomorrow
15:33:16 <amoralej> but if we show we are progressing i guess it'll be fine
15:33:26 <number80> ack
15:33:26 <amoralej> ok
15:33:29 <amoralej> next topic
15:33:39 <ykarel> ack
15:33:43 <amoralej> #topic doinfo reorganization status
15:33:46 <amoralej> #undo
15:33:47 <zodbot> Removing item from minutes: <MeetBot.items.Topic object at 0x7fe4f77d4b90>
15:33:48 <openstack> Removing item from minutes: #topic doinfo reorganization status
15:33:51 <amoralej> #topic rdoinfo reorganization status
15:34:24 <amoralej> #info rdoinfo reorganization has been merged \o/
15:34:28 <amoralej> #link https://review.rdoproject.org/r/#/q/topic:rdoinfo-reorg
15:34:57 <number80> Yes :)
15:35:00 <amoralej> this means that now, tags and buildsys-tags are not longer in rdo.yml or deps.yml but in per-tag file
15:35:20 <amoralej> we hit a problem with distroinfo this morning, it's now fixed
15:36:18 <amoralej> #info all rdopkg users should update rdopkg and distroinfo to ensure it works fine after reorganization
15:36:31 <amoralej> ykarel, is adapting documentation to new rdoinfo
15:37:00 <amoralej> #action amoralej to review https://github.com/redhat-openstack/website/pull/1270
15:37:10 <amoralej> that's it from my side
15:37:11 <jruzicka> amoralej, I might release new rdopkg with forced req...
15:37:28 <ykarel> amoralej, ^^ pull request still don't have new rdoinfo changes
15:37:31 <amoralej> jruzicka, that'd be good
15:37:44 <ykarel> amoralej, u can review, i will take care of updating
15:37:47 <amoralej> ykarel, ups, i thought it has, sorry :)
15:38:03 <ykarel> no issue :)
15:38:19 <amoralej> other than that, everything seems to keep working fine after reorganization
15:38:50 <amoralej> i'll send changes in ci jobs for rdoinfo reviews to take advantadge of it
15:39:00 <ykarel> cool
15:39:24 <amoralej> let me know if you have any problem with it
15:39:47 <jruzicka> #info fedora updates for python-distroinfo-0.2.0: https://bodhi.fedoraproject.org/updates/?search=python-distroinfo-0.2.0
15:40:24 <jruzicka> please test and +1/-1 karma ;)
15:40:51 <amoralej> ok
15:40:52 <number80> okie dokie
15:41:28 <amoralej> ok, let's move on to next topic
15:41:34 <amoralej> #topic chair for next week
15:41:37 <amoralej> volunteer?
15:43:33 <amoralej> don't be shy
15:43:35 <amoralej> :)
15:44:51 <ykarel> sure will do
15:45:02 <amoralej> thanks ykarel
15:45:12 <amoralej> #action ykarel will chair next week
15:45:17 <amoralej> #topic open floor
15:45:25 <amoralej> anything you'd like to bring to open floor?
15:45:59 <mjturek> baha and I are having some trouble with the power containers job that we'd like to bring up
15:46:33 <amoralej> sure
15:46:37 <amoralej> what's the problem?
15:46:39 <mjturek> so we're pretty confident that the failures  we're seeing in  the build are actually coming from not being able to push the containers
15:47:07 <mjturek> but I thought what I had for the push configuration  was sufficient
15:47:08 <amoralej> where are you trying to push?
15:47:20 <amoralej> rdo registry?
15:47:24 <mjturek> rdo-registry
15:47:27 <mjturek> yep
15:47:45 <mjturek> to tripleo-{release}-ppc64le
15:48:03 <mjturek> I was wondering if anyone could double check our configuration for holes
15:48:27 <amoralej> where are those jobs?
15:48:41 <mjturek> ci.centos.org let me grab the link
15:48:51 <baha> https://ci.centos.org/job/tripleo-upstream-containers-build-master-ppc64le/
15:48:59 <mjturek> thanks baha
15:49:06 <sfbender> Jakub Ružička created rdopkg master: Require distroinfo >= 0.2.0  https://softwarefactory-project.io/r/14913
15:49:18 <baha> np!
15:49:56 <baha> For reference, when we run effectively the same build script locally, we get 100% of the containers building
15:50:15 <baha> But each will produce a failure anyway because we obviously don't have credentials to push locally
15:50:47 <amoralej> but, all latest failures are because can get cico node
15:51:03 <mjturek> interesting
15:51:36 <mjturek> let me grab the latest where that didn[t happen
15:51:47 <baha> Yeah, right now it can't find any medium ppc64le nodes for some reason
15:52:00 <mjturek> https://ci.centos.org/job/tripleo-upstream-containers-build-master-ppc64le/lastSuccessfulBuild/console\
15:52:30 <mjturek> hmmm this might not be accurate either
15:52:42 <ykarel> baha, u can use kolla_push=false to avoid trying docker push locally
15:52:57 <amoralej> yeah, that one passed but didn't build anything :)
15:53:19 <amoralej> note you may have false positives, btw
15:53:57 <amoralej> that one is using bad delorean repos
15:54:23 <mjturek> oh right
15:54:26 <baha> mjturek: This one's from after the scripts were broken by that patch that broke us locally too
15:54:31 <mjturek> yep baha
15:54:32 <baha> ykarel: Thanks! We had a method of working around attempts at pushing before but a recent patch broke it
15:54:54 <ykarel> ack
15:54:55 <mjturek> amoralej: found an example
15:54:56 <mjturek> https://ci.centos.org/job/tripleo-upstream-containers-build-master-ppc64le/80/consoleFull
15:55:55 <amoralej> yeah, it's clear it's failing to push
15:56:09 <ykarel> hmm Unauthorized
15:56:22 <mjturek> we'll have a fix up for the other thing today (and reach out to centos about the cico stuff)
15:56:49 <baha> The local push workaround being broken made us realize that pushes generated failures for the builds themselves, which is why we brought this up
15:56:58 <rdogerrit> rdo-trunk created openstack/horizon-distgit rpm-master: python-django-horizon: failed to build b06657b  https://review.rdoproject.org/r/18629
15:57:12 <amoralej> it'd be nice to gather the logs mjturek
15:57:35 <mjturek> amoralej yeah that's fair - is there a space we could upload them to?>
15:57:57 <amoralej> mjturek, yes, to https://logs.rdoproject.org/
15:58:06 <mjturek> awesome, will look into that
15:58:15 <amoralej> i'll look for some example
15:58:21 <mjturek> thank you
15:59:00 <rdogerrit> Florian Fuchs proposed openstack/tripleo-validations-distgit rpm-master: Add python-ironic-inspector-client dependency  https://review.rdoproject.org/r/18447
15:59:18 <amoralej> well, meeting time is about to finish
15:59:32 <mjturek> yep thanks amoralej ykarel
15:59:35 <amoralej> mjturek, let's keep working on this after the meeting if it's ok for you
15:59:41 <mjturek> definitely
15:59:53 <rdogerrit> rdo-trunk created openstack/horizon-distgit rpm-master: python-django-horizon: failed to build b06657b07  https://review.rdoproject.org/r/18630
16:00:08 <amoralej> thanks all for joining
16:00:10 <amoralej> #endmeeting