rdo_meeting_-_2018-12-05
LOGS
15:00:31 <amoralej> #startmeeting RDO meeting - 2018-12-05
15:00:31 <zodbot> Meeting started Wed Dec  5 15:00:31 2018 UTC.
15:00:31 <zodbot> This meeting is logged and archived in a public location.
15:00:31 <zodbot> The chair is amoralej. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:31 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
15:00:31 <zodbot> The meeting name has been set to 'rdo_meeting_-_2018-12-05'
15:00:31 <moguimar> o/
15:00:33 <openstack> Meeting started Wed Dec  5 15:00:31 2018 UTC and is due to finish in 60 minutes.  The chair is amoralej. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:34 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:00:36 <openstack> The meeting name has been set to 'rdo_meeting___2018_12_05'
15:00:37 <amoralej> #topic roll call
15:01:07 <ykarel> o/
15:01:13 <amoralej> #chair moguimar ykarel
15:01:13 <zodbot> Current chairs: amoralej moguimar ykarel
15:01:15 <openstack> Current chairs: amoralej moguimar ykarel
15:01:55 <PagliaccisCloud> o/
15:02:09 <mjturek> o/
15:02:37 <amoralej> #chair PagliaccisCloud mjturek
15:02:37 <zodbot> Current chairs: PagliaccisCloud amoralej mjturek moguimar ykarel
15:02:38 <openstack> Current chairs: PagliaccisCloud amoralej mjturek moguimar ykarel
15:02:59 <chandan_kumar> \o/
15:03:07 <amoralej> #chair chandan_kumar
15:03:07 <zodbot> Current chairs: PagliaccisCloud amoralej chandan_kumar mjturek moguimar ykarel
15:03:09 <openstack> Current chairs: PagliaccisCloud amoralej chandan_kumar mjturek moguimar ykarel
15:03:57 <jpena> o/
15:04:48 <number80> o/
15:04:58 <amoralej> #chair jpena number80
15:04:58 <zodbot> Current chairs: PagliaccisCloud amoralej chandan_kumar jpena mjturek moguimar number80 ykarel
15:04:59 <openstack> Current chairs: PagliaccisCloud amoralej chandan_kumar jpena mjturek moguimar number80 ykarel
15:05:19 <amoralej> let's start with first topic
15:05:22 <amoralej> #topic Altarch image building job for cico
15:05:40 <amoralej> #link https://review.rdoproject.org/r/#/c/17657/
15:05:45 <amoralej> mjturek, your topic
15:05:46 <mjturek> hey!
15:06:00 <mjturek> basically it's the same idea as the tripleo containers job
15:06:04 <mjturek> for altarch\
15:06:27 <mjturek> but this will build ipa, overcloud, undercloud images
15:06:43 <mjturek> it's still WIP but figured I'd point it out and see if anyone has advice
15:06:44 <number80> do we have the resources for that?
15:07:02 <mjturek> number80: cico should
15:07:03 <number80> Especially regarding storage
15:07:16 <number80> Good to know
15:07:36 <mjturek> number80: when you say especially regarding storage do you mean publishing wise?
15:07:47 <mjturek> building wise I think cico should have enough resources
15:08:27 <number80> Yes, I know we have had issues in the past concerning storage which is independent of cico
15:08:34 <number80> dmsimard, jpena ^
15:09:00 <jpena> mjturek: where are you planning to host the resulting images?
15:09:06 <jpena> I can't tell from the review
15:09:34 <mjturek> jpena: we would hope to publish it to a place analogous to the x86_64 images
15:09:49 <mjturek> would that not be possible?
15:10:17 <jpena> we'd need to make some numbers to figure out the expected storage usage
15:10:55 <mjturek> ahhh and images.rdoproject.org doesn't specify arch currently
15:11:52 <mjturek> so we'd need to do something like add an rdo_truck_altarch dir to it?
15:13:34 <jpena> mjturek: yes, either we create an rdo_trunk_altarch under each release dir or we add a prefix. I don't have a special preference
15:13:51 <jpena> the important bit is to try to predict the storage requirements and see if they fit
15:13:54 <mjturek> cool, jpena is there anything I can do to help  figure out storage?
15:14:22 <jpena> mjturek: if you can build some test images without uploading, and check the resulting size, we can make some numbers
15:14:24 <mjturek> I guess build the images and see how large they are, then see how many versions we'd store at once?
15:14:32 <mjturek> jpena very cool we can work on that
15:14:43 * jpena thumbs up
15:16:01 <mjturek> alright I'm  good here if you'd like to move on amoralej !
15:16:35 <amoralej> ok, thanks
15:16:46 <amoralej> #topic push mariadb 10.3.10 & galera in stein
15:16:51 <amoralej> dciabrin, are you around?
15:16:57 <dciabrin> hey amoralej
15:17:02 <dciabrin> sorry i got elsewhere
15:17:34 <dciabrin> so yes, I'd like to move forward and push  the new mariadb upstream for stein
15:17:50 <dciabrin> I have a review upstream linked in the agenda which shows that it's passing both undercloud/overcloud and upgrades
15:18:13 <dciabrin> which i believe was the thing I promised to apevec and number80
15:18:56 <dciabrin> that was to let you guys know about my request
15:19:24 <amoralej> #link https://review.openstack.org/#/c/617355/
15:20:21 <number80> good
15:20:34 <radez> amoralej: we're inprocess of backporting networking-ansible to queens, what's the process for me to get a queens branch on distgit to build from?
15:21:08 <radez> https://review.rdoproject.org/r/#/c/17680/1/rdo.yml
15:21:40 <radez> oh, sry if I'm interupting the meeting
15:22:01 <amoralej> number80, do we have build for that mariadb and galera versions?
15:22:15 <number80> Normally yes
15:22:22 <dciabrin> amoralej, yes I've used number80's builds for the review's tests
15:23:10 <amoralej> ok
15:23:27 <amoralej> number, so, what we need is just to send a review to promote them to testing?
15:24:03 <number80> amoralej: yep, but up to dciabrin to do it :)
15:24:25 <amoralej> ok
15:25:48 <amoralej> dciabrin, is it https://review.rdoproject.org/r/#/c/16911/3/deps.yml ?
15:27:12 <amoralej> those are the builds?
15:29:25 <amoralej> we'll keep working on https://review.rdoproject.org/r/#/c/16911/
15:29:26 <amoralej> ok
15:29:29 <amoralej> let's move on
15:29:49 <amoralej> #topic fedora clients sync
15:30:02 <amoralej> #link https://trello.com/c/wkifSL7A/659-fedora-clients-sync
15:31:39 <amoralej> number80, short term we need to remove python2 subpackages in all openstack packages in fedora
15:31:51 <amoralej> do you have the list of packages that we maintain in fedora?
15:31:57 <amoralej> first thing would be to get the list
15:32:52 <rdogerrit> Jon Schlueter created openstack/tripleo-heat-templates-compat-distgit rpm-master: sync missing Requires from rocky-rdo branch  https://review.rdoproject.org/r/17695
15:32:53 <number80> I'll go throught that
15:33:06 <number80> #action number80 list packages maintained by openstack-sig
15:33:18 <amoralej> number80, maybe we could create a etherpad with the list and the status
15:33:28 <amoralej> we need to make sure that they have openstack-sig as admin
15:33:31 <number80> my concern is that automating fedora builds is not possible
15:33:42 <number80> amoralej: main-admin is not possible for sigs
15:33:47 <amoralej> right
15:33:59 <amoralej> well, add the group as comaintainer
15:34:42 <number80> Also an important thing is that we also have to monitor bugs so I suggest having an alias for that
15:34:44 <amoralej> number80, what's the blocker for automation?
15:34:51 <amoralej> number80, +1
15:35:22 <number80> amoralej: we do not have control over what happens in Fedora dist-git, so manual merges are often required
15:35:41 <number80> like 9 times out of ten
15:36:06 <number80> nothing difficult but not something that can be done a by bot safely
15:37:26 <leanderthal> o/
15:37:49 <leanderthal> utc-- me--
15:38:40 <amoralej> #chair leanderthal
15:38:40 <zodbot> Current chairs: PagliaccisCloud amoralej chandan_kumar jpena leanderthal mjturek moguimar number80 ykarel
15:38:42 <openstack> Current chairs: PagliaccisCloud amoralej chandan_kumar jpena leanderthal mjturek moguimar number80 ykarel
15:40:30 <amoralej> number80, what'd be next steps?
15:40:48 <amoralej> list packages, add to openstack-sig, check which ones need python2 removal
15:40:56 <amoralej> we'll need all that before stein ga
15:41:01 <number80> Next immediate step is checking what we owns and have sig co-owning them
15:41:06 <amoralej> at stein ga maybe we can do a more automated sync
15:41:13 <number80> I'll ping apevec for an alias
15:41:20 <number80> and Duck
15:43:35 <Duck> quack
15:44:31 <Duck> I know nothing about openstack-sig, but if I may help… :-)
15:45:38 <Duck> number80: mail alias?
15:45:42 <rdogerrit> Fabien Boucher proposed rdo-infra/rdo-infra-playbooks master: Add sf.io and koji.sf.io backup to the backup role  https://review.rdoproject.org/r/17642
15:45:58 <number80> Duck: alias or list so we can track bugs in bugzilla
15:46:27 <Duck> ok, just select the one you prefer and I can do that
15:47:00 <number80> \o/
15:49:17 <Duck> btw, ML phase 2 is being engaged…
15:49:53 <amoralej> number80, so, anything else about the topic?
15:50:05 <amoralej> next step is creating the list of openstack packages in fedora
15:50:12 <amoralej> will  you create an ehterpad?
15:50:26 <number80> not anymore (yes for the etherpad)
15:50:44 <amoralej> ok
15:50:47 <amoralej> let's move on
15:51:03 <amoralej> #topic chair for next week
15:51:06 <amoralej> any volunteer?
15:53:30 <number80> I can do it next week
15:53:46 <amoralej> thanks number80
15:53:56 <amoralej> #action number80 will chair next week
15:54:00 <amoralej> #topic open floor
15:54:10 <amoralej> any other topic?
15:55:17 <Duck> hum
15:55:28 <Duck> amoralej: new ducks for events?
15:55:45 <Duck> (and keeping one for me btw, so I can start a collection)
15:55:52 <amoralej> :)
15:56:41 <Duck> of course I can help man a booth and quack, but I know barely nothing about OpenStack
15:57:01 <Duck> so we need new rubber duckies
15:57:22 <Duck> I guess that's a priority topic for the upcoming FOSDEM & co events
15:57:42 <amoralej> i guess that's something for leanderthal ^
15:57:58 <Duck> yes
15:58:08 <Duck> leanderthal: don't forget to reply about the ML ;-P
15:58:43 <leanderthal> we'll be doing ducks, yes, but only for openstack summits; at fosdem and devconf we're doing scarves
15:59:12 <leanderthal> i will also need volunteers for the booths of both, so i'll need to put together a sign up page.
15:59:16 <number80> Because we're frozen there
15:59:21 <leanderthal> yesssssss
15:59:37 <leanderthal> maybe there will be snow ducks or something, but only if the budget remains
15:59:38 <number80> leanderthal: you can already sign me up for fosdem
15:59:45 <leanderthal> number80, you're awesomeness
15:59:54 <PagliaccisCloud> ooh scarves!
15:59:55 <leanderthal> i'll make sign ups by next week
15:59:59 * number80 not going to Brno coz it;s too cold
16:00:06 <leanderthal> it's so. freaking. cold.
16:00:21 <leanderthal> i would make snow suit swag, if i had the money, i swear it.
16:00:26 <leanderthal> omg legwarmers.
16:00:34 <leanderthal> ahem.
16:00:37 <leanderthal> but, yes. booths.
16:00:57 <leanderthal> i'm wrapping up travel (six?!? events?!?) so that i know our budget for the last quarter.
16:01:35 <number80> leanderthal: think about face mask
16:01:46 <leanderthal> i'm listening
16:02:01 <leanderthal> one of those infinite scarves that can wrap around the head / neck
16:02:10 <sfbender> Merged rdopkg master: Add support for *info in clone command  https://softwarefactory-project.io/r/14329
16:02:35 <PagliaccisCloud> OOOH. TRAIN CON-DUCK-TORS
16:02:48 <leanderthal> OMG YESSSSS
16:02:58 <leanderthal> PagliaccisCloud, that's totally what we're doing for denver. DONE AND DONE.
16:03:18 <PagliaccisCloud> yiss (insert Happy Gary)
16:03:32 <number80> Maybe we can wrap that discussion and have it next week ;-)
16:03:34 <leanderthal> amoralej, we're over time; my apologies
16:03:39 <amoralej> no problem
16:03:50 <leanderthal> (good to see you all again!)
16:03:50 <amoralej> yeah, i'll close
16:03:59 <amoralej> you can add the topic for next week
16:05:45 <amoralej> #endmeeting