rdo_meeting_-_2017-06-28
LOGS
15:03:04 <chandankumar> #startmeeting  RDO meeting - 2017-06-28
15:03:04 <zodbot> Meeting started Wed Jun 28 15:03:04 2017 UTC.  The chair is chandankumar. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:03:04 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
15:03:04 <zodbot> The meeting name has been set to 'rdo_meeting_-_2017-06-28'
15:03:04 <openstack> Meeting started Wed Jun 28 15:03:04 2017 UTC and is due to finish in 60 minutes.  The chair is chandankumar. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:03:06 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:03:09 <openstack> The meeting name has been set to 'rdo_meeting___2017_06_28'
15:03:21 <EmilienM> dmsimard: thx
15:03:27 <chandankumar> dmsimard: EmilienM trown apevec number80 rbowen meeting time
15:03:33 <chandankumar> jruzicka: ^^
15:03:39 * rbowen waves
15:03:42 <jpena> o/
15:04:04 <jruzicka> o/
15:04:15 <chandankumar> If you have not added the agenda, Feel free to add it
15:04:18 <chandankumar> #link https://etherpad.openstack.org/p/RDO-Meeting
15:04:38 <apevec> o/
15:04:38 <chandankumar> #chair jpena jruzicka
15:04:38 <zodbot> Current chairs: chandankumar jpena jruzicka
15:04:39 <openstack> Current chairs: chandankumar jpena jruzicka
15:04:43 <chandankumar> #chair apevec
15:04:43 <zodbot> Current chairs: apevec chandankumar jpena jruzicka
15:04:44 <openstack> Current chairs: apevec chandankumar jpena jruzicka
15:05:09 <chandankumar> #chair rbowen
15:05:09 <zodbot> Current chairs: apevec chandankumar jpena jruzicka rbowen
15:05:10 <openstack> Current chairs: apevec chandankumar jpena jruzicka rbowen
15:05:13 <coolsvap> o/
15:05:19 <chandankumar> sorry rbowen i forgot about you.
15:05:22 <chandankumar> #chair coolsvap
15:05:22 <zodbot> Current chairs: apevec chandankumar coolsvap jpena jruzicka rbowen
15:05:23 <openstack> Current chairs: apevec chandankumar coolsvap jpena jruzicka rbowen
15:05:23 <rbowen> :D
15:05:35 <chandankumar> see who is here coolsvap , long time no seexD
15:05:52 <chandankumar> #chair coolsvap
15:05:52 <zodbot> Current chairs: apevec chandankumar coolsvap jpena jruzicka rbowen
15:05:52 <openstack> Current chairs: apevec chandankumar coolsvap jpena jruzicka rbowen
15:05:57 <Duck> quack o/
15:06:02 <chandankumar> #chair Duck
15:06:02 <zodbot> Current chairs: Duck apevec chandankumar coolsvap jpena jruzicka rbowen
15:06:04 <openstack> Current chairs: Duck apevec chandankumar coolsvap jpena jruzicka rbowen
15:06:09 <chandankumar> Duck: quack quack
15:06:26 <coolsvap> hello all
15:06:34 <chandankumar> coolsvap: o/
15:06:56 <chandankumar> tosky: meeting time
15:07:05 <tosky> uh
15:07:11 <chandankumar> #chair tosky
15:07:11 <zodbot> Current chairs: Duck apevec chandankumar coolsvap jpena jruzicka rbowen tosky
15:07:12 <openstack> Current chairs: Duck apevec chandankumar coolsvap jpena jruzicka rbowen tosky
15:07:23 <chandankumar> so starting with the first topic
15:07:38 <chandankumar> #topic Enabling DLRN API on public instance
15:07:53 <chandankumar> jpena: i think it is your's topic?
15:07:57 <jpena> yes, it's mine
15:08:07 <chandankumar> jpena: go ahead, Thanks :-)
15:08:13 <jpena> we have migrated all the DLRN workers to use an external MariaDB instance
15:08:30 <dmsimard> jpena++
15:08:38 <jpena> our next step is to enable the DLRN API on the public URL (trunk.rdoproject.org), so we can have CI jobs reporting there
15:08:42 <chandankumar> dmsimard: we need to bring karma bot
15:09:03 <dmsimard> karma bot is muted
15:09:06 * jruzicka has custom rdokarma bot in works for ages
15:09:12 <jpena> I have everything ready, but enabling the API requires some little downtime (httpd restart, something can go wrong...)
15:09:53 <jpena> so I'll send an email to rdo-list telling about this, and preparing for the downtime. It shouldn't take long, but CI jobs can fail and such
15:09:56 <apevec> jpena, is there any noticable performance hit with the external db ?
15:10:21 <jpena> apevec: no, no performance hit. I've been monitoring the centos-master-head worker for some weeks, and everything looks pretty normal
15:10:27 <apevec> cool
15:10:29 <jpena> it's quite low traffic
15:10:34 <jpena> even with replication
15:10:40 <apevec> yeah, was just curious
15:10:59 <jpena> would tomorrow morning (European time) be ok for the downtime?
15:11:23 <jpena> if everything goes fine, it will be just a blip
15:11:33 <apevec> +1
15:11:41 <apevec> the sooner the better
15:11:44 <rbowen> as long as there's some advance notice, should be fine, I'd think.
15:11:50 <jpena> nice
15:12:00 <jpena> I'll take the opportunity to apply some security patches and reboot
15:12:39 <jpena> #action jpena to communicate planned downtime for DLRN public instance on Jun 29 morning
15:13:45 <dmsimard> jpena: you'll put up the patch for weirdo publisher ?
15:14:08 <jpena> dmsimard: oh, forgot about it. Sure, I'll update it
15:14:10 <dmsimard> Or playbook, not sure where the API location is defined
15:16:30 <jpena> that's it for this topic, I guess we can move on
15:16:47 <chandankumar> jpena: thanks for the update
15:16:51 <chandankumar> moving to next topic
15:16:59 <chandankumar> #topic Enabling RDO contribution through low hanging fruits
15:17:22 <chandankumar> contribution to RDO is hard, we have very less scope, like docs or packaging
15:17:29 <rbowen> HUGE props to whoever is spearheading this item. Please let me know if there is *ANY* way I can help out.
15:17:53 <chandankumar> let's make the packaging and code experience much more better so that we can get more contributors
15:18:04 <chandankumar> rbowen: i have created an etherpad for the same
15:18:14 <chandankumar> #link https://review.rdoproject.org/etherpad/p/rdo_low_hanging_fruits
15:18:21 <rbowen> I was just looking through that.
15:18:30 <rbowen> Documentation improvements is another thing that fits in there nicely.
15:18:46 <chandankumar> i have some challanges/questions which i need answers
15:18:51 <chandankumar> i am shooting one by one
15:19:21 <chandankumar> [1.] lots of rdo packages specs needs cleaning up, that will create lots of easy/low hanging fruits
15:19:32 <chandankumar> where should we file the issues for the same?
15:19:53 <chandankumar> is it good to use github/rdo-packages/project-distgit for issues?
15:20:16 <chandankumar> if yes, we have lots of issues, where we can put all these issues at one place
15:20:19 <chandankumar> ?
15:20:20 <rbowen> As long as they are clearly tagged as beginner/easy tasks and are easy to find.
15:20:48 <rdogerrit> Merged rdoinfo master: Bump rdoinfo pike-uc tags to latest upper-constraints  https://review.rdoproject.org/r/7276
15:20:56 <chandankumar> and for each issue we need mentors for the same
15:21:11 <chandankumar> so that they can guide people to accomplish the tasks
15:21:58 <rbowen> On the docs side, we are tracking them in https://github.com/redhat-openstack/website/issues
15:23:31 <rbowen> chandankumar: What do you need help with to move forward?
15:24:23 <chandankumar> rbowen: first is creating issues for each dist-git what things needs to be improved in a particular spec file and once issue is created tag is with proper label
15:24:28 <chandankumar> it would be the first step
15:25:03 <rbowen> It's important that the "regulars" are able to leave these things unfixed, so that newcomers have a shot at them.
15:25:40 <chandankumar> rbowen: in RDO, we have maintainers for each package, might be we can contact them for issues?
15:25:52 <rbowen> That makes a lot of sense.
15:26:10 <rbowen> also, asking them for their wish list of things that they'd like to see happen in RDO, but nobody has time for.
15:26:12 <Duck> is there no way to tag these tickets?
15:26:29 <chandankumar> jpena: jruzicka can we get some issues as LOW hanging fruits for DLRN and rdopkg?
15:26:54 <jpena> chandankumar: I'll have a look
15:27:04 <chandankumar> it would be good if we have some new project idea so that we can mentor new people to complete this.
15:27:31 <apevec> for packaging we should use BZ, but I wonder if that's too much overhead for low-hanging
15:27:34 <Duck> in Debian there is a +newcomer tag now, very practical, so that you don't forget about them and fix them by mistake
15:27:44 <apevec> I mean, bz is more bytes than the actual fix :)
15:28:09 <rbowen> It's good to use BZ so that people can learn the workflow, rather than having a different workflow adn then having to learn something new.
15:28:23 <chandankumar> apevec: i want to avoid bz for easier tasks.
15:28:30 <rbowen> But, yes, when you do this kind of thing, it often takes more time/effort than just fixing it yourself, but it's an investment in the future.
15:28:41 <apevec> hmm, good point about learning the workflow
15:29:01 <jruzicka> chandankumar, yup, I'll try
15:29:01 <apevec> it's just that BZ is soo.. uninviting
15:29:14 <rbowen> Yeah, there is that.
15:29:31 <rbowen> I'd be in favor of doing everything in Github issues, but then it's split over eleventy billion different trackers.
15:29:48 <jruzicka> BZ is one of the most uninviting websites still running ;)
15:29:57 <chandankumar> rbowen: that is my biggest concern.
15:30:20 <chandankumar> multiple dist-git and multiple issues hard to track at one place
15:30:36 <apevec> rbowen, no, let's not user github issues on distgit mirrors!
15:30:52 <apevec> I actualy want to check if SF can disable them automatically
15:31:10 <apevec> PR too (but that cannot be disabled afaict)
15:31:23 <rdogerrit> Eduardo Gonzalez created openstack/gnocchi-distgit rpm-master: Fix typo in gnocchi spec file  https://review.rdoproject.org/r/7288
15:31:27 <jpena> For DLRN we have an additional problem, issues should be placed at softwarefactory-project.io
15:31:35 <apevec> link to BZ component in github mirror description would be good
15:31:52 <apevec> jpena, in storyboard right?
15:32:00 <jpena> apevec: yep
15:32:19 <jruzicka> #action jruzicka to label low hanging rdopkg issues/RFEs
15:32:20 <jpena> maybe we could have an "aggregator page" (etherpad?) linking to each of the low hanging fruit trackers
15:32:25 <apevec> we have them all! trackers
15:32:29 <jruzicka> low hanging/fun
15:32:42 <apevec> low hanging fun?
15:32:53 <apevec> not right vibe I guess :)
15:32:56 <chandankumar> apevec: some many trackers, which might creates confusion for newbies
15:33:11 <rbowen> Yeah, multiple trackers is ... making it harder for newbies.
15:33:20 <chandankumar> for newbies, we need small learning curve
15:33:32 <chandankumar> less hurdles, we should enable them to get started
15:33:33 <apevec> chandankumar, maybe with some automatation, RDO trello board could aggregate them all
15:33:56 <apevec> but I don't have clear idea
15:34:18 <rbowen> Another option is to create a separate github repo, with just a README in it, and track issues there.
15:34:30 <chandankumar> rbowen: +1 for that
15:34:36 <rbowen> That way we can use a simple issue tracker, and have them in a single place.
15:34:46 <chandankumar> adding label with component as well as tags
15:34:50 <rbowen> Then it's up to each team to copy issues over there if they fit the "newbie" category.
15:35:20 <apevec> we could explore that, but I don't really like relying more on github
15:35:58 <chandankumar> first we need to start from some where, then we can change the mode.
15:36:01 <rbowen> apevec: ok, that's fair.
15:36:19 <apevec> could be fine if limited in scope to "newbie" category
15:37:01 <apevec> so redhat-openstack/easyfix ?
15:37:22 <rbowen> I'd also presume that most of the issues here would be duplicates of, or pointers to, other tickets. So if we eventually burn it down and put it somewhere else, we don't lose anything.
15:37:58 <apevec> yep
15:38:07 <rbowen> +1 to easyfix
15:38:35 <chandankumar> or something more meaningfule rdo/easyfix? i am not sure.
15:38:38 <apevec> repo created, who can provide me draft README ?
15:38:50 <apevec> chandankumar, please no, we have enough github orgs :)
15:39:01 <apevec> also, rdo is taken
15:39:12 <apevec> by a user called "rdo"
15:39:15 <rbowen> chandankumar: Using the same phrasing as another project (eg, fedora) is definitely a plus in helping people understand what we're doing.
15:39:19 <chandankumar> apevec: and i know him
15:39:34 <apevec> not sure if that's the same person :)
15:40:03 <chandankumar> apevec: rbowen: fedora has something like this also http://whatcanidoforfedora.org/en/
15:40:03 <apevec> anyway, easyfix/README anyone?
15:40:13 <chandankumar> apevec: i will put the README
15:40:54 <chandankumar> easy navigation based on the interest, we are not so big like fedoraxD
15:40:58 <rbowen> I suppose we could put up a separate website at some point, but it feels a bit overkill for now.
15:41:42 <apevec> yes, let's start small
15:42:25 <chandankumar> apevec: will i start adding AI from here?
15:42:54 <apevec> chandankumar, yes, take it, I'll push empty README and add just as owner of the github repo
15:43:06 <apevec> s/just/you/
15:43:33 <chandankumar> #action chandankumar to add README for redhat-openstack/easyfix
15:43:45 <chandankumar> shooting my next question
15:44:00 <chandankumar> [2.] What would be the format of an issues?
15:44:18 <chandankumar> s/issues/issue -> i mean easy fix
15:44:34 <chandankumar> Any template so that people can follow while creating it
15:46:20 <apevec> let's keep it simple, github issues are freeform that's why they're easy to use
15:46:32 <apevec> just some text and link to the code in question
15:46:56 <rbowen> Just be sure that every one mentions someone that they can ask for help/details/pointers, as chandankumar said.
15:48:32 <chandankumar> apevec: rbowen sure
15:49:19 <chandankumar> for this meeting, i will not shoot more question on this topic, once this is ready, i may bring in next meeting, if it ok?
15:49:29 <rbowen> +1
15:50:30 <chandankumar> apevec: can i move to next topic? if not any query on this.
15:51:11 <rbowen> Yeah. We're almost out of time.
15:51:14 <apevec> yes please!
15:51:39 <chandankumar> #topic Upcoming Events
15:51:42 <rbowen> Last item is just "save the date" announcements.
15:51:43 <rbowen> Upcoming events
15:51:43 <rbowen> Doc day, Jul 27, 28
15:51:44 <rbowen> P3 test day - Aug 3, 4
15:51:44 <rbowen> ORNL CentOS/RDO meetup, Sep 5
15:51:44 <rbowen> CERN CentOS/RDO meetup, Oct 20
15:51:49 <rbowen> </eom>
15:52:10 <rbowen> If you want more details on any of these, see messages on-list. I don't think there's a discussion item here.
15:52:58 <chandankumar> rbowen: Thanks :-)
15:53:06 <chandankumar> moving to famous topic
15:53:15 <chandankumar> #topic chair for next meeting
15:53:33 <chandankumar> Any volunteer up for chairing for next meeting?
15:53:46 <apevec> ykarel since he was scheduled for today?
15:54:08 <chandankumar> apevec: yes, his parents is in town, so donot make it
15:54:43 <apevec> anyone else willing?
15:55:05 <chandankumar> so do we drop the ball to ykarel court for next meeting?
15:55:32 <apevec> yeah he's not here so cannot complain :)
15:56:34 <chandankumar> if nobody, then i can take it for next week.
15:56:56 <rbowen> I'll be away again next week.
15:57:09 <chandankumar> #action chandankumar to chair for next meeting
15:57:09 <jpena> I can take it next week
15:57:15 <chandankumar> #undo
15:57:15 <zodbot> Removing item from minutes: ACTION by chandankumar at 15:57:09 : chandankumar to chair for next meeting
15:57:16 <openstack> Removing item from minutes: #action chandankumar to chair for next meeting
15:57:27 <chandankumar> #action jpena to chair for next week
15:57:31 <chandankumar> jpena: Thanks :-)
15:57:42 <chandankumar> moving to open floor
15:57:47 <chandankumar> #topic open floor
15:58:03 * Duck :-)
15:58:10 <chandankumar> Any topics or packages reviews or gerrit reviews missed feel free to bring it
15:58:40 <Duck> thanks apevec, jpena and dmsimard for onbording me kindly
15:59:18 <apevec> we have ftbfs review which are blocked on sphinx update
15:59:26 <Duck> rbowen: btw, website /stats is updated to common system
15:59:39 <rbowen> Oh, yeah! I saw that!
15:59:41 <rbowen> It's awesome
15:59:46 <rbowen> http://rdoproject.org/stats
15:59:55 <apevec> I'm updating Sphinx in rdo-common and will ping Fedora maintainers
15:59:55 <rbowen> Also, the list of repos that we're tracking has FINALLY been updated.
16:00:02 <apevec> rbowen, yay!
16:00:08 <Duck> rbowen: but it seems it is advertised nowhere on the site
16:00:20 <rbowen> https://rdo.biterg.io/app/kibana#/dashboard/Git
16:00:32 <rbowen> Yes, that's correct, it is not advertised anywhere on the site.
16:00:34 <jruzicka> if anyone has mad BDD skillz, namely behave, please loot at https://softwarefactory-project.io/r/#/c/8679/
16:00:44 <rbowen> I'll see if Ican find sensible places to add that in.
16:01:00 <chandankumar> times up!
16:01:14 <chandankumar> #endmeeting