rdo_meeting_-_2016-11-23
LOGS
15:00:26 <jpena> #startmeeting RDO meeting - 2016-11-23
15:00:26 <zodbot> Meeting started Wed Nov 23 15:00:26 2016 UTC.  The chair is jpena. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:26 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
15:00:26 <zodbot> The meeting name has been set to 'rdo_meeting_-_2016-11-23'
15:00:26 <openstack> Meeting started Wed Nov 23 15:00:26 2016 UTC and is due to finish in 60 minutes.  The chair is jpena. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:28 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:00:30 <number80> o/
15:00:30 <openstack> The meeting name has been set to 'rdo_meeting___2016_11_23'
15:00:36 * number80 can't hide anymore :)
15:00:51 <jpena> #chair number80 rbowen
15:00:52 <zodbot> Current chairs: jpena number80 rbowen
15:00:58 <jpena> #topic roll call
15:01:04 <amoralej> o/
15:01:18 <jpena> remember, the agenda is available at https://etherpad.openstack.org/p/RDO-Meeting and you can add any item you want discussed
15:01:25 <jpena> #chair amoralej
15:01:25 <zodbot> Current chairs: amoralej jpena number80 rbowen
15:01:35 <EmilienM> o/
15:01:36 <chandankumar> \o/
15:01:45 <jpena> #chair EmilienM chandankumar
15:01:45 <zodbot> Current chairs: EmilienM amoralej chandankumar jpena number80 rbowen
15:02:02 * EmilienM still confused why we add chairs all the time
15:02:21 <jpena> EmilienM, so anyone can add action items for example
15:02:31 <EmilienM> jpena: you can without
15:02:39 <jpena> oh, first news
15:02:41 <EmilienM> that's how we do in other OpenStack meetings, anyone can add actions
15:02:43 <jruzicka> o/
15:02:59 <EmilienM> anything can use #info or action without be the chair
15:03:11 <rbowen> #link https://etherpad.openstack.org/p/RDO-Meeting
15:03:43 * apevec double-booked, so half-present here
15:03:54 <EmilienM> jpena: https://wiki.debian.org/MeetBot
15:04:05 <EmilienM> jpena: action is a command for everyone
15:04:16 <number80> EmilienM: it's allows to keep meetings running when chair leaves
15:04:25 <jpena> EmilienM: thx, good to know :)
15:04:43 <jpena> anyway, let's start with the agenda
15:04:49 <number80> *nods*
15:04:52 <jpena> #topic Proposal: scheduled maintenance for review.rdoproject.org on Nov 30
15:05:16 <jpena> I got an email from the SF guys, who want to upgrade review.rdo.org to SF 2.2.6
15:05:38 <jpena> the proposal is to do it on November 30, at 12:00 PM UTC (for 1 hour)
15:05:57 <jpena> is this an issue to anyone?
15:06:16 <jruzicka> np with that, looking forward to new SF
15:06:47 <EmilienM> do we know what is new in SF?
15:07:05 <jpena> #link https://github.com/redhat-cip/software-factory/blob/master/CHANGELOG.md
15:07:13 <EmilienM> jpena: thanks
15:07:37 <jpena> I'm really looking forward to defining projects via Gerrit (although it's experimental for now)
15:07:54 <EmilienM> ++
15:08:38 <jruzicka> yup
15:09:45 <jpena> ok, if everyone agrees, we'll do the maintenance then
15:10:30 <jpena> #agreed review.rdoproject.org maintenance will happen on Nov 30
15:10:48 <jpena> #topic RDO at FOSDEM?
15:11:04 <jpena> apevec, rbowen ?
15:11:08 <rbowen> kbsingh has turned the planning of the CentOS Dojo over to the centos-promo mailing list.
15:11:20 <rbowen> Thus far, there's not been mention there as to what role RDO will play in that, if any.
15:11:34 <rbowen> Meanwhile, the question is whether we want to do a separate event, or do another joint event.
15:11:59 <rbowen> If joint event, it will again be at the IBM facility outside of town, and we'll need to work with the centos-promo mailing list to make it happen.
15:12:14 <rbowen> I presume that would look like last year, with 5-7 speakers presenting content.
15:12:38 <rbowen> We'd want to pull together a schedule very soon, so we can promote. December is hard to promote anything.
15:12:39 <rbowen> So ...
15:12:43 <rbowen> what'd the feeling of folks?
15:13:06 <rbowen> Stick with CentOS, or do our own event closer to downtown? (The latter involves spending more, of course.)
15:13:33 <jpena> I don't have a strong opinion, tbh
15:13:45 <rbowen> Related question - how many of you expect to attend FOSDEM and could make it to a Friday event?
15:14:31 <rbowen> We had roughly 45 in attendance last time.
15:15:17 <amoralej> i'd like to attend but i'm not sure yet
15:15:24 <rbowen> Hmm. Ok, well, I guess that given the responses on list, and the lack of responses here, I'll continue to pursue doing something in conjunction with CentOS.
15:15:31 <jpena> same for me, it will depend on budget :)
15:15:37 <amoralej> yeap
15:15:49 <rbowen> I'll work with Daniel on centos-promo and see what we can come up with.
15:16:13 * misc prefer downtown
15:16:31 <rdobot> [sensu] NEW: master.monitoring.rdoproject.org - check-delorean-master-head-current @ http://tinyurl.com/hcnq3ll |#| Build failure on centos7-master-head/current: heat, oslo.db, oslo.log, murano-dashboard: http://trunk.rdoproject.org/centos7-master-head/report.html
15:17:25 <rbowen> misc: I actually do also, but I also prefer cheaper, and I prefer the larger momentum of doing it with another group.
15:17:55 <rbowen> I guess this topic is done.
15:18:05 <jpena> ok, moving on
15:18:18 <jpena> #topic Puppet4 packaging
15:18:36 <number80> I checked for boost159 and scratch build passed
15:18:50 <EmilienM> o/
15:18:52 <number80> puppet4 depends on facter3 which is not yet ready
15:18:59 <number80> (well, it's packaged)
15:19:15 <EmilienM> number80: why can I deploy puppet4 in tripleo with your package then?
15:19:37 <number80> EmilienM: I suspect that you either don't use facter3 or use a package from somewhere else
15:19:39 <EmilienM> oh I'm using your repo and you must have facter inside
15:19:43 <EmilienM> https://review.openstack.org/#/c/371209/
15:19:49 <number80> weird
15:19:53 <EmilienM> I'm using  https://copr.fedorainfracloud.org/coprs/hguemar/puppet4-el7/repo/epel-7/hguemar-puppet4-el7-epel-7.repo
15:20:03 <number80> I tried on fresh installs and facter2 crashes with puppet4
15:20:10 <EmilienM> https://copr-be.cloud.fedoraproject.org/results/hguemar/puppet4-el7/epel-7-x86_64/00453488-puppet/
15:20:13 <EmilienM> it only has puppet4
15:20:19 <EmilienM> it works fine in tripleo
15:20:22 <number80> but I can tag it if nobody complains
15:20:23 <jpena> we have facter 1.3 in the repos, don't we?
15:20:35 <number80> jpena: facter 3 not 1.3
15:20:45 <jpena> number80: I mean currently
15:20:55 <pabelanger> number80: danke, appreciate it
15:21:06 <EmilienM> facter-2.4.4-3.el7.x86_64
15:21:06 <number80> jpena: currently we have 2.4.4
15:21:17 <EmilienM> http://logs.openstack.org/09/371209/39/check/gate-tripleo-ci-centos-7-undercloud/12b0783/logs/rpm-qa.txt.gz
15:21:27 <EmilienM> with puppet-4.6.2-2.el7.centos.noarch
15:21:33 <EmilienM> I'm ok to tag it asap
15:21:38 <number80> if you're ok with tagging (I mean puppet/3o/packstack folks) then, I'll do it
15:21:47 <jpena> we're only tagging it with Ocata, correct?
15:21:51 <number80> yes
15:21:52 <EmilienM> yes
15:22:05 <jpena> ok then, from the packstack PoV it works
15:22:05 <EmilienM> number80: let's sync on it later and do the change anytime soon
15:22:11 <number80> jpena: ack
15:22:16 <EmilienM> same for puppet & tripleo
15:22:23 <number80> #action number80 tag puppet4 in ocata
15:22:34 <EmilienM> number80: I'm doing a last recheck on my patch :D
15:22:34 <number80> EmilienM: yup, I assumed that :)
15:23:03 <jpena> next topic?
15:23:32 <EmilienM> jpena: yes, thx
15:23:36 <jpena> #topic: Announcement: rdopkg-0.42 released with %{?milestone} bug correction and more
15:24:15 <jpena> jruzicka, the stage is yours
15:27:16 <jruzicka> sry
15:27:22 <jruzicka> lost in codes
15:27:37 <jruzicka> #link https://github.com/openstack-packages/rdopkg/commit/31dc354666466083a1463391089868effc1ebc6e
15:27:40 <jruzicka> most importantly
15:28:09 <jruzicka> rdopkg patch/new-version
15:28:26 <jruzicka> will remove unwanted %global milestone %{?milestone} definition from .spec
15:28:39 <jruzicka> that was created by faulty first version of milestone support
15:28:49 <jruzicka> and still remains in few .spec's
15:29:05 <jruzicka> patch/new-version will fix or remove this unwanted line
15:29:13 <jruzicka> update-patches will work with it
15:29:18 <jruzicka> without touching
15:29:32 <jruzicka> finally, you can play with
15:29:37 <jruzicka> rdopkg findpkg you-package
15:29:53 <jruzicka> to smartly search rdoinfo
15:30:03 <jruzicka> EOF
15:30:40 <jpena> thanks jruzicka. BTW, we have the first reviews using rdopkg findpkg, will let you know how they go
15:31:08 <jpena> #topic Test day Dec 1-2 (next week)
15:31:53 <amoralej> we need to get a promotion in master...
15:32:23 <amoralej> and it seems planets are aligning against us
15:32:30 <apevec> what are current blockers?
15:32:39 <EmilienM> nova/neutron looks broken for us in puppet CI
15:32:46 <EmilienM> we're investigating on #puppet-openstack
15:32:47 <amoralej> a new mariadb-libs package was released
15:32:48 * number80 can use Death Star to unalign planets
15:32:57 <amoralej> that conflicts with our mariadb-common
15:32:59 <amoralej> package
15:33:07 <number80> amoralej: in EL7?
15:33:07 <apevec> where was that released?
15:33:15 <amoralej> mariadb-libs-1:5.5.52-1.el7.x86_64
15:33:23 <amoralej> aparently in centos CR repo
15:33:38 <amoralej> but it's not longer there
15:33:39 <number80> can you check which package pulls it?
15:33:41 <apevec> so 7.3
15:33:51 <amoralej> it's in base image
15:34:13 <apevec> why doesn't mariadb-libs 10 updates it?
15:34:29 <amoralej> because mariadb-common doesn't depends on mariadb-libs
15:34:44 <amoralej> nothing depends on mariadb-libs
15:34:52 <apevec> weird
15:35:16 <apevec> so as workaround, could we just do yum update with RDO deps repo enabled when job starts?
15:35:21 <number80> amoralej: libs depends on common
15:35:32 <number80> common can't depend on libs
15:35:48 <number80> (otherwise circular dep and my brain starts burning :) )
15:36:29 <apevec> amoralej, btw where is that tracked, https://etherpad.openstack.org/p/tripleo-ci-status seems to have all issues crossed?
15:36:32 <amoralej> mariadb-libs in centos repo doesn't depend on mariadb-common
15:36:44 <amoralej> apevec, i added it to the newton etherpad
15:36:51 <number80> ok, for 10.x it does
15:36:54 <amoralej> because i detected there
15:36:55 <apevec> is it newton only?
15:37:00 <amoralej> but affect all
15:37:08 * number80 will look
15:37:16 <amoralej> but tripleo, because mariadb-libs is not in tripleo images
15:37:44 <apevec> amoralej, which image is which has it?
15:37:55 <amoralej> image un ci.centos
15:38:01 <amoralej> i'm not sure who creates them?
15:38:16 <amoralej> are they shared for everyone in ci.centos?
15:38:22 <amoralej> do we create our own?
15:38:25 <apevec> dmsimard, ^ ?
15:39:06 <apevec> iirc machines are kickstarted for every job run
15:39:50 <amoralej> mmm
15:39:55 <amoralej> letme check the kickstart log
15:40:43 <amoralej> yep, you are right apevec
15:40:56 <apevec> amoralej, but anyway, wouldn't this be solved by running yum update after enabling rdo repo?
15:41:45 <amoralej> yes, it would
15:42:07 <amoralej> we may trick it in weirdo iirc
15:42:15 <amoralej> i need to check
15:42:25 <apevec> other than that, we still have intermittent failures?
15:42:28 <amoralej> btw, it's dependency for postfix, that's why we get it
15:42:41 <amoralej> hard to say apevec
15:42:53 <amoralej> we still hit badlinestatus from time to time
15:44:23 <amoralej> but i think we should be able to promote if we fix it
15:44:30 <amoralej> this one, i mean
15:44:35 <amoralej> tripleo jubs are passing
15:45:01 <apevec> cool, that would be great
15:45:13 <apevec> let's get promotion before more changes break it :)
15:45:58 <amoralej> yeah
15:46:15 <apevec> btw wasn't there something w/ new xstatic package yesterday?
15:46:26 <number80> yes
15:46:27 <apevec> is that resolved now?
15:46:33 <apevec> what was it?
15:46:51 <number80> it was rebuilt
15:46:52 <amoralej> yes apevec
15:47:21 <amoralej> horizon in lates promoted repo was incompatible with roboto 0.5.0.0 which is needed for promotion
15:47:48 <amoralej> and we need puppet-passed-ci to work to merge changes in p-o-i required for promotion
15:48:14 <amoralej> i did a dirty trick, i added old roboto rpm to the puppet-passed-ci repo
15:48:23 <amoralej> so that we could merge changes in p-o-i
15:48:37 <apevec> ah that worked w/ priorities
15:48:41 <amoralej> in fact, current-passed-ci is still affected by this
15:48:42 <amoralej> yes
15:48:55 <amoralej> we had to change priorities in p-o-i which was wrong
15:49:13 <apevec> ok, hopefully we'll get new promotion today
15:49:19 <amoralej> yeah...
15:49:31 <apevec> ...famous last words?
15:49:57 <apevec> ok, tl;dr let's check EOW if we are still on target for the ocata1 testday ?\
15:50:05 <amoralej> ok
15:50:16 <apevec> #info check EOW if we are still on target for the ocata1 testday
15:50:16 <dmellado> oh, awesome
15:50:27 * dmellado just noticed the different time on the rdo meeting
15:50:32 <dmellado> late hi, guys
15:50:45 <apevec> dmellado, meeting is on UTC :)
15:50:52 <apevec> so meeting never changes
15:50:53 <dmellado> apevec: now I know it
15:50:54 <apevec> it
15:50:54 <dmellado> xD
15:50:58 <number80> amoralej: quick question, do you need to wait for puppet4 to get tagged in ocata? (not to block promotions)
15:51:02 <apevec> 's funny timezones which do
15:51:18 <apevec> number80, yeah, let's get promotion first
15:51:18 <dmellado> apevec: I had it on the wrong calendar, so it changed on my calendar notification
15:51:27 <amoralej> number80, could we use -pending so far?
15:51:37 <amoralej> there is not ocata-pending, right?
15:51:42 <number80> yep
15:51:46 <apevec> no there is common-pending only
15:51:48 <amoralej> then, let's wait
15:51:53 <number80> roger
15:52:13 <jpena> ok then, next topic?
15:54:40 <jpena> #topic Chair for next meeting
15:54:49 <jpena> any volunteers?
15:55:30 <amoralej> i can do it
15:55:44 <jpena> #action amoralej to chair next meeting
15:55:47 <jpena> thx amoralej :)
15:55:51 <jpena> #topic open floor
15:55:59 <jpena> Anything else before we close?
15:56:06 <apevec> or 5 min back?
15:56:42 <number80> nothin'
15:56:55 <jpena> great, we're done then!
15:56:58 <jpena> #endmeeting