rdo_meeting_(2016-05-18)
LOGS
15:00:51 <jpena> #startmeeting RDO meeting (2016-05-18)
15:00:51 <zodbot> Meeting started Wed May 18 15:00:51 2016 UTC.  The chair is jpena. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:51 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
15:00:51 <zodbot> The meeting name has been set to 'rdo_meeting_(2016-05-18)'
15:00:52 <openstack> Meeting started Wed May 18 15:00:51 2016 UTC and is due to finish in 60 minutes.  The chair is jpena. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:53 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:00:56 <openstack> The meeting name has been set to 'rdo_meeting__2016_05_18_'
15:00:56 <imcsk8> o/
15:00:59 <jpena> #topic roll call
15:00:59 <dmsimard> oh no
15:01:12 <jruzicka> oh yeah
15:01:24 <leifmadsen> :kool-aid man:
15:01:50 <dmsimard> let's see if that helps
15:01:53 <jpena> #chair imcsk8 dmsimard jruzicka
15:01:53 <zodbot> Current chairs: dmsimard imcsk8 jpena jruzicka
15:01:56 <dmsimard> I don't want to ban him again
15:01:57 <openstack> Current chairs: dmsimard imcsk8 jpena jruzicka
15:02:10 <dmsimard> oh
15:02:15 <gkadam> 0/
15:02:27 <leifmadsen> nice
15:02:33 <jpena> #chair leifmadsen gkadam
15:02:33 <zodbot> Current chairs: dmsimard gkadam imcsk8 jpena jruzicka leifmadsen
15:02:42 <dmsimard> yes! openstack bot muted
15:02:45 <apevec> bot fight!
15:02:48 <jpena> yep, it worked :)
15:02:55 <jpena> #chair apevec
15:02:55 <zodbot> Current chairs: apevec dmsimard gkadam imcsk8 jpena jruzicka leifmadsen
15:03:03 <dmsimard> that openstack-infra patch still hasn't landed, I see :p
15:03:07 <amoralej> o/
15:03:08 <jpena> chandankumar, amoralej: you around?
15:03:16 <jpena> #chair amoralej
15:03:16 <zodbot> Current chairs: amoralej apevec dmsimard gkadam imcsk8 jpena jruzicka leifmadsen
15:03:32 <apevec> dmsimard, patch to disable meetbot part of openstack bot?
15:03:45 <dmsimard> apevec: patch to make it only trigger on #openstack-meeting.* channels
15:04:05 <apevec> ah so it wasn't just us
15:04:08 <chandankumar> jpena, \o/
15:04:16 * dmsimard nods
15:04:22 <jpena> #chair chandankumar
15:04:22 <zodbot> Current chairs: amoralej apevec chandankumar dmsimard gkadam imcsk8 jpena jruzicka leifmadsen
15:04:28 <tristanC> dmsimard: that should work: http://review.rdoproject.org/r/1166
15:04:39 <jpena> the agenda today is quite short :)
15:04:41 <dmsimard> tristanC: oh no
15:04:44 <dmsimard> tristanC: !
15:04:53 <rbowen> \0/
15:05:01 <tristanC> always fun to fix thing with a single character :)
15:05:04 <jpena> #chair rbowen
15:05:05 <zodbot> Current chairs: amoralej apevec chandankumar dmsimard gkadam imcsk8 jpena jruzicka leifmadsen rbowen
15:05:07 <rdogerrit> Merged config: DLNR: fix publishers typo missing an 's'  http://review.rdoproject.org/r/1166
15:05:09 <jpena> #topic Comment for EOL Bugs
15:05:27 <jpena> chandankumar, the stage is yours
15:05:53 <chandankumar> rbowen, has suggested comment "This bug is against an EOL'ed version. Please reopen if it is still relevant with a supported version."" on EOL bugs
15:06:09 <chandankumar> which is sweet and simple
15:06:11 <rbowen> That's what I use when I close questions on ask.openstack for EOL. Seems sufficient.
15:06:11 <apevec> +1 maybe we just need to define EOL ?
15:06:31 <jpena> rbowen: is that Juno and earlier, or should we include Kilo?
15:06:33 <trown> o/
15:06:37 <rbowen> EOL is defined upstream, right?
15:06:38 <jpena> #chair trown
15:06:38 <zodbot> Current chairs: amoralej apevec chandankumar dmsimard gkadam imcsk8 jpena jruzicka leifmadsen rbowen trown
15:06:43 <apevec> jpena, yes, include Kilo
15:06:46 <rbowen> https://wiki.openstack.org/wiki/Releases
15:06:53 <chandankumar> http://releases.openstack.org/
15:06:55 <dmsimard> rbowen: http://releases.openstack.org/
15:07:02 <apevec> we'll push last update then move it to vault.centos.org
15:07:05 <rbowen> Right. That. :-)
15:07:57 <rbowen> That says Kilo is EOL on May 2.
15:08:09 <jpena> good. chandankumar, I see an item in the agenda about a "script to close EOL Bugs". Does it exist?
15:08:17 <chandankumar> jpena, nope
15:08:30 <chandankumar> jpena, i will create it tonight
15:08:36 <chandankumar> if someone has please share.
15:08:41 <chandankumar> misc, ^^
15:08:53 <imcsk8> chandankumar: i can help i've done some bugzilla API scripts
15:09:08 <chandankumar> imcsk8, sure
15:09:21 <jpena> action?
15:09:23 <apevec> ok, I updated 1liner to: "This bug is against a version which reached End of Life. Please reopen if it is still relevant with a latest version."
15:09:42 <apevec> rbowen, ^ is that still proper English?
15:09:47 <dmsimard> apevec: should we include teh releases.openstack.org link ?
15:09:53 <rbowen> Yes, that looks fine.
15:09:55 <apevec> dmsimard, good idea
15:09:56 <chandankumar> #action chandankumar to share EOL script with imcsk8 and others for review.
15:10:01 <rbowen> dmsimard: +1
15:10:37 <apevec> "This bug is against a version which reached End of Life. Please reopen if it is still relevant with a latest version: http://releases.openstack.org/"
15:10:37 <chandankumar> #info EOL message "This bug is against a version which reached End of Life. Please reopen if it is still relevant with a latest version"
15:10:41 <imcsk8> chandankumar: should launchpad bugs be addressed too?
15:10:44 <apevec> #undo
15:10:44 <zodbot> Removing item from minutes: INFO by chandankumar at 15:10:37 : EOL message "This bug is against a version which reached End of Life. Please reopen if it is still relevant with a latest version"
15:10:57 <chandankumar> imcsk8, nope
15:10:58 <apevec> let's see some +1 :)
15:11:10 <dmsimard> apevec: your message lgtm
15:11:14 <jpena> +1
15:11:17 <chandankumar> +1
15:11:27 <apevec> #info EOL message for RDO bugzillas "This bug is against a version which reached End of Life. Please reopen if it is still relevant with a latest version: http://releases.openstack.org/"
15:11:27 <amoralej> +1
15:11:30 <leifmadsen> "This bug is against a version which has reached End of Life [link to EOL data]. Please reopen if it is still relevant with a latest version."
15:11:44 <apevec> leifmadsen, that's too complicated :)
15:11:45 <chandankumar> #chair leifmadsen
15:11:45 <zodbot> Current chairs: amoralej apevec chandankumar dmsimard gkadam imcsk8 jpena jruzicka leifmadsen rbowen trown
15:12:03 <leifmadsen> apevec: ok, then just add the "which has reached" part :)  (add word 'has')
15:12:04 <apevec> and it changes from release (it's post on openstack-dev)
15:12:15 <apevec> #undo
15:12:16 <zodbot> Removing item from minutes: INFO by apevec at 15:11:27 : EOL message for RDO bugzillas "This bug is against a version which reached End of Life. Please reopen if it is still relevant with a latest version: http://releases.openstack.org/"
15:12:26 <apevec> #info EOL message for RDO bugzillas "This bug is against a version which has reached End of Life. Please reopen if it is still relevant with a latest version: http://releases.openstack.org/"
15:12:31 <leifmadsen> +1
15:12:33 <apevec> is it perfect now? :)
15:12:37 <chandankumar> +1
15:12:44 <imcsk8> +1
15:12:45 <leifmadsen> it is acceptable, that's as far as I will go :D
15:12:47 <dmsimard> +1
15:12:53 <imcsk8> like shakespeare!
15:13:16 <gkadam> chandankumar, how do i check if the bug is still relevant . i found this bug it is for Juno. no comments yet. should i close ?  https://bugzilla.redhat.com/show_bug.cgi?id=1180201
15:13:41 <chandankumar> gkadam, meeting is going on.
15:13:43 <apevec> imcsk8, not quite :)
15:14:02 <jpena> next topic?
15:14:08 <jruzicka> "if it's" > "if it is" :-p
15:14:15 <imcsk8> hehehe, apevec i lacks drama but we're engineers so there's no problem :P
15:14:23 <rdogerrit> trown proposed openstack/ironic-distgit: Do TFTP/iPXE setup in packaging  http://review.rdoproject.org/r/1157
15:14:33 <chandankumar> #chair gkadam
15:14:33 <zodbot> Current chairs: amoralej apevec chandankumar dmsimard gkadam imcsk8 jpena jruzicka leifmadsen rbowen trown
15:15:00 <jpena> #topic move rdostats project under RDO
15:15:13 <rdogerrit> trown proposed openstack/ironic-distgit: Do TFTP/iPXE setup in packaging  http://review.rdoproject.org/r/1157
15:15:27 <chandankumar> So we are using rdostats to generate Weekly RDO bug stats
15:15:45 <chandankumar> can we move this under rdo projects?
15:15:46 <apevec> would it fit in rdo-infra ?
15:15:53 <chandankumar> https://github.com/larsks/rdostats
15:16:00 <chandankumar> larsks, ^^
15:16:36 <chandankumar> apevec, yes, will work for me, but needs other's input.
15:16:38 <apevec> if so, I'd ask larsks to move it
15:16:40 <dmsimard> tristanC: swift working
15:16:58 <jpena> it looks like something we could have under rdo-infra, yep
15:17:09 <dmsimard> tristanC: but http returning 404
15:17:09 <jpena> chandankumar: are you running it manually, or automated in some VM?
15:17:31 <chandankumar> jpena, it is just a two line of shell script
15:17:59 <chandankumar> manually i would say
15:18:13 <apevec> I've added larsks as an owner in rdo-infra so he can move the repo
15:18:23 <dmsimard> apevec: +1
15:19:15 <jpena> so should we add an action to larsks?
15:19:58 <apevec> of course, he's not paying attention :)
15:20:03 <rbowen> :)
15:20:17 <jpena> #action larks to migrate https://github.com/larsks/rdostats to rdo-infra
15:20:20 <jpena> #undo
15:20:20 <zodbot> Removing item from minutes: ACTION by jpena at 15:20:17 : larks to migrate https://github.com/larsks/rdostats to rdo-infra
15:20:29 <jpena> #action larsks to migrate https://github.com/larsks/rdostats to rdo-infra
15:20:34 <dmsimard> let's ask him nicely first? :)
15:20:49 <apevec> dmsimard, that is nicely, via action item :)
15:20:55 <apevec> #undo
15:20:55 <zodbot> Removing item from minutes: ACTION by jpena at 15:20:29 : larsks to migrate https://github.com/larsks/rdostats to rdo-infra
15:21:06 <jpena> silence is acknowledgment, they say in Spain :)
15:21:11 <imcsk8> hahahaaa
15:21:15 <misc> chandankumar: mhh ?
15:21:17 <apevec> #action larsks to be asked nicely to migrate https://github.com/larsks/rdostats to rdo-infra
15:21:22 <dmsimard> apevec: hah
15:21:37 <trown> he has an action to ask himself nicely?
15:21:37 <chandankumar> misc, do you have bz script to close EOL bugs?
15:22:23 <jpena> so we're done with this topic, let's go to the next one
15:22:32 <jpena> #topic Hangouts - speakers wanted
15:22:42 <rbowen> Before and during summit, I did some awesome interviews with some of you. Many thanks to all that participated.
15:22:52 <rbowen> I need a volunteer for some time in May.
15:22:56 <dmsimard> rbowen++
15:23:05 <rbowen> Someone who wants to talk about what exciting things they're doing for Newton.
15:23:20 <rbowen> Preferably someone that I haven't already done an interview with in the last few months.
15:23:22 <chandankumar> dmsimard, zodbot is not listening in #rdo channel
15:23:40 <imcsk8> i was about to step up but i've already been interviewed
15:23:44 <rbowen> Time investment on your part is roughly 20-30 minutes, plus whatever time you need to prepare.
15:24:14 <rbowen> I'll ask on list, but wanted to give folks here an opportunity first.
15:24:17 <rdogerrit> trown proposed openstack/ironic-distgit: Do TFTP/iPXE setup in packaging  http://review.rdoproject.org/r/1157
15:24:23 <tristanC> dmsimard: I'm investigating the swift 404, it's weird because the files are in the container but in another path
15:24:44 <rbowen> Ok, so if there's no immediate volunteers, I'm done with this topic. :-)
15:25:02 <jpena> #topic DLRN instance migration to ci.centos infra (reloaded)
15:25:13 <dmsimard> oh hai
15:25:18 <misc> chandankumar: nope
15:25:22 <dmsimard> it turns out it's pretty hard to delete things from the buildlogs cdn
15:25:29 <dmsimard> but KB is working on it
15:25:44 <dmsimard> to remove kilo and the trunk repos
15:26:34 <jpena> dmsimard: what about the promotion job? I remember from last week that trown figured out a way to run them, but there was still something missing (I can't remember what)
15:27:18 <dmsimard> the script in tripleo ci needs to be adapted to use the new promotion job instead of doing it iself
15:27:25 <dmsimard> I believe trown already spoke to derekh
15:28:07 <dmsimard> I'm pretty sure this is the last outstanding item unless I am mistaken
15:28:23 <dmsimard> we will need to coordinate the cutover
15:28:43 <jpena> ok, so we'll wait until the tripleo ci script is adapted, then coordinate the change
15:28:49 <dmsimard> the RDO promotion jobs use trunk-primary.rdoproject.org as promotion target
15:28:53 <trown> dmsimard: jpena, ya I spoke with derekh about it yesterday, and will submit a patch to tripleoci to switch the method
15:28:58 <dmsimard> so that will be transparent once we change the dns to the internal IP
15:29:11 <apevec> let's keep this topic for the next week unless it gets done in the meantime
15:29:36 <dmsimard> we should agree on a cutoff date once the script is in review for tripleoci and tested
15:29:37 <trown> #action trown submit patch to tripleoci to change repo promotion method
15:30:05 <jpena> great
15:30:08 <dmsimard> I guess I will setup a ssh key from rhos-ci on the jenkins slave to the dlrn instsance
15:30:18 <dmsimard> trown: or did you already do that ?
15:30:31 <tristanC> dmsimard: the swift container was missing "post -m 'web-listings: true'", ci links works good now
15:30:37 <trown> dmsimard: no I didnt do that
15:30:46 <dmsimard> trown: ok, I'll set it up.
15:31:10 <tristanC> trown: DLNR-rpmbuild repo artifacts are now published to swift, you can find the repo url at the bottom of console-log
15:31:29 <jpena> ok, so we're done with this
15:31:34 <jpena> #topic chair for next meeting
15:31:39 <dmsimard> #undo
15:31:39 <zodbot> Removing item from minutes: <MeetBot.items.Topic object at 0x3373c450>
15:31:39 <imcsk8> i can do it
15:31:45 <dmsimard> #action dmsimard to set up ssh authentication between the ci.centos.org slave and dlrn instance
15:31:50 <dmsimard> #topic chair for next meeting
15:32:08 <jpena> #action imcsk8 to chair next meeting
15:32:18 <trown> tristanC++ thanks!
15:32:28 <jpena> thanks imcsk8 for volunteering ;)
15:32:36 <imcsk8> np:)
15:32:42 <jpena> #topic open floor
15:32:51 <jpena> anything else to share?
15:33:15 <apevec> just to remind, it's Bug Triage today/tomorrow
15:33:37 <apevec> goal is to check all NEW bzs
15:33:42 <tristanC> trown: you're welcome, next we need to thing about artifact time-to-live (TTL), we could set it to something like 6 months... it's the --delete-after parameter of the upload tool
15:33:50 <chandankumar> rbowen, can you set the topic for RDO bug triage day/
15:33:50 <tristanC> think*
15:33:51 <chandankumar> ?
15:34:04 <chandankumar> *channel topic
15:34:20 <trown> tristanC: ya 6 months would be plenty... could maybe even go lower 3months?
15:34:22 <apevec> tristanC, how big is swift storage  ?
15:34:42 <chandankumar> rbowen, Thanks :-)
15:34:46 <imcsk8> apevec: we can triage any component right?
15:35:01 <dmsimard> apevec: it'd be great to have a mitaka version in bz.
15:35:08 <apevec> imcsk8, yes, cross-pollination explicitly encouraged :)
15:35:30 <apevec> dmsimard, oh yes, I slacked on that bz request
15:35:40 <imcsk8> apevec: cool!
15:35:49 <tristanC> apevec: it's currently using a temporary swift all in one (saio) installation which has 200GB avail, but there is a new bare-metal swift deployed with 1.5TB that we could use
15:35:51 <apevec> #action apevec to send bz request to update RDO versions in bz
15:36:26 <tristanC> apevec: and finally, zuul swift configuration is modular, you can set the target container per job, so repository artifacts could be offloaded somewhere else too
15:37:38 <apevec> tristanC, good, we could maybe get resource donnors
15:37:49 <tristanC> and ftr, swift endpoint are configured with sfconfig.yaml (need shell access), but then container setting per jobs is set in config-repo, like I did here: https://review.rdoproject.org/r/#/c/1162/1/zuul/projects.yaml
15:38:18 <apevec> cool, thanks for the pointers
15:38:37 <tristanC> apevec: your welcome, I'm glad it was just a missing setting to get publication working :)
15:38:43 <apevec> so "artifacts" is endpoint defined in sfconfig.yaml ?
15:39:00 <apevec> tristanC, make sure that all ends up in SF docs :)
15:39:45 <jpena> should we end now?
15:40:39 <chandankumar> jpena, yes if nothing more to discuss.
15:40:42 <apevec> let's
15:40:45 <tristanC> apevec: oh, well there is only the default swift_logsexport_container currently supported in sfconfig.yaml, we'll have to support a list... not very hard though
15:41:30 <jpena> #endmeeting