rdo_meeting_(2016-03-23)
LOGS
15:00:46 <trown> #startmeeting RDO meeting (2016-03-23)
15:00:46 <zodbot> Meeting started Wed Mar 23 15:00:46 2016 UTC.  The chair is trown. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:46 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
15:00:46 <zodbot> The meeting name has been set to 'rdo_meeting_(2016-03-23)'
15:01:03 <apevec> \o\
15:01:08 <imcsk8> o/
15:01:10 <trown> /o/
15:01:18 <tristanC> |o-
15:01:47 <trown> #chair apevec imcsk8 tristanC
15:01:47 <zodbot> Current chairs: apevec imcsk8 tristanC trown
15:02:15 <jruzicka> o/
15:02:21 <tosky> hi
15:02:29 <trown> #link agenda https://etherpad.openstack.org/p/RDO-Meeting
15:02:37 <trown> #chair jruzicka tosky
15:02:37 <zodbot> Current chairs: apevec imcsk8 jruzicka tosky tristanC trown
15:03:41 <trown> light agenda today, we can get started
15:03:54 <dmsimard> o/
15:03:57 <trown> #topic Defintion of Done for Mitaka release
15:03:59 <chandankumar> \o/
15:04:08 <trown> #chair dmsimard chandankumar
15:04:08 <zodbot> Current chairs: apevec chandankumar dmsimard imcsk8 jruzicka tosky tristanC trown
15:04:28 <trown> #link https://www.redhat.com/archives/rdo-list/2016-March/msg00118.html
15:04:48 <trown> We need to define what our criteria is for defining a release as done
15:05:20 <dmsimard> trown: I haven't had the time to reply
15:05:38 <trown> I put a proposal to the list a while back, but I do not think the original proposal is CI'able which is important
15:05:54 <dmsimard> but my definition of done would include other things non-tripleo
15:06:00 <dmsimard> i.e, packstack, puppet-openstack
15:06:44 <trown> note that I have been focused specifically on the technical deliverables of tripleo, so additive things for packstack, puppet-openstack, as well as non-tecnical deliverables would be great additions
15:06:45 <apevec> 3 tempest + 5 pingtest seems reasonable compromise for tripleo
15:07:39 <trown> we are rapidly approaching mitaka GA, so we should maybe spend some time (maybe hacking on an etherpad) to get it ironed out
15:07:42 <tosky> I still think it's worth investigating why a simple tempest test can't work from undercloud in the 5 node model
15:08:00 <number80> o/
15:08:07 <trown> #chair number80
15:08:07 <zodbot> Current chairs: apevec chandankumar dmsimard imcsk8 jruzicka number80 tosky tristanC trown
15:08:08 <apevec> dmsimard, yes, for non-tripleo current mitaka pipeline is fine
15:09:46 <trown> that's all I have on the topic for now, maybe we can start fleshing out the proposal via the mailing list
15:10:28 <number80> *nods*
15:10:32 <trown> #topic Packaging status of project-specific Horizon dashboards?
15:11:22 <trown> not sure who this one belongs to
15:12:02 <dmsimard> I don't know either
15:12:22 <tosky> me
15:12:24 <tosky> sorry
15:12:56 <tosky> looking at the status of packages, I think that few dashboards (now in separate projects) are missing
15:13:56 <apevec> mrunge has submited example spec:
15:13:59 <tosky> did you notice as well, or am I searching for the wrong package name?
15:14:09 <apevec> https://github.com/javierpena/openstack-example-spec/blob/master/example-ui.spec
15:14:18 <number80> tosky: I know that people were working on sahara dashboard
15:15:06 <tosky> so openstack-<name>-ui
15:15:32 <tosky> trove is missing too
15:15:44 <tosky> I see manila is available, good
15:15:54 <number80> this one was already a separate one
15:16:24 <imcsk8> is there a list of those dashboards?
15:16:37 <trown> maybe we could start a trello card for tracking it?
15:16:48 <chandankumar> what about tracking the dashboard packaging on a card?
15:16:55 <tosky> the other relevant could be neutron-lbaas-dashboard
15:17:04 <trown> then interested folks could sign up for unpackaged dashboards
15:17:07 <tosky> at least, looking for -dashboard here: http://git.openstack.org/cgit/openstack/
15:17:10 <apevec> imcsk8, https://github.com/openstack?query=-ui is close enough
15:17:20 <trown> chandankumar: +1
15:17:23 <tosky> others seem to be dashboard of non-integrated projects
15:17:41 <tosky> apevec: -dashboard
15:17:45 <apevec> tosky, such inconsistency...
15:18:00 <apevec> tosky, both
15:18:07 <tosky> yeah
15:18:58 <chandankumar> apevec, so the final name will be openstack-component-dashboard?
15:19:02 <number80> btw https://trello.com/c/TewV7Pv7/136-horizon-sahara-ui
15:19:05 <apevec> chandankumar, no
15:19:11 <number80> chandankumar: openstack-<service>-ui
15:19:29 <chandankumar> ok, Thanks :-)
15:20:13 <apevec> number80, yeah, there's crickets on that card...
15:20:52 <number80> I haven't received any update about it too
15:20:54 * apevec adds ping
15:22:35 <trown> #link trello card for tracking https://trello.com/c/Of7pkmjI/145-add-missing-ui-packages
15:22:52 <imcsk8> i one question: could it be confusing for users to have -ui instead of dashboard in the package?
15:22:56 <trown> I think we should create a checklist there ^ and track all of them in one place
15:23:30 <number80> imcsk8: it's already the convention, so according the principle of least surprise, we should keep it that -ui
15:23:46 <apevec> imcsk8, not more confusing that python-django-horizon and openstack-dashboard
15:24:03 <imcsk8> that's my point
15:24:08 <trown> tosky: is it good to further iterate via trello
15:24:16 <tosky> trown: sure
15:24:26 <trown> cool moving on
15:24:35 <apevec> imcsk8, but good point for installers, when it should install it?
15:24:36 <tosky> trown: I thought it was part of "completness criteria" for Mitaka
15:24:37 <tosky> :)
15:24:44 <trown> #topic RDO Mitaka in CBS status
15:24:53 <apevec> tosky, no, that's separate topic
15:24:59 <dmsimard> is that essentially delorean-deps ?
15:25:05 <dmsimard> or the release rpm ?
15:25:10 <apevec> dmsimard, no, real builds
15:25:13 <tosky> apevec: I mean, related anyway
15:25:18 <number80> currently built: http://paste.fedoraproject.org/344201/45874584/
15:25:19 <apevec> for GA repo
15:25:21 <dmsimard> apevec: well, we still don't have a -mitaka delorean-deps
15:25:27 <dmsimard> it confuses users
15:25:32 <number80> now, we've finished oslo libs, it should go faster
15:25:44 <number80> dmsimard: we will be able to have that soon
15:25:54 <apevec> dmsimard, users shold not look into impl. details :)
15:26:02 <apevec> dmsimard, they get blackbox delorean-deps.repo
15:26:05 <dmsimard> lol
15:26:41 <number80> now, building clients + services after that
15:26:45 <trown> nice
15:26:58 <apevec> number80, nice, now naught question: ETA? :)
15:27:04 <apevec> naughty
15:27:11 <trown> number80: are we using rpmfactory process?
15:27:13 <dmsimard> so, this reminds me.. I need to add support for testing stable releases with weirdo
15:27:14 <apevec> and where we can help?
15:27:22 <number80> apevec: just above I posted a link of currently built packages
15:27:22 <dmsimard> it can only use delorean repos right now.
15:28:05 <apevec> dmsimard, with that generic job, we can point to release repos as ad-hoc
15:28:07 <number80> trown: I'm testing fred script to automate the build, it's launched manually so that I can catch issues and fix them
15:28:15 <apevec> but yeah, might want better formalized support
15:28:15 <trown> cool
15:29:05 <number80> one question about the script, should we keep .gitreview in stable branches?
15:29:19 <number80> we used to remove them. but the script fixes the branch
15:29:23 <number80> *and keep tem
15:29:44 <apevec> remove
15:29:48 <apevec> no review on rdo-*
15:29:59 <number80> ack
15:29:59 <apevec> it should all come from corresponding rpm-*
15:30:09 <trown> +1 .gitreview signals using gerrit
15:30:10 <apevec> and be scripted in rpmfactory eventually
15:30:28 <number80> one thing that could help immediately would be ensuring that packstack and puppet-modules branches are up-to-date
15:30:50 <trown> they should be
15:30:58 <apevec> number80, you mean source ?
15:31:01 <trown> they are thoroughly vetted via the delorean promote
15:31:05 <number80> apevec: yes, sources
15:31:14 <apevec> yeah, what trown says
15:31:22 <number80> good
15:31:36 <trown> next?
15:31:41 <number80> as for builds, I suspect I could finish them all today or tomorrow morning with fred's script
15:31:41 <apevec> packstack stable/mitaka even has a tag now!
15:31:48 <trown> nice
15:31:54 <number80> if I can't, I'll request for help on the list :)
15:32:00 <number80> or ere
15:32:08 <apevec> number80, cool, we'll need to ask KB to activate buildlogs mirroring ?
15:32:26 <apevec> or is it all set and we just need tag -mitaka-testing ?
15:32:28 <number80> apevec: yes, we already have packages on mitaka testing
15:32:36 <number80> all new builds are tagged
15:33:05 <apevec> number80, nothing here http://buildlogs.centos.org/centos/7/cloud/x86_64/
15:33:16 <number80> ack
15:33:17 <apevec> ok, so it needs KB action
15:33:38 <apevec> number80, but let's test first against cbs/repos
15:33:50 <number80> wfm
15:34:21 <apevec> yeah, that's here http://cbs.centos.org/repos/cloud7-openstack-mitaka-testing/x86_64/os/Packages/
15:34:41 <apevec> number80, btw, I've requested -pending tags
15:34:57 <number80> apevec: good, mariadb update is coming soon :)
15:35:09 <apevec> https://bugs.centos.org/view.php?id=10593
15:35:13 <number80> #info new -pending tags have been requested
15:35:58 <apevec> number80, yes, mariadb-10.1.12-4 (from Fedora master) is building in CBS
15:36:31 <dmsimard> next topic ?
15:36:41 <apevec> yes, that's all for CBS updates
15:36:43 <number80> yup
15:36:47 <trown> #topic Update for discussions regarding making trunk repos more available
15:37:04 <number80> we're speaking about HA?
15:37:27 <dmsimard> HA of the repositories so that outages impact less consumers
15:37:31 <trown> slightly editorialized from the etherpad :P, I think we decided to refer to the repos as trunk, rather than by project name that produces them
15:37:43 * number80 suggests using dynamic mirrorlist in .repo
15:38:05 <dmsimard> It's really awful that the intermittent outages impact the upstream CI like puppet-openstack, packstack and kolla
15:38:13 <dmsimard> We actually block their reviews
15:38:13 <apevec> number80, then you have spof in mirror
15:38:38 <apevec> yeah, lots of folks came here complaining earlier today...
15:38:54 <dmsimard> Anyway, I've chatted briefly with KB, he's interested in seeing how they can help us. I have a time slot with him next week.
15:38:54 <apevec> so one thing is what derekh is doing for tripleo ci
15:39:07 <apevec> with mirroring repos locally afaict
15:39:20 <dmsimard> yeah, that's what exposing a rsync server would simplify
15:39:42 <apevec> dmsimard, afaik we can send only signed CBS content to centos "CDN"
15:39:49 <trown> sshnaidm was asking about how to get involved helping with this effort also
15:39:51 <dmsimard> which was another (non mutually exclusive) option
15:40:05 <jlibosva> apevec: hi, do you know if openvswitch rpm on cbs.centos.org contains also kernel modules? or is it just userspace?
15:40:11 <dmsimard> apevec: yeah, we'll see if we can do something
15:40:17 <apevec> jlibosva, userspace only
15:40:26 <apevec> jlibosva, no kmods
15:40:35 <dmsimard> I have to step out but that was my part of the update
15:40:35 <jlibosva> apevec: are those available somewhere beside kernel?
15:40:40 <dmsimard> brb (sorry)
15:41:06 <trown> so tl;dr for the topic seems to be it is a WIP
15:41:07 <apevec> jlibosva, kmods are not supported
15:41:09 <derekh> apevec: I havn't (yet) approached mirroring trunk.rdo for tripleo, I have other resources I was looking into first, but may eventually get to trunk.r.o if it looks like it makes sense
15:41:19 <jlibosva> =-o
15:41:42 <apevec> trown, yeah, I think what we could do is to provide rsync server
15:41:57 <apevec> and then let folks mirror locally to their CIs
15:42:00 <trown> derekh: we get some amount of mirroring for free if we get to pre-baked undercloud images like RDO is using
15:42:01 <jlibosva> apevec: ok, thanks for info :)
15:42:31 <derekh> We could also separate the delorean instances from the http server altogether
15:42:49 <apevec> derekh, yes, dmsimard and jpena have a grand HA plan
15:42:49 <trown> true
15:42:58 <apevec> there's card somewhere...
15:43:13 <derekh> trown: yup, once my tripleo mirror patches merge I'm going to be looking into that
15:43:34 <trown> cool, I am keen to help with that
15:43:54 <trown> anything else on HA DLRN topic?
15:43:55 <imcsk8> i'm available too
15:44:30 <sshnaidm> I can help too
15:45:11 <trown> #topic Chair for next meeting?
15:45:30 <chandankumar> Anyone up for the same?
15:46:12 * chandankumar chandankumar points to imcsk8
15:46:21 * trown chirps
15:46:45 <imcsk8> i can do it
15:46:50 <jruzicka> I can do it
15:47:01 <jruzicka> I CAN DO IT
15:47:04 <jruzicka> ICanDoIt
15:47:13 <jruzicka> EICANDOIT
15:47:13 <apevec> now with _ ?
15:47:15 <trown> imcsk8: got there first, maybe next time jruzicka :)
15:47:22 <jruzicka> :D
15:47:25 <imcsk8> hehe
15:47:30 <chandankumar> #action imcsk8 to chair for next meeting.
15:47:39 <trown> nice
15:47:49 <trown> #topic open floor
15:48:15 <apevec> I've sent reminder about new packaging draft docs
15:48:17 <trown> nice one on the packaging docs apevec
15:48:21 <chandankumar> Just an small update on my side, i am working on DLRN rename part https://trello.com/c/bUU36T7R/144-rename-delorean-to-dlrn
15:48:22 <tristanC> Is it the right time to talk about some weirdo improvement ?
15:48:23 <trown> lol
15:48:28 <jruzicka> imcsk8, you say it like it was a privilege as opposed to responsability ^^
15:48:28 <apevec> please let me know if something is unclear!
15:48:41 <jruzicka> errr, that was for trown
15:48:41 <number80> tristanC: yes
15:48:42 <chandankumar> Here is the code review https://review.gerrithub.io/269944
15:48:59 <trown> tristanC: it would be, but dmsimard is probably the most interested and he popped out
15:49:21 <tristanC> Basically I've been tasked to investigate weirdo integration in rpmfactory workflow
15:49:21 <chandankumar> It is still in progress, I am looking at the code on how to fix backward compatibility for reponame in project.ini file.
15:49:32 <chandankumar> <EOM>
15:49:33 <imcsk8> jruzicka: it would be my first chair here so it feels like a resposnability :P
15:50:02 <number80> imcsk8: just follow the script and keep an eye on the clock ;)
15:50:04 <chandankumar> apevec, sure
15:50:46 <apevec> tristanC, we have WIP generic job which dmsimard said could be used for rpmfactory integration too
15:50:56 <tristanC> dmsimard: when you have some spare cycle, I'd like to check how to implement: "use localhost when cico api_key is undefined" and "make logs collection and publication in a dedicated role outside of common"
15:51:04 <imcsk8> number80: thanks :)
15:51:50 <tristanC> apevec: it seems like ansible is the new thing to run test and it will replace jenkins/jjb at some point
15:51:54 <apevec> tristanC, https://review.gerrithub.io/270016
15:52:15 <trown> tristanC: I would be keen on a totally seperate ansible-role-openstack-log-collect repo so I could use it in tripleo-quickstart :)
15:53:00 <tristanC> apevec: awesome, so that would be to keep the ci.centos.org workhorse
15:53:09 <apevec> oh yes, log collection should be generic
15:54:10 <apevec> tristanC, trown - ok, let's continue when dmsimard is back
15:54:19 <trown> cool
15:55:14 <tristanC> well the idea is that zuulv3 may be able to execute playbook directly to run test jobs, so that we don't need jenkins or jjb anymore (iiuc)
15:55:32 <trown> that would be sweet
15:55:33 <apevec> ah nice
15:55:41 <hewbrocc`> whoa
15:55:44 <hewbrocc`> bye bye jenkins
15:55:46 <trown> jjb is really painful
15:55:47 <apevec> Mr. Jenkins go home
15:56:06 <hewbrocca> weshay: ^^^
15:56:14 <apevec> trown, but zuul/layout is also yaml :)
15:56:22 <hewbrocca> Everything is yaml
15:56:26 <apevec> indeed
15:56:36 <apevec> new xml!
15:56:42 <imcsk8> arghh!!
15:56:54 <apevec> imcsk8, what, you prefer json? :)
15:57:10 <chandankumar> apevec, we cannot comment in json
15:57:15 <imcsk8> i prefer yaml over xml
15:57:20 <trown> seems like we are done with meeting :)
15:57:23 <trown> #endmeeting