rdo_meeting_(2016-03-16)
LOGS
15:02:42 <dmsimard> #startmeeting RDO meeting (2016-03-16)
15:02:42 <zodbot> Meeting started Wed Mar 16 15:02:42 2016 UTC.  The chair is dmsimard. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:02:42 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
15:02:42 <zodbot> The meeting name has been set to 'rdo_meeting_(2016-03-16)'
15:02:43 <leanderthal> \o/
15:02:47 <chandankumar> \o/
15:02:47 <jpena> o/
15:02:53 <leanderthal> o/
15:02:55 <tosky> \o
15:02:55 <dmsimard> roll call !
15:02:56 <rbowen> /0/
15:02:58 <dmsimard> o\
15:02:59 <jruzicka_> o/
15:03:02 <elmiko> o/
15:03:06 <apevec> \o/
15:03:08 <elmiko> that really blew up
15:03:33 <dmsimard> #topic Setting up rsync server for trunk repositories
15:03:56 <dmsimard> That came up last week I believe
15:04:09 <chandankumar> #chair leanderthal dmsimard tosky rbowen jruzicka_ elmiko apevec elmiko
15:04:10 <dmsimard> When someone wanted to access our trunk repositories over IPv6 and had to resort to dirty hacks
15:04:27 <dmsimard> #chair leanderthal tosky rbowen jruzicka_ elmiko apevec elmiko chandankumar
15:04:28 <zodbot> Current chairs: apevec chandankumar dmsimard elmiko jruzicka_ leanderthal rbowen tosky
15:04:33 <dmsimard> chandankumar: thanks :p
15:04:34 <jpena> yep, and it came back this week during the DLRN instance outage, ccamacho mentioned it
15:05:13 <dmsimard> so setting up a rsync server is fairly easy, the question is more do we have the resources/bandwidth for it
15:05:21 <apevec> right
15:05:28 <dmsimard> I don't think we want to set up the rsync server on the server where the build are taking place
15:05:33 <dmsimard> as it can be fairly resource intensive
15:05:36 <apevec> I'd suggested to export current-passed-ci only
15:05:41 <dmsimard> +1 to that
15:06:00 <jpena> apevec: for centos-master?
15:06:12 <apevec> yes and stable branches
15:06:16 <jpena> maybe current-tripleo could also be a good option?
15:06:32 <apevec> not sure if that'd be worth, derekh ^ ?
15:06:48 <apevec> unless you want to keep local mirror in tripleoci
15:06:52 <apevec> derekh, dprince ^
15:07:06 <dmsimard> I think I saw somewhere that they eventually want to get rid of current-tripleo since the CI is getting better with oooq and stuff
15:07:08 <dmsimard> trown: ^
15:07:33 <apevec> afaict there are different opinions in ooo community
15:07:40 <dmsimard> :)
15:08:13 <trown> dmsimard: working on it :p
15:08:18 <apevec> so arch would be to 2-level:
15:08:27 <apevec> first sync to some other server than trunk.rdo
15:08:35 <dmsimard> So, as I understand it, we should have a second server (let's call it mirror.trunk.rdoproject.org or something), this mirror syncs the current-passed-ci from the main trunk.rdoproject.org server and then exposes these through rsync
15:08:38 <apevec> and run public rsync server there?
15:08:41 <dmsimard> yeah
15:08:44 <dmsimard> makes sense
15:08:50 <dmsimard> I don't feel a whitelist is necessary
15:09:01 <dmsimard> unless we see some malicious intent, this is a public and open mirror
15:09:09 <apevec> ack, it is not w/ separate mirror server
15:09:14 <derekh> I'm been thinking of keeping a mirror of current-tripleo on a server local to the tripleo ci rack, but no firm plans yet, we also use /curent for some packages, so we would still be hit by an outage
15:09:38 <dmsimard> derekh: would exposing a rsync server on current-tripleo be helpful ?
15:09:45 <derekh> but I was going to do a wget -m or somthing
15:09:54 <derekh> rsync could be more efficient
15:09:58 <dmsimard> We're trying to make it easy for people to sync.,
15:10:11 <apevec> so do where could we host mirror.rdo ? Same rcip cloud?
15:10:38 <jpena> apevec: I'd ask for resources elsewhere, so we could use it as another backup in case of issues
15:10:47 <apevec> or use proper CDN ?
15:10:48 <dmsimard> jpena: +2
15:10:56 <apevec> jpena, good point
15:11:01 <dmsimard> +2 for hosting it elsewhere, hosting a mirror in the same place is kind of beyond the point
15:11:19 <jpena> does anyone around have a public cloud with resources to share?
15:11:48 <apevec> or can anyone give an estimate how much would it be to use real CDN, from RAX or elswhere?
15:12:00 <dmsimard> other than os1 and trystack I don't know
15:12:14 <apevec> trown, ^ you had some pricing for rax cdn iirc ?
15:12:31 <rbowen> We still have some free rax credits, right?
15:12:41 <dmsimard> a rax cdn is not a rsync server
15:12:48 <dmsimard> rax cdn perhaps for exposing the mirror through http
15:12:54 <dmsimard> but you can't expose rsync over cdn o_O
15:12:57 <rbowen> This was from a while back, we took advantage of the free-for-opensource program they had?
15:13:16 <apevec> rbowen, we never went to the bottom of that free-for-oss rax offer
15:13:24 <rbowen> Oh, ok. I couldn't remember how that panned out.
15:13:25 <dmsimard> they're probably mutually exclusive, the question goes back to do we want 1) expose rsync 2) host trunk mirrors on cdn
15:13:36 <apevec> iirc trown asked and there wasn't any answer
15:13:37 <trown> apevec: I tried to use RAX CDN for the undercloud image, but they never charged me
15:13:44 <derekh> making use of a CDN may reduce the need for rsyc, less likely people will want to mirror if they arn't getting hit by outages
15:14:01 <apevec> trown, that was your personal account?
15:14:09 <trown> apevec: ya I never got a response on the community account
15:14:56 <dmsimard> Red Hat probably has a good connection with RAX, they support OSP and stuff now
15:15:00 <dmsimard> We can dig
15:15:53 <rbowen> I'll ask around OSAS some, and see if other projects have a thing like that that we can get in on.
15:15:53 <apevec> we could, but I'm not sure if that biz relationship extends into free accounts :)
15:16:09 <dmsimard> apevec: well, not saying that
15:16:09 <rbowen> CentOS has a mirror network, too. It seems that we could tap into that.
15:16:10 <apevec> rbowen, yeah, that must be a common topic
15:16:14 <dmsimard> but knowing who to ask is a good first step
15:16:19 <dmsimard> and we must have people that know who to ask
15:16:28 <rbowen> I would expect that CentOS is the right place to ask.
15:16:36 <apevec> rbowen, we are using centos mirror for stable releases
15:16:57 <apevec> which need to be CBS builds for centos to sign and distribute
15:17:01 <apevec> this is for trunk.rdo
15:17:10 <rbowen> Sorry, I spaced out for a moment there.
15:18:11 <apevec> ok, so actions? rbowen ask oass, me ask up to mgmt chain about rax relationship?
15:18:20 <dmsimard> sounds good to me
15:18:24 <apevec> oops, osas!
15:19:03 <jpena> yep, sounds like a plan
15:19:05 <dmsimard> #action apevec to ask around for a RAX contact for a community oss account
15:19:05 <apevec> #action apevec to ask internally about rax cdn contacts
15:19:09 <apevec> #undo
15:19:09 <zodbot> Removing item from minutes: ACTION by apevec at 15:19:05 : apevec to ask internally about rax cdn contacts
15:19:10 <dmsimard> #undo
15:19:10 <zodbot> Removing item from minutes: ACTION by dmsimard at 15:19:05 : apevec to ask around for a RAX contact for a community oss account
15:19:13 <dmsimard> lol
15:19:13 <apevec> he
15:19:15 <apevec> h
15:19:15 <dmsimard> #action apevec to ask around for a RAX contact for a community oss account
15:19:27 <jruzicka> :D
15:19:34 <jruzicka> that was dramatic
15:19:36 <dmsimard> rbowen: you going to ask osas about CDN stuff ?
15:20:05 <EmilienM> do we have plan to use OpenStack Infra (one day) to build packages? It would help to have free hosting
15:20:06 <rbowen> Yes.
15:20:23 <dmsimard> #action rbower to ask OSAS team about CDN usage
15:20:26 <dmsimard> #undo
15:20:26 <zodbot> Removing item from minutes: ACTION by dmsimard at 15:20:23 : rbower to ask OSAS team about CDN usage
15:20:29 <dmsimard> #action rbowen to ask OSAS team about CDN usage
15:20:33 <rbowen> #action rbowen to ask OSAS for other projects with CDN that we can share
15:20:35 <rbowen> oops
15:20:36 <dmsimard> EmilienM: yes, eventually
15:20:37 <rbowen> #undo
15:20:37 <zodbot> Removing item from minutes: ACTION by rbowen at 15:20:33 : rbowen to ask OSAS for other projects with CDN that we can share
15:20:50 <EmilienM> dmsimard: their cloud is very reliable
15:21:01 <dmsimard> next topic
15:21:09 <dmsimard> #topic Updates on openstack test subpackage
15:21:12 <dmsimard> chandankumar: ^ ?
15:21:47 <chandankumar> except openstack-sahara-tests, all openstack projects have now test subpackage
15:21:50 <EmilienM> hey chandankumar ! thanks for your work here, puppet-tempest now installs the packages: https://review.openstack.org/#/c/292638/
15:22:08 <dmsimard> that's cool
15:22:25 <chandankumar> sahara-tests package is blocked due to this review https://review.openstack.org/293258
15:22:35 <dmsimard> EmilienM: slightly off topic but those package names should probably go in a ::params :p
15:22:40 <EmilienM> I'm working on using Tempest plugins in Puppet CI now... but lot of blockers to make it work. Packaging was the first one, thanks a lot RDO for it.
15:22:46 <dmsimard> EmilienM: oh wait they are, nm
15:22:52 <chandankumar> once merged i will file a package review for sahara tests
15:22:55 <EmilienM> dmsimard: they are https://review.openstack.org/#/c/292638/3/manifests/params.pp
15:23:00 <chandankumar> that's it from my side
15:23:15 <dmsimard> chandankumar: that patch has two +2's, do you know what's holding it back ?
15:23:16 <apevec> chandankumar, good work!
15:23:18 <chandankumar> EmilienM, you are welcome. :-)
15:23:21 <dmsimard> chandankumar: the CI ?
15:23:26 <chandankumar> dmsimard, yes
15:23:33 <apevec> we'll also need tests in clients at least keystoneclient
15:23:50 <chandankumar> apevec, i will be starting on clients from tomorrow
15:23:54 <apevec> according to ayoung that's where keystone integration tests will be/are
15:24:04 <EmilienM> FYI using tempest plugins will allow to increase testing coverage because plugins cover more than tempest tree tests. So thanks to chandankumar's packages, upstream CI will test more things
15:24:06 <tosky> dmsimard: it was submitted (sahara_tests) few hours ago, give it some time
15:24:35 <dmsimard> tosky: aye, was just wondering if two +2's wasn't enough :)
15:24:52 <ayoung> apevec, ++
15:24:53 <apevec> "my code is merging" https://xkcd.com/303/
15:24:59 <tosky> dmsimard: if they are not balanced, maybe not
15:25:23 <chandankumar> there are couples of reviews with +2 but with failed CI
15:25:37 <EmilienM> apevec: lol nice one
15:25:53 <dmsimard> sounds good to me
15:25:55 <dmsimard> great work chandankumar
15:25:57 <dmsimard> chandankumar++
15:25:58 <zodbot> dmsimard: Karma for chandankumar changed to 3 (for the f23 release cycle):  https://badges.fedoraproject.org/tags/cookie/any
15:26:16 <dmsimard> Anything else on the topic of test packages ?
15:26:26 <chandankumar> not from myside
15:26:28 <apevec> chandankumar++
15:26:28 <zodbot> apevec: Karma for chandankumar changed to 4 (for the f23 release cycle):  https://badges.fedoraproject.org/tags/cookie/any
15:26:55 <dmsimard> #topic open floor
15:27:21 <chandankumar> dmsimard, also we need to find chair for next meeting
15:27:27 * dmsimard nods
15:27:30 <dmsimard> after open floor !
15:27:41 <dmsimard> I guess I can give a small update
15:27:44 <dmsimard> regarding rdo-infra
15:27:53 <dmsimard> #link https://github.com/rdo-infra
15:28:01 <trown> can we merge https://review.gerrithub.io/#/c/265812/ and fix the requirements in follow-up?
15:28:02 <dmsimard> We've been trying to open up our infrastructure more
15:28:04 <trown> eggmaster: ^
15:28:20 <trown> that is our only failure to build from source
15:28:22 <dmsimard> So, basically stuff like playbooks to setup the website, modules for delorean, monitoring, stuff like that
15:28:35 <eggmaster> trown: yeah, that's ok by me I guess
15:28:37 <apevec> trown, I'll fix that, reqs is needed
15:28:42 <eggmaster> although
15:28:43 <dmsimard> rdo-infra can be seen as analogous to openstack-infra
15:28:59 <eggmaster> I notice no os-testr in trunk latest build report
15:29:15 <apevec> eggmaster, so is it dep or not?
15:29:18 <eggmaster> it is
15:29:23 <flepied> FYI RDO dev dashboard is back online: http://46.231.133.253:3030/rdo-dev
15:29:26 <eggmaster> it used to be python-tempest-lib dep so idk how that was working
15:29:43 <apevec> flepied, please add that to rdo-infra :)
15:30:00 <dmsimard> #link http://46.231.133.253:3030/rdo-dev
15:30:05 <flepied> apevec: ok how do I do that ?
15:30:07 <eggmaster> there are a couple other Reqs, paramiko, jsonschema, that were python-tempest-lib deps
15:30:14 <apevec> related to infra, has everyone seen rpmfactory status report from fbo ?
15:30:20 <apevec> any questions/ concerns?
15:30:23 <dmsimard> flepied: where is the repository for the code for that ?
15:30:27 <apevec> dmsimard, SSL was fixed in the meantime
15:30:37 <dmsimard> flepied: we have a rdo-infra organization now https://github.com/rdo-infra
15:30:42 <eggmaster> apevec: I have spec change review queued up, shall I submit?
15:30:44 <flepied> dmsimard: https://github.com/fredericlepied/rdo-dashboards
15:31:22 <dmsimard> jpena: can you also consider moving puppet-dlrn to rdo-infra ?
15:31:37 <jpena> dmsimard: sure, what do I need to do for that?
15:31:49 <dmsimard> jpena: settings -> transfer ownership -> rdo-infra
15:31:57 <jpena> easy enough :D
15:32:12 <apevec> dmsimard, or not.. still HSTS issues w/ my Firefox on https://review.rdoproject.org/ :(
15:32:22 <apevec> fbo, tristanC ^
15:32:27 <dmsimard> apevec: yeah, might need to clear cache or something on browser side
15:32:30 <dmsimard> HSTS sticks client side
15:32:34 <apevec> aah
15:32:40 <dmsimard> I haven't cleared cache fwiw
15:33:00 <jpena> dmsimard: I'll need admin rights in rdo-infra
15:33:10 <dmsimard> basically HSTS is "don't ever visit this domain on non-https"
15:33:12 <tristanC> apevec: heh, I'm redeploying it as we speak
15:33:18 <flepied> dmsimard: yes me too
15:33:22 <apevec> FF say cert is sefl-signed, while it should be letsencrypt...
15:33:26 <tristanC> apevec: let'sencrypt certificate are not yet re-imported
15:33:33 <apevec> ah ok
15:33:43 <dmsimard> apevec: okay to send invites to jpena and flepied for rdo-infra ?
15:33:52 <tristanC> I redeployed it from scratch just to be sure the instance is clean
15:33:53 <apevec> dmsimard, ack
15:34:19 <dmsimard> invites sent
15:34:21 <dmsimard> apevec: ^
15:34:31 <dmsimard> Okay, important next topic
15:34:35 <dmsimard> #topic chair for next meeting
15:34:51 <trown> I can take next week
15:35:04 <dmsimard> #action trown to chair next meeting
15:35:05 <dmsimard> thanks trown
15:35:07 <dmsimard> :D
15:35:18 <dmsimard> thanks everyone for attending
15:35:34 <dmsimard> #endmeeting