gluster_community_meeting_2017-01-18
LOGS
15:00:56 <kshlm> #startmeeting Gluster Community Meeting 2017-01-18
15:00:56 <zodbot> Meeting started Wed Jan 18 15:00:56 2017 UTC.  The chair is kshlm. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:56 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
15:00:56 <zodbot> The meeting name has been set to 'gluster_community_meeting_2017-01-18'
15:01:17 <kshlm> #topic Roll call
15:01:24 <kshlm> Anyone here?
15:01:33 <kshlm> Or has everyone forgotten the meeting.
15:01:43 * kkeithley is here
15:02:00 <kshlm> Hey kkeithley
15:02:07 * ndevos _o/
15:02:17 <kshlm> Hey ndevos
15:02:55 <vbellur> o/
15:03:08 <kshlm> Let's wait for ~5 minutes for more people to show up.
15:03:12 <kshlm> Hey vbellur!
15:03:25 <kshlm> In that time, everyone here think up of topics to discuss.
15:03:33 <vbellur> kshlm: hey!
15:03:42 * misc is here
15:04:30 * jdarcy o/
15:04:40 <kshlm> Add topics/updates to https://bit.ly/gluster-community-meetings
15:04:54 * rastar is here
15:07:22 <kshlm> We can start the meeting now.
15:07:35 <kshlm> We have a person adding the first topic
15:07:40 <vbellur> I added that
15:07:54 <kshlm> #topic Regression test suite hardening
15:07:58 <vbellur> maybe I should re-phrase that as "Changes in Testing"
15:08:02 <kshlm> vbellur, You have the floor.
15:08:17 <vbellur> we had a bunch of discussions/ideas related to changing our test strategy
15:08:41 <vbellur> what are our next steps for bringing about changes there?
15:09:03 <vbellur> The next steps are not very clear to me..
15:09:23 <misc> what do you mean by hardening ?
15:09:33 <kshlm> Are you referring to the discussions we had about reducing regression tests runtime?
15:09:36 <misc> (because to me, I think of security hardening, so I guess I am wrong)
15:09:51 <vbellur> misc: hardening = correctness
15:09:59 <vbellur> nothing to do with security
15:10:00 <vbellur> kshlm: yes
15:10:36 <kshlm> Okay.
15:10:44 <rastar> vbellur: I have some updates
15:11:03 <kshlm> I think the decision there was to first reduce the runtime, and then follow up with fixing tests.
15:11:12 <kshlm> rastar, Please go on.
15:11:14 <rastar> nigelb and I discussed about it a little
15:11:30 <rastar> kshlm: yes, nigelb is actively concentrating on reducing test times
15:11:40 <rastar> that is priority 1
15:12:04 <rastar> also, fstat dashboard that nigelb has will give out data for 1 release time
15:12:24 <rastar> that way we get complete idea on what tests started failing after a release branching
15:12:35 <rastar> easier to track failing tests
15:13:16 <kshlm> rastar, Good to know. Are there any specific things nigelb and you are trying to reduce runtime.
15:13:39 <kshlm> There were a lot of ideas that were put forward.
15:15:34 <kshlm> Looks like rastar is distracted.
15:15:48 <kshlm> vbellur, nigelb put up this page https://github.com/gluster/glusterfs/wiki/Test-Clean-Up
15:16:02 <kshlm> This was also discussed in last weeks meeting.
15:16:27 <kshlm> The meeting minutes/logs should have some more information.
15:16:48 <kshlm> Do these help?
15:17:10 <jdarcy> I think Nigel was working on parallelization.
15:17:10 <jdarcy> He was also playing with containers, which I think was related to parallelization.  Not sure if he stuck with that approach.
15:17:22 <rastar> nigelb and I will identify tests that are failing because of timeouts and fix them by increasing wherever necessary
15:17:22 <rastar> rest would be assigned to test owners
15:17:22 <rastar> kshlm: nigelb is trying the distribution method, splitting tests across slaves
15:17:22 <rastar> we will look at other ideas only if split/aggregate method does not work with jenkins
15:17:22 <rastar> we still want to look at running tests in container but haven't tried it yet
15:17:22 <rastar> one suggestion we have for test hardening and 3.10
15:17:22 <rastar> marking some test bugs(known issue/bad tests) bugs as blocker for 3.10 release
15:17:46 <rastar> I confirm what jdarcy says
15:18:08 <rastar> running in parallel and then containers
15:18:22 <jdarcy> I've developed quite a list of tests that I'd rather do without for 3.10; just look at which tests have been modified or disabled in the multiplexing patch.
15:18:43 <vbellur> rastar: ok..
15:18:43 <vbellur> rastar: how do we act on frequently failing tests in fstat?
15:18:45 <rastar> my update ends.
15:18:53 <vbellur> kshlm: checking
15:19:01 <vbellur> oops, I seem to have a lag.
15:19:16 <vbellur> got a burst of messages now from jdarcy and rastar.
15:19:23 <rastar> vbellur: initial triage is still upto the maintainers
15:19:32 <jdarcy> I got a burst from rastar too.
15:19:50 <rastar> hmm, my connection has some latency then..
15:20:10 <kshlm> Netsplit!
15:20:16 <vbellur> rastar: ok, the proposal in the wiki looks good. A big +1 for addressing intermittent failures.
15:20:26 <vbellur> wish we can have that soon!
15:20:44 <rastar> I don't know if nigelb proposed this in last meet
15:20:52 <rastar> 1. blocker test bugs for 3.10
15:21:20 <rastar> 2. stopping merge for a module if number of known issues/bad tests from that module goes beyond a watermark
15:21:29 <rastar> we need community buy in for above two
15:21:57 <kshlm> I remember 2 being discussed.
15:22:01 <vbellur> rastar: sounds good to me
15:22:24 <rastar> ok..more ideas welcome
15:22:55 <rastar> jdarcy: will surely look at the failed tests list in your patch
15:23:50 <vbellur> rastar: I think we need to start a discussion on 1. in -devel
15:24:07 <rastar> vbellur: I will send that mail
15:24:14 <vbellur> rastar: cool, thank you!
15:25:16 <vbellur> kshlm: nothing more on this topic from me
15:25:33 <kshlm> #action rastar will start a conversation on gluster-devel about 3.10 blocker test bugs.
15:25:40 <kshlm> vbellur, Cool!
15:26:02 <kshlm> We don't have any other topic.
15:26:27 <kshlm> So this is an actual open floor (as opposed to a pre-planned one)
15:26:54 <vbellur> kshlm: who all are going to be at FOSDEM?
15:27:00 <kshlm> Does anyone want share anything?
15:27:07 <ndevos> I'll be at FOSDEM
15:27:11 * misc will be
15:27:13 <kshlm> Me too.
15:27:18 * misc will also be at devconf
15:27:28 <ndevos> and the CentOS Dojo the day before FOSDEM starts
15:27:58 <amye> I've sent out a planning page to the people who let me know they were at FOSDEM.
15:28:00 <amye> Did I miss anyone?
15:28:22 <misc> didn't got anything
15:28:56 <amye> It was for the people who let me know from my post on the mailing list, misc.
15:28:57 <ndevos> amye: not sure, maybe link it on the events page? (and approve https://github.com/gluster/glusterweb/pull/125 for me?)
15:29:10 <amye> on it.
15:30:03 <kkeithley> I'll be at both DevConf and FOSDEM
15:30:04 <vbellur> are all of you going to be at devconf too?
15:30:23 <ndevos> FYI: I'm aiming to get the 3.9 release on the CentOS mirrors and announced tomorrow - pending items are on the CentOS team atm
15:30:34 * ndevos wont be at DevConf
15:30:46 <kshlm> Most of us should be.
15:31:03 <misc> amye: mhh, on gluster-devel ?
15:31:13 <vbellur> ok
15:31:25 <misc> I can't find anything related to fosdem, except the announce of the cfp, but I didn't answered to that room
15:31:30 <amye> oh, thank you ndevos.
15:31:55 <kshlm> misc, this was on gluster-users
15:31:56 <jdarcy> Proposals for the Linux FAST summit are due *today*.
15:32:07 <misc> kshlm: this one, I do not read :)
15:32:24 <jdarcy> https://www.usenix.org/conference/linuxfastsummit17/call-for-participation
15:32:32 <misc> (as I am likely unable to help user myself)
15:32:54 <amye> oh, thank you jdarcy.
15:32:59 <amye> Do we have anyone planning on FAST?
15:33:21 <ndevos> jdarcy: I sent something there, now hopeful awaiting for acceptance
15:33:43 <ndevos> amye: I'll be attending FAST, but not speaking there
15:34:41 <amye> ack
15:34:59 <amye> I'll add it to the events cal today.
15:35:05 <jdarcy> I am definitely planning to attend FAST.
15:35:11 <vbellur> I need to drop off now, will ttyl. Thank you all!
15:35:35 <jdarcy> Can do a BoF and such, but getting an actual paper accepted at FAST is no more than a long-term dream.
15:35:39 <kkeithley> There's some poster session or something on Thursday (at FAST).  I'll pop over from Connect-a-Thon for that
15:35:40 <jdarcy> Pretty high bar, TBH.
15:36:36 <amye> a BoF at FAST would be a nice thing, so I'll connect with jdarcy and nvdevos to plan.
15:37:04 <ndevos> sure!
15:37:59 <amye> I've got a talk at SCALE the next week, anyone else at SCALE?
15:38:21 * ndevos isnt
15:38:53 <amye> I don't expect anyone at this point.
15:39:28 <ndevos> I think we need to improve our updates to the event page, I didnt even know SCALE was happening soon - https://www.gluster.org/events/
15:39:42 <amye> I just found out about SCALE.
15:39:52 <amye> They didn't follow their own process for talk acceptance.
15:41:28 * ndevos needs to drop off, thanks and ttyl!
15:41:29 <kshlm> Are we all out of topics?
15:41:39 <kshlm> I'll end the meeting early if we are.
15:42:24 <amye> Sounds like.
15:43:08 <kshlm> Good. I'll end the meeting.
15:43:18 <kshlm> Thanks for attending everyone!
15:43:22 <kshlm> #endmeeting