weekly_community_meeting_2017-01-11
LOGS
12:02:36 <kshlm> #startmeeting Weekly Community Meeting 2017-01-11
12:02:36 <zodbot> Meeting started Wed Jan 11 12:02:36 2017 UTC.  The chair is kshlm. Information about MeetBot at http://wiki.debian.org/MeetBot.
12:02:36 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
12:02:36 <zodbot> The meeting name has been set to 'weekly_community_meeting_2017-01-11'
12:02:44 <kshlm> #topic Roll call
12:03:02 <kshlm> Welcome everyone!
12:03:09 * jdarcy o/
12:03:28 <kshlm> I'll wait for a couple of minutes more before continuing.
12:03:31 * Saravanakmr here
12:03:55 * ndevos _o/
12:03:57 <kshlm> We have 2 topics entered for discussion (1 by me and one carried forward from December)
12:04:05 <kshlm> And not a lot of updates.
12:04:18 <kshlm> If you'd like to add topics or updates now, you're welcome.
12:04:28 * partner \o/
12:04:33 * skoduri here for about ~1/2 hr
12:04:35 * anoopcs is here
12:04:41 <kshlm> The agenda is at https://bit.ly/gluster-community-meetings
12:04:55 <nigelb> o/
12:07:03 <kshlm> Let's move on
12:07:24 <kshlm> We have 3 topics for discussion. nigelb added one right now.
12:07:37 * shyam is here now
12:07:47 <kshlm> I'll take the simpler 2 topics up first.
12:08:06 <kshlm> #topic Is 3.9.20 required?
12:08:22 <kshlm> It should read 3.7.20
12:08:32 <kshlm> #topic Is 3.7.20  required?
12:08:50 <kshlm> 3.10 is coming out next month.
12:08:50 <shyam> 3.10.20 would be ~Feb 20th?
12:09:02 <shyam> Sorry 3.7.20
12:09:16 <kshlm> 3.7.x is planned for ~30 of each month.
12:09:40 <ndevos> I would say "yes", a end of January release would be in order
12:09:52 <shyam> +1
12:09:56 <ndevos> and call out that it is the last 3.7 release in the notes too :)
12:10:21 <kshlm> Okay then.
12:10:34 <shyam> What if 3.10 slips? Hopefully a rhetorical question...
12:10:54 <kshlm> #agreed 3.7.20 will be the (hopefully) last release of release-3.7
12:11:30 <kshlm> shyam, We'll probably need to do another release then.
12:11:53 <shyam> That sounds fine then, thanks.
12:11:56 <ndevos> 3.10 isnt supposed to slip, we do timed based releases, anything not ready for the release just moves on to the next version
12:12:01 <kshlm> We'll look at the backports being posted and take a decision, if required.
12:12:27 <kshlm> I'll move on to the next topic.
12:12:43 <kshlm> #topic Testing discussion update: https://github.com/gluster/glusterfs/wiki/Test-Clean-Up
12:12:52 <kshlm> nigelb you're up!
12:12:54 <kkeithley> 3.11 will be an STM release?
12:13:03 <nigelb> I have nothing to add, but I wanted to open the floor for any discussion/questions.
12:13:11 <ndevos> kkeithley: yes
12:13:30 <kshlm> #link https://www.gluster.org/pipermail/gluster-devel/2017-January/051859.html
12:13:34 <ndevos> nigelb: I was wondering how we can comment on the wiki?
12:13:43 <nigelb> Add comments at the bottom?
12:13:46 <nigelb> Or ask on the list?
12:13:49 <nigelb> There's a thread going on.
12:14:02 <kkeithley> it's a wiki, right?  Can't you just edit it?
12:14:15 <ndevos> right, but there is no way to match mail <-> wiki
12:14:18 <kkeithley> If you can't, it's not a wiki, right?
12:14:21 <jdarcy> I have one more suggestion for shortening tests.  Have them bail on the first failure, instead of trying to continue.
12:14:29 <ndevos> where do you want the commets? on the list, or on the wiki?
12:14:34 <nigelb> on the list, please.
12:14:40 <nigelb> jdarcy: don't we already do that?
12:14:45 <ndevos> ok :)
12:15:06 <jdarcy> First test *within* a file.  Setting EXIT_EARLY will do this BTW.
12:15:16 <nigelb> Ahhhhhh.
12:15:34 <jdarcy> Often if one test within a file has failed, others will fail also.
12:15:39 <jdarcy> Small savings, but still.
12:15:54 <nigelb> If it's a test that takes 10 minutes to fail and now takes 1, that is a big win.
12:16:29 <jdarcy> If it failed because something died, then yes, those additional wasted tests can take a while to time out.
12:16:38 <kshlm> The success of the other tests isn't counted anyways.
12:17:01 <kshlm> The whole file is marked as a failure.
12:17:01 <ndevos> jdarcy: I like that, it will also make the logs a little shorter and easier to use
12:17:07 <kshlm> +1 from me.
12:17:08 <jdarcy> Vijay, what do you think?
12:17:44 <kshlm> vbellur, are you here?
12:18:30 <nigelb> While we wait for Vijay, I'm going to me mucking around in our test runner a bit for the next few weeks.
12:19:10 <nigelb> There are questions taht will come up that I'll need help with.
12:19:15 <kshlm> We can't hold up this meeting for a few weeks.
12:19:27 <kshlm> So vbellur will have to comment on the mail thread.
12:19:29 <nigelb> FOr example, if we know a test in one chunk failed, do we fail all the chunks right away?
12:19:52 <nigelb> that makes sense for the CI, but perhaps not much for running it locally
12:20:38 <shyam> For CI the above makes sens, but, if run time is down to 30 minutes, maybe other failures in other chunks can be caught early?
12:20:47 <kshlm> nigelb, I'd prefer that each test file fail early, but all the tests need to run.
12:21:02 <nigelb> We don't do that right now :)
12:21:07 <nigelb> We stop where we fail.
12:21:21 <shyam> Also, if we have enough machines to run the tests and a queue does not build up, then I would say let the chunks finish irrespective of another chunks failure
12:22:05 <nigelb> okay, so we'll see.
12:22:35 <kshlm> nigelb, So can we continue on to the next topic?
12:22:38 <nigelb> Yep.
12:22:45 <kshlm> Cool.
12:22:48 * Saravanakmr added a topic - courtesy ndevos
12:22:52 <Saravanakmr> :)
12:23:04 <kshlm> #topic Do we need a wiki page for meeting minutes?
12:23:51 <kshlm> This will reduce work for me.
12:24:06 <ndevos> I was wondering who reads the notes in the wiki
12:24:15 <nigelb> I don't read it immediately
12:24:24 <nigelb> BUt it's useful to go back and read it.
12:24:41 <nigelb> For instance, what was the outcome of discussions.
12:24:46 <kshlm> And it's nice and formatted well. Easier to read.
12:24:47 <ndevos> if the notes and minutes are in the email archive, no need to also have it in the wiki - or maybe just link to the email
12:24:49 <nigelb> especially to search.
12:24:59 <shyam> I use the mail sent and links there to read minutes and check logs etc. I do not remember visiting the Wiki ever, if it helps in the decision making process...
12:25:00 <Saravanakmr> nigelb, but you can refer the mail- using a wiki is overkill IMHO
12:25:46 <nigelb> I'm not particularly passionate either way, tbh.
12:25:59 <ndevos> decisions should probably be summarized in an email anyway?
12:26:26 <Saravanakmr> and if you want expanded one - refer the irc logs..link in email.
12:26:48 <kshlm> It's not just the meeting though.
12:27:13 <kshlm> We have weekly updates, so this gives a nice place to search/track progress.
12:28:07 <Saravanakmr> kshlm, search in email  - nice subject line right ?
12:29:18 <kshlm> I don't have a strong opinion on this.
12:29:21 <ndevos> I probably dont know how to search the wiki, I mostly get source code results....
12:29:43 <kshlm> I'll continue archiving to the wiki.
12:30:16 <ndevos> yes, if it helps someone, go for it
12:30:23 <kshlm> Other meeting hosts can decide what they want to do.
12:30:42 <ndevos> we were discussing it in yesterdays bug triage meeting, and I do not think it adds value for that meeting
12:31:18 <kshlm> So we agree about meeting owners/hosts taking the decision to archive in the wiki or not?
12:31:44 <ndevos> well, not owner/host dependent, but more related to the meeting itself
12:32:12 <kshlm> I'll rephrase that.
12:32:25 <ndevos> if this meeting should have its notes copied to the wiki, lets add the task in the etherpad
12:32:31 <ndevos> no, hackmd page
12:33:44 <kshlm> It's easier to copy the hackmd notes to wiki. They're already markdown formatted.
12:34:24 <kshlm> The reason for having the archive was to keep the choice of etherpads/alternatives free.
12:34:48 <kshlm> Meetings could use whatever they want, but the notes would be archived into a single place.
12:35:11 <kshlm> If some meetings don't see the benefit of archiving, then it's okay for them not to.
12:35:32 <ndevos> s/single place/email archive and optional in the wiki/ :)
12:36:00 <kshlm> That's sounds much better
12:36:24 <kshlm> I guess everyone agrees to this?
12:36:51 <ndevos> I guess so too
12:36:56 <nigelb> Just be consistent.
12:37:02 <nigelb> Pick one and stick to it, that's all.
12:37:13 <nigelb> So it's clear that a meeting needs to be looked for in email rather than wiki.
12:37:34 <ndevos> nigelb: everything will be in email, some meetings (like this one) will also be on the wiki
12:38:04 <sankarshan> (this seems like a topic that is going around today for a while, do we see that we can decide one way or another and move forward?)
12:38:28 <kshlm> For the weekly meeting we'll continue with what we're doing.
12:38:42 <kshlm> For other meetings, they need to email the lists after the meeting.
12:38:52 <kshlm> If they wish they can add a wiki as well.
12:39:07 <ndevos> kshlm: btw, do you link the wiki page in your email too?
12:39:15 <kshlm> Yes.
12:39:17 <ndevos> ok :)
12:40:07 <kshlm> Shall I move on?
12:40:27 <ndevos> maybe #info something?
12:40:34 <ndevos> or #agreed even
12:41:27 <kshlm> #agreed Meetings need to email minutes/notes to the mailing list. Optionally add notes to wiki.
12:41:43 <kshlm> #info Weekly Community Meeting will do both.
12:41:57 <kshlm> #topic Discuss participation in the meetings
12:42:19 <kshlm> This was a carry forward from late Nov/early Dec
12:42:31 <kshlm> A period when we had very low participation.
12:43:16 <kshlm> We've recovered in the new year. We have more participation this week than the last.
12:43:25 <kshlm> But still not the best we ever had.
12:43:30 * ndevos doesnt think much changed, if we see the participation today
12:43:54 <ndevos> at least we're not waiting for maintainers to give a status update, and then moving on because they are non responsive
12:44:09 <ndevos> ... well, vbellur was todays exception
12:44:46 <kshlm> It was just one instance today,
12:45:24 <ndevos> yes, there will always be someone, but at least it is not the majority of the time :)
12:45:26 <kshlm> The majority of the meetings used to be silent before this format.
12:45:34 <kshlm> Okay.
12:45:38 <shyam> I find the current format more valuable than the past ones, I am not sure about the participation issue though
12:45:54 <kshlm> So atleast the attendees aren't wasting their time.
12:46:10 <kshlm> Anythin else we can do better?
12:46:48 <nigelb> I wonder if it's worth adding a presentation slot if it's worth it.
12:47:04 <nigelb> Quick presentation about a new feature/new thing we're working on.
12:47:47 <kshlm> That would be cool.
12:47:50 <sankarshan> As an optional placeholder it sounds nice.
12:48:03 <sankarshan> By optional I mean that it won't bring grief if there is nothing to present
12:48:04 <shyam> Then we move out of IRC and use something else for the meeting? just asking
12:48:08 <ndevos> I think it would take too long, even todays meeting is already at 45+ minutes
12:48:28 <ndevos> a presentation needs some other media indeed, and that is more tricky
12:48:40 <sankarshan> To fit that in, perhaps other things can be looked into again and pared down
12:48:51 <shyam> Also, current format we seem to discuss more operational elements of the community, technical content is very low
12:49:04 <shyam> So the presentation idea is good to improve on that
12:49:14 <sankarshan> The on-ramp for technical content needs to be created and placed in
12:49:33 <ndevos> do we need this meeting to be more technical?
12:50:36 <ndevos> I think amye was planning to do some hangouts for new features for the previous release, imho that is more suitable
12:51:18 <shyam> I am not sure if this meeting should be more technical or not, but I know it is not atm :)
12:52:00 <shyam> So what other ideas can we think of to increase participation...
12:52:59 <kshlm> We had a suggestion some time back to alternate weekly meeting slot between meeting and hangouts for new stuff.
12:53:09 <ndevos> do we know why component maintainers and developers are not joining or speaking up in this meeting?
12:53:32 <shyam> Impact of the decisions, or impact on decisions taken due to discussions in this meeting, should reach the community, then there is more need to participate here, so that one can participate in the decision making process than get handed down what to do
12:53:35 <kshlm> ndevos, In India people are busy getting back home.
12:53:40 <ndevos> or other community members even?
12:54:08 <ndevos> kshlm: yes, I guess the time for people in India is a pain, it definitely is for me when I'm there
12:54:53 <sankarshan> I'm not sure if maintainers *have* figured out that this meeting is a place to join and provide updates
12:55:16 <sankarshan> I noticed a specialized maintainers meeting as well being posted to list - was it not?
12:56:09 <ndevos> yes, and I do not know why it is a separate meeting
12:56:28 <kshlm> Because it's a bluejeans session?
12:56:28 <ndevos> those topics seem to suite this meeting too
12:56:35 <sankarshan> Well, this forum is probably a nice *additional* one for maintainers to do outreach and provide previews of plans and such
12:56:47 <ndevos> well, it does not need to be bluejeans, it could be IRC too?
12:57:11 <sankarshan> Which is perhaps a good segue into the reason we have the new format - what can we do with this IRC meeting and make it useful to wider Gluster community
12:57:20 <shyam> It is a separate meeting to get maintainers to participate and bubble up things here, if maintainers are here and participating then possibly this forum can be leveraged
12:58:41 <sankarshan> Which, in all ways, is optimal for the moment - as things stand
12:59:33 <ndevos> shyam: so, should we get the maintainers to join this meeting instead then?
12:59:39 * ndevos hopes so...
13:00:04 * shyam hopes so too...
13:01:03 <kshlm> We're over time.
13:01:17 <kshlm> How do we move on forward from here?
13:01:34 <kkeithley> They can join the maintainers bluejeans call because it's later? And they have time to get home and joint the meeting from home?
13:01:41 <kkeithley> *join*
13:01:50 <kshlm> kkeithley, Looks like it.
13:02:18 <kshlm> Are you gonna suggest moving this meeting itself to that time?
13:02:22 <ndevos> so change this meetings time to the time the maintainers meeting happens?
13:02:48 <kkeithley> This timeslot was originally a compromise between too late for India and too early for EST/EDT, and tough luck for anyone in PST/PDT, Australia or Japan.
13:03:17 <kkeithley> Am I going to suggest that?  lol. Sure, I'll suggest we make the meeting later. ;-)
13:04:05 <ndevos> at least amye should also be able to join more regularly then
13:04:40 <kshlm> Shall we bring this up in the maintainers meeting today?
13:04:45 <ndevos> yes!
13:04:49 <kshlm> Because we're out of time for this meeting.
13:05:04 <kshlm> Cool. I'll add a topic to the agenda for that meeting.
13:05:15 <kshlm> This means we're finished.
13:05:27 <kshlm> Wait!
13:05:34 <kshlm> We need to pick a host for next week.
13:05:43 <kkeithley> will discuss in maintainers meeting, but FYI, I plan to tag/release 3.9.1 Real Soon
13:05:52 <kshlm> Any volunteers?
13:06:06 <kshlm> (I can continue...)
13:06:21 <ndevos> I think you're doing a good job ;-)
13:06:22 <kkeithley> I can't be here by 7:00 AM EST. Not reliably. Otherwise I'd volunteer.
13:06:37 <kshlm> We'll need to pick a volunteer for the 25th. I'll be travelling.
13:06:43 <kshlm> ndevos, Thank you.
13:06:50 <kkeithley> oh, me too. I'll be travelling
13:07:12 <kshlm> I'll host the next meeting.
13:07:14 <kkeithley> I can prob. host the next meeting
13:07:19 <ndevos> also, I'm normally having lunch during the meeting, and can not type constantly without my food getting cold
13:07:34 <kshlm> We can pick a host for the 25th next week.
13:08:04 <kshlm> kkeithley, Thanks for the offer. But I'll be hosting. :)
13:08:07 <kshlm> #endmeeting