weekly_community_meeting_2016-11-23
LOGS
12:01:03 <kshlm> #startmeeting Weekly Community Meeting 2016-11-23
12:01:03 <zodbot> Meeting started Wed Nov 23 12:01:03 2016 UTC.  The chair is kshlm. Information about MeetBot at http://wiki.debian.org/MeetBot.
12:01:03 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
12:01:03 <zodbot> The meeting name has been set to 'weekly_community_meeting_2016-11-23'
12:01:34 <kshlm> I'm standing in for nigelb this time. He needed to be somewhere else.
12:01:40 <kshlm> #topic Rollcall
12:01:50 * amye is very here.
12:01:55 * Saravanakmr is here
12:02:48 * rafi is here
12:02:57 * ndevos _o/
12:03:07 <kshlm> amye, Where are you this week? Not in NA I guess.
12:03:20 <kshlm> Hey ndevos!
12:03:26 <amye> I'm in Kiev for a conference.
12:03:28 <kshlm> shyam's here too.
12:03:43 * shyam waves
12:04:00 * jdarcy o/
12:04:15 <kshlm> amye, I guessed right!
12:04:19 <amye> You totally did.
12:04:24 <kshlm> Hey jdarcy!
12:04:33 <kshlm> I'll wait for a minute more.
12:04:45 * shyam will drop off in 30 minutes... just a heads up
12:04:52 <amye> This is a totally unique conference, they do one round in Lithuania and then move the entire conference to Kiev. :D
12:04:58 <kshlm> In the meantime, anyone wishing to add a last minute topic or last minute update please do so.
12:05:02 * hchiramm o/
12:05:24 <kshlm> The agenda is at https://bit.ly/gluster-community-meetings
12:05:44 <kshlm> We're trying out an alternative to etherpad this week.
12:06:41 <amye> i like it, it's nice
12:07:27 <kshlm> Okay. Let's start
12:07:34 <ndevos> oh, and I updated the old one with notes for some topics :-/
12:07:52 * shyam was distracted looking at the alternative etherpad for a bit, looks good...
12:08:03 <kshlm> ndevos, I thought I cleared the old board.
12:08:11 <kshlm> I'll get to that later.
12:08:21 <kshlm> #topic Next week's host
12:08:33 <ndevos> kshlm: hmm, I did not notice it, maybe I used an older link...
12:09:12 <kshlm> Any volunteers?
12:10:40 <kshlm> Seems like I'll be continuing as the host next week.
12:10:50 <kshlm> #info kshlm will host the next meeting
12:11:16 <kshlm> Onto the actual discussions.
12:11:29 <kshlm> Just 3 topics right now. All mine.
12:11:42 <kshlm> Doesn't anyone else want to discuss something?
12:12:21 <kshlm> I'll start with the 3.9 topic first.
12:12:30 * jiffin is here
12:12:31 <kshlm> #topic What's happening with 3.9?
12:12:51 <amye> Update: Waiting on upgrade guide and release notes into RTD, packaging in CentOS SIG.
12:13:09 <hchiramm> even 3.8 upgrade is missing
12:13:12 <amye> I may just push the blog post + announcements live as soon as we get packaging completed, but we're nearly there.
12:13:17 <kshlm> amye, Is the release still on for today?
12:13:26 <amye> We've got a few more hours.
12:13:30 <hchiramm> ndevos, jiffin may be one of u can help
12:13:48 <amye> ndevos is already on packaging.
12:13:54 <kshlm> What packages are we waiting on?
12:13:59 <kshlm> CentOS-SIG?
12:14:09 <kshlm> kkeithley already did the other packages last week IIRC.
12:14:11 <amye> I need the release managers to push the documentation updates into RTD though
12:14:12 <hchiramm> amye, we dont have 3.8 upgrade guide in RTD
12:14:24 <ndevos> kshlm: currently nfs-ganesha for CentOS-6, it is a dependency for the glusterfs-ganesha sub-package
12:14:37 <amye> hchiramm, That's why the upgrade guide is going in for 3.9 as part of standard release process.
12:14:42 <hchiramm> yeah, ndevos and jiffin did 3.8 release :)
12:15:07 <amye> Happens. :)
12:15:19 <hchiramm> :)
12:15:32 <amye> So yes, we're still on. That's 3.9.
12:15:33 <kshlm> ndevos, So we're waiting on getting ganesha packages for CentOS 6?
12:15:47 <ndevos> hchiramm: heh, we also rely on the maintainers for the different components... we do not seem to have anyone that takes care of the documentation :-/
12:16:35 <hchiramm> previously it was a must thing before the releaase
12:16:36 <amye> hchiramm, if I send you a copy of release notes and upgrade guide, can you push them?
12:16:37 <ndevos> kshlm: yes, nobody really reported the broken dependency for the testing repository, and publishing it is not possible if something is missing
12:16:47 <hchiramm> then it was violated ..
12:16:54 <hchiramm> amye, sure.
12:16:59 <kshlm> amye, Did pranith get back to you?
12:17:12 <amye> kshlm, nope, but if hchiramm can help, that gets us that much closer.
12:17:15 <amye> Sweet. :)
12:17:28 <amye> Doing so now.
12:17:31 <hchiramm> ndevos, heh. may be we need to make sure we have docs from maintainers before releasing major versions
12:18:06 <ndevos> hchiramm: yes, probably in a similar fashion how we gather the release notes
12:18:13 <hchiramm> yep.
12:19:01 * shyam coughs!
12:19:04 <shyam> maybe we should also test out the documentation steps, so that nothing is broken
12:19:32 <amye> That is my hope, but you know what, we work iteratively. We improve every time.
12:19:54 <kshlm> shyam, Did you mean the upgrade steps that were documented?
12:19:59 <hchiramm> shyam, may be we need a maintainer for upgrade component :)
12:20:04 <kshlm> Or the steps to create documentation.
12:20:46 <shyam> The steps in the documentation
12:21:00 <shyam> not to create the doc. I am sort of fine with htat
12:21:34 <post-factum> amye, oh, nice, you are in Kyiv
12:21:53 <post-factum> amye, /me lived there for 9 years before relocating to Brno
12:21:53 <hchiramm> I think shyam meant , some one has to test the upgrade process
12:21:58 <amye> post-factum, it's nice!!
12:22:17 <post-factum> amye, which conf?
12:22:34 <amye> BuildStuff, will take it offline. Great conference. <3
12:22:53 <kshlm> shyam, Doing that would be part of the release process. I hope the maintainers have done it this time.
12:23:02 <kshlm> I'll move on to the next topic.
12:23:14 <shyam> hchiramm: yes... among other detailed stuff laid out in the documentation, but as amye stated, we will get better over time...
12:23:23 <shyam> kshlm: ok
12:23:44 <kshlm> Just to summarize, 3.9 is up for announcement very soon (later today). Still waiting on some documentation and packaging.
12:23:48 <amye> shyam, absolutely. But we know we need it, so I'll work on tracking it.
12:23:53 <amye> Correct. Moving on. :)
12:24:01 <ndevos> amye: sounds good, please do a blogpost/email about the Gluster interest there, that would be great to know more about!
12:24:06 <kshlm> shyam, Since you're dropping off early, I you wanted to say anything about 3.10, you can now.
12:24:33 <amye> ndevos, shall do.
12:25:13 <shyam> Hmmm... ok, first question is the mail clear, and instructions understandable? Just a cross check here...
12:25:26 <shyam> mail on 3.10 (and thanks for giving me an early slot :) )
12:25:30 <kshlm> #topic 3.10
12:25:51 <kshlm> The referred mail is at https://www.gluster.org/pipermail/gluster-devel/2016-November/051584.html
12:26:05 <amye> Clear to me, will let others weigh in.
12:26:12 <rastar> clear to me too
12:26:27 * ndevos did not have time to read it
12:26:45 <shyam> Next AI would be, we need issues opened, so that the scope is filled up quicker, so AI on all there I guess...
12:27:28 <kshlm> Do we have any existing plans for 3.10?
12:27:36 <kshlm> Or do we just add everything that we want?
12:27:40 <amye> See email
12:27:41 <shyam> Nope, there never was a roadmap page before
12:27:46 <kshlm> For 3.10 and beyond.
12:27:51 <amye> oh, sorry, there are focus areas in the email
12:28:26 <shyam> We should add everything 3.10 and beyond, but we should add everything 3.10 for sure ASAP, I will come out with a scope cut off date in a day or 2, so that we can push people to get that done.
12:28:38 <amye> Next week work?
12:28:44 <shyam> yes
12:28:46 <amye> We're about to lose a few people to American Thanksgiving.
12:29:10 <shyam> yup, so reminder on scope cut off goes out Monday, and ends Friday 2-Dec-2016
12:30:19 <shyam> nothing more for 3.10 atm
12:30:31 <kshlm> shyam, Cool!
12:30:43 <kshlm> I'll add a AI on you for that.
12:30:49 <shyam> ty
12:31:24 * shyam enters sporadic screen checking mode, otherwise known as not in the meeting anymore
12:31:26 <kshlm> #action shyam will send out a reminder on 3.10 scope submission cutoff on Monday (2016-11-28)
12:31:36 <kshlm> Thanks shyam.
12:31:45 <kshlm> Okay. Onto the next.
12:31:58 <kshlm> #topic Discuss feedback on new format meetings
12:32:07 <kshlm> I sent out a mail, and got 2 replies.
12:32:27 <kshlm> https://www.gluster.org/pipermail/gluster-devel/2016-November/051543.html for the thread.
12:33:13 <kshlm> The conclusion from this, everyone who attends the meeting likes the new format. And wants to continue.
12:33:37 <amye> So ordered. :)
12:33:38 <kshlm> But not enough people attend. Hence the low updates and feedback.
12:34:01 <kshlm> amye, Thank you :)
12:34:56 <kshlm> What we now need to discuss is how can we improve the participation?
12:35:17 <ndevos> there is very little participation, we hoped it would be better with this new format, do you think that is the case?
12:35:17 <shyam> kshlm: I like this better as well, but had attended only 1 till now, so did not respond, so +1 from me on this format + updates via mail
12:35:48 <kshlm> ndevos, The first couple of weeks were really good.
12:36:04 <kshlm> But it dropped of since the last 2 weeks.
12:36:22 <kshlm> But in general, the interactivity has increased.
12:36:39 <ndevos> hmm, and I missed the earlier meetings, so thats unfortunate
12:36:51 <kshlm> Since it's just an open floor, the topic proposers have been very active.
12:38:41 <amye> Previously when we moved it to a time better for NA in Feb, we had even less activity.
12:38:48 <amye> And we're about to go into a pretty heavy holiday period.
12:38:50 <ndevos> well, thats good, but maybe we need to encourage stronger that anyone can add topics
12:39:03 <amye> I propose we keep the open floor, keep the current time, and revisit in Jan.
12:39:56 <kshlm> amye, It may just be that. It's been holiday season in India recently.
12:40:41 <kshlm> amye, I'm okay with that. We'll continue with this format, and revisit the topic of participation in Jan.
12:40:51 <kkeithley> _o/
12:41:03 <amye> kshlm, it seems to make the most sense, because I think the low participation is a function of holidays.
12:41:19 <kshlm> ndevos, I try to mention that in my meeting minutes.
12:41:26 <kshlm> Hey kkeithley!
12:41:49 <kkeithley> hi
12:41:56 <kshlm> Okay, let's revisit this in Jan.
12:42:45 <kshlm> #action Discuss participation in the meetings in January.
12:43:36 <kshlm> Onto the last topic
12:43:46 <kshlm> #topic How's the etherpad alternative?
12:43:50 <kshlm> This might be too early.
12:43:56 <kshlm> But, I'd like to know.
12:44:02 <kshlm> Anything we're missing from etherpad?
12:44:29 <ndevos> colors of who is edited what line were helpful
12:45:04 <amye> oh, ndevos, what else did you have?
12:45:24 <kshlm> ndevos, Yeah. Even if the nsame wasn't known, we could at least follow the author around the pad.
12:45:52 <kshlm> But this looks so much better IMO. And works much better for archiving later.
12:45:56 <ndevos> I dont see how to change my name in the upper right corner, everyone is called 'guest <something>' there
12:46:13 <ndevos> I dont even know which guest I am :)
12:46:35 <hchiramm> http://gluster.readthedocs.io/en/latest/Upgrade-Guide/upgrade_to_3.9/ amye upgrade is up and running
12:46:41 <hchiramm> I will push the release notes soon
12:46:41 <kshlm> You need to register to get a name.
12:47:01 <amye> hchiramm++
12:47:13 <amye> You are the best. :)
12:47:21 <ndevos> kshlm: I dont see a register button...
12:47:22 <hchiramm> \o/ :)
12:48:09 <kshlm> ndevos, You need to login via the homepage, https://hackmd.io
12:48:21 <kshlm> hchiramm++ Cool!
12:49:09 <ndevos> kshlm: ah, this 'advanced usage' seems to be a little more tricky than with etherpad - but I like the formatting options
12:49:17 <hchiramm> yw
12:49:38 <kshlm> There aren't any terrible problems with this. So I'll continue with this for the next week as well.
12:50:10 <amye> Change one thing at a time. :)
12:50:58 <kshlm> Huh, colours appeared after I signed in.
12:51:31 <kshlm> amye, But we need to get off FSFE ASAP.
12:51:46 <amye> No I know - but let's try this again next week and see if we can keep it.
12:51:54 <amye> We don't have quorum today. :/
12:51:56 <kshlm> amye, Cool!
12:52:09 <kshlm> Okay. We're done with the topics.
12:52:23 <kshlm> If there's nothing else to discuss, I'll end the meeting.
12:53:02 <amye> On time, even. :)
12:53:50 <kshlm> Yup!
12:53:52 <kshlm> So I'll end.
12:53:59 <kshlm> Some announcements before we end.
12:54:07 <ndevos> hey, and it seems nfs-ganesha is building *finally* on CentOS-6 :)
12:54:24 <kkeithley> woohoo
12:54:25 <kshlm> 3.8.6 will be tagged finally!
12:54:35 <kshlm> 3.9 will be announced later today.
12:55:03 <kshlm> 3.10 development cycle has begun.
12:55:13 <ndevos> yes, I'll tag 3.8.6 once I gather the release notes, which I do after finishing the 3.9 builds
12:55:19 <amye> we are awesome. :D
12:55:37 <kshlm> Thanks for attending everyone!
12:55:41 <kshlm> #endmeeting