weekly_community_meeting_10aug2016
LOGS
12:00:35 <kshlm> #startmeeting Weekly community meeting 10/Aug/2016
12:00:35 <zodbot> Meeting started Wed Aug 10 12:00:35 2016 UTC.  The chair is kshlm. Information about MeetBot at http://wiki.debian.org/MeetBot.
12:00:35 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
12:00:35 <zodbot> The meeting name has been set to 'weekly_community_meeting_10/aug/2016'
12:00:43 <kshlm> Welcome everyone!
12:00:48 <kshlm> #topic Roll call
12:00:49 <kkeithley> o/
12:00:51 <post-factum> o/
12:01:08 * kkeithley is here
12:01:12 <kshlm> o/
12:01:29 * ira is here.
12:01:33 <kshlm> I'll wait for a minute more.
12:01:43 * ira also wonders what the bread's number is...
12:02:00 <kshlm> Bread's number?
12:02:08 * msvbhat is here
12:02:28 * anoopcs is here
12:02:28 <ira> So I can call the roll of course ;).
12:02:32 * obnox is here
12:02:33 * skoduri is here
12:02:38 <kshlm> Ah!
12:02:46 <kshlm> :)
12:03:18 <kshlm> Okay! Let's start.
12:03:31 <kshlm> Welcome again everyone!
12:03:51 <obnox> cheers
12:03:57 <kshlm> The agenda is available at https://public.pad.fsfe.org/p/gluster-community-meetings
12:04:07 * ndevos _o/
12:04:07 <kshlm> #topic Next weeks meeting host
12:04:25 <kshlm> ndevos, Did you volunteer to be the next host?
12:04:38 * rafi is here
12:04:40 <kshlm> That was fast.
12:04:46 <ndevos> kshlm: sorry, no, I didnt :)
12:04:49 <kshlm> :)
12:05:04 <ndevos> I think rafi might want to do it
12:05:10 * loadtheacc is here
12:05:12 <kkeithley> or obnox
12:05:23 <rafi> ndevos: :o
12:05:24 <kshlm> So last week I decided that I'd alternate hosting these meetings.
12:05:47 <kshlm> I need a volunteer for next week. rafi, are you the volunteer?
12:06:03 <rafi> ndevos, kshlm: I can do that :)
12:06:09 <kshlm> Cool! Thanks rafi.
12:06:23 <kshlm> #info rafi hosts the next meeting
12:06:42 <kshlm> #topic GlusterFS-4.0
12:07:04 <kshlm> I'll start with GlusterD-2.0
12:07:20 <kshlm> I've got the multi-node transaction RPCs working!
12:07:55 <kshlm> The only problem I have right now is, I'm having trouble having some structs encoded correctly for transmission.
12:08:39 <ndevos> kshlm: what rpc protocol is that?
12:08:43 <kshlm> Go is doing such a good job of automatically encoding stuff in dictionaries(or maps).
12:09:32 <kshlm> ndevos, GD2 is using the RPC package in Go's standard library, with protobuf for encoding.
12:09:53 <ndevos> ok :)
12:10:08 <kshlm> I was trying to use a mixture of protobuf and json for encoding, as I didn't want to write a proto definition for all structs.
12:10:31 <post-factum> kshlm: bson, maybe, if there are binary data?
12:10:49 <kshlm> But the json encoding, which works after decoding in the same process, doesn't work once the encoded data is sent over the wire.
12:10:59 <kshlm> Looks like something related to pointers and such.
12:11:02 <kshlm> I'm debugging it now.
12:11:32 <kshlm> post-factum, I'll check it out. But I don't think that's the problem anyway.
12:11:44 * ndevos hopes Wireshark understands the format
12:11:45 <post-factum> kshlm: just to have another option
12:12:37 <kshlm> ndevos, It should be easy to write a dissector.
12:13:14 <kshlm> That's it from GD2 this week.
12:13:28 <kshlm> Do we have updates for JBR and DHT2?
12:14:26 <kshlm> jdarcy is on leave till Monday.
12:14:37 <kshlm> I don't see anyone else working on these features around.
12:14:44 <kshlm> So let's move on.
12:14:50 <kshlm> #topic GlusterFS-3.9
12:15:12 <kshlm> Are either pranithk or aravindavk here?
12:15:48 <post-factum> nope
12:16:18 <kshlm> post-factum, Yeah.
12:16:42 <kshlm> So shall we move on?
12:16:47 * ankitraj join late
12:17:02 <kshlm> I don't think there's anything particular to report on for 3.9 for this week.
12:17:25 <ndevos> maybe a reminder that patches need to be in by the end of this month?
12:17:26 <rafi> i couldn't see pranith around here
12:18:04 <kshlm> ndevos, Here or on the mailing lists?
12:18:05 <kkeithley> oh, I'm thinking of pushing back the switchover to storhaug to 3.10
12:18:14 <post-factum> ndevos: ah, merge window closes soon
12:18:15 <kshlm> rafi, thanks for checking.
12:18:36 <kkeithley> that's the newer common-ha that will include Samba along with Ganesha HA
12:18:47 <ndevos> post-factum: for features, yes, real bugs still can get included later
12:19:03 <kkeithley> not set in stone yet, but want to give people some warning
12:19:16 <kkeithley> I don't think anyone is desperate to have it, are they?
12:19:19 <ndevos> kkeithley: move it, if you think it won't be ready in 20 days
12:19:23 <kshlm> post-factum, https://github.com/gluster/glusterdocs/pull/139
12:19:26 <kkeithley> yeah
12:19:52 * ndevos looks for csaba to check on the Kerberos things
12:20:01 <kkeithley> 3.10 will be out three months after 3.9, IIRC
12:20:08 <ndevos> correct
12:20:33 <kshlm> #action pranithk/aravindavk/dblack to send out a reminder about the feature deadline for 3.9
12:21:24 <kshlm> Shall we move on?
12:21:36 <kshlm> #topic GlusterFS 3.8
12:22:04 <kshlm> ndevos, How is 3.8.2 looking?
12:22:07 <ndevos> I plan to tag 3.8.2 this (my) afternoon, and the packagers get a note when that is done
12:22:41 <post-factum> ndevos: would be nice not to miss 15127
12:22:48 <ndevos> there are still quite some patches waiting for review/testing, so 3.8.3 will happen in a month
12:23:30 <ndevos> post-factum: there are many nice-to-have fixes, but at one point I need to make the cut-over
12:23:56 <post-factum> ndevos: sure, but it is ready
12:23:59 <obnox> kkeithley: ndevos: i can only repeat that there will be close to 0 changes in gluster code required, bet I know
12:24:08 <obnox> kkeithley: ndevos: for moving to storhaug
12:25:09 <ndevos> post-factum: not completely, a maintainer still needs to +2 the backports :)
12:25:21 <post-factum> ndevos: you want to do that :)?
12:25:34 <ndevos> obnox: well, as long as there are no upstream storhaug releases, I dont think we'll know
12:25:35 <obnox> kkeithley: ndevos: all we've been waiting for (since end of last year?) is someone from gluster/ganesha to start using and testing it
12:25:45 <obnox> ndevos: the code is out ther
12:25:49 <obnox> +e
12:26:32 <ndevos> obnox: I'm happy to rebuild an RPM and put it in the testing repositories for the CentOS Storage SIG, send it my way!
12:26:41 <kshlm> Is storhaug useful just for gluster/nfs-ganesha or nfs-ganesha in general?
12:26:50 <obnox> kkeithley: both
12:26:57 <obnox> kshlm: both
12:27:04 <kshlm> Oh cool!
12:27:07 <obnox> kshlm: rather ganesha in general
12:27:25 <obnox> kshlm: the connection to gluster only comes in because ganesha ha is currently managed from *within* gluster
12:27:46 <obnox> kshlm: storhaug removes that need. (ganesha-ha scripts can stay around, but the storhaug mode will not use them)
12:28:13 <obnox> kshlm: staurhaug can work with samba + ganesha managed by a pacemaker cluster on top of other backend storage systems as well
12:28:27 <kshlm> obnox, Nice to know!
12:28:34 <kshlm> Thanks for all the information.
12:28:48 <kkeithley> indeed, the code is out there, but it needs to be updated to catch up to some recent fixes we've made in the old common-ha
12:29:05 <kkeithley> and some CLI needs to be removed that's not relevant to storhaug
12:29:06 <kshlm> ndevos, If there is nothing more to add for 3.8 I'll move on.
12:29:13 <kkeithley> so it's not big, but it's not zero
12:29:16 <obnox> kkeithley: it's an open source project :-)
12:29:26 <ndevos> kshlm: not that I am aware of
12:29:33 <kshlm> ndevos, Thanks.
12:29:52 <kkeithley> and I may still get it into 3.9, so don't panic yet
12:30:01 <kshlm> #topic GlusterFS-3.7
12:30:14 <obnox> kkeithley: the removal of irrelevant CLIs, is ... irrelevant for moving to storhaug ;-) ... or at least optional ;-)
12:30:24 * post-factum sent lots of backports for 3.7
12:30:42 <kshlm> 3.7.15 is on track for 30th August.
12:30:44 * obnox shuts up now about storhaug here --- off-topic it is
12:30:59 <rafi> post-factum++
12:31:01 <glusterbot> rafi: post-factum's karma is now 3
12:31:09 <kshlm> post-factum, I'll be taking a look at all the pending patches in the coming weeks.
12:31:37 * ira doesn't find obnox off-topic.
12:31:38 <kshlm> If they have the relevant votes, I'll be merging them.
12:32:07 <kshlm> post-factum, Thanks for the patches BTW.
12:32:16 <post-factum> np
12:32:41 <post-factum> i'm just tired of cherry-picking them for internal branch ;)
12:33:03 <skoduri> post-factum++ yupp thanks for the backport
12:33:43 <kshlm> skoduri, rafi, If you guys are the original authors or maintainers of the components, make sure you give your votes.
12:34:00 <skoduri> kshlm, yupp...done already
12:34:11 <kshlm> skoduri, Awesome!
12:34:16 <post-factum> and, even better, submit backports as well ;)
12:34:22 <rafi> kshlm: that patch is merged
12:34:25 <kkeithley> that's what open source is all about — pushing your fixes upstream so you don't have to maintain them in your own tree(s)
12:34:42 <kshlm> I'll be sending a reminder next week about 3.7.15.
12:34:47 <skoduri> post-factum, that's the aim..sometimes it takes a while :/
12:35:14 <post-factum> skoduri: keep calm, everything is under our control. resistance is futile, you'll be assimilated
12:35:21 <skoduri> :)
12:35:31 <obnox> kkeithley: https://github.com/linux-ha-storage/storhaug
12:35:41 <kkeithley> gort, klaatu barata nikto
12:36:10 <obnox> ndevos: https://github.com/linux-ha-storage/storhaug/releases
12:36:24 <post-factum> kkeithley: :)
12:36:37 <kshlm> kkeithley, I think your keyboard just went nuts ;-)
12:37:02 <post-factum> kshlm: https://en.wikipedia.org/wiki/Klaatu_barada_nikto huh?
12:37:05 <ndevos> obnox: cool, do you know if it planned to add it as a package in Fedora?
12:37:08 <kkeithley> yeah, I crossed the beam.
12:37:11 <kkeithley> beams
12:38:00 <kshlm> Okay!
12:38:06 <obnox> ndevos: sure, i guess at some point, as soon as it has gotte some testing from ganesha folks... :-D
12:38:06 <kshlm> That's all for 3.7.
12:38:27 <kshlm> #topic GlusterFS-3.6
12:38:33 <kshlm> Not a lot to report here.
12:38:44 <ndevos> obnox: hah, and I normally expect a package in Fedora before I add it to the CentOS Storage SIG repos :)
12:38:57 <kshlm> I was supposed to set up a time for screening the existing 3.6 bugs.
12:39:01 <kshlm> And I didn't.
12:39:09 <kshlm> I hope to do that this week.
12:39:20 <ndevos> kshlm: I hope you enjoyed your extra free time then!
12:39:45 <obnox> ndevos: these are just builds. not official afaict
12:39:47 <kshlm> ndevos, I did. I spent the extra time on GD2 this week. And it helped.
12:40:00 <ndevos> kshlm: heh, very good :D
12:40:33 <kshlm> Would it be alright to have this bug screening after next weeks bug-triage?
12:40:57 <kshlm> I don't know how long the triages take, so I'm not sure if it's possible to squeeze it in.
12:41:03 <kkeithley> +1 to getting glusterd2 work done
12:41:30 <kkeithley> unless we get a lot of bugs triage only takes 20-30 minutes usually
12:41:35 <ndevos> depends, the bug triage still takes too long, maintainers+developers fail to triage quite some bugs every week :-/
12:41:56 <kkeithley> faster if more people participate
12:42:09 <kshlm> I'll be present, so that should help a little.
12:42:23 <ndevos> even faster when maintainers+developers triage the bugs for the components they work on ;-)
12:42:39 <kshlm> So then shall we do the screening next week?
12:42:51 <kkeithley> even faster still if devs remember to assign bugs to themselves and set Triaged keyword when they submit a patch
12:43:06 <kkeithley> +1 to screening next week
12:43:16 <ndevos> but yes, 30 minutes is normally sufficient, not sure who volunteered to do host it next week
12:43:39 <kshlm> kkeithley, ndevos, Thanks. I'll send the announcement after this meeting.
12:44:04 <kshlm> Let's move on.
12:44:12 <kshlm> #topic NFS-Ganesha
12:44:36 <kshlm> We've discussed ganesha already today.
12:44:43 <kkeithley> I think we're getting close to reaching closure on 2.4 GA
12:44:44 <kshlm> Anything else to share.
12:45:04 <kkeithley> some preliminary upstream testing looks like it's pretty solid.
12:45:05 <ndevos> and 2.3.3 will get released later this week
12:45:24 <kkeithley> looks like 2.4 is pretty solide
12:45:27 <kkeithley> solid
12:45:32 <skoduri> And support for dynamic exports update may come in 2.4
12:45:53 <post-factum> skoduri: that wouldbe definitely nice to have
12:46:27 <skoduri> yeah
12:47:26 <kshlm> Would either of these releases be using storhaug? Or is it independent?
12:47:48 <skoduri> its independent
12:47:52 <kkeithley> we didn't decide to change anything wrt to gnfs/ganesha migration in 3.9. Maybe in 3.10 we will look at a build option to build/not build the nfs xlator.  We'll leave it enabled by default in 3.10, and disabled by default in 3.11.  How does that sound?
12:48:09 <kkeithley> well, you can use storhaug today, but you're on your own
12:48:38 <kkeithley> we want better integration. and have it packaged in Fedora, CentOS Storage SIG, etc.
12:48:52 <kshlm> So basically the community needs to say yes to storhaug?
12:49:10 <kshlm> I know you guys can get that done :)
12:49:18 <kkeithley> some of the community are already saying yes to it. I haven't heard any nos
12:49:18 <obnox> kshlm: someone other than jose and the samba team needs to start looking at it and testing it
12:49:23 <obnox> kshlm: that's what is needed :-)
12:49:38 <kshlm> Thanks kkeithley, skoduri, obnox!
12:49:45 <kshlm> #topic Samba
12:50:00 <ndevos> storhaug!
12:50:22 <obnox> no news about storhaug. it has been released and announced  some 8 months ago
12:50:45 <obnox> currently very promising work is going on
12:50:56 <ira> Samba 4.5.0rc2 soon? :)
12:50:58 <obnox> regarding performance improvements for readdir and smallfile workloads
12:51:06 <obnox> for gluster use
12:51:16 * ira nods... there's some very good work there.
12:51:22 <obnox> with poonimas's work on the md cache translator
12:51:39 <obnox> this is imho currently the most exciting thing going on between samba and gluster
12:51:55 <ira> yep.
12:52:05 * anoopcs agrees
12:52:17 <obnox> ira: and indeedn. samba.org is working towards the 4.5 release (scheduled for september)
12:52:36 * ira nods...
12:52:50 <ira> "Coming soon to a test lab near you."
12:53:07 <kshlm> Cool! With GlusterFS-3.9 also being targetted for September, it should work out nice.
12:53:25 <kshlm> Thanks obnox and ira!
12:53:40 <ira> We will see, I've been playing with both ;).
12:53:54 <anoopcs> and we need reviews on md-cache patches from Poornima
12:54:05 <kshlm> #topic Community Infrastructure
12:54:09 * ira nods in agreement with anoopcs.
12:54:12 <kshlm> nigelb, You're on.
12:54:13 <nigelb> o/
12:54:18 <obnox> anoopcs: thanks for mentioning it! very true
12:54:26 <nigelb> The Jenkins Job Builder conversion is ongoing (nearly done!)
12:54:33 <nigelb> I've just got 3 more jobs to go.
12:54:39 <nigelb> The regression ones and the release ones.
12:54:51 <nigelb> There's light at the end of this tunnel!
12:55:00 <kshlm> The release one should be simple.
12:55:01 <kkeithley> that's the train
12:55:06 <nigelb> I've also been trying to get netbsd specific changes in tests to be merged to master. Current Diff: https://github.com/gluster/glusterfs-patch-acceptance-tests/pull/47
12:55:08 <misc> kkeithley++
12:55:10 <glusterbot> misc: kkeithley's karma is now 10
12:55:13 <nigelb> kkeithley: ^^ this is the train.
12:55:26 * ira thought it was bugs bunny with a flash light.
12:55:32 <nigelb> So, over the years we've acquired a lot of changes to the test code for netbsd
12:55:47 <nigelb> I'm slowly trying to figure out how to get it to work on mastre
12:55:52 <nigelb> and remove changes that aren't needed anymore.
12:56:09 <nigelb> The repo has another pull request where I have one just for the posix compliance changes.
12:56:14 <nigelb> If anyone wants to help with review.
12:56:35 <nigelb> In other exciting news, I sat down and wrote some code for the script to check if maintainer has given +1 See: https://github.com/nigelbabu/check-maintainer/blob/master/tests.py
12:56:44 <ndevos> reviews are done in github, or did you move it to gerrit already?
12:57:03 <nigelb> Not yet moved.
12:57:17 <nigelb> While investigating the move, I ran into the netbsd diff issue.
12:58:01 <nigelb> That's all from me.
12:58:21 <kshlm> nigelb, Thanks.
12:58:22 <nigelb> If you have feedback for the maintainer check, catch me after the meeting or reply on the bug.
12:58:31 <nigelb> (bug 1350477)
12:58:31 <glusterbot> Bug https://bugzilla.redhat.com:443/show_bug.cgi?id=1350477 unspecified, unspecified, ---, nigelb, NEW , Test to check if the maintainer reviewed the patch
12:58:43 <kshlm> nigelb, Is that working somewhere already?
12:59:08 <nigelb> No, I've written very little code. Mostly the tests and the yml file in there are relevant, that's all.
12:59:25 <kshlm> Okay. I'll check it out.
12:59:31 <kshlm> When I get some time.
12:59:59 <nigelb> Thanks. I'm looking for edge cases I might run into
13:00:01 <nigelb> with the script.
13:00:10 <kshlm> I've been trying to get the centos-ci job for GD2 to work correctly. It's not reporting correctly.
13:00:26 <kshlm> The same problem is also seen with the heketi job in centos-ci.
13:00:43 <kshlm> I've asked for help on the centos-ci mailing lists, and haven't heard back yet.
13:01:03 <kshlm> That's all I have for the infra.
13:01:16 <kshlm> Shall we move on to the next topic?
13:01:20 <ndevos> oh, bstinson should be available this week again, we can ping him in #centos-devel
13:01:37 <kshlm> ndevos, That's what kbsingh replied with.
13:01:51 <kshlm> I'll see if I can catch him later.
13:01:52 <ndevos> ah, ok then
13:02:09 <kshlm> Ok. Next topic.
13:02:22 <kshlm> #topic Open Floor
13:02:47 <kshlm> #topic Glusto - libraries have been ported by the QE Automation Team and just need your +1s on Glusto to begin configuring upstream and make available
13:02:52 * ndevos looks at amye for a Summit update
13:03:13 <kshlm> loadtheacc, You have the floor.
13:03:42 <loadtheacc> The QE Automation team has completed porting of libs and are adding new ones as well. Just need your +1s to start configuring upstream and push them.
13:03:59 <ndevos> loadtheacc: are there tests that we can easily run in the CentOS CI, without the need to wait on including changes in the main glusterfs sources?
13:04:21 <msvbhat> Oh, Great
13:04:31 <msvbhat> loadtheacc: Where are they? I can't find them in gerrit
13:04:55 <kshlm> I had the same question as msvbhat.
13:05:11 <loadtheacc> ndevos, they are downstream. we haven't pushed anything upstream. were waiting on community okay of the move to Glusto before doing a push upstream.
13:05:22 <loadtheacc> msvbhat, ^^^
13:05:58 <loadtheacc> ndevos, sorry... crossed the streams... I'll have to let Shwetha and the rest of the automation team speak to "tests". effort has been libs at this point.
13:06:27 <msvbhat> Okay, So you need +1 for glusto... Not to the libs
13:06:48 * kshlm notes we are 5 minutes over time.
13:06:58 <loadtheacc> msvbhat, yes.
13:07:00 <ndevos> loadtheacc: ah, ok, it is mainly the tests I care about, some examples somewhere would be nice - and I could run it in the CentOS CI to try out
13:07:37 <loadtheacc> ndevos, ok. have you had a  chance to look at the demos?
13:07:40 <msvbhat> loadtheacc: Great, I will reply to the mail soon (Haven't completed the videos/code-reading yet)
13:07:53 <ndevos> loadtheacc: not yet, it is still on my TODO - and very high at that!
13:08:20 <loadtheacc> ndevos, I walk through some examples of testscripts in the Running Unittest demo
13:08:22 <kshlm> loadtheacc, I'm done with 1 video. I still need to go through the others.
13:08:26 <ndevos> loadtheacc: in general, I do not care so much about the framework itself, if quality assurance specialists say it is good, I accept it ;)
13:08:30 <kshlm> I'm pretty sure it's a +1 from me.
13:08:57 <msvbhat> From me too
13:09:09 <nigelb> I want to talk details on running it, but otherwise, I'm all for it
13:09:10 <loadtheacc> ndevos, kshlm, great, so should we start pushing libs upstream so we can get some tests there?
13:09:40 <msvbhat> yes, Please
13:09:45 <kshlm> I'm ok with it.
13:09:59 <ndevos> loadtheacc: I'm not sure about the inclusion of gluste(+libs) in the main glusterfs sources, does it work as a seperate project?
13:10:21 <ndevos> loadtheacc: the tests themselves can be in the sources, that makes sense for many of them
13:11:04 <loadtheacc> ndevos, it can. we had discussed doing the dsitaflibs as a separate project, but that changed to glusterfs repo later in discussion.
13:11:44 <msvbhat> ndevos: We have libs as part of the tests. The idea was to move them out once it becomes stable and/or exhaustive
13:11:48 <loadtheacc> ndevos, agreed. it's setup as a separate package, so it can easily live outside glusterfs
13:12:17 <loadtheacc> and what ms said ^^^ :-)
13:12:21 <kshlm> I'd like it outside as well. If it were in the project, we'd need to keep backporting libs to all the branches.
13:12:31 <ndevos> ah, thanks, that makes sense to me now, msvbhat + loadtheacc
13:12:51 <kshlm> The framework and libs needn't be tied to a glusterfs branch.
13:12:59 <ndevos> kshlm: I started to write ... loadtheacc: I would just like to be able to use the same tool to test different branches/versions, and backporting glusto-libs
13:13:08 <ndevos> :)
13:13:13 <ira> But... how do you know what version to use with what... etc. :/.
13:13:29 <ira> Incompatible changes will be made.
13:13:40 <ira> (It is software!)
13:14:02 <ndevos> ira: testcases are part of the branches, as long as Glusto can run those tests, things should be fine
13:14:13 <obnox> well, if this is the framework, and tests are triggerd from outside, and the test stay with the gluster software, it should work
13:14:33 <obnox> ndevos: :-)
13:14:42 <ira> ndevos: Then you should have glusto as a sub project ;).
13:15:00 <ndevos> ira: heh, yes
13:15:00 <ira> obnox: Until glusto 2.0... and it breaks old tests.
13:15:16 <ira> That's my concern.
13:15:21 <loadtheacc> ndevos, ira, there is the libs in-between. the framework is just the tool providing remote calls, etc.
13:15:31 <ndevos> at the moment, we do not have any tests yet, so breakage is fictional
13:15:37 <ira> loadtheacc: You aren't reassuring me ;).
13:15:57 <obnox> ndevos: that is an excellent plan! don't add tests ever, and all is great!
13:16:09 <ndevos> obnox: oh, nice one! :D
13:16:15 <msvbhat> Ha ha :)
13:16:39 <kshlm> We are 15 minutes over.
13:16:40 <ndevos> loadtheacc: I hope we push the libs to be part of the framework :)
13:16:47 <obnox> kshlm: yeah...
13:16:49 <kshlm> Last topic.
13:17:00 <msvbhat> Anyway, Util we have more (and exhaustive) libs, i think it makes sense to keep them together
13:17:01 <ira> "One more!"
13:17:05 <kshlm> #topic Need some more reviews for https://github.com/gluster/glusterdocs/pull/139
13:17:25 <kshlm> This is the pull-request I sent for the update to the Release process document.
13:17:29 <kshlm> It needs more reviews.
13:17:48 <kshlm> Also, nigelb brought up a valid point about having a proper testing period.
13:17:55 <kshlm> We need to discuss that as well.
13:18:34 <kshlm> So, @all, particularly the maintainers, we need you to review this.
13:18:53 <kshlm> That's all the topics we have for this week.
13:19:09 <kshlm> Here are the general end of meeting announcements.
13:19:18 <kshlm> f you're attending any event/conference please add the event and yourselves to Gluster attendance of events: https://public.pad.fsfe.org/p/gluster-events
13:19:18 <kshlm> Put (even minor) interesting topics on https://public.pad.fsfe.org/p/gluster-weekly-news
13:19:18 <kshlm> Use the following etherpad for backport requests  https://public.pad.fsfe.org/p/gluster-backport-requests
13:19:27 <kshlm> Thanks for attending todays meeting everyone.
13:19:34 <post-factum> thx kshlm
13:19:35 <ndevos> does anyone ever open the backport etherpad?
13:19:41 <kshlm> It was quite a lively meeting today.
13:19:48 <kshlm> ndevos, I asked the same question some weeks back.
13:19:53 <kshlm> #endmeeting