gluster_bug_triage
LOGS
12:00:22 <skoduri> #startmeeting Gluster Bug Triage
12:00:22 <zodbot> Meeting started Tue Jul 12 12:00:22 2016 UTC.  The chair is skoduri. Information about MeetBot at http://wiki.debian.org/MeetBot.
12:00:22 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
12:00:22 <zodbot> The meeting name has been set to 'gluster_bug_triage'
12:00:35 <skoduri> #topic Roll Call
12:00:53 * Saravanakmr is here
12:01:03 * kkeithley is here
12:01:26 <skoduri> cool.. anyone else? jiffin ndevos ??
12:01:42 * hgowtham is here
12:01:56 <skoduri> okay lets start
12:01:58 <kkeithley> ndevos is in Tel Aviv with the virt team
12:02:14 <skoduri> right! ..
12:02:15 <skoduri> #info agenda: https://public.pad.fsfe.org/p/gluster-bug-triage
12:02:33 <skoduri> #topic Next weeks meeting host
12:02:38 <skoduri> any volunteers?
12:02:52 <hgowtham> skoduri, i can do that
12:02:58 <skoduri> hgowtham, thanks
12:03:01 <hgowtham> it has been a while since i took it up
12:03:13 <skoduri> #info hgowtham will be next weeks meeting host
12:03:19 * jiffin is here
12:03:28 <skoduri> #topic ndevos need to decide on how to provide/use debug builds
12:03:47 <skoduri> since ndevos is not here today, will move it to next week
12:03:54 <skoduri> #action ndevos need to decide on how to provide/use debug builds
12:04:05 <skoduri> #topic Manikandan and gem to wait until Nigel gives access to test the scripts
12:04:13 <skoduri> I do not see Manikandan
12:04:25 <skoduri> anyone has any idea ?
12:04:29 <skoduri> hgowtham?
12:04:30 <hgowtham> gem has left
12:04:34 <skoduri> right
12:04:45 <hgowtham> so we have to ask manikandan when he is back.
12:04:51 <hgowtham> im not aware of the status
12:04:55 <skoduri> I will move this AI as well to next week then
12:04:59 <skoduri> #action Manikandan and gem to wait until Nigel gives access to test the scripts
12:05:01 <hgowtham> sure
12:05:07 <skoduri> Last one
12:05:10 <skoduri> #topic jiffin will try to add an error for bug ownership to check-bugs.py
12:05:10 * rafi is here partialy
12:05:20 <skoduri> jiffin, any update?
12:05:35 <jiffin> skoduri: nope, mark it as not done
12:05:43 <skoduri> jiffin, okay sure
12:05:47 <skoduri> #action jiffin will try to add an error for bug ownership to check-bugs.py
12:05:58 <skoduri> #topic Group Triage
12:06:07 <skoduri> #link https://public.pad.fsfe.org/p/gluster-bugs-to-triage
12:10:15 <kkeithley> hmmm.  Some of these would (could?) go away if the script that adds a comment when a patch is posted also changed the state to POST.  Seems like it could also set the Assignee to the person who posted the patch.
12:10:29 <kkeithley> is that a reasonable thing to do?
12:10:37 <skoduri> kkeithley, +1 agree
12:11:07 <Saravanakmr> Hi, Who can be best person to look into rpc related bug?
12:11:17 <skoduri> kkeithley, was that the same Manikandan and gem were working on ?
12:11:27 <Saravanakmr> https://bugzilla.redhat.com/show_bug.cgi?id=1353561
12:11:28 <glusterbot> Bug 1353561: medium, unspecified, ---, bugs, NEW , Multiple bricks could crash after TCP port probing
12:11:35 <kkeithley> maybe
12:11:35 <skoduri> Saravanakmr, Raghavendra Gowdappa is rpc maintainer
12:11:42 <Saravanakmr> skoduri, ok
12:12:00 * ndevos looks around
12:12:01 <skoduri> Saravanakmr, I have been looking at that bug too..but better involve Du too
12:12:13 <Saravanakmr> skoduri, ok..sure
12:12:18 <kkeithley> ndevos missed all the fun
12:12:20 <skoduri> ndevos, hello .. you just missed your AI ;)
12:12:35 <ndevos> yeak, you seem to have finished all the bugs already!
12:12:49 <ndevos> I guess I'll get reminded about the AI next week again
12:13:06 <skoduri> yup...these days the number is less and kkeithley finishes most of them by the time Group triage starts :)
12:13:16 <kkeithley> lol
12:13:18 <Saravanakmr> :)
12:13:23 <skoduri> okay we are done with Group triage
12:13:28 <skoduri> #topic Open Floor
12:14:12 <kkeithley> where is the script that adds comments when a patch is posted. Maybe I'll take a look at it.
12:14:15 <kkeithley> anyone know?
12:14:24 <skoduri> ndevos, ^^^ ?
12:14:35 <jiffin> kkeithley: intially it was avati's name,
12:14:44 <ndevos> no, I dont know
12:14:51 <ndevos> I think it is part of the Gerrit config
12:14:56 <jiffin> ndevos suggested to change into gluster-org I guess
12:15:16 <jiffin> then at the end it become hagarth's name
12:15:23 <ndevos> Manikandan was working on the bug status automation, and they were waiting to get that script too
12:15:24 <kkeithley> yup
12:16:07 <skoduri> and Manikandan is waiting for nigelb to provide access to test thsoe scripts
12:16:32 <ndevos> https://public.pad.fsfe.org/p/gluster-automated-bug-workflow should be the etherpad, but it does not finish loading for me
12:17:07 <skoduri> still loading :D
12:17:16 <ndevos> I thought that also included status updates of the different tasks...
12:17:18 <kkeithley> if Manikandan is really going to do it, then I'll wait.
12:17:57 <kkeithley> Not sure what the hold up would be for getting access to the script
12:18:09 <skoduri> kkeithley, right.. we should check with him on that..
12:18:41 <ndevos> he and gem did some work, it seems to be at https://github.com/nandajavarma/gerrit-hooks
12:19:34 <kkeithley> I'll wait. Won't step on his toes.
12:20:04 <skoduri> okay :) I will poke him too next time I see him
12:20:31 <skoduri> hopefully by next bug-triage meeting
12:21:26 <skoduri> any other topic/thoughts to discuss?
12:21:54 <hgowtham> nothing from my side
12:22:00 <Saravanakmr> none from my end
12:22:02 <jiffin> skoduri: nope
12:22:26 <skoduri> okay ..I guess then we can end the meeting
12:22:37 <skoduri> thank you all for attending :)
12:22:46 <jiffin> skoduri: thanks for hosting
12:22:47 <skoduri> #endmeeting