gluster_community_meeting_20-apr-2016
LOGS
12:01:50 <rastar> #startmeeting Gluster Community Meeting 20-Apr-2016
12:01:50 <zodbot> Meeting started Wed Apr 20 12:01:50 2016 UTC.  The chair is rastar. Information about MeetBot at http://wiki.debian.org/MeetBot.
12:01:50 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
12:01:50 <zodbot> The meeting name has been set to 'gluster_community_meeting_20-apr-2016'
12:02:02 <rastar> post-factum: :)
12:02:16 <rastar> #topic Roll call
12:02:24 * anoopcs is here
12:02:25 <post-factum> o/
12:02:25 * rastar is here
12:02:33 * overclk is here
12:02:52 <rastar> we shall wait for a few more mins
12:03:58 * Saravanakmr is here
12:04:08 * aravindavk is here
12:06:02 <rastar> I guess it will be a very short meeting
12:06:35 <rastar> Moving on..
12:06:46 <rastar> #topic Next weeks meeting host?
12:07:56 <rastar> I will do it next week too
12:08:12 <rastar> #info rastar to host next meeting
12:08:21 <rastar> #topic Last weeks AIs
12:08:45 <rastar> #topic kshlm & csim to set up faux/pseudo user email for gerrit, bugzilla, github
12:08:45 * msvbhat arrives bit late to the meeting
12:08:52 <rastar> hi msvbhat
12:08:58 <msvbhat> Hello
12:09:11 <rastar> we don't have kshlm or csim to update on it
12:09:28 <rastar> I think it isn't done yet.
12:09:36 <rastar> #action kshlm & csim to set up faux/pseudo user email for gerrit, bugzilla, github
12:09:54 <rastar> #topic jdarcy to provide a genral Gluster-4.0 status update
12:11:19 <rastar> I did not find any mails about this, moving it to next week
12:11:25 <rastar> #action jdarcy to provide a genral Gluster-4.0 status update
12:11:57 <rastar> #topic hagarth to take forward discussion on release and support strategies (onto mailing lists or another IRC meeting)
12:12:14 <post-factum> the decision was not presented yet, afaik
12:12:38 <post-factum> hagarth talked about some voting among devs
12:13:16 <rastar> #info pranith sent a mail to maintainers@gluster.org regarding the same
12:13:49 <rastar> #info post-factum says hagarth talked about some voting among devs
12:14:01 <rastar> will carry forward this to next week
12:14:09 <rastar> #action hagarth to take forward discussion on release and support strategies (onto mailing lists or another IRC meeting)
12:14:30 <rastar> #topic jdarcy will get more technical and community leads to participate in the weekly meeting
12:14:42 <rastar> :)
12:15:08 <rastar> This week is an exception, I know we have many devs are attending vault
12:15:53 <rastar> but we definitely need more participation
12:15:59 <rastar> #action jdarcy will get more technical and community leads to participate in the weekly meeting
12:16:38 <rastar> #topic GlusterFS-3.7
12:17:07 * hagarth is here now
12:17:25 * post-factum updated part of cluster to 3.7.11+extra patches, seems to work :)
12:17:28 <hagarth> we have 3.7.11 out, yay!
12:17:35 <hagarth> post-factum: what are the extra patches?
12:17:51 <rastar> #info kshlm announced 3.7.11
12:17:59 <rastar> #link https://www.mail-archive.com/gluster-users@gluster.org/msg24508.html
12:19:10 <rastar> hagarth: would like to update on any of the other AIs?
12:19:23 <post-factum> #link http://termbin.com/13oa
12:19:26 <post-factum> hagarth: ^^
12:19:35 <hagarth> rastar: I was waiting for Pranith's discussion to complete regarding release strategy
12:19:46 <hagarth> looks like we have not yet converged there
12:19:54 <rastar> hagarth: yes, agreed
12:20:05 <hagarth> once we have convergence, I will start a thread about older release maintenance
12:20:59 * msvbhat brb
12:21:32 <hagarth> 4.0 is moving a bit slower than what we would like due to various other things the core developers are working on
12:21:34 <rastar> post-factum: are these 12 patches in 3.7 or you picked them from master?
12:22:34 <post-factum> rastar: some of them were merged into 3.7, some of them are still under review
12:23:32 <rastar> post-factum: thanks, but all of them are on 3.7 branch on some state
12:23:47 <rastar> moving on to 4.0 now
12:23:54 <hagarth> post-factum, rastar: the ones not yet merged in release-3.7 should be likely candidates for 3.7.12
12:24:19 <post-factum> that's fine
12:24:32 <rastar> hagarth: yes
12:24:50 <rastar> #topic GlusterFS 4.0
12:25:20 <hagarth> 4.0 is moving a bit slower than what we would like due to various other things the core developers are working on
12:25:28 * msvbhat is back
12:25:29 <hagarth> (as I mentioned previously)
12:25:37 <rastar> hagarth: :)
12:25:44 <overclk> rastar: one update with dht2
12:26:15 <overclk> rastar: the design document would be sent for review to -devel sometime next week.
12:26:43 <overclk> overclk: it's taking longer than expected to finish it :)
12:26:53 <rastar> overclk: Why -devel?
12:27:02 <rastar> and not glusterfs-specs gerrit?
12:27:39 <overclk> rastar: it's a google doc. isn't it easier to review there?
12:27:48 <rastar> I already see some design docs by shyam on http://review.gluster.org/#/q/project:glusterfs-specs
12:28:13 <overclk> rastar: yeh. those are very high level, not at the granularity of what's expected in a design document..
12:28:36 <rastar> overclk: easier yes, but not agreed by all in community
12:29:33 <rastar> #info dht2 updated design docs will be up for review some time next week
12:29:44 <overclk> rastar: IMO, reviewing ladder diagrams in gerrit would be pain and with dht2 we have loads of flow diagrams
12:30:02 <overclk> rastar: we should still link it, but I'd perfer inline.
12:30:13 <overclk> s/should/could/ :)
12:30:39 <rastar> overclk: those are valid points
12:31:09 * rastar feels we should all just write design docs in ascii like RFCs
12:31:38 <overclk> rastar: we could do that for the final version (once reviewed and approved)
12:31:57 <rastar> overclk: agreed
12:32:16 <rastar> any other updates on 4.0?
12:32:45 <hagarth> not that I can think of
12:32:52 <rastar> ok, moving on
12:33:02 <rastar> I had missed 3.8
12:33:10 <rastar> #topic GlusterFS 3.8
12:33:30 <rastar> #info Feature Freeze is April 30 2016
12:35:01 <rastar> #info msvbhat has sent mails on how to use distaf
12:35:44 <msvbhat> Yeah, And one of us will be sending few test cases as example.
12:36:06 <msvbhat> We have example already. But myself or Jonathan will send fs-sanity related test cases there
12:36:40 <rastar> thanks msvbhat
12:37:04 <msvbhat> The packaging of distaf is still missing and I am working on that
12:37:19 <rastar> In the absence of ndevos I would remind everyone to update and actively review patches for 3.8 features
12:37:40 <rastar> moving on..
12:37:51 <rastar> #topic
12:37:53 <rastar> Open Floor
12:37:56 <rastar> #topic Open Floor
12:38:36 <msvbhat> I haven't added any topic in etherpad, but I have one I want to discuss
12:39:00 <msvbhat> Aravinda asked me this question. But he isn't here today.
12:39:31 <msvbhat> For the new features that gets added to 3.8 (REST API was his example), do we need tests both as .t and as distaf tests?
12:39:53 <hagarth> msvbhat: yes
12:40:02 <rastar> Good question
12:40:35 <rastar> hagarth: would you them in duplicate or complimentary to each other
12:40:39 <msvbhat> Okay, But wouldn't that be double work?
12:40:59 <hagarth> rastar: .t tests are essentially single node tests / basic sanity checks to ensure that nothing regresses due to a new patch
12:41:25 <hagarth> tests in distaf are meant to be run on multi node setups and would be part of longer regression runs on a build
12:41:46 <hagarth> .t and distaf address different categories of tests
12:42:41 <hagarth> msvbhat: does that help?
12:42:42 <msvbhat> Okay, As long as same test is re-written in both, I don't think it is a point of concern
12:42:44 <rastar> hagarth: so it means some basic .t tests for all new features are compulsory
12:42:53 <hagarth> rastar: right..
12:43:01 <rastar> hagarth: makes sense
12:43:11 <msvbhat> hagarth: Yes, Thanks
12:43:38 <Saravanakmr> I have something related to gluster blog
12:43:53 <Saravanakmr> I can see some of the blogpost content totally distorted.
12:44:04 <Saravanakmr> example: http://blog.gluster.org/2016/03/nos-conf-2016/
12:44:19 <Saravanakmr> but original blogpost is good..
12:44:35 <hagarth> amye: ^^
12:44:56 <Saravanakmr> original: https://joelearnsopensource.wordpress.com/2016/03/22/nosconf2016/
12:44:59 <msvbhat> nyone know of any snags we might encounter with namespace_packages?
12:45:00 <msvbhat> Since nyone know of any snags we might encounter with namespace_packages?
12:45:11 <msvbhat> sorry, Never mind...
12:45:27 <msvbhat> My mistake :)
12:46:05 <hagarth> Saravanakmr: might be worth a mail on gluster-infra
12:46:30 <Saravanakmr> ok..will send a mail
12:46:49 <rastar> #action amye to check on some blog posts being distored on blog.gluster.org
12:47:03 <amye> I know what the problem is
12:47:16 <amye> WP isn't pulling updates
12:47:35 <rastar> amye++
12:47:35 <zodbot> rastar: Karma for amye changed to 3 (for the f23 release cycle):  https://badges.fedoraproject.org/tags/cookie/any
12:47:35 <glusterbot> rastar: amye's karma is now 3
12:47:47 <amye> So for a syndicated post like that, that's the original formatting
12:47:54 <Saravanakmr> formatting is fully gone - if you compare both.
12:48:00 <amye> If you update your post, the gluster.org blog won't pull it.
12:48:31 <amye> That's because it's how it originally was. ;)
12:48:52 <amye> Let this be a lesson to preview before you hit publish. ;)
12:49:12 <rastar> amye: and it is not configurable on our side?
12:50:09 <Saravanakmr> I will send out a mail..there should be some solution :)
12:50:27 <amye> The only way to do it (that I know of) is to either manually edit it, or to erase the post and resyndicate.
12:51:08 <rastar> amye: ok
12:51:19 <amye> I'll try the 2nd one on this problem
12:51:42 <Saravanakmr> amye++
12:51:43 <glusterbot> Saravanakmr: amye's karma is now 4
12:51:53 <rastar> any other topic for open floor?
12:52:32 <anoopcs> Tracker bug for some previous releases have not yet closed.
12:52:54 <amye> Oh! I'm going to put this in the newsletter as well, but we have https://www.gluster.org/events/ instead of https://public.pad.fsfe.org/p/gluster-events
12:53:11 <rastar> anoopcs: kshlm is aware of it and working on closing them
12:53:24 <anoopcs> rastar, Ok. THanks
12:53:25 <amye> Not everything is added up to events but it's a quick markdown page in the glusterweb repo.
12:53:43 <rastar> amye: and looks much better!
12:53:47 <rastar> thanks
12:54:11 <amye> Will put a note in the publicpad about where the source is exactly
12:56:13 <rastar> I guess we are done with all the topics to discuss
12:58:16 <rastar> #endmeeting