gluster_bug_triage
LOGS
12:00:36 <Saravanakmr> #startmeeting Gluster Bug Triage
12:00:36 <zodbot> Meeting started Tue Apr 19 12:00:36 2016 UTC.  The chair is Saravanakmr. Information about MeetBot at http://wiki.debian.org/MeetBot.
12:00:36 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
12:00:36 <zodbot> The meeting name has been set to 'gluster_bug_triage'
12:01:01 <Saravanakmr> #info agenda: https://public.pad.fsfe.org/p/gluster-bug-triage
12:01:13 <Saravanakmr> #topic Roll Call
12:01:24 * post-factum is watching
12:02:06 * hgowtham is here
12:02:55 * kkeithley is here
12:03:58 <Saravanakmr> anyone else ?
12:04:56 <Saravanakmr> msvbhat, rafi ?
12:05:37 <hgowtham> jiffin, skoduri ?
12:05:48 * skoduri is present
12:06:01 <kkeithley> jiffin is probably asleep (jet lagged) in Raleigh. ;-)
12:06:30 <jiffin> kkeithley: he he
12:06:39 <Saravanakmr> :)
12:06:42 <jiffin> i will around for another 15mins
12:06:52 <Saravanakmr> jiffin, thanks :)
12:06:56 <jiffin> and will go for breakfast
12:07:04 <jiffin> Saravanakmr: np
12:07:20 <Saravanakmr> ok..then..lets start
12:07:44 <Saravanakmr> #topic msvbhat will look into lalatenduM's automated Coverity setup in   Jenkins  which need assistance from an admin with more permissions
12:08:36 <Saravanakmr> msvbhat, are you there?
12:09:04 <Saravanakmr> moving on..
12:09:08 <Saravanakmr> #action msvbhat will look into lalatenduM's automated Coverity setup in   Jenkins  which need assistance from an admin with more permissions
12:09:31 <Saravanakmr> #topic ndevos need to decide on how to provide/use debug builds
12:10:05 <Saravanakmr> as ndevos is not there..moving next week..let me know if anybody have any update
12:10:06 <Saravanakmr> ?
12:10:13 <Saravanakmr> #action ndevos need to decide on how to provide/use debug builds
12:10:33 <Saravanakmr> #topic     Manikandan to followup with kashlm to get access to gluster-infra
12:10:34 <kkeithley> ndevos is in Raleigh too
12:10:35 <skoduri> jiffin, is ndevos around?
12:11:24 <Saravanakmr> Manikandan informed he won't be able to attend..so moving his item too.
12:11:44 <Saravanakmr> #action     Manikandan to followup with kashlm to get access to gluster-infra
12:11:54 <Saravanakmr> #action     Manikandan and Nandaja will update on bug automation
12:12:08 <Saravanakmr> #topic     msvbhat  provide a simple step/walk-through on how to provide testcases for the nightly rpm tests
12:12:18 <Saravanakmr> #action     msvbhat  provide a simple step/walk-through on how to provide testcases for the nightly rpm tests
12:12:27 <Saravanakmr> #action     ndevos to propose some test-cases for minimal libgfapi test
12:12:36 <Saravanakmr> #topic     rafi needs to followup on #bug 1323895
12:12:37 <glusterbot> Bug https://bugzilla.redhat.com:443/show_bug.cgi?id=1323895 low, unspecified, ---, bugs, NEW , Can I configure data transfer network and ping check network separately?
12:12:46 <Saravanakmr> rafi, are you there?
12:14:02 <Saravanakmr> moving on :(
12:14:04 <Saravanakmr> #action     rafi needs to followup on #bug 1323895
12:14:05 <glusterbot> Bug https://bugzilla.redhat.com:443/show_bug.cgi?id=1323895 low, unspecified, ---, bugs, NEW , Can I configure data transfer network and ping check network separately?
12:14:27 <Saravanakmr> #topic     need to discuss about writing a script to update bug assignee from gerrit patch
12:14:57 <Saravanakmr> hgowtham, is this for you?
12:15:17 <hgowtham> Saravanakmr, i don't think so
12:15:34 <jiffin> skoduri: may be ndevos also have the jetlag issue
12:16:17 <Saravanakmr> kkeithley, any idea about this?
12:17:58 <kkeithley> no, no idea
12:18:04 <Saravanakmr> ok
12:18:06 <Saravanakmr> as per last week log there is some discussion between ndevos and rafi. I will assign this to ndevos and then we will take this forward.
12:18:29 <Saravanakmr> #action ndevos need to discuss about writing a script to update bug assignee from gerrit patch
12:18:52 <Saravanakmr> #topic     hari to send a request asking developers to setup notification for bugs being filed
12:19:12 <hgowtham> Saravanakmr, i have done that
12:19:28 <Saravanakmr> link please
12:19:39 <hgowtham> a mail was sent last monday
12:19:47 <hgowtham> i dont have link
12:19:59 <Saravanakmr> which mailing list?
12:21:08 <hgowtham> to gluster devel
12:21:18 <Saravanakmr> hgowtham, ok..thanks!
12:21:42 <hgowtham> Saravanakmr, :)
12:22:20 <Saravanakmr> #link http://www.spinics.net/lists/gluster-devel/msg19169.html
12:24:07 <Saravanakmr> we are done with action items .. expect that only one is solved :)
12:24:19 <Saravanakmr> #topic Group Triage
12:25:17 <skoduri> link please?
12:25:28 <hgowtham> https://public.pad.fsfe.org/p/gluster-bugs-to-triage
12:26:03 * jiffin is stepping out from the meeting
12:26:08 <kkeithley> who is the release manager for 3.7.12?
12:26:19 <Saravanakmr> #info you can fine the bugs to triage here in https://public.pad.fsfe.org/p/gluster-bugs-to-triage
12:33:46 <Saravanakmr> ok..we are done with Bug triage
12:33:50 <Saravanakmr> moving to next topic
12:34:00 <Saravanakmr> #Topic Open Floor
12:34:27 <kkeithley> you don't want to triage some of the Bugs with incorrect status owned by bugs@gluster.org (i.e. nobody) ?
12:34:57 <hgowtham> thats a huge list
12:35:04 <kkeithley> ;-)
12:35:14 <kkeithley> we don't have to do them all today.
12:35:45 <hgowtham> okie :)  how can we sort them?
12:36:32 <kkeithley> sort them how?
12:37:33 <skoduri> okay v can take top 10 bugs ?
12:37:46 <skoduri> that comes to till bug1196026 (line 163)
12:37:48 <hgowtham> yes that could work
12:38:13 <kkeithley> FWIW, Niels' email with the original list doesn't have the BZ query that he uses, so I don't have a good way to do anything without  first trying to reconstruct the query.
12:38:28 <kkeithley> anyway, skoduri++
12:38:44 <skoduri> okay..lets start :)
12:38:45 <Saravanakmr> some of these bugs are on_qa ..but still assigned to nobody?
12:39:17 <Saravanakmr> anyway..
12:40:38 <hgowtham> could someone guide me with the changes that we are supposed to do with these bugs?
12:41:20 <kkeithley> set an owner, if it's obvious who the owner should be.  Set the bug status accordingly.
12:41:44 <kkeithley> e.g. if a patch is posted to gerrit, POST; merged, MODIFIED, etc.
12:41:49 <hgowtham> hmm okie
12:41:50 <Saravanakmr> if the owner is community guy, can he/she be assigned too?
12:42:04 <Saravanakmr> for example Bug# 1147252
12:42:05 <glusterbot> Bug https://bugzilla.redhat.com:443/show_bug.cgi?id=1147252 medium, unspecified, ---, bugs, NEW , Pacemaker OCF volume Resource Agent fails when bricks are in different domain to the system hostname.
12:42:25 <Saravanakmr> kkeithley, need your help
12:42:30 <kkeithley> yes, if they have a bugzilla account
12:44:19 <kkeithley> you might have to try to set Assigned To: and have it fail to find out.  If nothing is obvious, just skip it.
12:44:53 <hgowtham> i have assigned it to a suitable person
12:45:12 <hgowtham> and the status is correct. so does this mean i can move to the next one?
12:45:19 <kkeithley> yup
12:45:26 <hgowtham> thank you
12:45:29 <hgowtham> kkeithley++
12:45:30 <glusterbot> hgowtham: kkeithley's karma is now 4
12:46:06 <skoduri> kkeithley, there are few false alarms too..what do we do about it?
12:46:26 <skoduri> skip it? :)
12:48:21 <kkeithley> or close the BZ as NOTABUG
12:48:39 <skoduri> I have assigned them to ndevos to correct the status :)
12:53:37 <Saravanakmr> kkeithley, skoduri are we done?
12:55:03 <kkeithley> yes, just in time.
12:55:39 <Saravanakmr> so we should look from 164 next week
12:55:45 <Saravanakmr> line no.164
12:56:10 <Saravanakmr> so back to open floor
12:56:19 <kkeithley> or just erase the ones we've already done
12:56:33 <Saravanakmr> yeah..thats better..I will do it.
12:57:26 <Saravanakmr> anything else ?
12:57:58 <kkeithley> not from me
12:58:08 <Saravanakmr> skoduri, hgowtham ?
12:58:23 <Saravanakmr> cool...Thank you all
12:58:26 <skoduri> nothing from me too
12:58:32 <hgowtham> Saravanakmr, nothing from my side
12:58:56 <Saravanakmr> ok..the end :)
12:58:58 <Saravanakmr> #endmeeting