gluster_community_meeting
LOGS
12:06:52 <hagarth> #startmeeting Gluster Community Meeting
12:06:52 <zodbot> Meeting started Wed Mar 16 12:06:52 2016 UTC.  The chair is hagarth. Information about MeetBot at http://wiki.debian.org/MeetBot.
12:06:52 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
12:06:52 <zodbot> The meeting name has been set to 'gluster_community_meeting'
12:07:05 <kshlm|Phone> Thanks hagarth!
12:07:08 <hagarth> #topic RollCall
12:07:13 <hagarth> who do we have here today?
12:07:13 <ndevos> thanks hagarth++ !
12:07:14 * jiffin is here
12:07:15 <post-factum> o/
12:07:20 * obnox is here
12:07:24 * ndevos is there, but the connection seems to be flaky
12:07:27 * rastar is here
12:07:31 <jiffin> hagarth save the day
12:07:46 * dannyb is here
12:07:59 <kshlm|Phone> I'm here but not completely
12:08:05 <hagarth> #topic Last weeks AIs
12:08:12 * kkeithley_ is here
12:08:21 <hagarth> kkeithley to send a mail about using sanity checker tools in the codebase
12:08:24 <lpabon> o/
12:08:33 * rjoseph o/
12:08:35 * skoduri is here
12:08:35 * anoopcs is here
12:08:44 * poornimag is here
12:08:56 <kkeithley_> haven't done it. :-/
12:09:28 <hagarth> kkeithley_: to be noted for next week?
12:09:56 <kkeithley_> sure, there's lots of people around who can poke me to do it. ;-)
12:10:05 <hagarth> #action kkeithley to send a mail about using sanity checker tools in the codebase
12:10:11 <hagarth> kkeithley_: done :)
12:10:24 <hagarth> next AI - kshlm & csim to set up faux/pseudo user email for gerrit, bugzilla, github
12:10:33 <hagarth> kshlm|Phone: any update on this one?
12:10:55 <kshlm|Phone> Nope.
12:11:11 <kshlm|Phone> I had linked to a mail thread last week,
12:11:25 <kshlm|Phone> Discussion needs to continue on it.
12:11:51 <hagarth> kshlm|Phone: was this on gluster-infra?
12:12:35 <kshlm|Phone> Yes. But it was part of another thread.
12:12:50 <kshlm|Phone> misc asked for opinions in the middle of the thread.
12:13:07 <hagarth> kshlm|Phone: ok
12:13:14 <hagarth> will anyway track this for next week
12:13:15 * ira_ wakes up and notes he's here.
12:13:23 <hagarth> #action kshlm & csim to set up faux/pseudo user email for gerrit, bugzilla, github
12:13:24 <kshlm|Phone> Sure.
12:13:33 <hagarth> next AI - msvbhat will add a HOWTO for DiSTAF for developers to write tests
12:14:20 <hagarth> msvbhat: any update on this one?
12:15:10 <hagarth> looks like we do not have msvbhat atm, moving to the next one.
12:15:15 <hagarth> #action msvbhat will add a HOWTO for DiSTAF for developers to write tests
12:15:24 <hagarth> next AI - overclk to share notes from DHT2 discussion with jdarcy
12:15:39 <hagarth> we don't have overclk around, so moving on.
12:15:43 <hagarth> #action overclk to share notes from DHT2 discussion with jdarcy
12:15:54 <hagarth> next AI - jdarcy to share his notes from his Bangalore discussions with the community
12:16:02 <hagarth> we don't seem to have Jeff either
12:16:12 <hagarth> #action jdarcy to share his notes from his Bangalore discussions with the community
12:16:18 <hagarth> next AI - kshlm to ping jdarcy to share his notes
12:16:27 <hagarth> kshlm|Phone: did you get a chance to ping jdarcy?
12:17:43 <hagarth> moving on
12:18:16 <hagarth> #action kshlm to ping jdarcy to share his notes
12:18:25 <hagarth> next AI - kshlm/atinm to share notes on the GD2 discussions with jdarcy
12:18:35 <hagarth> this has been done - http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/14564
12:18:37 <atinm> hagarth, this is done
12:18:43 <hagarth> thank you atinm!
12:18:55 <hagarth> next AI - rabhat to open a 3.6.10 tracker and close the .9 tracker, kshlm will ping him to do it.
12:19:15 <hagarth> not sure if this happened
12:19:52 <hagarth> the 3.6.9 tracker is closed - https://bugzilla.redhat.com/show_bug.cgi?id=glusterfs-3.6.9
12:19:53 <glusterbot> Bug glusterfs: could not be retrieved: InvalidBugId
12:20:17 <hagarth> and we do have the tracker bug for 3.6.10 - https://bugzilla.redhat.com/show_bug.cgi?id=glusterfs-3.6.10
12:20:17 <glusterbot> Bug glusterfs: could not be retrieved: InvalidBugId
12:20:25 <hagarth> so we seem to be good with this AI
12:20:43 <hagarth> #topic GlusterFS 3.7
12:21:33 <hagarth> While testing 3.7.9, I observed a memory/inode leak with the fuse client
12:21:48 <hagarth> I have sent a patch for that and tests with the patch show fairly stable behavior
12:21:58 <hagarth> patch  - http://review.gluster.org/13689
12:21:59 <post-factum> hagarth: oh, that is pretty nice
12:22:09 <atinm> hagarth, so are we ready for tagging 3.7.9?
12:22:29 <hagarth> so we should be tagging 3.7.9 today once jenkins is back and this patch gets merged
12:22:39 <atinm> hagarth, cool
12:23:08 <post-factum> could I have feature request/rfc?
12:23:11 <kshlm|Phone> What's wrong with jenkins?
12:23:22 <hagarth> post-factum: sure, please go ahead
12:23:34 <atinm> hagarth, I think kshlm|Phone has already fixed that problem IIRC
12:24:02 <post-factum> some time ago pranithk told me that it is quite easy to add arbiter brick hotplug. could that be done for 3.7?
12:24:34 <hagarth> kshlm|Phone, atinm: ok. we probably need to manually trigger jobs for patches that did not get auto-triggered.
12:24:57 <hagarth> post-factum: sure, can you please log a bug and propose that for a 3.7.x release?
12:25:06 <rastar> hagarth: I just triggered smoke for this patch
12:25:36 <post-factum> hagarth: should i send feature request to bugzilla?
12:25:40 <hagarth> rastar: thank you
12:25:54 <hagarth> post-factum: yes, we track feature requests also in bugzilla
12:26:01 <post-factum> hagarth: ok, will do that today
12:26:10 <hagarth> post-factum: cool, thank you!
12:26:38 <hagarth> any more questions, thoughts on 3.7?
12:27:11 <hagarth> figure not, moving on
12:27:16 <hagarth> #topic Gluster 3.6
12:27:42 <hagarth> 3.6.9 has been released and the 3.6.10 tracker is available at https://bugzilla.redhat.com/show_bug.cgi?id=glusterfs-3.6.10
12:27:43 <glusterbot> Bug glusterfs: could not be retrieved: InvalidBugId
12:28:19 <hagarth> I see no dependent bugs for 3.6.10. If you would like to see anything fixed in 3.6.10, please add such bugs to the tracker.
12:28:43 <hagarth> any other questions on 3.6?
12:29:01 <hagarth> figure not, moving on
12:29:05 <hagarth> #topic GlusterFS 3.5
12:29:14 <hagarth> ndevos: any updates here?
12:29:29 <ndevos> 3.5.9 was tagged last week(end?)
12:29:56 <ndevos> the packaging mailinglist is informed, but I do not think any of the contributors started with packaging
12:30:12 <kkeithley_> s/contributors/volunteers/ ?
12:30:27 <kkeithley_> and no, our volunteer packagers have been MIA
12:30:31 <ndevos> thats basically the same in this case?
12:30:34 <kkeithley_> (missing in action)
12:31:14 <ndevos> anyway, two bugs have been fixed, although I can not remember what they were about
12:31:33 <ndevos> https://bugzilla.redhat.com/show_bug.cgi?id=glusterfs-3.5.10 is open for the next update
12:31:34 <glusterbot> Bug glusterfs: could not be retrieved: InvalidBugId
12:31:44 <hagarth> ndevos: ok, would you mind pinging the packagers again?
12:32:18 * msvbhat arrives late to the meeting and reading chatlogs
12:32:26 <ndevos> yeah, I think I need to do that... I've been waiting for them beforI announce the release
12:32:57 <hagarth> ndevos: thanks, will note an AI on you
12:33:12 <hagarth> #action ndevos to reach out to packagers about 3.5.9 packaging
12:33:20 <hagarth> any other thoughts on 3.5?
12:33:31 <ndevos> not from me
12:34:19 <hagarth> ok, thanks!
12:34:22 <hagarth> moving on
12:34:26 <hagarth> #topic Gluster 3.8
12:34:33 <hagarth> ndevos: the floor is yours again :)
12:34:53 <ndevos> ah, right!
12:35:08 <ndevos> there is an [IMPORTANT] email on gluster-devel
12:35:26 <ndevos> #link http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/14537
12:35:40 <ndevos> this explains the plan and timelines for 3.8
12:36:03 <ndevos> *all* features listed on the roadmap should comply with *all* requirements
12:36:31 <ndevos> there have been several pull requests for the roadmap already, that is a good sign
12:36:47 <ndevos> but still, it needs many more updates from the feature owners/developers
12:36:50 <ndevos> #link https://www.gluster.org/community/roadmap/3.8/
12:36:52 * hagarth observed the increase in pull requests too after the email
12:37:33 <ndevos> I think I have merged all pending changes, but really hope t osee muc hactivity there
12:38:07 <hagarth> ndevos: that sounds good
12:38:10 <ndevos> *all* features should have a visible progress on the feature page and/org designs
12:38:39 <ndevos> by the end of this week (including weekend) those bits need to be available in the glusterfs-specs repository
12:39:09 <ndevos> features that do not have them, will be marked as 'on risk' and stand a chance of getting removed from 3.8 after branching
12:39:38 <ndevos> really, like "git rm path/to/file/of/your/feature"
12:39:54 <ndevos> and some build/Makefile changes, and whatever is needed
12:40:10 <ndevos> we dont want partial features in 3.8, there are waaaaay to many features already
12:40:11 <kkeithley_> +1
12:40:14 <kkeithley_> ndevos++
12:40:16 <glusterbot> kkeithley_: ndevos's karma is now 10
12:40:32 <hagarth> +1
12:40:48 <ndevos> if your feature is not ready, that is fine, we have a next release in 6 months aain
12:40:49 <obnox> ndevos: "git rm feature" is of more theoretical value of course for some things
12:40:51 <ndevos> *again
12:41:13 <obnox> some may be isolated in files, others aren't
12:41:22 <ndevos> obnox: yes, I'm probably not reverting patches that touch common code
12:41:28 <ndevos> but "probably"
12:42:04 <obnox> ;-)
12:42:07 <ndevos> and of course,  Iwont revert my own features either ;-)
12:42:29 <ndevos> are there any questions for 3.8?
12:42:31 <hagarth> and of course, ndevos won't revert features from folks that are nice to him ;)
12:42:51 <ndevos> that depends, you have to be REALLY NICE
12:43:16 <hagarth> ndevos: #define REALLY NICE
12:43:21 * ndevos awaits the presents to land on his desk
12:43:47 <hagarth> lol
12:43:55 <hagarth> thank you for the update ndevos!
12:44:00 <ndevos> hagarth: if the present is not nice enough, your feature will get removed too :)
12:44:09 <hagarth> ndevos: makes complete sense :)
12:44:38 <hagarth> moving on
12:44:44 <hagarth> #topic Gluster 4.0
12:44:49 <ira> 💩 for ndevos? :)
12:44:56 <hagarth> atinm: any updates here?
12:45:03 <atinm> hagarth, yup
12:45:45 <ndevos> ira: fortunately not!
12:45:50 <atinm> hagarth, from GD2 side we have shared couple of updates, the first one on the design discussions we had on flexi volgen, plugins and the second one was on how we have done ETCD bootstrapping in GD2
12:46:02 <atinm> http://www.gluster.org/pipermail/gluster-devel/2016-March/048755.html
12:46:08 <atinm> http://www.gluster.org/pipermail/gluster-devel/2016-March/048759.html
12:46:37 <atinm> From DHT2 I don't think we have made much progress, overclk or shyam can correct me
12:47:06 <hagarth> atinm: ok
12:47:11 <atinm> NSR team is working on reconciliation & data logging translators
12:47:37 <hagarth> right
12:48:04 <atinm> that's about it
12:48:58 <hagarth> atinm: thank you!
12:49:13 <hagarth> any questions on 4.0?
12:49:35 <ndevos> is the release of 4.0 planned for 6 months after 3.8?
12:49:47 <hagarth> ndevos: tentatively yes
12:49:47 <ndevos> (that is the question I heard a lot last week)
12:50:28 <ndevos> so, if 4.0 is not ready by then, we'll have to do a 3.9 to keep with the 6 month cycle.
12:51:22 <ndevos> *and* that automatically gives 4.0 an other 6 months
12:51:48 <atinm> ndevos, yes, that should be a safer option
12:52:17 <ndevos> atinm: well, it is the only option I could come up with
12:52:19 <hagarth> ndevos: right, let us see how features intended for 4.0 shape up
12:52:25 * post-factum is remembering linux-0.99.15 just for skipping the rest of numeration
12:52:45 <hagarth> post-factum: :)
12:53:09 <hagarth> moving on
12:53:15 <hagarth> #topic Open Floor
12:53:27 <hagarth> any topics here?
12:53:30 <post-factum> I've filed rfe for arbiter hotplug
12:53:33 <kkeithley_> I'll just note that (since over time it's becoming a more and more important piece of GlusterFS) that NFS-Ganesha-2.3.1 was released today. The NFS-Ganesha "community" is very small and not as well organized as Gluster, so I'm doing a bit of advertising and promotion for them here.
12:53:35 <post-factum> #link https://bugzilla.redhat.com/show_bug.cgi?id=1318289
12:53:36 <glusterbot> Bug 1318289: low, unspecified, ---, bugs, NEW , [RFE] Add arbiter brick hotplug
12:53:59 <hagarth> kkeithley_: nice to know!
12:54:46 <hagarth> post-factum: I will seek inputs from pranithk, itisravi and propose it for a 3.7.x release
12:54:56 <post-factum> hagarth: many thanks
12:55:10 <ndevos> post-factum: I've triaged that now, the arbiter devs should respond to that soon
12:55:44 <hagarth> mandatory weekly reminders:
12:55:51 <post-factum> ndevos: thanks
12:55:56 <hagarth> If you're attending any event/conference please add the event and yourselves to Gluster attendance of events: https://public.pad.fsfe.org/p/gluster-events
12:56:02 <hagarth> Put (even minor) interesting topics on https://public.pad.fsfe.org/p/gluster-weekly-news
12:56:08 <hagarth> anything else for today?
12:56:21 <ndevos> pick the moderator for next week?
12:56:50 <hagarth> ok, who wants to (be) volunteer(ed) for next week? :)
12:56:58 <post-factum> echo ${RANDOM}
12:57:03 <hagarth> lol
12:57:45 <hagarth> ok, we will figure that out
12:57:54 <hagarth> thank you all for attending today!
12:58:03 <hagarth> #endmeeting