gluster-meeting
LOGS
15:01:05 <jclift> #startmeeting Weekly Gluster Community Meeting
15:01:05 <zodbot> Meeting started Wed Mar 26 15:01:05 2014 UTC.  The chair is jclift. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:01:05 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
15:01:21 <jclift> Roll call.  kkeithley_mtg already present :)
15:01:24 * kkeithley_mtg is here
15:01:41 * msvbhat is present
15:02:05 * lalatenduM is here
15:02:09 * jdarcy is present
15:02:27 <jclift> Cool
15:02:49 <jclift> #topic Action items from last meetings
15:02:51 <shyam> here
15:02:58 <jclift> "hagarth to send note to gluster-devel, that patches older than 1 year will be abandoned"
15:03:21 <jclift> Not done yet.  If it's not done by next week, we'll either drop it or someone else will do it.
15:03:23 * raghu is here
15:03:43 <jclift> "jclift will ping lpabon to find out if he's the owner of the new Jenkins instance in Rackspace"
15:03:46 <jclift> Done
15:03:52 <jclift> "jclift will put semiosis in touch with whoever the owner of the new Jenkins instance is, so he can get an account"
15:03:55 <jclift> Done
15:04:04 <jclift> "semiosis will add java projects to jenkins"
15:04:09 <semiosis> :O
15:04:12 <johnmark> howdy
15:04:26 <jclift> semiosis: How'd that go? :)
15:04:42 <semiosis> never got a jenkins account.  who do I talk to?
15:05:11 <jclift> semiosis: lpabon
15:05:18 <semiosis> will do
15:05:36 <jclift> "lalatenduM to find out if we have docs available for geo-rep in 3.5"
15:05:39 <jclift> lalatenduM: ?
15:05:50 <purpleidea> o hai
15:05:56 <lalatenduM> jclift, msvbhat has done a writeup for it
15:06:03 <msvbhat> jclift: It's not...
15:06:17 <lalatenduM> jclift, the next AI cover this
15:06:24 <lalatenduM> msvbhat, ^^
15:06:31 <purpleidea> (sorry im late)
15:06:41 <jclift> "msvbhat to find out if the porting of geo-rep docs from RHS to upstream is already underway"
15:06:52 <msvbhat> jclift: I am writing one. Done with writing. Want to add a screen cast
15:07:02 * semiosis left a message for lpabon on glusterbot
15:07:14 <msvbhat> jclift: Will send the draft for interested people for review
15:07:22 <jclift> msvbhat: Cool.  :)
15:07:31 <lalatenduM> msvbhat, thanks :)
15:07:47 <msvbhat> jclift: I want to know what all should I cover in screencaset
15:08:13 <purpleidea> msvbhat: i'd love to see the draft feel free to send it my way
15:08:14 <jclift> msvbhat: Cover what's in the docs?
15:08:36 <msvbhat> purpleidea: Sure. Will send
15:08:55 <jclift> #action msvbhat to send draft of new geo-rep docs to interested ppl.  purpleidea is one such.
15:09:15 <msvbhat> jclift: I was only targetting admins/users without going into details like installation guise and studd like that
15:09:30 <jclift> #action msvbhat to create screencast of geo-rep.  Would like suggestions on what content to include.
15:09:39 <jclift> msvbhat: Ask on gluster-users I guess. :)
15:09:40 <msvbhat> jclift: :)
15:09:55 <jclift> "lala to find the bug for the xlator .so.0.0.0 and inform ndevos so he can fix it"
15:09:58 <jclift> Done
15:09:59 <msvbhat> Sure. Will figure out off-line
15:10:03 <johnmark> msvbhat: cool!
15:10:11 <jclift> "lalatenduM To do a review of Atin's patch http://review.gluster.org/#/c/7292/"
15:10:16 <jclift> lalatenduM: ?
15:10:18 <lalatenduM> jclift, done :)
15:10:20 <jclift> :)
15:10:31 <jclift> "jclift to find a more stable Etherpad than TitanPad"
15:10:34 <jclift> In progress.
15:10:43 <jclift> Trying out this beta etherpad software first.
15:10:56 <johnmark> jclift: oh? which? where?
15:10:58 <jclift> If it's ok, we'll wait for release then spin up an instance in Rackspace.
15:11:04 <jclift> johnmark: http://beta.etherpad.org/gluster-community-meetings
15:11:13 <johnmark> ah, ok
15:11:25 <johnmark> jclift: if we spin up on rackspace, who's going to maintain it?
15:11:51 <jclift> No intention to maintain it.  I've nearly got automatic spin up and install working via API calls.
15:11:59 <jclift> So, completely scriptable to spin up new instance.
15:12:10 <jclift> Any time there's an upgrade needed... kill old one, run script. Done.
15:12:50 * jclift is an optimist.
15:12:57 <johnmark> jclift: dude, no
15:13:04 <jclift> Was a thought
15:13:23 <johnmark> jclift: maintaining an instance of etherpad is not somethign we shoudl be doing
15:13:36 <johnmark> it will be painful and *someone* will have to spend time babysitting it
15:13:43 <jclift> k.
15:13:49 <jclift> Open to suggestions then.
15:13:57 <jclift> (not being smart, am actually open)
15:13:58 <johnmark> jclift: does titanpad suck? has i tfailed repeatedly?
15:14:02 <johnmark> jclift: understood
15:14:02 <jclift> Yes
15:14:14 <jclift> Fails repeatedly.  Literally every meeting
15:14:21 <johnmark> there are other things for collaborative editing, ie. google docs
15:14:34 <kkeithley_mtg> last two or three meetings. It seemed pretty solid before that
15:14:38 <johnmark> kkeithley_mtg: ok
15:14:49 <jdarcy> http://meetingwords.com/
15:14:58 <jclift> kkeithley_mtg: It failed on me earlier today too
15:15:21 <jclift> jdarcy: k, lets try that one next week
15:15:25 <johnmark> jclift: ouch :(
15:15:36 <johnmark> jdarcy: also built on etherpad
15:15:45 <semiosis> how about a gluster.org wiki page?
15:15:48 <johnmark> I smell an opportunity for a business based on a stable etherpad :)
15:16:03 <johnmark> semiosis: not possible to do "real-time" editing
15:16:05 <jdarcy> johnmark: Yep.  I think people are happy with the interface, it's a matter of whether the people running it keep it stable.
15:16:11 <dlambrig> google docs is good. I've used it in similar cases.
15:16:14 <jclift> semiosis: Doesn't allow multiple simultanous authours
15:16:16 <johnmark> jdarcy: yup. worth investigating
15:16:37 <jdarcy> I'd also be OK with Google Docs.  A little "richer" than we really need interface-wise, but that's OK.
15:16:40 <jclift> dlambrig: We could use Google Docs, depending if it needs to have everyone signed in or not.  I don't remember.
15:16:42 <johnmark> I think we could/should consider google docs.
15:16:53 <johnmark> jclift: last I checked it does not require that
15:16:58 <dlambrig> Yes, I believe sign in is required for google docs
15:16:58 <jclift> k.  Let's discuss offline and see what's feasible :)
15:17:04 <johnmark> it depends on the restrictions you put on a shared doc
15:17:08 <jclift> Cool
15:17:08 <johnmark> jclift: perfect :)
15:17:14 <jdarcy> jclift: Anons can definitely view, owners can allow them to comment/edit as well (though the UI for that isn't as pretty as one might hope).
15:17:22 <johnmark> jclift: right
15:17:24 <semiosis> google recently TOS'ed a doc from a colleage of mine we were collaborating on
15:17:29 <johnmark> let's send a note to gluster-infra and discuss there
15:17:32 <semiosis> it just disappeared
15:17:35 <jdarcy> The URLs are also butt-ugly, but you can use Google's own link shortener to deal with that.
15:17:39 <johnmark> semiosis: ugh! not good
15:17:49 <semiosis> since then i've been very wary of gdocs
15:17:56 <johnmark> semiosis: yeah, ok. no bueno.
15:17:58 * lalatenduM want to stay away from google :)
15:18:02 <johnmark> I'll send a note to gluster-infra
15:18:03 <jclift> lalatenduM: Same
15:18:05 <johnmark> lalatenduM: ok
15:18:15 <semiosis> this was a QA form for a mobile app, no way it was in violation of TOS.  they never responded to our requests for review
15:18:21 <semiosis> really bugged me
15:18:36 <jclift> johnmark: Who's the person best place to investigate the options properly?
15:18:37 <semiosis> i used to really like gdocs
15:18:43 <jclift> dlambrig: your kind of thing?
15:18:57 <jclift> I'm looking for someone to assign the action item to :)
15:19:13 <dlambrig> jclift: sure, I can look into that.
15:19:48 <jclift> #action dlambrig to investigate Google Docs as a replacement for Etherpad.  Can people collaborate anonymously is an important point.
15:19:52 <jdarcy> http://meetingwords.com/6X85SfaYeW if anyone wants to give MeetingWords a try right away.
15:20:14 <jclift> jdarcy: After the meeting.  Let's not get too off topic :)
15:20:32 <semiosis> also http://collabedit.com/
15:21:01 <jclift> "kshlm will look into the review of http://review.gluster.org/#/c/6737/2 so we can get it into 3.4.3"
15:21:18 <jclift> kshlm: ping
15:21:44 <kshlm> I looked into it. It just needed the maintainers to merge.
15:21:55 <kkeithley_mtg> 6737 has +2, but the release-3.5 and master versions do not.
15:22:06 <kshlm> I pinged hagarth about it, he said he'd take a look when he found time.
15:22:09 <jclift> Ahhh, it's related to that.
15:22:28 <kshlm> Also, I believe a2 said on the mailing list he'd have a look as well
15:22:35 <jclift> np
15:22:37 <jclift> "kshlm to talk to pk about +2'ing the patches for bug 859581"
15:22:38 <glusterbot> Bug https://bugzilla.redhat.com:443/show_bug.cgi?id=859581 high, unspecified, ---, vsomyaju, ASSIGNED , self-heal process can sometimes create directories instead of symlinks for the root gfid file in .glusterfs
15:22:39 <kkeithley_mtg> I'm not going to merge to 3.4 if there's going to be a regression later on because it never gets merged
15:22:50 <kkeithley_mtg> lots of promises... ;-)
15:22:54 <jclift> kkeithley_mtg: Yeah.  Just do it for 3.4.nextone :)
15:23:31 <kkeithley_mtg> 3.4.4 is ..... unlikely? Or is it? I don't know.
15:23:51 <jclift> Meh.  Just saying there's no need to delay on it.
15:24:08 <kkeithley_mtg> everyone else agree?
15:24:10 <jclift> Did your best, but if people can't make the schedule... ;)
15:24:33 <kkeithley_mtg> Okay, I'll do beta2 after the meeting. GA in a week?
15:24:44 <jclift> Works for me.  Anyone object?
15:25:06 <jclift> Done
15:25:07 <jclift> "kshlm to talk to pk about +2'ing the patches for bug 859581"
15:25:09 <glusterbot> Bug https://bugzilla.redhat.com:443/show_bug.cgi?id=859581 high, unspecified, ---, vsomyaju, ASSIGNED , self-heal process can sometimes create directories instead of symlinks for the root gfid file in .glusterfs
15:25:12 <jclift> kshlm: ping
15:25:18 <kshlm> jclift, its the same thing
15:25:22 <jclift> :)
15:25:34 <jclift> I'm just going down the list ;)
15:25:35 <johnmark> hang on guys...
15:26:15 <jclift> ...
15:26:45 <jclift> "jclift to do a live webcast with johnmark talking about glusterflow!"
15:27:00 <purpleidea> -1 :P
15:27:02 <jclift> Should be feasible for next week, now that Glupy patch has been merged
15:27:17 <jclift> purpleidea: For which item?
15:27:47 <purpleidea> jclift: glusterflow of course... i'm poking fun as a joke ;)
15:28:02 <jclift> Ahhh k.  Sorry, very literal minded atm. :)
15:28:08 <johnmark> sorry
15:28:09 <semiosis> purpleidea: no having fun!
15:28:12 <johnmark> hallway meetings :(
15:28:29 * purpleidea semiosis, is sorry
15:28:36 <jclift> johnmark: Ok to continue?
15:28:51 <jclift> "jclift_ and johnmark to update guidelines on community standards"
15:28:55 <johnmark> jclift: yup :)
15:28:58 <johnmark> and I love me some glusterflow
15:29:07 <jclift> "Not done yet.  If it's not done by next week, we'll either drop it or someone else will do it."
15:29:11 <johnmark> er... what community standards?
15:29:19 <johnmark> sorry, refresh my memory
15:29:19 <jclift> Ugh.  I meant that for his previous item.
15:29:23 <johnmark> lol ok
15:29:47 <johnmark> semiosis: ha!
15:29:50 <jclift> #action johnmark and jclift to discuss the Community Standards item offline
15:30:01 <jclift> There's back history I need to dig up, etc ;)
15:30:07 <semiosis> is that like "no name calling?"
15:30:31 <jclift> Nah, it's about the "where do decisions affecting the community take place"
15:30:43 <semiosis> oh ok
15:30:45 <jclift> eg via mailing list, on gluster-devel on irc, etc.
15:30:48 <johnmark> jclift: yup, gotcha.
15:31:00 <johnmark> that conversation is not a closed-door conversation
15:31:11 <jclift> It's not a big thing, was just a clarity point we worked out a few weeks ago, and needs to be reflected into online docs if not already
15:31:20 <johnmark> gotcha, ok
15:31:31 <jclift> Since we already have Governance docs, it needs to be done in relation to that
15:31:34 <jclift> Anyway, moving on...
15:31:48 <johnmark> ok
15:32:00 <jclift> "lalatenduM + purpleidea to try setting up Rackspace vm's for automatic testing using puppet-gluster"
15:32:17 <purpleidea> this is still a decent amount of time away from my POV.
15:32:34 <johnmark> purpleidea: ok. let me know if we need to help
15:32:42 <jclift> In progress then
15:32:48 <purpleidea> i've got a number of pre-requisites i need to get done before then that i'm not done
15:32:52 <jclift> Sure
15:33:01 <purpleidea> eg: vagrant 1.5.1 for example on Fedora (not working 100% yet)
15:33:03 <jclift> I've got code working for spinning up VM's via the rackspace api
15:33:12 <purpleidea> vagrant-rackspace doesn't seem to work with 1.3.5
15:33:17 <jclift> Was doing that earlier today
15:33:22 <purpleidea> but if anyone has used it at all, let me know
15:33:35 * jclift hasn't touched vagrant yet
15:33:40 <purpleidea> jclift: post link to code
15:34:01 <purpleidea> anyways, the item is WIP from my POV anyways
15:34:09 <jclift> purpleidea: It's in a repo on my desktop atm.  I'll chuck it in a project on the Forge later on today
15:34:30 <jclift> #action jclift to put the code for spinning up new Rackspace vms on the Forge
15:34:44 <jclift> "jclift will include lpabon in the jenkins testing stuff"
15:34:45 * purpleidea loves the forge!
15:34:47 <jclift> Done.
15:34:59 <jclift> "several new xlators (encryption, cdc, changelog, prot_client, prot_server, reddir-ahead, dht) have .so.0 and .so.0.0.0 in both release-3.5 and master branch"
15:35:05 <johnmark> lol
15:35:14 <jclift> I think ndevos did that already...?
15:35:29 <kkeithley_mtg> it's in gerrit
15:35:31 <johnmark> hrm... doesn't seem to be here
15:36:06 <lalatenduM> jclift, yes, it is done
15:36:13 <jclift> Cool. :)
15:36:17 <jclift> Thanks lalatenduM
15:36:25 <jclift> k, next topic
15:36:27 <jclift> #topic 3.5
15:36:36 <johnmark> wow, took a while to get to this point
15:36:41 <jclift> Yeah
15:37:03 <jclift> For 3.5, we don't seem to have user level docs for any of the new features, nor most of the 3.4 features
15:37:20 <jclift> I propose we delay 3.5.0 release until that's done
15:37:40 <jclift> eg It's not acceptable for us to make releases without docs any more *period* kind of thing
15:37:45 <johnmark> jclift: that means we need the docs team to participate in this discussion
15:38:02 <purpleidea> jclift: why aren't docs going upstream first? i thought that happens before RHS gets things?
15:38:02 <semiosis> +1 for docs
15:38:10 <purpleidea> +1
15:38:10 <johnmark> jclift: that's an acceptable position
15:38:11 <jclift> johnmark: Cool.  Lets get that discussion started then. :)
15:38:19 <semiosis> anything is better than nothing, even if just basic usage syntax
15:38:24 <kkeithley_mtg> we're still educating some of the team on upstream first
15:38:32 <johnmark> yup - that is supposed to happen as per the feature dev pages
15:38:42 <purpleidea> kkeithley_mtg: right. okay
15:38:57 <johnmark> ie. feature dev pages on the wiki are supposed to have descriptions along with usage and testing instructions
15:39:07 <purpleidea> kkeithley_mtg: the 'set group' feature is also missing in upstream (although emulated for glusterfs by puppet-gluster ;)
15:39:10 <johnmark> kkeithley_mtg: right. and it's a work in progress
15:39:26 <johnmark> I think what we need to do is send a reminder to gluster-devel
15:39:31 <johnmark> saying that lack of docs is a blocker
15:39:37 <johnmark> and we won't release until it's unblocked
15:39:38 <lalatenduM> agree with purpleidea semiosis  yeah, we need docs! johnmark
15:39:40 <johnmark> I can take that AI
15:39:44 <johnmark> jclift: ^^
15:40:02 <jclift> k, sounds like there's general agreement on this position, but we need to a) include the docs team in this discussion before making it final, and b) if it becomes the official position, then we be anal about it
15:40:03 <johnmark> which means we also need to track with BZ
15:40:20 <jclift> Cool
15:40:24 <johnmark> jclift: actually, it's for devs first- they need to make the first cut of simple docs to unblock for release
15:40:39 <jclift> Cool
15:40:43 <johnmark> and docs team needs to create refined docs or plug in developers' docs into the user and admin guides
15:40:54 <johnmark> jclift: I'll make sure they're involved in the discussion
15:40:57 <jclift> #action johnmark to start the conversation with the docs team about getting docs ready for 3.5 release
15:41:03 <johnmark> cool
15:41:38 <jclift> #action johnmark to email gluster-devel reminding feature owners that 3.5 will not be released until the 3.4 & 3.5 feature pages have at least basic user level docs
15:41:48 <johnmark> jclift: cool
15:41:53 <purpleidea> who is "the docs team" and do they ever come in here?
15:42:07 <jclift> purpleidea: RHS docs team I think
15:42:10 <johnmark> purpleidea: they're in bangalore, and they've agreed to participate in upstream discussions
15:42:14 <johnmark> but they're still not here
15:42:14 <lalatenduM> purpleidea, nope
15:42:24 <purpleidea> do they have names?
15:42:28 <johnmark> because they don't know how to participate. I will hold their hands on this
15:42:34 <purpleidea> johnmark: great! :)
15:42:36 <jclift> Cool :)
15:42:42 <jclift> Moving on
15:42:43 <johnmark> purpleidea: yeah... just an education thing
15:42:47 <jclift> #topic 3.4
15:42:51 <lalatenduM> johnmark, the lack of documentation is getting in our way as a bottle neck
15:42:52 <johnmark> the outside internet is a scary place, apparently :)
15:43:02 <johnmark> lalatenduM: yes, as we discovered yesterday ;)
15:43:06 <jclift> "http://review.gluster.org/#/c/6737 has received +2 (thanks Jeff) but the  matching fixes for release-3.5 and master  — http://review.gluster.org/6736 and http://review.gluster.org/5075 respectively — also still need +2 and merged. I am still reluctant to take this fix  into release-3.4 unless I'm certain the corresponding fixes will also be  taken into release-3.5 and master. This is going on 3+ weeks now!"
15:43:19 <lalatenduM> johnmark, yeah :(
15:43:23 <jclift> kkeithley_mtg: Ugh, that's bad to cut-n-paste ;)
15:43:40 <jclift> kkeithley_mtg: So, this is the item mentioned above in the action points?
15:43:48 <kkeithley_mtg> well, already discussed, but then johnmark said "hang on guys"
15:43:54 <jclift> Yeah
15:43:57 <kkeithley_mtg> dunno if that was related to this
15:44:12 <jclift> I'm think the "hang on guys" was just the meeting in general, not this item
15:44:13 <kkeithley_mtg> so, where do we stand?
15:44:28 <kkeithley_mtg> okay, so beta2 later today and GA next week
15:44:33 <jclift> Yep.  do it.
15:44:34 <jclift> :)
15:44:37 <johnmark> kkeithley_mtg: that was because I was in a hallway discussion
15:44:42 <johnmark> sorry, should have been more clear
15:44:59 <johnmark> I meant "dont' expect a response from me for the next couple of minutes"
15:45:01 <kkeithley_mtg> no prob. it wasn't clear to me what it was in ref. to
15:45:06 <johnmark> sorry
15:45:11 <jclift> "Inclusion in Ubuntu Main repository"
15:45:19 <semiosis> i just added that
15:45:20 <jclift> semiosis: So this is sounding positive?
15:45:22 <johnmark> kkeithley_mtg: +1 ot beta release today and GA next week
15:45:28 <johnmark> yes!
15:45:44 <kkeithley_mtg> consider it done
15:45:58 <jclift> "semiosis continues to bug the ubuntu team" doesn't really indicate progres
15:46:03 <lalatenduM> jclift, semiosis anything we can do it , to include it in main repo
15:46:06 <semiosis> i'm bugging the ubuntu team almost once a week about this.  there is still reason to be optimistic that 3.4.2 will get into Main for trusty, and thus qemu support for glusterfs, although i'm not too optimistic
15:46:13 <jclift> semiosis: But from other conversation it sounds like it's happening at some point
15:46:21 <jclift> ?
15:46:35 <johnmark> jclift: yes, where "at some point" is sometime this year
15:46:35 <semiosis> it's been "happening at some point" for over two years already.
15:46:37 <jclift> semiosis: Is 3.5 more likely, since that should be out soonish?
15:46:51 <johnmark> semiosis: but I thought the 3.4.2 was already included in the universe repo?
15:46:54 <johnmark> or scheduled to...
15:46:59 <semiosis> main != universe
15:47:04 <johnmark> oh right
15:47:12 <johnmark> I don't expect main - although it is a "nice to have"
15:47:18 <johnmark> 3.4.2 in universe is progress
15:47:22 <johnmark> let's take this one step at a time
15:47:26 <jclift> semiosis: Is there any version of Gluster in there, or would this be our first appearance?
15:47:29 <semiosis> 3.4.2 is in review for Main, if it passes review it might get into trusty, otherwise it will be 14.10
15:47:32 <johnmark> and most people add universe to their repos
15:47:40 <semiosis> jclift: glusterfs has never been in Main before
15:47:45 <jclift> k
15:47:49 <johnmark> semiosis: correct. only universe, and it was a very old version
15:47:51 <johnmark> until now
15:47:56 <lalatenduM> semiosis, johnmark kkeithley_mtg we need the samba vfs packages in ubuntu main too
15:48:09 <johnmark> lalatenduM: yeah, that will be another thing
15:48:14 <semiosis> qemu is in Main, so in order for qemu to support glusterfs, glusterfs needs to be in Main also.  Main does not depend on Universe, though Universe can depend on Main.
15:48:20 <johnmark> lalatenduM: we'll have to file a bug, it's too late for this release, though
15:48:20 <jclift> semiosis: Same question as Lala... anything we can do?
15:48:26 <johnmark> will have to go into 14.10
15:48:45 <kkeithley_mtg> and what about getting NFS-ganesha w/ fsal in Ubuntu too? Or is that too ambitious?
15:48:46 <semiosis> lalatenduM: i will look into that
15:49:00 <semiosis> #action semiosis to look into getting samba-vfs in ubuntu
15:49:06 <lalatenduM> semiosis, if we can do it before next LTS, that would be great
15:49:06 <jclift> This sounds like a conversation for gluster-devel to thrash out the full understanding of details
15:49:12 <johnmark> kkeithley_mtg: way too ambitious. I don't even know if ganesha has ubuntu packages in universe or multiverse
15:49:16 <johnmark> jclift: agreed
15:49:23 <johnmark> semiosis: thanks :)
15:49:44 <johnmark> semiosis: and it's the right version of qemu, right?
15:49:51 <semiosis> yes
15:49:52 <lalatenduM> semiosis, thanks   :)
15:50:00 <johnmark> semiosis: if there's a gluster-capable qemu in main, and glustefs is in universe, that should be ok
15:50:04 <jclift> #action semiosis to email gluster-devel with progress status of Gluster in Ubuntu main
15:50:15 <johnmark> oh wait, dependency hell... ok, now I understand
15:50:20 <semiosis> johnmark: right
15:50:26 <johnmark> got it
15:50:39 <jclift> so people can discuss in length and figure out what else is needed, if they can help, etc
15:51:05 <jclift> #topic Other agenda items
15:51:08 <lalatenduM> johnmark, we are going to face similar issues with CentOS storage SIG, isn't it?
15:51:51 <jclift> "Gluster Forge: upgrade gitorious or switch to gitlab, or use GitHub?"
15:52:01 <semiosis> we had a lengthy discussion about the forge yesterday, it was good
15:52:14 <semiosis> i for one am unhappy with gitorious
15:52:18 <purpleidea> semiosis: what was the recap?
15:52:22 <lalatenduM> semiosis,+ 1
15:52:24 <johnmark> lalatenduM: possibly. the whole purpose of the storage SIG is to get packaging in good shape
15:52:37 <johnmark> semiosis: I'm also not happy
15:52:39 * jclift isn't a fan of Gitorious either
15:52:55 <johnmark> I agreed yesterday to look into GitHub organizations - which is free for open source projects
15:52:57 <semiosis> possibilities are: 1. a Github organization, 2. our own Gitlab installation on rscloud
15:53:14 <kshlm> we already have a github org
15:53:15 <jclift> This might also be a conversation to be had on gluster-devel, after we've done some research into options
15:53:18 <johnmark> and also the possibility of looking into gitlab, although that would be painful and, imho, should be avoided
15:53:23 <johnmark> jclift: agreed
15:53:36 <johnmark> kshlm: yeah, but I don't know if it will wokr for our purposes
15:53:48 <johnmark> I don't know how much we can customize it
15:53:56 <johnmark> or create a subdomain, which would be important to me
15:54:08 <johnmark> we want a "gluster community" experience
15:54:13 <johnmark> which may mean creating a frontend to github
15:54:14 <lalatenduM> Github would be good if we include pull requests as part of development workflow , johnmark jclift kkeithley_mtg jdarcy ^^
15:54:19 <kshlm> AFAIK github doesn't support that for free.
15:54:20 <jclift> There's the possibility we could create our own front end for branding purposes (new forge.gluster.org ), and use GitHub API calls to hook things together
15:54:38 <johnmark> kshlm: right. if we need to pay for services, that's also an option
15:54:39 <purpleidea> jclift: yikes!
15:54:42 <kshlm> that would be too much work
15:54:57 <jclift> lalatenduM: Either way.  Now that I'm used to Gerrit I'm ok with it.  There are more people used to the Pull Request approach though. :)
15:54:58 <johnmark> kshlm: agreed
15:55:12 <johnmark> RHT is already paying for the forge.
15:55:19 <purpleidea> jclift: -1 for the pull requests
15:55:22 <johnmark> we would be willing to switch customers if it means we get better service
15:55:26 <semiosis> pull requests would be good for forge projects, even if we dont use them for glusterfs itself
15:55:39 <johnmark> semiosis: right
15:55:47 <lalatenduM> semiosis, yup
15:55:48 <johnmark> ok, first step is to look into github capability
15:55:58 <johnmark> then report to gluster-devel
15:56:02 <jclift> Yeah
15:56:05 <johnmark> and we'll decide if it meets requirements
15:56:07 <johnmark> sound good?
15:56:13 <johnmark> and I have to leave for now.
15:56:15 <jclift> Who has the time/skill/inclination to do it?
15:56:21 <johnmark> the only other thing I want to know is latest 3.5 schedule
15:56:27 <johnmark> we really need it to go out soon
15:56:40 <johnmark> otherwise I fear it will start to delay other things, like 3.6 dev
15:56:52 <jclift> I haven't heard from hagarth about 3.5.0 schedule this week.  I forgot to ask before this meeting. :(
15:57:14 <kshlm> jclift, I can look into the forge replacement
15:57:27 <jclift> And it's likely going to be waiting on docs
15:57:29 <kkeithley_mtg> there are several patches in gerrit for release-3.5 waiting for review.
15:57:34 <johnmark> jclift: true
15:57:37 <johnmark> ok, signing off
15:57:40 <jclift> :)
15:57:42 <johnmark> let me know if I have more AIs :)
15:57:50 <jclift> Of course
15:58:13 <jclift> #action kshlm to investigate Gluster Forge replacement options
15:58:53 <semiosis> imo the benefits of github outweight the downsides.  i dont see any real blockers.
15:59:13 <jclift> kkeithley_mtg: Hmmm, not sure what to do about them, apart from emailing gluster-devel asking for people to review
15:59:45 <jclift> Next item
15:59:47 <jclift> "/ on build.gluster.org keeps filling up, taking itself off-line; cores in /, large /var/log/httpd/access*, and regression, smoke, and rh-bugid build results are the biggest causes. :-("
16:00:11 <jclift> We should be able to do something about the /var/log/httpd/access* stuff pretty easily
16:00:20 <jclift> eg aggressive logrotate maybe
16:00:39 <jclift> Or disable apache logging temporarily
16:00:42 <jclift> Meh
16:00:50 <jclift> Lets discuss that in gluster-infra
16:00:52 <jdarcy> Do we have any unused storage on that machine, or a way to add more?
16:01:06 <jclift> Good question
16:01:15 <jdarcy> Or can something be moved to another machine entirely?  Old results?
16:01:19 <kkeithley_mtg> there's an big lvm volume mounted on /d with lots of room.  / is too small
16:01:21 <purpleidea> jdarcy: ironic that we have a storage problem, eh?
16:01:23 <jclift> build.gluster.org seems to be in Rackspace (from IP address)
16:01:28 <jclift> purpleidea: :)
16:01:35 <kkeithley_mtg> and jenkins may not have been installed in an optimal way
16:01:55 <jclift> However the IP of the build.gluster.org server isn't appearing in the Rackspace account we here have access to
16:02:11 <jclift> So I suspect Avati has a different rackspace account with it or something
16:02:18 <jdarcy> We should be able to shove http stuff onto a different partition, using bind mounts if we have to.
16:02:30 <jclift> If it was in our rackspace account, we could add a new block storage volume to it very easily
16:02:34 <kkeithley_mtg> it's not a rackspace machine AFAIK
16:02:34 <jdarcy> And we should never have developed the habit of cd'ing to / so our cores go there.  :(
16:02:52 <jclift> #action jclift to ask Avati where build.gluster.org is hosted, and try to get more storage allocated
16:02:53 <kkeithley_mtg> (and I have console access finally)
16:03:01 <jclift> kkeithley_mtg: Ahhh, k
16:03:18 <kkeithley_mtg> I know where it is. I'll follow up after the meeting with the info
16:03:53 <jclift> kkeithley_mtg: Should we think about spinning it up on rackspace then?
16:03:54 <kkeithley_mtg> it's not a secret, I just have to grovel through my mail to find it
16:04:00 <jclift> Meh, lets discuss on gluster-infra
16:04:03 <jclift> Next...
16:04:07 <jclift> Last item
16:04:16 <jclift> "Do we have someone to take over RPM packaging yet for Fedora and download.gluster.org?"
16:04:25 <jclift> I'm not sure what that's for?
16:04:40 <kkeithley_mtg> hagarth said a new hire came on board in BLR who could do that.
16:04:41 <jclift> Btw, we're running over time atm.  Let's get this one finished then wrap up
16:04:50 <jclift> Cool
16:05:01 <jclift> Good enough :)
16:05:04 <jclift> Let's wrap it up
16:05:08 <kkeithley_mtg> but I don't know any more about it
16:05:11 <jclift> Thanks for attending everyone. :)
16:05:15 <kkeithley_mtg> ttyl
16:05:41 <jclift> #action jclift to find out who the new hire in BLR is that could do the RPM packaging for Fedora and download.gluster.org
16:05:44 <jclift> #endmeeting