fzug
LOGS
13:02:18 <zsun> #startmeeting FZUG
13:02:18 <zodbot> Meeting started Fri Sep 29 13:02:18 2017 UTC.  The chair is zsun. Information about MeetBot at http://wiki.debian.org/MeetBot.
13:02:18 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
13:02:18 <zodbot> The meeting name has been set to 'fzug'
13:02:18 <K410> trying to broadcast tech activities on twitch.tv... :P
13:02:19 <BadGirl> [2010-08-20 22:18:24] Posted by z/odbot@fedora-zh already: MeetBot - Debian Wiki
13:02:22 <zsun> #topic Roll Call
13:02:34 <zsun> #chair tiansworld K410 lchh
13:02:34 <zodbot> Current chairs: K410 lchh tiansworld zsun
13:03:01 <zsun> 有话题聊嘛
13:03:06 <zsun> 没有就自由讨论啦
13:03:09 <teleboto> [Ro Lu] #info robberphex
13:03:40 <zsun> @roberphex tg那边用不了命令
13:03:52 <zsun> .hellomynameis zsun
13:03:53 <zodbot> zsun: zsun 'Ziqian SUN (Zamir)' <sztsian@gmail.com>
13:04:06 <K410> .hellomynameis kaio
13:04:07 <zodbot> K410: kaio 'Caius Chance (かいお)' <me@kaio.net>
13:04:29 <teleboto> [zsun_remote] 「Re Ro Lu: #info ro...」发现你没设置username,所以在IRC上不能at你(
13:04:52 <teleboto> [Ro Lu] .hellomynameis robberphex
13:04:55 <tiansworld> .hellomynameis tian
13:04:56 <zodbot> tiansworld: tian 'None' <tian@c-sait.net>
13:05:05 <zsun> tiansworld:  xD
13:05:24 <teleboto> [Ro Lu] 没事,方便记录会议日志,标明身份
13:05:29 <tiansworld> .hellomynameis tiansworld
13:05:30 <zodbot> tiansworld: tiansworld 'None' <tiansworld@gmail.com>
13:06:57 <zsun> #topic Fedora 27
13:07:05 <teleboto> [Ro Lu] 我觉得可以讨论下MBP如何使用Fedora
13:07:08 <tiansworld> 这个其实该放在开始会议前进行。不然邮件地址都被收到会议记录了。
13:07:46 <zsun> #info Fedora 27 Beta is a GO, release on October 03, 2017
13:08:44 <zsun> tiansworld: 有道理。也许可以考虑给 zodbot 提个issue
13:09:15 <zsun> 话说群里有多色MBP/MBA用户?我是ThinkPad党(
13:09:58 <teleboto> [Ro Lu] :(
13:10:10 <zsun> 穷,没办法(
13:10:19 <tiansworld> 这个不算是zodbot的问题。
13:10:21 <zsun> ThinkPad都是二手的
13:10:43 <teleboto> [Ro Lu] #topic 如何打包electron-based的软件
13:11:09 <lchh> ThinkPad +1
13:11:18 <zsun> tiansworld: 按照 Council 的讨论似乎是认为ambassador和各subproject的leader就应当公开邮箱地址,便于人联络(
13:11:25 <zsun> 也许我的翻译不妥。
13:11:55 <zsun> @robberphex 这个。。。群里有谁是packager?
13:12:11 <zsun> 我没打过electron为基础的包
13:12:15 <tiansworld> 到也没问题。就怕被垃圾邮件骚扰。
13:12:43 <zsun> tiansworld: 所以我刚刚想的是,给zodbot提RFE让记录log时做下转换
13:13:06 <tiansworld> 也可。
13:13:07 <teleboto> [Ro Lu] electron-based的软件,要push到官方,非常麻烦(node的依赖要一个一个打包)
13:13:28 <zsun> F27有其他内容么
13:13:31 <lchh> Node 怕不是打包地狱?
13:13:38 <zsun> 没有的话讨论下打包也不错
13:14:33 <zsun> no objections?
13:14:49 <tiansworld> 当然可以
13:14:54 <zsun> #topic Packaging
13:15:29 <zsun> lchh 说的有道理。我记得Mosquito尝试过推动electron进Fedora。但是遇到了困难
13:15:42 <teleboto> [Ro Lu] 我想知道http://pencil.evolus.vn/的打包者现在是什么心情
13:15:42 <BadGirl> Home - Pencil Project
13:16:04 <teleboto> [Ro Lu] pencil 3.x切换到electron了
13:16:31 <lchh> 我个人不用 Node, 但是也听闻过 Node 项目要一堆依赖
13:16:41 <zsun> 他。。。。
13:17:12 <zsun> tuanta。 APAC Ambassadors 的前协调人
13:17:43 <zsun> 上次更新是1年之前了
13:17:58 <teleboto> [Ro Lu] 我记得要打一个all in one的rpm也是可以的。
13:18:16 <teleboto> [Ro Lu] 1、包元信息里面标记用到了那些依赖
13:18:27 <teleboto> [Ro Lu] 2、我记得要申请例外?
13:18:36 <teleboto> [Ro Lu] 请求确认
13:18:58 <zsun> 我确认不了。。没搞过这么麻烦的
13:18:59 <zsun> https://github.com/FZUG/repo/blob/master/rpms/electron/electron.spec
13:19:09 <zsun> 你可以问问Mosquito
13:19:16 <zsun> 发个issue啥的,然后我ping他
13:19:42 <teleboto> [Ro Lu] 这个打包不难,难得是如何符合官方标准
13:20:10 <teleboto> [Ro Lu] 官方标准导致一大批软件无法进入
13:20:18 <teleboto> [Ro Lu] 比如github atom
13:20:33 <lchh> 我很好奇 spec 文件是生成的还是自己写的?
13:20:39 <zsun> 有中文用户组源啊
13:20:48 <zsun> lchh: 手写为主
13:21:14 <zsun> @robberphex 很多没法进入官方的,没有法务问题我们都可以打包到中文用户组源
13:21:21 <zsun> 虽然现在CI平台有问题
13:21:56 <zsun> 中文用户组这边有不少electron相关的issue。。。 https://github.com/FZUG/repo/issues?utf8=%E2%9C%93&q=is%3Aissue%20electron
13:23:53 <zsun> 我们现在都太忙,非常缺乏帮手
13:24:21 <lchh> 所以看了一下我觉得是不是应该把中文用户组源放到 Copr 上?
13:24:34 <zsun> 不行,因为不符合Fedora的规定
13:24:37 <teleboto> [Ro Lu] 可以搞一个task list,让新人知道干啥
13:24:41 <zsun> 符合规定的我们都在尝试推送
13:25:07 <zsun> all todo list https://github.com/FZUG/repo/projects/1
13:25:29 <zsun> 最近在折腾的 - 推送官方源的 https://github.com/FZUG/repo/issues/53
13:25:50 <lchh> 那么所以这个源 rpm 的构建是在哪里完成的?
13:26:04 <zsun> FDZH捐助的服务器上
13:26:21 <lchh> Sounds cool
13:26:24 <zsun> 啊搞清楚,是FDZH的,不是FZUG自己的。。。
13:26:30 <zsun> 所以约束很多
13:27:17 <lchh> 有区别吗?
13:27:32 <zsun> FDZH是一个第三方的Fedora网站
13:27:45 <zsun> FZUG是Fedora 中文用户组 的英文简写
13:27:55 <zsun> 差异很大
13:28:12 <teleboto> [Ro Lu] 1、目前为止没有法律问题的electron包,都可以push到fdzh
13:28:31 <zsun> s/到fdzh/到fzug
13:28:34 <teleboto> [Ro Lu] 2、目前electron包推送到官方repo,难度很大
13:28:43 <zsun> Ack 1 with modification
13:28:45 <teleboto> [Ro Lu] …
13:28:50 <zsun> ack 2
13:31:02 <teleboto> [Ro Lu] 那fdzh这边有类似fedora的 build testing update这个流程吗?
13:32:13 <paper318> 坏了坏了,来晚了
13:32:26 <paper318> meeting?
13:32:37 <zsun> @robberphex  啊我觉得我不该提FDZH
13:32:43 <zsun> 现在感觉更乱了
13:32:48 <lchh> FDZH 和我们有什么关系吗?
13:33:05 <zsun> FDZH为我们提供了赞助
13:33:24 <zsun> (果然早该听高层的独立寻求资助)
13:33:39 <lchh> 那么赞助的服务器配置如何?
13:33:59 * zsun 不是sysadmin
13:34:12 <zsun> 可以确定的是,是共享的vps
13:34:54 <tiansworld> 跑题了
13:35:07 <lchh> 如果 Build Service 所要的服务器资源不是很大的话可以考虑赞助
13:35:20 <zsun> lchh: 我在考虑改进编译方式
13:35:42 <teleboto> [Ro Lu] 我在想,可以让developer在Travis ci里面写上将ci完成后的rpm上传到fdzh的build服务器,然后人工确认推到fdzh的repo
13:35:42 <teleboto> [Ro Lu] zsun 我觉得fedora的规则要改一改了
13:35:43 <zsun> 由私有机器编译,编译好之后推送到服务器
13:35:43 <teleboto> [Ro Lu] 打包规则
13:35:56 <zsun> 这样就不需要很强大的CPU了
13:36:07 <zsun> @robberphex 差不多。
13:36:27 <zsun> 关于Fedora官方的规则,怕是不可能更松了
13:36:38 <lchh> Fedora 的规则是怎样的?
13:36:46 <lchh> 还真没怎么了解
13:37:29 <zsun> lchh Fedora 官方打包是推送SPEC和source的URL到dist-git,如 https://src.fedoraproject.org/rpms/danmaq
13:37:29 <BadGirl> Overview - rpms/danmaq - Pagure
13:37:54 <zsun> 然后koji编译
13:38:17 <zsun> 编译好了,packager如果认为可以发布,要发bodhi
13:38:36 <zsun> bodhi上测试通过了,或者过了soak time,可以push 到 stable(就是发布了
13:39:11 <lchh> 看起来挺麻烦的
13:39:13 <teleboto> [Ro Lu] 我们为什么不发散下思维呢?developer为啥不能将自己的软件直接给用户呢?比如自建repo?
13:39:26 <zsun> 那就是copr啊
13:39:52 <lchh> @robberphex Copr
13:40:00 <zsun> Fedora的copr不需要packager权限,只要包不违反Fedora的规定就可以在其中打包
13:40:05 <lchh> 我觉得甚至还可以 Flatpak
13:40:49 <teleboto> [Ro Lu] #topic flatpak
13:40:50 <teleboto> [Ro Lu] 哈哈
13:40:58 <zsun> 其实由开发者打包这个想法现在认可度是高一些的。。。 Gerard 在一次GNOME活动上还提过这个思想
13:41:10 <zsun> flatpak我不懂。。。留给将来Gerad在线的时候吧
13:41:19 <zsun> (他最近太忙,就不ping他了)
13:41:21 <teleboto> [Ro Lu] copr的问题在于和ci结合太少
13:41:33 <zsun> copr不难结合
13:41:36 <zsun> 有token
13:41:36 <teleboto> [Ro Lu] 而且需要src.rpm,太麻烦
13:41:45 <zsun> 你想多了
13:41:59 <zsun> 我可以很容易实现spec到srpm啊
13:41:59 <lchh> 还有"对面"阵营的 snap
13:42:28 <zsun> https://github.com/FZUG/repo/blob/master/repos/rebuildtool.sh
13:42:44 <zsun> 我还专门搞了这么个工具,做临时性的mass rebuild用
13:42:51 <zsun> 所以copr本身不是难题
13:43:02 <zsun> 而且其实最初中文用户组的repo末端就是copr
13:43:20 <zsun> 后来因为赞助方的资源不够了,才降到了mock
13:43:30 <teleboto> [Ro Lu] 我线下看看copr和github的结合
13:43:42 <teleboto> [Ro Lu] 现在很多软件,不都是直接在release 页面上传rpm包嘛。
13:43:43 <teleboto> [Ro Lu] 我觉得可以写一个DNF插件,完成新版检测、自动更新功能(利用github的api?)
13:44:05 <zsun> 啊我觉得你是思路很好
13:44:11 <zsun> 而且应该有,或者很容易实现
13:44:37 <teleboto> [Ro Lu] 这两个需要加action吗?哈哈
13:44:39 <zsun> 而对于中文用户组,现在最大的问题反而是,没有公网可自由使用的服务器
13:44:47 <zsun> 如果你愿意(
13:45:06 <zsun> #action robberphex look into copr integration with github
13:45:20 <teleboto> [Ro Lu] zsun thx
13:45:23 <zsun> 只要有地方能发布repo,这些问题都不是问题了
13:45:49 <zsun> AOSC OS的做法就是,用一致的工具编译,然后有权限的用户可以推送到官方repo
13:46:22 <lchh> 嗯,逛了一圈 Flatpak.org ,发现居然没上 HTTPS。。
13:46:24 <zsun> 那样充分分散了CPU需求
13:46:49 <teleboto> [Ro Lu] zsun 不能确保上传的二进制包是不是来自源码,甚至有没有后门
13:47:00 <teleboto> [Ro Lu] 所以core不能这么干吧
13:47:44 <teleboto> [Ro Lu] 一些以root运行的包,还是在build server编译吧😅
13:47:51 <zsun> 理论上是的。实际上有权限直接上传的人毕竟是少数受信任的开发者
13:49:02 <zsun> 16个开发者维护6个架构。。想想AOSC的开发者的努力程度(
13:49:55 <zsun> 这个道理其实与谁负责维护编译服务器差不多
13:50:00 <zsun> 唉又远了
13:50:36 <zsun> 如果有人能提供或者找到webserver的赞助(最好是HK的机器),大多数问题就不是问题了
13:50:49 <zsun> (对fedora 中文用户组而言)
13:50:56 <lchh> 众筹?
13:51:00 <zsun> no
13:51:08 <zsun> 违反Fedora规定。
13:51:33 <teleboto> [Ro Lu] 我不觉得众筹是一个好主意
13:51:48 <zsun> 我并没有把这个列入action。反正包总是有办法的。。
13:51:58 <teleboto> [Ro Lu] 但是user group也要遵守fedora规定吗?
13:52:33 <zsun> 好问题。。。那我仍然不能参与(考虑到Ambassador身份)
13:52:44 <paper318> zsun: 问个事:重庆那边得拿点宣传材料什么的吧(小册子,贴纸,光盘)我可以帮忙带过去嘛
13:52:53 <teleboto> [Ro Lu] 好消息是,我不是大使
13:52:54 <zsun> paper318: 没有物资了。
13:53:04 <zsun> paper318: 光盘已经寄过去了
13:53:22 <zsun> lchh也不是
13:53:27 <paper318> 哦哦
13:53:28 <lchh> 我其实比较好奇服务器资源的占用,如果开销不是很大的话我可以考虑赞助
13:53:28 <zsun> 其实我们非常缺乏大使
13:53:29 <teleboto> [Ro Lu] 坏消息是 我不是大使😂
13:54:04 <zsun> #action zsun query server resource consuming for current FZUG repo
13:54:09 <zsun> 我问问,回头给你消息
13:54:28 <zsun> 你是lichs对吧
13:54:34 <lchh>13:54:38 <zsun>13:54:40 <lchh> 需要证明吗?
13:54:43 <zsun> 不哟个
13:54:47 <zsun> 不必
13:55:20 <zsun> 啊今天讨论packaging的问题讨论了不少
13:55:48 <teleboto> [Ro Lu] 还有一个flatpak 是不是没有说到
13:56:03 <zsun> @robberphex 如果你有打包的建议(添加××软件包之类),可以去github/fzug/repo 开issue或者pr
13:56:12 <zsun> flatpak我刚刚说留给以后聊吧
13:56:25 <teleboto> [Ro Lu] 哦…ok
13:58:23 <zsun> 今天时间也差不多了。。。可以会后继续聊
13:58:39 <zsun> 对了 tiansworld 如果你用telegram, 可以到channel里来。会议结束后我发地址
14:00:02 <zsun> #endmeeting