fedora-websites
LOGS
00:59:07 <mchua> #startmeeting
00:59:07 <zodbot> Meeting started Tue Nov 10 00:59:07 2009 UTC.  The chair is mchua. Information about MeetBot at http://wiki.debian.org/MeetBot.
00:59:07 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
01:00:24 <YeLong> why do we come here?
01:01:08 <mizmo> hi YeLong, this is the Fedora websites channel
01:01:16 <mizmo> welcome :)
01:01:17 <mchua> YeLong: We're here because this is the place where the Fedora Websites team does their work, and we're going to be helping them today.
01:01:35 <YeLong> I see.
01:04:11 <mchua> mizmo: We've got logging on, so go ahead and tell us what we're working on today ;)
01:04:22 <tira> thank you for joining us the teachingopensource-posse students
01:04:31 <mizmo> mchua: one quick question, do folks have FAS accounts?
01:04:49 <mizmo> mchua: to commit stuff to git i think they need them
01:04:50 <mchua> mizmo: Almost all, if not all.
01:04:53 <mizmo> hi tira :) it's nice to meet you
01:04:56 <mizmo> mchua: oh okay great
01:05:09 * mchua does a quick introduction
01:05:21 * mchua is Mel Chua, one of the instructors in this week's POSSE in Singapore (but most of you already know that ;)
01:06:30 * mizmo is Máirín Duffy, I'm a designer who works on Fedora and I live in Boston (it's 8 PM here now) :)
01:06:50 <mizmo> this is my picture: http://mairin.wordpress.com/2009/11/06/get-to-know-a-fedora-ambassador-or-user/
01:07:02 <mizmo> mchua: should i go ahead and start?
01:07:07 <YeLong> good evening mizmo, it's 9 AM in singapore
01:07:23 <mizmo> YeLong: lol you're living in the future :) I'm living in yesterday :)
01:07:25 <YeLong> go aheadm, mchua
01:07:39 <mchua> mizmo: go for it
01:07:48 <mizmo> okay cool
01:07:51 <mizmo> so for the Fedora project, we have a bunch of different versions of Fedora for special purposes
01:07:58 <mchua> mizmo: and whenever you need to go, that's totally ok - thanks for sticking around so late tonight to help us!
01:08:17 <mizmo> we have one that's made for designing electronics.... one for playing lots of games... and ones that have different styles of desktops
01:08:24 <tira> mizmo: cute pic ;)
01:08:32 <mizmo> thanks tira :)
01:08:50 <mizmo> we decided it would be good to have one nice central website where people can find information about these versions of fedora (called 'spins') and be able to download them
01:09:00 <mizmo> so I designed some mockups for how the site should look.
01:09:06 <mizmo> here is the link to the mockups, look through them:
01:09:16 <mizmo> https://fedoraproject.org/wiki/Website_redesign_2009/Mockups/Spins.fpo
01:09:27 <mizmo> today you're going to help us make these designs a reality :)
01:10:40 <mizmo> so here's an example of a spin page - it's for LXDE, which is a type of desktop:
01:10:42 <mizmo> https://fedoraproject.org/w/uploads/8/80/Spin-details-lxde-home.png
01:11:03 <mizmo> there is a team of people who work on each spin
01:11:13 <mizmo> and they submitted content that they wanted in the pages for their spin
01:11:25 <mizmo> so your task is to take the content the spin owners gave us and turn it into web pages
01:11:52 <mizmo> we have the base templates and code for the website in place, we just need to fill in specific details for each spin.
01:12:04 <tira> mizmo: On the XFCE art, whats with the mice jumping in the air? are they on hashish or something?
01:12:16 * mchua falls over laughing
01:12:21 <mizmo> tira: lol
01:12:31 <mizmo> tira: the mouse is the logo for XFCE
01:12:46 <mchua> "XFCE: It makes you happier than hashish"
01:12:48 <mizmo> tira: they are running so fast they are kicking up a cloud of smoke.
01:12:54 <mizmo> tira: but they're not smoking anything ;-)
01:13:20 <mizmo> so all the frame work for the website is put together. there are instructions on how to download and run it here:
01:13:21 <mizmo> http://fedoraproject.org/wiki/Websites/ShowUs
01:13:40 <mizmo> everything for the spins site is in the directory spins.fedoraproject.org that will be created after you go through the steps at http://fedoraproject.org/wiki/Websites/ShowUs
01:14:18 <mizmo> the content that the spin creators put together for their pages is linked to here:
01:14:19 <mizmo> https://fedoraproject.org/wiki/Website_redesign_2009/Mockups/Spins.fpo#Spins_Content
01:14:25 <mchua> mizmo: is there an example of a spin page that is finished, so that we know what we are aiming for?
01:14:30 <mchua> (and how do we know we are done?)
01:14:34 <mchua> (and where do we submit our work?)
01:14:41 <mizmo> with one exception - the electronics lab content is here:http://chitlesh.fedorapeople.org/FEL/
01:14:59 <mchua> (and how do we tell which spin pages are done or not?)
01:15:01 <mizmo> mchua: well the test server is here. it updates from the git repo every hour or so http://spins-test.fedoraproject.org/
01:15:34 <mizmo> mchua: none of them are really finished, some of them are partially done by sijis and the design team
01:16:24 <mizmo> mchua: it looks like sijis actually did a lot more than i thought he had :-/
01:16:31 <mizmo> mchua: the electronics lab one is empty though
01:16:43 <mchua> sijis_afk: you, sir, are awesome
01:17:19 <mizmo> the games one also needs filling in
01:17:26 <mizmo> the tabs besides the 'games' tab are unfinished
01:17:57 <mchua> mizmo: is there a checklist of which parts of which pages need to be finished, or should our first job be to make one?
01:18:01 <mizmo> mchua: so there are examples of some of how the spins pages should look when they are finished starting here with FEL: https://fedoraproject.org/wiki/Website_redesign_2009/Mockups/Spins.fpo#Fedora_Electronic_Lab_Spins_Mockups
01:18:10 <mizmo> mchua: i think the first job should probably be to make one
01:18:44 <mchua> mizmo: can do!
01:18:52 <mizmo> mchua: lxde needs to be filled in too. it's tricky because it's not listed on the fornt page, you have to know the url: http://spins-test.fedoraproject.org/lxde/
01:19:06 <mchua> #action Task 1: Make a "what needs to be done" chart for each spin listed on https://fedoraproject.org/wiki/Website_redesign_2009/Mockups/Spins.fpo
01:19:38 <mchua> mizmo: is there a sample finished page we can look at to make sure we have all the features for each page in?
01:20:03 <mchua> mizmo: html-wise, I mean
01:20:03 <mizmo> mchua: no, you want to look at the mockups i pointed at for that
01:20:21 <mchua> mizmo: oh, okay.
01:20:27 <mchua> d'oh, right, you said that none of them were finished yet.
01:20:40 <mizmo> it's all good :)
01:20:45 <mchua> mizmo: how do we know where the links should go?
01:20:56 <tira> mizmo : Since XFCE is supposed to fly in comparision with others, perhaps we could add some rockets for the mice to ride on and the smoke is the after burner?
01:20:57 * mchua waves at the rest of the class to also ask questions, too!
01:21:07 <mizmo> mchua: the wiki writeups the spins owners put together *should* have the links in them
01:21:23 <mizmo> mchua: if you ever run into a case where there's a missing link make the link <a href="#MISSING"> so we can track them down easily afterwards
01:21:26 <mchua> and if they don't we can email the spin owners and go "hey, what's up?"
01:21:37 <mchua> #info if there's a missing link, make the link <a href="#MISSING">
01:21:37 <mizmo> tira: that's a very cool idea actually
01:21:43 <mizmo> tira: give the mouse a cute rocket helmet :)
01:22:10 * mchua looking at http://spins-test.fedoraproject.org/ and going oooo, nice!
01:22:20 <mchua> and also "ooh, we have a lot of work to do today"
01:22:25 <mizmo> :)
01:23:07 <mchua> mizmo: where should we report back when we're done (or when we have to leave for the day, whichever one comes first)?
01:23:25 <mchua> mizmo: and should we be pushing code straight to git (if we can get someone to grant group access) or using the ShowMe instructions?
01:23:36 <mizmo> mchua: fedora-websites-list@redhat.com is a good place to report back
01:23:49 <mizmo> mchua: i will be around-ish for the next 4 hours or so
01:24:11 <mchua> Cool.
01:24:18 <mizmo> mchua: which method would be easier?
01:24:20 <mchua> Anybody else have any questions? I think I'm finished with mine.
01:24:29 <mchua> mizmo: Well... git, if we can get access.
01:24:30 <mizmo> mchua: let me see if i have permissions to grant website commit access (i'm not sure if i do)
01:25:58 <martz927> hello all
01:25:59 <mizmo> mchua: my role type is 'user' i dont think i can sponsor people then
01:26:04 <ianweller> mizmo: correct
01:26:06 <ianweller> .sponsors web
01:26:07 <zodbot> ianweller: Sponsors for web: ivazquez @nman64 @quaid ricky @skvidal
01:26:11 <ianweller> those people can!
01:26:19 <tiansworld> where is the Fedora 12 website page ? Is it available now? I just want to view/check the translations
01:26:21 <mchua> oh hey, quaid is around
01:26:23 <mchua> quaid: ping
01:27:17 <mizmo> tiansworld: http://fedoraproject.org/zh_CN/
01:27:20 <ianweller> s/is/was/ ;)
01:28:01 <tiansworld> mizmo: it is the Fedora 11 websites
01:28:32 <mchua> mizmo: I think tiansworld is asking, if we want to help translate the new design into Chinese, what design should we be translating?
01:29:57 <tiansworld> mchua: well, I just want to view the translations in the page, so we can find if there are some mistakes
01:30:21 <tiansworld> some little mistakes may not be found in the PO
01:30:24 <tiansworld> PO file
01:30:46 <mizmo> mchua: that i dont know
01:31:38 <mizmo> mchua: i know there are po files in the git repo
01:31:44 <mizmo> mchua: but i dont know much about how that all works
01:31:55 <mchua> mizmo: Ok, no problem, we'll just do the spins stuff for now
01:32:10 <mizmo> kk
01:32:11 <mchua> mizmo: harish-xchat-upf is going to stand in for me for a bit - I need to drop to the back to work on a press release.
01:32:21 <mchua> mizmo: (harish is the other instructor today)
01:32:28 <mizmo> okay
01:32:41 <harish-xchat-upf> mizmo, hi!
01:32:48 <mchua> harish-xchat-upf: ask lots of questions, make sure everyone's on the same page about what we're doing, and that everyone has a FAS account... then start figuring out how to make a task table on the big ol' whiteboard up front
01:32:50 <mizmo> hi harish-xchat-upf how are you doing?
01:32:53 <mchua> or at least that's what I'd do
01:33:10 <harish-xchat-upf> mizmo, great. just trying to herd cats as it were
01:33:15 <mizmo> lol
01:34:05 <harish-xchat-upf> so, i am trying to get the group here to update the f12 site you have been working on. please tell me what we can do.
01:34:14 <harish-xchat-upf> or if there is a document, point me there.
01:34:25 <mizmo> harish-xchat-upf: well i pretty much explained it all up there ^^ :)
01:34:31 <mizmo> harish-xchat-upf: do you have the back log?
01:34:46 <mizmo> i dont know how the bot works
01:34:53 <mizmo> so im not sure how to get the back log besides copy/paste
01:35:12 <harish-xchat-upf> mizmo, pastebin?
01:35:17 <mizmo> #halp
01:35:22 <mizmo> #help
01:35:40 <mizmo> stupid bot
01:35:47 <ianweller> there's no meeting in here right now
01:35:47 <mizmo> okay ill paste bin it harish
01:35:51 <ianweller> i think
01:36:00 <mizmo> ianweller:
01:36:00 <mizmo> <zodbot> Meeting started Tue Nov 10 00:59:07 2009 UTC.  The chair is mchua. Information about MeetBot at http://wiki.debian.org/MeetBot.
01:36:01 <mizmo> Useful Commands: #action #agreed #halp #info #idea #link #topic.
01:36:03 <ianweller> ohw ait yeah there is.
01:36:13 <ianweller> #chairs
01:36:16 <ianweller> .chairs
01:36:28 <ianweller> weird.
01:37:01 <mizmo> harish-xchat-upf: http://fpaste.org/oMDH/
01:41:49 <zodbot> Announcement from my owner (nirik): Fedora 12 has gone gold!
01:43:52 <harish-xchat-upf> #help
01:44:41 <mchua> mizmo: oh, I can get the logs
01:45:08 <mchua> #link http://meetbot.fedoraproject.org/fedora-websites/2009-11-10/
01:45:18 <mchua> #chair
01:45:18 <zodbot> Current chairs: mchua
01:45:23 <mchua> ianweller: ^^
01:45:39 <mchua> oo, F12 gold! do we get a party now? ;)
01:48:04 <mchua> mizmo: I think we've got enough to get started, btw, so we'll ping and holler in channel if we need help, and I think we can figure it out even if everybody has to leave and sleep and stuff
01:48:09 <mchua> mizmo: thank you so much!
01:48:11 <mizmo> mchua: okay sweet
01:48:13 <mizmo> my pleasure
01:49:04 <tiansworld> how to add other language support to the "fedora release counter"?
01:49:38 <tiansworld> Now I see it says "Currently, the values de, en, hu, is, it, pt_BR, ru, and tr are supported."
01:50:13 <Omnifarious> http://fedoraproject.org/static/fedora.css contains this section:  pre { font-size: 2.6ex; overflow: auto; }
01:50:48 <Omnifarious> That section causes the pre sections to be so incredibly huge as to be useless.
01:50:48 <Omnifarious> I've taken to using firebug to edit it out.
01:51:36 <mizmo> tiansworld: I don't know the answer to your question unfortunately :( ricky knows a lot about how translations work but he isn't around i don't think
01:52:00 <mizmo> Omnifarious: the way font sizes on fpo work is a little strange. I think everything is scaled down by a percentage so in practice i think 2.6ex won't really be 2.6ex
01:52:32 <Omnifarious> Well, that doesn't explain why the font is utterly huge on my screen until I use firebug to edit that bit out.
01:52:51 <mizmo> Omnifarious: oh okay i dont really know
01:52:57 <tiansworld> mizmo: thank you ,may be next time when ricky is around.
01:53:12 <mizmo> Omnifarious: I've not had problems with pre tags viewing fpo before, but i dont doubt you may have found an issue
01:53:51 <Omnifarious> I've always had a problem.  But I also have the fonts set differently from the default in Firefox.
01:54:12 <mizmo> Omnifarious: ah okay that may be affecting it too
01:54:20 * Omnifarious nods.
01:54:29 <Omnifarious> Though that causes me no problems anywhere else.  :-)
01:59:22 <mizmo> Omnifarious: it may be related to the weird % controls on the fedora website
01:59:29 <mizmo> Omnifarious: it used to happen to me a while back too
01:59:36 <mizmo> Omnifarious: but when I upgraded the problem went away
02:02:22 <harish-going-for> COFFEE break all!
02:08:27 <Omnifarious> mizmo: Interesting.
02:34:43 <mchua> mizmo mizmo mizmo! I think we just had a MOMENT OF WIN
02:34:52 <mizmo> mchua oh yeah?
02:35:02 <mchua> and I'm going to ramble out loud about it for a bit because I want to try to understand it and how to reproduce it
02:35:18 <mchua> Okay. So we had the chat here, and you were explaining to us what we would be doing.
02:35:21 <mchua> And everyone was confused.
02:35:23 <mchua> Like, really confused.
02:35:29 <mchua> And sort of asking questions, but mostly just confused.
02:35:32 <mchua> And frustrated.
02:36:01 <mchua> (not because of you - but because this is a new experience for them, they don't know how to cope with it yet)
02:36:20 <mchua> So after everyone had a FAS account, I called us all to the front of the room, where we have a projector
02:36:23 <mchua> and said "okay, who's confused?"
02:36:25 <mchua> and everyone raised their hand
02:36:40 <mizmo> hehe
02:36:41 <mchua> (and I raised my hand too, and Harish did too)
02:36:51 <mchua> and I think there was a "wtf? they don't know what they're teaching?" moment
02:36:59 <mchua> and Harish pulled out a marker and wrote "PRODUCTIVELY LOST" on the board
02:37:12 <mchua> and we said "yesterday, we told you that this was the most important skill you'd learn this week"
02:37:19 <mchua> "now we're all lost"
02:37:22 <mchua> "let's figure out how to be productive"
02:37:44 <mchua> so we all decided we were going to figure out what the hell it was, the project we were supposed to be doing, from what we could remember of our chat here.
02:37:58 <mchua> I passed out markers, made people go to the board and write down fragments of what they could remember, questions that they had
02:38:04 <mchua> There are some great ones, I'll take a picture
02:38:18 <mchua> and we got some things out, mostly questions of what we were confused about, what we needed to learn.
02:38:28 <mchua> Then we pulled down the projector screen and threw up the chat log.
02:38:46 <mchua> And went through the chat, pretty much line by line, trying to figure out the question of what we were doing
02:38:56 <mchua> getting it really, really wrong at first
02:39:02 <mchua> ("are we working on fedora 12?")
02:39:16 <mchua> ("why did she give us a link to a wiki page? I thought we were supposed to be getting code")
02:39:45 <mchua> and then we got to this line: "we decided it would be good to have one nice central website..."
02:39:49 <mchua> and lights started turning on
02:40:08 <mchua> (and along the way, we were pausing and pointing to unfamiliar words on the screeen - "what's git?" "It's version control." "what's version control?")
02:40:17 <mizmo> hehe
02:40:18 <mchua> (and the people who knew explained to the people who didn't know)
02:40:34 <mchua> and eventually it dawned "OH! She is asking us to make a website!"
02:40:49 <mchua> Not just any website, but the website for these "spins" things
02:41:12 <mchua> Okay, and the rest of the chat log is probably notes and suggestions and things that she is telling us that we need to know to make the website
02:41:18 <mchua> But the code we are checking out is the html code for the website
02:41:22 <mchua> and the code we are writing is html for the website
02:41:30 <mchua> and our project basically is the website
02:41:33 <mchua> mizmo: this took, like, 30 minutes.
02:41:47 <mchua> It also included an extensive discussion of "well this is too messy, why didn't you just TELL us that"
02:41:51 <mizmo> that's not bad considering how new it must be to them
02:42:00 <mchua> and I said "well, I didn't know either! We're all figuring this out together, this is how we figure this out"
02:42:10 <mchua> this is how you learn how to deal with this sort of messy and confusing world
02:42:19 <mchua> you ask questions, you try things.
02:42:42 <mchua> (one of the questions on the board was "how do we make the info more structured for learning?" and I wanted to make sure that we had a little bit of a discussion on what the tradeoffs were if you did that)
02:42:59 <mchua> (it makes it easier to get that specific task done, but you also don't learn how to deal with anything except structured problems)
02:43:05 <mchua> (and these are the kind you face at work)
02:43:39 <mchua> mizmo: anyway, after the "OH! We're making a WEBSITE! for SPINS!" triumphal lightbulb-turns-on moment, I decided that we should take a reward coffeebreak
02:43:41 <mchua> and that's where everyone is now
02:43:55 <mchua> and I'm sitting in front of my computer typing this and going "whoa, that was cool"
02:44:08 <mizmo> hehe
02:44:09 <mchua> mizmo: ...and now we need to figure out how to make this moment happen for Design POSSE too ;)
02:44:18 * mchua done with excited spewingness
02:44:29 <tiansworld> :)
02:45:00 <mchua> tiansworld: *completely* did not plan this.
02:45:05 <mchua> tiansworld: how do you think it went?
02:45:30 * mchua going to grab a drink, brb
02:45:36 <Omnifarious> I hate git.  :-/
02:45:53 <spevack> Omnifarious: me too
02:46:05 <tmz> Omnifarious: Give it a chance.  It's a really useful tool.
02:46:08 <ianweller> i prefer hg personally
02:46:08 <tiansworld> mchua: I am viewing the words you type
02:46:36 <Omnifarious> I think the only reason it's popular is the cachet that comes with Linus' name and being used for kernel development.  *sigh*
02:46:50 <spevack> mchua: awesome story
02:47:51 <tmz> Indeed.
02:48:13 <tmz> I'm always happy to try and help with the annoying details of git when I'm around here.
02:48:53 <nb> tmz is the git master
02:48:55 <nb> :)
02:49:01 <tiansworld> I think it will be good if we mark the question in bold type
02:49:21 <tiansworld> we can find them easily
02:49:41 <tmz> nb: Haha. ;)
02:50:46 <tiansworld> and also to us non English speaking guys, we are confused about some phrases and sentences
02:51:20 <Omnifarious> mchua: That is a neat story.
02:51:46 <Omnifarious> I'm now curious because there is a lot of story behind it that I'm missing.
02:53:26 <Omnifarious> tmz: My solution for git is to convert it to some other sort of repository and use that instead.
02:56:36 <mchua> Omnifarious: I'd love to fill in more of the story, so ask away - I'm not sure what I'm missing.
02:57:06 <mchua> tiansworld: If we are using some phrases and sentences that don't make sense, remind us, and we'll explain
02:57:14 <mchua> tiansworld: it actually helps me a lot when you remind me of that kind of thing
02:59:02 <tmz> Omnifarious: Heh, I do the same thing with other SCM repositories. :)  Thankfully, there's work being done to make it easier for everyone to use the SCM they like best.
03:08:48 <mchua> All right, fair warning to all the experienced Fedora folks in this channel: we're about to teach a whole bunch of people new to git... how to use git.
03:08:56 <mchua> Chaos will probably ensue.
03:09:07 <mchua> Any assistance with easing the pain is much appreciated.
03:16:27 <sijis_afk> mchua: i apologize for not sending you that list.. i was going to compile it now.. but i'm late :(
03:17:35 <tmz> mchua: If it helps to point folks at some reading material, there's http://www.git-scm.com/documentation and a short quick reference doc on the Fedora wiki at https://fedoraproject.org/wiki/Git_Quickref
03:18:18 <Omnifarious> mchua: Mostly I'm wondering who you and these other people are.  :-)
03:18:59 <sijis> for quick git intro, i typically point to: http://www.spheredev.org/wiki/Git_for_the_lazy
03:21:51 <tiansworld> mchua: thanks for some git guide
03:24:08 <nb> Omnifarious, we are all members of the fedora websites team
03:26:25 <Omnifarious> nb: Except, it sounds like mchua and the people mchua was talking to are relatively new to the team and are geographically located near one another.
03:26:47 <nb> oh, sorry, i thought you were one of the ones mchua was talking to
03:27:36 <tiansworld> i think i am new to this team,
03:27:39 * nb wasn't paying attention
03:43:33 <mchua> sijis: no worries, I think we got it
03:43:44 <mchua> tmz, sijis ooh, docs, thanks!
03:43:51 <mchua> #link http://www.git-scm.com/documentation
03:43:58 <mchua> #link https://fedoraproject.org/wiki/Git_Quickref
03:44:07 <mchua> #link http://www.spheredev.org/wiki/Git_for_the_lazy
03:44:28 <mchua> Omnifarious, nb: Yep, we're at http://teachingopensource.org/index.php/POSSE_APAC
03:44:47 <rudi> Hey all -- can anyone look at some apparently broken PHP for me? I seem to have toasted part of docs.fp.o :(
03:44:47 <mchua> #info Zhang Xinyi and Ye Long are working on the Electronics Lab Spin page
03:44:57 <Omnifarious> mchua: Oh, neat!  :-)
03:45:00 <mchua> #info Lim Kin Chew and Cheng Renquan are working on the Education Spin page
03:45:07 <nb> mchua, did you #startmeeting?
03:45:08 <mchua> #info Tirath and Jaric are working on the Games Spin page
03:45:13 <mchua> nb: yep
03:45:15 <nb> oh ok
03:45:20 <mchua> #chair
03:45:20 <zodbot> Current chairs: mchua
03:45:25 <mchua> phew. yep!
03:45:30 <mchua> #topic work on websites begins
03:47:52 <sijis> rudi: sure.. what you got?
03:48:47 <rudi> Thanks sijis -- http://cvs.fedora.redhat.com/viewvc/web/html/docs/install-guide/f11/index.php?revision=1.11&root=fedora&view=markup
03:48:54 <rudi> this redirect doesn't seem to work
03:49:27 <rudi> I hoped it would redirect this: http://docs.fedoraproject.org/install-guide/f11/
03:49:37 <rudi> to this: http://docs.fedoraproject.org/index.html
03:49:53 <rudi> But we're just getting a blank page...
03:50:16 <sijis> rudi: you were working with Sparks earlier?
03:50:22 <sijis> rudi: i'm taking a look.
03:51:58 <rudi> sijis -- yeah
03:52:52 <rudi> sijis -- he didn't know it was my fault yet :)
03:57:49 <sijis> rudi: did that redirect ever work?
03:58:03 <sijis> it seems to work for me.
03:58:04 <rudi> Not as far as I can see
03:58:08 <rudi> Really?
03:58:16 <sijis> well. locally on my system
03:58:30 <rudi> Oh yeah -- I thought you meant on the site
03:58:53 <rudi> Locally, it's great :)
04:02:07 <sijis> rudi: so, that index.php doesn't seem to be on the server.
04:02:14 <sijis> do you get a page not found with this? http://docs.fedoraproject.org/install-guide/f11/index.php
04:02:35 <rudi> Yeah
04:02:52 <sijis> somehow that page is not on the server... or it hasn't been updated yet.
04:03:12 <rudi> OK -- I thought we had a sync since then. Maybe not.
04:03:31 <sijis> do you know what server docs.fp.o is on?
04:03:50 <rudi> Unfortunately not
04:05:29 <mchua> #info Snafu! The ports we need to ssh, checkout from git, etc. are blocked. Fortunately, Jaric has 3G...
04:05:42 <mchua> #info if we find a thumbdrive, Jaric will become everyone's new best friend :)
04:05:57 <sijis> rudi: i'm pinging mmcgrath on #fedora-admin to take a look
04:06:12 <sijis> mchua: you cna also use http to clone.
04:06:12 <rudi> Thanks -- I'll join you there
04:07:05 <mchua> sijis: how?
04:07:42 <tmz> mchua: If port 80 is open (for http), you can clone the fedora-web repo via 'git clone http://git.fedorahosted.org/git/fedora-web.git'
04:08:01 <sijis> instead of git clone ssh://username@domain.com/repo.git, its git clone http://user@domain.com/repo.git
04:08:18 <sijis> (i'm sure my syntax is a tad off)
04:08:28 <mchua> xinyi: YeLong: ^^ want to try that?
04:08:30 <mchua> while we're waiting
04:08:37 <mchua> tira: ^^
04:08:48 <tmz> It's far slower than using git:// or ssh://, but better than nothing.
04:09:07 <tmz> The various clone URL's are listed at http://git.fedorahosted.org/git/?p=fedora-web.git
04:09:32 <martz927-AFK> mizmo: u tried f12 on x61 tablet?
04:09:40 <mizmo> martz927-AFK: yes its amazing
04:10:08 <martz927> mizmo, no xtra config?
04:10:15 <mizmo> martz927: nope none at all
04:10:37 <martz927> mizmo, good news! = ]
04:10:43 <mizmo> yep :)
04:11:05 <martz927> mizmo, cld try on a fujitsu tablet and see if it goes well too
04:11:21 <mizmo> yay :)
04:11:24 <martz927> mizmo, when f12 is out ya
04:11:25 <mizmo> that would be great
04:11:30 <mizmo> in less than 2 weeks
04:11:52 <martz927> mizmo, just saw it on ya blog ... looks impressive
04:12:10 <mizmo> martz927: thanks :)
04:13:16 <mchua> martz927: why wait? try the beta. ;)
04:14:17 <tira> here is a way that works - git clone http://git.fedorahosted.org/git/fedora-web.git
04:14:44 <martz927> mizmo, my f11 is pretty well configured already
04:14:52 <martz927> mizmo, lazy to upgrade
04:15:00 <mchua> tira: oh hey, it does work? great!
04:15:19 <mchua> xinyi: YeLong: ^^^ tira was able to check out code, did it work for you?
04:16:28 <mchua> harish_afk: what time are we doing lunch?
04:17:06 <YeLong> someone is hungery,haha
04:19:30 <tmz> mchua, et al: If you clone via http to work now, when you're ready to push you can update the git url easily via: git config remote.origin.url ssh://git.fedorahosted.org/git/fedora-web.git
04:19:54 <tmz> that will allow you to push work back -- for anyone who has commit access that is.
04:19:58 <mchua> tmz: thanks!
04:20:04 <mchua> Lemme put that in notes for the bot
04:20:17 <mchua> #info If you clone via http to work now, when you're ready to push you can update the git url easily via: git config remote.origin.url ssh://git.fedorahosted.org/git/fedora-web.git
04:20:26 <mchua> #info that will allow you to push work back -- for anyone who has commit access that is.
04:20:27 <tmz> If not, we can walk you through sending patches to the websites list for review and inclusion.
04:20:35 <mchua> #info If not, we can walk you through sending patches to the websites list for review and inclusion.
04:20:43 <YeLong> whois tmz
04:20:54 * mchua is like that person in Galaxy Quest whose only job is to repeat things ;)
04:21:05 <mchua> YeLong: you can ask tmz, or you can ask zodbot :)
04:21:07 <mchua> .fas tmz
04:21:08 <zodbot> mchua: tmz 'Todd M. Zullinger' <tmz@pobox.com>
04:21:25 <YeLong> mchua:thanks!
04:21:35 <mchua> I prefer to think of tmz as "An Incredibly Helpful Person Of Awesome"
04:21:49 <sijis> he's also a git guru :)
04:21:50 <mchua> (thanks, tmz)
04:21:50 <tmz> Hehe, thanks mchua.
04:21:55 <mchua> I prefer to think of tmz as "An Incredibly Helpful Person Of Awesome"
04:21:59 * Ac-town is about 70% done transcribing the website mock ups
04:22:25 * mchua <3 git gurus
04:23:11 <sijis> Ac-town: great!
04:23:25 <YeLong> mchua:what's the meaning of the last two instructions above?
04:24:40 <YeLong> who is *?
04:24:44 <Ac-town> sijis: :)
04:25:40 <mchua> YeLong: It's a way of showing that you are doing an action.
04:25:44 <YeLong> the network is so slow that the codes haven't been download till now.
04:25:57 <mchua> YeLong: It's like how I would say *jumps up and down*
04:25:57 <mchua> YeLong: (in IRC.)
04:26:01 <mchua> YeLong: except in IRC I would type "/me jumps up and down" (with no quotes)
04:26:04 <mchua> and it looks like this:
04:26:07 * mchua jumps up and down
04:26:08 <mchua> YeLong: It's a way of showing that you are doing an action.
04:26:23 <mchua> YeLong: does that make sense? you can try it also, type "/me does something" (without the quotes)
04:26:28 <mchua> YeLong: but you have code now?
04:26:37 <Omnifarious> What's the git command for pulling outstanding changes from a remote repository?
04:26:59 * YeLong jumps up and down
04:27:35 * YeLong just for test
04:27:58 <YeLong> mchua:thanks
04:28:26 * xinyi jumps up and down
04:28:32 * mchua laughs
04:28:39 <mchua> I think you've got it. :D
04:29:30 <mchua> LUNCHTIME!
04:29:38 <mchua> I'm going to break the log here...
04:29:40 <mchua> #endmeeting