rolekitweekly
MINUTES

#fedora-server: rolekit (2015-08-04)

Meeting started by sgallagh at 13:00:18 UTC (full logs).

Meeting summary

  1. init process (sgallagh, 13:00:19)
  2. Agenda (sgallagh, 13:06:03)
    1. Agenda Item: Issue Triage (sgallagh, 13:06:17)

  3. https://github.com/libre-server/rolekit/issues/1 - [RFE] Support deploying roles in kickstart (sgallagh, 13:08:19)
    1. IDEA: Fedora 23 Beta Blocker (sgallagh, 13:11:48)
    2. AGREED: Fedora 23 Beta Blocker (sgallagh, 13:13:54)

  4. https://github.com/libre-server/rolekit/issues/3 - [RFE] Add single-node kubernetes role (sgallagh, 13:18:57)
    1. IDEA: Fedora 23 Beta, Nice-to-have (sgallagh, 13:21:39)
    2. AGREED: Fedora 23 Beta, Nice-to-have (sgallagh, 13:27:11)

  5. https://github.com/libre-server/rolekit/issues/4 - Add official mechanism for chaining roles together (sgallagh, 13:27:47)
    1. IDEA: Reduce scope to detecting dependent roles on the system and fail if they are not present with a useful message. Fedora 23 Beta, Nice-to-have (sgallagh, 13:32:07)
    2. IDEA: We don't need additional infrastructure for this. We can solve it with existing systemd unit file options. (sgallagh, 13:41:39)

  6. https://github.com/libre-server/rolekit/issues/6 - Redeploy() needs to handle packages and firewall rules (sgallagh, 13:43:08)
    1. IDEA: Fedora 23 Final, Blocker (sgallagh, 13:44:17)
    2. AGREED: Fedora 23 Final, Blocker (sgallagh, 14:06:55)

  7. https://github.com/libre-server/rolekit/issues/7 - Firewall rules need to be manipulatable based on role settings (sgallagh, 14:07:05)
    1. IDEA: Fedora 24 Alpha, Blocker (sgallagh, 14:08:19)
    2. AGREED: Fedora 24 Alpha, Blocker (sgallagh, 14:09:02)

  8. https://github.com/libre-server/rolekit/issues/8 - Implement the update() routine for all currently-supported roles (sgallagh, 14:09:50)
    1. IDEA: Fedora 24 Alpha, Nice-to-have (sgallagh, 14:10:50)
    2. AGREED: Fedora 24 Alpha, Nice-to-have (sgallagh, 14:13:00)

  9. https://github.com/libre-server/rolekit/issues/13 - Refactoring: handle settings in roles more simply (sgallagh, 14:14:00)
    1. IDEA: Defer until other things settle down, ask DevAssistant devs if an assistant could mitigate this (sgallagh, 14:21:13)
    2. AGREED: Defer until other things settle down, ask DevAssistant devs if an assistant could mitigate this (sgallagh, 14:21:50)

  10. https://github.com/libre-server/rolekit/issues/14 - Add support for deploying roles using the nulecule specification (sgallagh, 14:22:43)
    1. IDEA: Fedora 23 Beta, Nice-to-have (sgallagh, 14:22:53)
    2. AGREED: Fedora 23 Beta, Nice-to-have (sgallagh, 14:24:23)

  11. https://github.com/libre-server/rolekit/issues/16 - Delete systemd helper unit files on decommission (sgallagh, 14:25:29)
    1. IDEA: Fedora 23 Final, Blocker (sgallagh, 14:25:37)
    2. AGREED: Fedora 23 Final, Blocker (sgallagh, 14:26:15)

  12. https://github.com/libre-server/rolekit/issues/17 - Refactor systemd unit file creation to use python-systemdunit (sgallagh, 14:27:00)
    1. AGREED: Defer until needed patches land in python-systemd (sgallagh, 14:28:40)

  13. https://github.com/libre-server/rolekit/issues/18 - Role deploy, decommission, etc. needs progress updater (sgallagh, 14:29:58)
    1. IDEA: Fedora 24 Alpha, Blocker (sgallagh, 14:32:21)

  14. https://github.com/libre-server/rolekit/issues/19 - 'rolectl settings <role>' should list mandatory and optional settings for deployment (sgallagh, 14:33:21)
    1. IDEA: Fedora 24 Alpha, Nice-to-have (sgallagh, 14:34:12)
    2. AGREED: Fedora 24 Alpha, Nice-to-have (sgallagh, 14:34:41)

  15. https://github.com/libre-server/rolekit/issues/20 - Handle the "__NULL__" responses gracefully (sgallagh, 14:35:02)
    1. IDEA: Close as wontfix until someone complains (sgallagh, 14:36:10)
    2. AGREED: Close as wontfix until someone complains (sgallagh, 14:37:52)

  16. https://github.com/libre-server/rolekit/issues/21 - Check for .rksave files if the 'sed' fails in the DB role deploy. (sgallagh, 14:38:25)
    1. IDEA: Fedora 23 Final, Nice-to-have (sgallagh, 14:38:33)
    2. AGREED: Fedora 23 Final, Nice-to-have (sgallagh, 14:39:02)

  17. https://github.com/libre-server/rolekit/issues/22 - Enable translations of documentation and help text (sgallagh, 14:39:27)
    1. IDEA: Fedora 24 beta, Nice-to-have (sgallagh, 14:39:40)
    2. IDEA: Fedora 24 Alpha, Blocker (sgallagh, 14:40:58)
    3. AGREED: Fedora 24 Alpha, Nice-to-have (sgallagh, 14:42:07)

  18. https://github.com/libre-server/rolekit/issues/24 - Convert rolekit to different dbus implementation (sgallagh, 14:42:42)
    1. IDEA: Fedora 24 Alpha, Blocker (sgallagh, 14:43:18)
    2. IDEA: Fedora 24 Alpha, Nice-to-have - #idea Fedora 24 Beta, Blocker (twoerner, 14:46:52)

  19. https://github.com/libre-server/rolekit/issues/28 - redeploy should accept JSON settings via stdin as well (sgallagh, 14:49:49)
    1. IDEA: Fedora 23 Final, Blocker (sgallagh, 14:50:28)

  20. Open Floor (sgallagh, 14:57:17)


Meeting ended at 14:59:57 UTC (full logs).

Action items

  1. (none)


People present (lines said)

  1. sgallagh (242)
  2. twoerner (146)
  3. nphilipp (85)
  4. zodbot (9)
  5. simo (2)


Generated by MeetBot 0.1.4.