neurofedora
MINUTES

#fedora-neuro: NeuroFedora - 2022-09-26

Meeting started by FranciscoD_ at 13:00:50 UTC (full logs).

Meeting summary

  1. Agenda (FranciscoD_, 13:01:12)
    1. The agenda is here: https://neuroblog.fedoraproject.org/2022/09/24/next-open-neurofedora-meeting-26-September-1300-utc.html (FranciscoD_, 13:01:23)

  2. Introductions and roll call (FranciscoD_, 13:01:33)
  3. Tasks from last meeting (FranciscoD_, 13:07:05)
    1. Minutes from last meeting (12 Sep) are here: https://meetbot.fedoraproject.org/fedora-neuro/2022-09-12/neurofedora.2022-09-12-13.00.html (FranciscoD_, 13:07:18)
    2. FranciscoD_ file ticket with releng about python-pyABF repo: request cleaning, and ask if shallow clones can be used -> DONE (FranciscoD_, 13:08:07)
    3. ACTION: FranciscoD_ look at python-pyABF build issues (FranciscoD_, 13:11:04)
    4. ACTION: FranciscoD_ update python-mne: https://bugzilla.redhat.com/show_bug.cgi?id=2115503 (FranciscoD_, 13:12:49)
    5. FranciscoD update python-mne: https://bugzilla.redhat.com/show_bug.cgi?id=2115503 -> PENDING, reassigned (FranciscoD_, 13:13:12)
    6. FranciscoD package up deps for python-pybids update: https://bugzilla.redhat.com/show_bug.cgi?id=1996270 -> WIP (FranciscoD_, 13:14:32)

  4. Open Pagure tickets (FranciscoD_, 13:16:00)
    1. Any tickets that need to be discussed at a meeting should be tagged "next meeting": https://pagure.io/neuro-sig/NeuroFedora/issues?status=Open&tags=S%3A+Next+meeting (FranciscoD_, 13:16:21)
    2. No tickets to discuss (reading list is discussed in a separate topic) (FranciscoD_, 13:16:37)

  5. Package health check (FranciscoD_, 13:16:56)
    1. Please open up the neuro-sig packager dashboard: https://packager-dashboard.fedoraproject.org/dashboard?groups=neuro-sig (FranciscoD_, 13:17:50)
    2. Suggested bug priority order: Security bugs (CVEs), FTBFS/FTI, other general bugs and updates (FranciscoD_, 13:20:13)
    3. https://bugzilla.redhat.com/show_bug.cgi?id=2113639 -> pinged MeWjOr , wait till 2022-10-03 for response, take over if none (FranciscoD_, 13:22:33)
    4. ACTION: Penguinpee keep an eye on https://bugzilla.redhat.com/show_bug.cgi?id=2113639 and take over bug if we don't hear from MeWjOr in a week (FranciscoD_, 13:24:42)
    5. python-neatdend is FTBFS, filed https://bugzilla.redhat.com/show_bug.cgi?id=2129862 (FranciscoD_, 13:29:23)
    6. python-numpoly is FTBFS for rawhide, filed: https://bugzilla.redhat.com/show_bug.cgi?id=2129863 (FranciscoD_, 13:31:05)
    7. python-nilearn is FTBFS, already filed: https://bugzilla.redhat.com/show_bug.cgi?id=2126115 (FranciscoD_, 13:31:30)
    8. ACTION: FranciscoD_ fix https://bugzilla.redhat.com/show_bug.cgi?id=2126115 (FranciscoD_, 13:31:33)
    9. python-pynn needs to also excludearch s390x because python-neo now does it (FranciscoD_, 13:33:02)
    10. ACTION: FranciscoD_ make pynn excludearch s390x (FranciscoD_, 13:33:53)
    11. ACTION: FranciscoD_ also add excludearch for elephant and efel and epyviewer (FranciscoD_, 13:36:23)
    12. Packages are healthy: a few minor FTBFS bugs, and then lots of update bugs (FranciscoD_, 13:37:29)
    13. ACTION: neuro-sig please update packages by working on the update bugs that release-monitoring.org files for us (FranciscoD_, 13:37:55)

  6. Open package reviews check (FranciscoD_, 13:38:59)
    1. Please open the neuro-sig review tracker bug, and then click on "show advanced fields" to see what review bugs are blocking it: https://bugzilla.redhat.com/show_bug.cgi?id=fedora-neuro (FranciscoD_, 13:39:22)
    2. Only python-pyABF review is open (because of build issues). No other tickets to review (FranciscoD_, 13:39:48)

  7. CompNeuro lab compose status check for Fedora 36/37 (FranciscoD_, 13:40:36)
    1. please head to the koji task for our CompNeuro OS build to see if it's chugging along nicely: https://koji.fedoraproject.org/koji/packageinfo?packageID=30691 (FranciscoD_, 13:41:00)
    2. All good: green ticks for both rawhide and F37 (FranciscoD_, 13:41:11)

  8. Neuroscience query of the week (FranciscoD_, 13:41:48)
    1. Anything science/neuroscience related that we want to share with the team goes here. One can also post on the pagure ticket: https://pagure.io/neuro-sig/NeuroFedora/issue/318 (FranciscoD_, 13:42:17)
    2. we host planet neuroscientists: collection of blogs etc. related to neuroscience: https://neuroblog.fedoraproject.org/planet-neuroscientists/ (FranciscoD_, 13:43:15)
    3. we also host planet-neuroscience: collection of feeds from peer-reviewed journals: https://neuroblog.fedoraproject.org/planet-neuroscience (FranciscoD_, 13:43:33)

  9. Next meeting day, and chair (FranciscoD_, 13:45:27)
    1. Next meeting in 2 weeks: 1300 UTC on October 10 (FranciscoD_, 13:46:58)
    2. FranciscoD_ will chair (FranciscoD_, 13:47:18)

  10. Open floor (FranciscoD_, 13:47:34)


Meeting ended at 14:00:48 UTC (full logs).

Action items

  1. FranciscoD_ look at python-pyABF build issues
  2. FranciscoD_ update python-mne: https://bugzilla.redhat.com/show_bug.cgi?id=2115503
  3. Penguinpee keep an eye on https://bugzilla.redhat.com/show_bug.cgi?id=2113639 and take over bug if we don't hear from MeWjOr in a week
  4. FranciscoD_ fix https://bugzilla.redhat.com/show_bug.cgi?id=2126115
  5. FranciscoD_ make pynn excludearch s390x
  6. FranciscoD_ also add excludearch for elephant and efel and epyviewer
  7. neuro-sig please update packages by working on the update bugs that release-monitoring.org files for us


Action items, by person

  1. FranciscoD_
    1. FranciscoD_ look at python-pyABF build issues
    2. FranciscoD_ update python-mne: https://bugzilla.redhat.com/show_bug.cgi?id=2115503
    3. FranciscoD_ fix https://bugzilla.redhat.com/show_bug.cgi?id=2126115
    4. FranciscoD_ make pynn excludearch s390x
    5. FranciscoD_ also add excludearch for elephant and efel and epyviewer
  2. MeWjOr
    1. Penguinpee keep an eye on https://bugzilla.redhat.com/show_bug.cgi?id=2113639 and take over bug if we don't hear from MeWjOr in a week
  3. Penguinpee
    1. Penguinpee keep an eye on https://bugzilla.redhat.com/show_bug.cgi?id=2113639 and take over bug if we don't hear from MeWjOr in a week


People present (lines said)

  1. FranciscoD_ (111)
  2. Penguinpee (24)
  3. zodbot (14)
  4. lbazan (2)
  5. vanessa_kris[m] (1)
  6. vanessa_kris (0)
  7. HafsatAjia-Egbey (0)
  8. music (0)
  9. davdunc (0)
  10. Alessio (0)
  11. zbyszek[m] (0)
  12. mairacanal (0)
  13. mairacanal[m] (0)
  14. achilleas (0)
  15. aekoroglu (0)
  16. major (0)
  17. MeWjOr (0)
  18. mhough (0)


Generated by MeetBot 0.4.