neurofedora
LOGS
13:00:51 <shaane[m]> #startmeeting neurofedora
13:00:51 <zodbot> Meeting started Mon Sep 27 13:00:51 2021 UTC.
13:00:51 <zodbot> This meeting is logged and archived in a public location.
13:00:51 <zodbot> The chair is shaane[m]. Information about MeetBot at https://fedoraproject.org/wiki/Zodbot#Meeting_Functions.
13:00:51 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
13:00:51 <zodbot> The meeting name has been set to 'neurofedora'
13:01:14 <shaane[m]> \o/ Hello everyone!
13:01:25 <FranciscoD> o/
13:01:57 <shaane[m]> #chair omnidapps[m] shaane[m] music achilleas zbyszek_ FranciscoD
13:01:57 <zodbot> Current chairs: FranciscoD achilleas music omnidapps[m] shaane[m] zbyszek_
13:02:10 <FranciscoD> MeWjOr: here?
13:02:25 <FranciscoD> #chair MeWjOr music_ MorganHough[m]
13:02:25 <zodbot> Current chairs: FranciscoD MeWjOr MorganHough[m] achilleas music music_ omnidapps[m] shaane[m] zbyszek_
13:02:39 <FranciscoD> MorganHough[m]: o/
13:03:03 <shaane[m]> #topic Agenda for today
13:03:22 <shaane[m]> #info Static agenda noted here: https://docs.fedoraproject.org/en-US/neurofedora/communicating/#_open_meetings
13:03:35 <shaane[m]> #info New introductions and roll call
13:03:40 <MeWjOr> \o
13:03:47 <shaane[m]> o/
13:04:08 <MeWjOr> .fasinfo major
13:04:12 <zodbot> MeWjOr: User: major, Name: Aniket Pradhan, Email: aniketpradhan1999@gmail.com, Creation: 2019-02-09T11:57:57, IRC Nicks: MeWjOr and major_, Timezone: Asia/Kolkata, Locale: en-US, GPG Key IDs: None, Status: None
13:04:15 <zodbot> MeWjOr: Groups: fedora-contributor, fedorabugs, neuro-sig, packager, qa, wikiedit
13:04:26 <MeWjOr> :D
13:04:34 <shaane[m]> Nice nice
13:04:39 <shaane[m]> .fasinfo shaneallcroft
13:04:42 <zodbot> shaane[m]: User: shaneallcroft, Name: Shane Allcroft, Email: shane@lambdasymbol.com, Creation: 2021-08-05T15:04:56, IRC Nicks: irc:/shaane, Timezone: UTC, Locale: en-US, GPG Key IDs: None, Status: None
13:04:45 <zodbot> shaane[m]: Groups: fedora-contributor, fedorabugs, neuro-sig, packager
13:04:47 <FranciscoD> .fasinfo ankursinha
13:04:48 <zodbot> FranciscoD: User: ankursinha, Name: Ankur Sinha, Email: sanjay.ankur@gmail.com, Creation: 2008-05-28T06:16:53, IRC Nicks: FranciscoD and FranciscoD_ and Ankur^^ and FranciscoD[m], Timezone: Europe/London, Locale: en-GB, GPG Key IDs: E629112D, Status: None
13:04:51 <zodbot> FranciscoD: Groups: fedora-contributor, ask-fedora, fedora-join, fedorabugs, freemedia, gitfedora-tour, gitfpaste, neuro-sig, packager, provenpackager, qa, robotics-sig, scitech, scitech_sig, wikiedit
13:04:56 <music_> .fasinfo music
13:04:57 <zodbot> music_: User: music, Name: Benjamin Beasley, Email: code@musicinmybrain.net, Creation: 2013-01-23T10:40:36, IRC Nicks: musicinmybrain and music_, Timezone: US/Eastern, Locale: en-US, GPG Key IDs: None, Status: None
13:05:00 <zodbot> music_: Groups: fedora-contributor, fedorabugs, neuro-sig, packager
13:06:01 <shaane[m]> #info Tasks from last meeting
13:06:13 <omnidapps[m]> .fasinfo nerdsville
13:06:14 <zodbot> omnidapps[m]: User: nerdsville, Name: Josh Santos, Email: josh@omnidapps.com, Creation: 2014-08-01T06:40:41, IRC Nicks: omnidapps, Timezone: Asia/Bangkok, Locale: en, GPG Key IDs: None, Status: None
13:06:17 <zodbot> omnidapps[m]: Groups: fedora-contributor, fedorabugs, neuro-sig, packager, wikiedit
13:06:29 <FranciscoD> shaane[m]: was going to throw your pyplane review into fedora-review, but just saw that you've forgotten to add the spec/srpm links there :P
13:06:37 <omnidapps[m]> .hello nerdsville
13:06:38 <zodbot> omnidapps[m]: nerdsville 'Josh Santos' <josh@omnidapps.com>
13:07:09 <shaane[m]> Should I add those as attachments directly to the bug?
13:07:29 <FranciscoD> No, just add the links as a comment---the links should be "raw", so that something like wget can download the files
13:07:48 <shaane[m]> ahhh okay perfect thats pretty straightforward
13:07:50 <FranciscoD> did you manage to get fedorapeople etc. working, otherwise we can look into that after the meeting etc
13:08:55 <shaane[m]> As of an hour ago i was still getting 500 errors, its weird tho cause I'm not getting it after I enter my login, just clicking the 'login' button takes me directly to a 500 error
13:09:09 <FranciscoD> OK, let's debug that after the meeting
13:09:22 <shaane[m]> :+1: sounds good
13:09:27 <FranciscoD> got the spec/srpm link? If you give it to me here, I'll update the review and chuck it through fedora-review in the meatime
13:09:31 <FranciscoD> s/meatime/meantime/
13:09:38 * FranciscoD is having typing issues today
13:10:05 <shaane[m]> yeah I can get that just one sec
13:11:07 <shaane[m]> spec:
13:11:08 <shaane[m]> https://paste.centos.org/view/raw/c0352967
13:11:42 <FranciscoD> ah, hrm, we need it in a "permanent" place until it's approved, the paste will disappear in a week :/
13:11:46 <FranciscoD> let's do it after the meeting
13:12:07 <shaane[m]> Okay yeah good point sounds good
13:12:31 <shaane[m]> Whoops I still have to add more #info and then progress the topic
13:12:33 <shaane[m]> sec
13:12:39 <shaane[m]> #info Open Pagure tickets
13:12:44 <FranciscoD> yeh, sorry XD
13:12:49 <shaane[m]> #info Package health check
13:12:52 * FranciscoD was hoping to run the review in parallel :P
13:12:53 <shaane[m]> #info Open package reviews check
13:13:00 <shaane[m]> #info CompNeuro lab compose a status check for F34/F35
13:13:05 <shaane[m]> #info Neuroscience query of the week
13:13:11 <shaane[m]> #info Next meeting day, and chair
13:13:17 <shaane[m]> #info Open floor
13:13:22 <shaane[m]> #topic New introductions and roll call
13:13:36 <FranciscoD> o/
13:13:46 <FranciscoD> everyone tends to do it before the topic starts XD
13:14:29 <shaane[m]> okay what about a new one:     /o/    their arms are both going to the right
13:14:41 <FranciscoD> #info shaane[m] MeWjOr omnidapps[m] FranciscoD are here at the mo
13:14:55 <FranciscoD> shaane[m]: there, roll call done, let's proceed to the next topic :)
13:15:02 <MeWjOr> ^.^
13:15:04 <FranciscoD> others can join in as they come
13:15:18 <shaane[m]> #topic Tasks from last meeting
13:15:23 <shaane[m]> Perfect
13:16:17 <shaane[m]> Okay we already talked a little about 401, but hopefully will have that on its way to being closed shortly after this meeting, sorry for all the delays with that issue will make sure to have future ones be more expedient : )
13:17:42 <shaane[m]> #info Logs from last meeting can be seen here: https://meetbot.fedoraproject.org/teams/neurofedora/neurofedora.2021-09-13-13.00.log.html
13:17:47 <FranciscoD> +1
13:18:23 <FranciscoD> shaane[m]: if you look at the minutes, you'll see the action items in a list at the bottom: https://meetbot.fedoraproject.org/teams/neurofedora/neurofedora.2021-09-13-13.00.html
13:18:34 <FranciscoD> saves you from having to search the full logs for `#action` etc :)
13:19:04 <shaane[m]> whoa yeah thats nice
13:19:11 <shaane[m]> ty ty
13:20:20 <omnidapps[m]> I totally dropped the ball on planet migration for fedora infra, please reassign to me
13:22:09 <FranciscoD> omnidapps[m]: you can reassign it to yourself :)
13:22:10 <shaane[m]> Okay will do sorry how do i do that lol
13:22:23 <FranciscoD> shaane[m]: so we go through each action item one by one
13:22:25 <FranciscoD> like this:
13:22:30 <FranciscoD> FranciscoD add retrospective blog post for today's meeting
13:22:39 <FranciscoD> and then, I'll say whether I completed it or not
13:22:39 <omnidapps[m]> #action omnidapps follow up with fedora infra on planet migration
13:22:41 <FranciscoD> (I did)
13:22:44 <FranciscoD> so then you go:
13:22:47 <FranciscoD> #info FranciscoD add retrospective blog post for today's meeting: DONE
13:23:05 <FranciscoD> if I hadn't done it, you'd do an info with "WIP" or "PENDING"
13:23:15 <omnidapps[m]> Oh, oops
13:23:16 <FranciscoD> and then reassign it to me using the action command like omnidapps[m] just did
13:23:24 <shaane[m]> Ahh okay those tags make more sense now i think i'm following
13:23:41 <FranciscoD> omnidapps[m]: no worries, it's just an organised way of doing things, but not strict rules ;)
13:23:42 <shaane[m]> omnidapps[m] update configupdater: rhbz 1994442
13:23:54 <FranciscoD> I think that ones complete
13:24:05 <omnidapps[m]> That one is done and deployed to rawhide
13:24:11 <shaane[m]> Yo naise
13:24:19 <FranciscoD> https://src.fedoraproject.org/rpms/python-configupdater/c/ac2b30e85b7f0d2654de3f4fdfeaa6c5ebb73ef0?branch=rawhide
13:24:26 <omnidapps[m]> Deployed also to 34 I think… 33 had issues iirc
13:24:32 <shaane[m]> #info omnidapps[m] update configupdater: rhbz 1994442: DONE
13:24:51 <FranciscoD> omnidapps[m]: I think we did 36 and 35, and won't do 34 because lots of deps also need updating
13:25:05 <omnidapps[m]> Ah right that was it
13:25:14 <shaane[m]> MeWjOr update mne-bids: rhbz 1982826
13:25:21 <FranciscoD> .bug 1982826
13:25:23 <zodbot> FranciscoD: 1982826 – python-mne-bids-0.8 is available - https://bugzilla.redhat.com/1982826
13:25:45 <MeWjOr> its still WIP... Working with the upstream on its dependency right now
13:26:01 <FranciscoD> MeWjOr: ugh, more new packages needed for the update?
13:26:18 <MeWjOr> just one lol... it had issues with big-endian arches
13:26:21 <MeWjOr> archs*
13:26:23 <FranciscoD> *sigh*
13:26:25 <shaane[m]> #info MeWjOr update mne-bids: rhbz 1982826: WIP
13:26:45 <FranciscoD> that's mostly because upstreams use travis/GitHub actions where you don't get s390x and powerpc etc to test with
13:26:54 <FranciscoD> we're seeing quite a few of these issues :/
13:26:56 <MeWjOr> It's almost done as well... The PR should be merged today itself
13:27:04 <FranciscoD> awesome
13:27:05 <MeWjOr> https://github.com/bids-standard/pybv/pull/80
13:27:34 <FranciscoD> awesome++
13:27:34 <zodbot> FranciscoD: Karma for awesome changed to 1 (for the current release cycle):  https://badges.fedoraproject.org/tags/cookie/any
13:27:45 <MeWjOr> FranciscoD, yep, had to replicate the job by setting up travis on a fork... turned out a fun adventure
13:28:03 <omnidapps[m]> Who is irc handle awesome?
13:28:10 <FranciscoD> MeWjOr: don't forget to note that upstream contribution in our ticket here: https://pagure.io/neuro-sig/NeuroFedora/issue/461
13:28:15 <FranciscoD> omnidapps[m]: oh LOL
13:28:17 <MeWjOr> they just got lucky XD
13:28:25 <MeWjOr> Sure, FranciscoD
13:28:33 <FranciscoD> #action MeWjOr add PR info to our tracker ticket: https://pagure.io/neuro-sig/NeuroFedora/issue/461
13:29:11 <shaane[m]> FranciscoD fix and update arbor
13:29:17 <FranciscoD> donezo
13:29:28 <shaane[m]> Nice nice nice
13:29:34 <FranciscoD> took me all day, the arch builds take forever, but all done now
13:29:35 <shaane[m]> #info FranciscoD fix and update arbor: DONE
13:29:45 <shaane[m]> +1
13:30:02 <shaane[m]> FranciscoD fix ITK
13:30:02 <FranciscoD> https://bodhi.fedoraproject.org/updates/?packages=arbor -> in testing now
13:30:10 <FranciscoD> still WIP I'm afraid
13:30:16 <shaane[m]> #info FranciscoD fix ITK : WIP
13:30:17 <FranciscoD> that's the next mammoth on my list to slay
13:30:31 <shaane[m]> What is ITK?
13:30:32 <FranciscoD> next massive tree to chop?
13:30:42 <shaane[m]> Beeg tree
13:30:53 <FranciscoD> https://itk.org/
13:31:05 <FranciscoD> "ITK is an open-source, cross-platform library that provides developers with an extensive suite of software tools for image analysis.  Developed through extreme programming methodologies, ITK builds on a proven, spatially-oriented architecture for processing, segmentation, and registration of scientific images in two, three, or more dimensions."
13:31:14 <FranciscoD> used by quite a few tools
13:31:19 <MeWjOr> ITK :D
13:31:27 <FranciscoD> but yeh, their software dev style is quite extreme IIRC
13:31:34 <FranciscoD> or is that dcmtk?
13:31:48 <FranciscoD> no backward compatibility---no soname versioning
13:31:59 <shaane[m]> Oh wow itk seems really neat, image-processing / computer vision is boss
13:32:06 <FranciscoD> folks just use snapshots as git submodules etc
13:32:14 * FranciscoD hates submodule usage on github
13:32:20 <shaane[m]> lol
13:32:22 <shaane[m]> relatable
13:32:42 <shaane[m]> omnidapps - reach out to fedora infra about migrating fedora main pluto as well
13:33:17 <FranciscoD> WIP, already reassigned
13:33:28 <omnidapps[m]> Yea WIP
13:33:28 <shaane[m]> Oh shoot thats right my bad
13:33:41 <omnidapps[m]> Let’s add an info about it though :)
13:33:42 <shaane[m]> #info omnidapps - reach out to fedora infra about migrating fedora main pluto as well: WIP
13:33:47 <shaane[m]> yes : )
13:33:47 <omnidapps[m]> Nvm lol nice
13:33:49 <omnidapps[m]> :-)
13:33:56 <shaane[m]> \o
13:33:59 <shaane[m]> sorry sorr
13:34:06 <MeWjOr> but submodules are nice.. simplifies the process of reuploading the snapshots again and again :'(
13:34:12 <shaane[m]> oops paste from wrong window
13:34:21 <shaane[m]> FranciscoD send out logs etc.
13:34:22 <shaane[m]> there we go
13:34:28 <shaane[m]> xclip failed me
13:34:35 <FranciscoD> done
13:34:40 <shaane[m]> Nice nice
13:34:51 <shaane[m]> #info FranciscoD send out logs etc.
13:35:03 <shaane[m]> #info FranciscoD send out logs etc.: DONE
13:35:08 <FranciscoD> #action shaane[m] send out logs
13:35:10 <FranciscoD> (for today :P)
13:35:50 <FranciscoD> MeWjOr: they're useful, bit I'd rather people use released versions as the submodule---people using random git commits is where the issues start
13:36:16 <shaane[m]> : ) heck yeah excited to be logmeister
13:36:29 <shaane[m]> Should i change the topic now? since we've gone over all actions from last meeting?
13:36:44 <MeWjOr> +1
13:38:01 <shaane[m]> #topic Open Pagure tickets
13:38:20 <FranciscoD> nothing here, I don't think
13:38:36 <shaane[m]> #topic Package health check
13:38:51 <shaane[m]> how healthy are these packages lookin
13:39:12 <FranciscoD> #info Neuro-sig packager dashboard: https://packager-dashboard.fedoraproject.org/user/neuro-sig
13:39:46 <FranciscoD> very few ftbfs bugs, so that's good
13:40:01 <FranciscoD> lots koschei reports, but not bugs yet, so they're all installable: which is fine
13:40:18 <FranciscoD> loadsa updates there, so please feel free to take them up and open PRs folks :)
13:40:47 <FranciscoD> most should be simple spec bumps etc
13:40:54 <shaane[m]> Nice, this is a cool dashboard
13:41:08 <omnidapps[m]> Wow my matrix client totally lagged out
13:41:15 <omnidapps[m]> I was sitting waiting for the next message
13:41:58 <FranciscoD> uh, the web client?
13:42:05 <omnidapps[m]> Element
13:42:12 <FranciscoD> hrm, :/
13:42:42 <FranciscoD> MeWjOr: anything in the package list you think needs urgent attention?
13:43:13 <FranciscoD> (music_ has been working on fixes and updates too)
13:43:48 <MeWjOr> not really... I'll get to fixes/updates as soon as I get done with bids
13:44:55 <shaane[m]> #topic CompNeuro lab compose a status check for F34/F35
13:45:11 <shaane[m]> Is this topic still germane?
13:45:29 <shaane[m]> What does composing a status check mean / entail?
13:45:54 <MeWjOr> basically checking if the image composes are going well
13:46:15 <shaane[m]> Okay that seems pretty straightforward nice
13:47:02 <FranciscoD> +1
13:47:11 <MeWjOr> #info CompNeuro ISO compose task on Koji: https://koji.fedoraproject.org/koji/packageinfo?packageID=30691
13:47:14 <FranciscoD> so, each new release we get a new image compose
13:47:24 <FranciscoD> at the moment, until f35 is released, that's the image that's being generated
13:47:41 <FranciscoD> once f35 releases, this image will be frozen and put on the labs website for everyone to use
13:47:54 <FranciscoD> and we'll go forward and later branch to f36 from rawhide and so on
13:48:17 <FranciscoD> (if a compose fails, some package somewhere is broken)
13:48:34 <FranciscoD> from MeWjOr 's link, both rawhide and F35 look fine
13:48:45 * FranciscoD needs to check if arbor is included in our comp-neuro image or not
13:48:51 <shaane[m]> Okay that makes sense neato
13:48:55 <FranciscoD> it's quite mature now, should be added if not
13:49:07 <FranciscoD> #action FranciscoD add arbor to comp-neuro image if it isn't included
13:49:23 <FranciscoD> it'll be from f36 though, no more changes to f35 this late in the release cycle
13:50:06 <FranciscoD> #info Rawhide + f35 compose is OK
13:50:13 <FranciscoD> shaane[m]: that's all there is in this topic :)
13:50:29 <shaane[m]> Okay sweet next topic coming right up
13:50:40 <shaane[m]> #topic Neuroscience query of the week
13:51:08 <FranciscoD> there were a few that I added as a comment: https://pagure.io/neuro-sig/NeuroFedora/issue/318#comment-752844
13:51:52 <FranciscoD> is anyone else able to access https://www.frontiersin.org/articles/10.3389/fncir.2021.732315/full ?
13:51:58 <FranciscoD> I get "website under maintenance" :/
13:52:35 <FranciscoD> now I get 503
13:52:37 <FranciscoD> *sigh*
13:52:41 <shaane[m]> Yeah same : (
13:52:43 <shaane[m]> rip
13:52:44 <FranciscoD> anyway, that's a good one---lots of historical notes etc
13:53:04 <shaane[m]> The titles sound cool, I'll ahve to check back up with those later in the day
13:53:09 <FranciscoD> Alex is now an Emeritus prof here at UCL. Was around for lots of big things, very well known in Pharmacology etc.
13:53:41 <FranciscoD> the cerebellum one is very short, but lots of links to other papers that sort of give an idea of the state of our knowledge about the area
13:53:57 <FranciscoD> (also frontiers, so may not work )
13:54:55 <FranciscoD> haven't looked at the journals this week yet, may find some new stuff when I do :P
13:55:35 <shaane[m]> Is Alex an author of the circuits and synapses one? Very cool : )
13:56:24 <FranciscoD> Yeh, the opinion piece
13:58:05 <shaane[m]> Nice nice nice
13:59:17 <omnidapps[m]> shaane++ - amazing job as meeting coordinator, and now being logmeister for today ^.^
13:59:26 <MeWjOr> ^.^
13:59:30 <MeWjOr> shaane++
13:59:43 <omnidapps[m]> What’s your fas handle?
13:59:48 <shaane[m]> Haha tysm : )))
13:59:52 <shaane[m]> handle is shaneallcroft
13:59:58 <omnidapps[m]> shaneallcroft++
14:00:06 <MeWjOr> shaneallcroft++
14:00:07 <zodbot> MeWjOr: Karma for shaneallcroft changed to 2 (for the current release cycle):  https://badges.fedoraproject.org/tags/cookie/any
14:00:11 <MeWjOr> :D
14:00:23 <shaane[m]> Yo thank you : )
14:00:26 <FranciscoD> shaane[m]: I think we can skip open floor and end the meeting
14:00:28 <omnidapps[m]> Oh right I’ll have to give you karma on IRC
14:00:33 <FranciscoD> and continue chatting after words
14:00:44 <FranciscoD> it's just good to start and stop the meeting on time
14:00:54 <shaane[m]> Okay does same time 2 weeks from now work for everyone?
14:01:00 <shaane[m]> I'm itching to use that #agreed tag
14:01:05 <MeWjOr> lol yes
14:01:11 <FranciscoD> +1
14:01:14 <omnidapps> shaneallcroft++
14:01:21 <zodbot> omnidapps: Karma for shaneallcroft changed to 3 (for the current release cycle):  https://badges.fedoraproject.org/tags/cookie/any
14:01:34 <shaane[m]> #agreed Next meeting in 2 weeks at 1300 UTC on Monday 11 October
14:01:51 <shaane[m]> #endmeeting