neurofedora
LOGS
13:00:25 <FranciscoD> #startmeeting NeuroFedora - 2021-09-13
13:00:25 <zodbot> Meeting started Mon Sep 13 13:00:25 2021 UTC.
13:00:25 <zodbot> This meeting is logged and archived in a public location.
13:00:25 <zodbot> The chair is FranciscoD. Information about MeetBot at http://wiki.debian.org/MeetBot.
13:00:25 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
13:00:25 <zodbot> The meeting name has been set to 'neurofedora_-_2021-09-13'
13:00:32 <FranciscoD> #meetingname neurofedora
13:00:32 <zodbot> The meeting name has been set to 'neurofedora'
13:00:41 <FranciscoD> #chair omnidapps[m] shaane[m] music achilleas zbyszek_
13:00:41 <zodbot> Current chairs: FranciscoD achilleas music omnidapps[m] shaane[m] zbyszek_
13:01:03 <zbyszek_> Hi FranciscoD
13:01:20 <FranciscoD> zbyszek_: hello!
13:01:38 <shaane[m]> Hello everyone : )
13:01:41 <zbyszek_> I have to run in a few minutes, but while I'm here, let me say that I'm looking forward to seeing Numba in Fedora. Let me know if I can help.
13:02:17 <FranciscoD> zbyszek_: awesome, that's next on my list. Hopefully it won't be too complicated a package :)
13:02:28 <FranciscoD> thanks for all your help with the reviews etc. :)
13:02:30 <FranciscoD> zbyszek++
13:02:32 <zodbot> FranciscoD: Karma for zbyszek changed to 5 (for the current release cycle):  https://badges.fedoraproject.org/tags/cookie/any
13:02:40 <FranciscoD> shaane[m]: o/
13:02:46 <FranciscoD> #topic Agenda for today
13:02:58 <FranciscoD> #info Static agenda noted here: https://docs.fedoraproject.org/en-US/neurofedora/communicating/#_open_meetings
13:03:05 <FranciscoD> #info New introductions and roll call
13:03:20 <FranciscoD> #info Tasks from last meeting
13:03:21 <shaane[m]> hey sorry real quick what does the o/ mean again?
13:03:27 <omnidapps[m]> same like hey
13:03:31 <omnidapps[m]> it's like a guy waving
13:03:33 <FranciscoD> #info Open Pagure tickets
13:03:38 <MeWjOr> \o
13:03:40 <FranciscoD> \o \o/ o/
13:03:42 <FranciscoD> :D
13:03:46 <shaane[m]> Haha okay nice thats fun
13:03:46 <shaane[m]> o/
13:03:47 <FranciscoD> shaane[m]: ascii figures XD
13:03:55 <FranciscoD> #chair MeWjOr
13:03:55 <zodbot> Current chairs: FranciscoD MeWjOr achilleas music omnidapps[m] shaane[m] zbyszek_
13:03:57 <FranciscoD> #info Package health check
13:03:58 <shaane[m]> I'm a fan
13:04:09 <FranciscoD> #info Open package reviews check
13:04:16 <FranciscoD> #info CompNeuro lab compose a status check for F34/F35
13:04:23 <FranciscoD> #info Neuroscience query of the week
13:04:29 <FranciscoD> #info Next meeting day, and chair
13:04:36 <FranciscoD> #info Open floor
13:04:47 <FranciscoD> #topic New introductions and roll call
13:04:57 <FranciscoD> .hello
13:04:57 <zodbot> FranciscoD: (hello <an alias, 1 argument>) -- Alias for "hellomynameis $1".
13:05:01 <FranciscoD> .hello ankursinha
13:05:02 <zodbot> FranciscoD: ankursinha 'Ankur Sinha' <sanjay.ankur@gmail.com>
13:05:12 <omnidapps[m]> .hello nerdsville
13:05:13 <zodbot> omnidapps[m]: nerdsville 'Josh Santos' <josh@omnidapps.com>
13:05:23 <FranciscoD> that's `.hello <FAS username>`
13:05:28 <MeWjOr> .hello major
13:05:29 <omnidapps[m]> broken?
13:05:29 <zodbot> MeWjOr: major 'Aniket Pradhan' <aniketpradhan1999@gmail.com>
13:05:33 <omnidapps[m]> ah
13:05:44 <shaane[m]> .hello shaneallcroft
13:05:45 <zodbot> shaane[m]: shaneallcroft 'Shane Allcroft' <shane@lambdasymbol.com>
13:05:49 <omnidapps[m]> was that just me it lagged out for?
13:05:58 <FranciscoD> shaneallcroft++ nerdsville++ major++
13:05:58 <zodbot> FranciscoD: Karma for shaneallcroft changed to 1 (for the current release cycle):  https://badges.fedoraproject.org/tags/cookie/any
13:05:59 <omnidapps[m]> my notification didn't come back for a while
13:06:01 <zodbot> FranciscoD: Karma for nerdsville changed to 1 (for the current release cycle):  https://badges.fedoraproject.org/tags/cookie/any
13:06:06 <shaane[m]> It seemed delayed yea
13:06:13 <FranciscoD> omnidapps[m]: yeh, just a little slow, could also be the matrix bridge
13:06:27 <omnidapps[m]> k
13:06:28 <FranciscoD> let's wait another minute for anyone else that wants to join in
13:07:00 <omnidapps[m]> should we do another mass ping?
13:07:05 <FranciscoD> ah, I forgot to publish a blog post
13:07:15 <shaane[m]> MeWjOr: o/
13:07:19 <FranciscoD> #action FranciscoD add retrospective blog post for today's meeting
13:07:25 <FranciscoD> omnidapps[m]: sure, go for it
13:07:47 <omnidapps[m]> .members neuro-sig meeting if anyone wants to join :)
13:07:48 <zodbot> omnidapps[m]: Sorry, but group 'neuro-sig meeting if anyone wants to join :)' does not exist
13:08:03 <omnidapps[m]> .members neuro-sig
13:08:03 <zodbot> omnidapps[m]: Members of neuro-sig: sagitter, ignatenkobrain, bt0dotninja, zbyszek, sergiopr, blackfile, ankursinha, lbazan, ilgrad, gicmo, alciregi, bizdelnick, nerdsville, mhough, victortyau, music, major, fangq, anilbey, iztokf, shaneallcroft
13:08:11 <omnidapps[m]> ^ meeting if anyone wants to join :)
13:09:20 <FranciscoD> #chair major
13:09:20 <zodbot> Current chairs: FranciscoD MeWjOr achilleas major music omnidapps[m] shaane[m] zbyszek_
13:09:40 <FranciscoD> OK, let's proceed and folks can just keep joining in :)
13:10:00 <FranciscoD> #topic Tasks from last meeting
13:10:13 <FranciscoD> #info Logs from last meeting can be seen here: https://meetbot.fedoraproject.org/teams/neurofedora/neurofedora.2021-08-16-13.01.html
13:10:41 <FranciscoD> MeWjOr: I thought you did do a meeting last time, just for the logs?
13:10:47 <FranciscoD> I don't see the logs on meetbot though
13:11:00 <omnidapps[m]> he did, I saw it
13:11:01 <MeWjOr> Yeah, there were not enough people at that time
13:11:12 <MeWjOr> So, I just re-assigned the pending tasks
13:11:19 <FranciscoD> OK, yueh
13:11:20 <MeWjOr> and sent out the logs for that
13:11:21 <FranciscoD> *yeh
13:11:23 <shaane[m]> Yeah sorry about that i messed up the timezone, wanted to be at last meeting MeWjOr
13:11:37 <FranciscoD> I think you used fedora-neuro instead of neurofedora for the meeting name, so it's archived in a different place
13:11:42 <MeWjOr> no issues shaane[m] ... we're here now :D
13:11:47 <FranciscoD> #info Last meetings logs: https://meetbot.fedoraproject.org/teams/fedora-neuro/fedora-neuro.2021-08-30-13.01.html
13:11:56 <shaane[m]> :D
13:11:58 <omnidapps[m]> and now we all know a cool CLI command to translate the time :)
13:11:58 <MeWjOr> ohh, probably forgot to rename that meeting
13:12:10 <FranciscoD> #info FranciscoD[m] FranciscoD continue packaging SALib deps and update it to its new release: DONE
13:12:13 <FranciscoD> that's the only one then
13:12:30 <FranciscoD> all our other tasks from previous meetings have been completed
13:12:33 <FranciscoD> *nice*!
13:12:40 <MeWjOr> ^.^
13:12:46 <FranciscoD> ๐Ÿš€
13:13:01 <MeWjOr> ๐Ÿฅณ
13:13:06 <FranciscoD> #topic Open Pagure tickets
13:13:15 <omnidapps[m]> let's add a task for me to pick up a version bump :)
13:13:24 <FranciscoD> omnidapps[m]: sure things
13:13:29 <FranciscoD> s/things/thing/
13:13:45 <FranciscoD> omnidapps[m]: should we do it when we see the package dashboard, where we can see what version bumps are available?
13:13:52 <omnidapps[m]> sure
13:13:57 <FranciscoD> Awesome, I'll note that down
13:14:13 <FranciscoD> #info Any tickets that need to be discussed can be tagged "next meeting" on our pagure project: https://pagure.io/neuro-sig/NeuroFedora/issues?status=Open&tags=S%3A+Next+meeting
13:14:22 <FranciscoD> #info No tickets to discuss this time
13:14:36 <FranciscoD> #topic Package health check
13:14:54 <shaane[m]> For issue #401, I got past the error I was having on , but its now not recognizing the repo's test_core.py as a valid test/module, I'll update the issue on  pagure after the meeting
13:14:54 <FranciscoD> #info Neuro-sig package dashboard is here: https://packager-dashboard.fedoraproject.org/user/neuro-sig
13:15:04 <omnidapps[m]> that link is pretty neat https://www.nature.com/articles/d41586-021-02346-4
13:15:22 <FranciscoD> shaane[m]: ah, interesting---I think that'll be related to unittest test discovery or something
13:15:34 <FranciscoD> shaane[m]: we can look at that after the meeting, or via the ticket---whichever works
13:15:48 <shaane[m]> That makes sense, okay sounds good
13:15:50 <FranciscoD> omnidapps[m]: yeh, some good tips there
13:16:00 <FranciscoD> OK, let's look at the dashboard
13:16:14 <FranciscoD> we prioritise FTBFS (fails to build from source) and FTI (fails to install) bugs
13:16:37 <FranciscoD> I see a few koschei FTBFS notes, but not bugs yet, and the packages install fine
13:16:47 <FranciscoD> So I wouldn't worry about those
13:16:51 <omnidapps[m]> build from source == configure/make?, fail to install == make install?
13:17:10 <FranciscoD> omnidapps[m]: no, build from source -> configure/make/make install, i.e. building of the RPM
13:17:29 <omnidapps[m]> ah install is of the rpm itself
13:17:35 <FranciscoD> FTI is when the rpm has built and is in the repos but cannot be installed---usually because some runtime dependency is missing or of the wrong version
13:17:48 <FranciscoD> Yeh, like this one: https://bugzilla.redhat.com/show_bug.cgi?id=2003321
13:17:50 <omnidapps[m]> ok cool
13:17:51 <FranciscoD> .bug 2003321
13:17:54 <zodbot> FranciscoD: 2003321 โ€“ F34FailsToInstall: python3-multiprocess - https://bugzilla.redhat.com/2003321
13:18:17 <FranciscoD> it built fine but I pushed the update before sagitter pushed the python-dill update
13:18:28 <FranciscoD> so at the moment, python3-multiprocess cannot be installed.
13:18:37 <FranciscoD> Should be fixed in a few days once the python-dill update goes out
13:19:02 <FranciscoD> I hope FTBFS and FTI is clear---they crop up quite a bit :)
13:19:13 <FranciscoD> (we have an automated script that checks and files bugs, along with koschei)
13:19:35 <MeWjOr> I don't see any FTI bug tho?
13:19:47 <omnidapps[m]> what is koschei? is that the package build system?
13:20:08 <MeWjOr> Ohh, wait, I was searching for "FTI" instead of "FailsToInstall"
13:20:14 <FranciscoD> MeWjOr: :D
13:20:23 <FranciscoD> omnidapps[m]: https://koschei.fedoraproject.org/groups/neuro-sig
13:20:39 <FranciscoD> each time some packages are rebuilt, koschei will check for dependency changes etc.
13:20:47 <FranciscoD> Think of it as Continuous Integration (CI)
13:21:05 * FranciscoD likes all the green ticks on our Koschei page :)
13:21:32 <shaane[m]> Green ticks for days
13:21:55 <FranciscoD> we're almost at 200 packages now, so yeh, lots of ticks XD
13:21:57 * omnidapps[m] only sees the red ticks
13:22:06 <FranciscoD> omnidapps[m]: on koschei?
13:22:21 <omnidapps[m]> I was being sarcastic about over-obsessing over 100% green :D
13:22:30 <FranciscoD> oh, I freaked out for a minute XD
13:22:53 <FranciscoD> omnidapps[m]: if you search the dashboard for "is available", those are the bugs for new versions of packages
13:23:15 <FranciscoD> omnidapps[m]: this should be a good but simple one: https://bugzilla.redhat.com/show_bug.cgi?id=1994442
13:23:19 <FranciscoD> .bug 1994442
13:23:23 <zodbot> FranciscoD: 1994442 โ€“ python-configupdater-3.0 is available - https://bugzilla.redhat.com/1994442
13:23:30 <omnidapps[m]> https://koschei.fedoraproject.org/search?q=is+available
13:23:44 <FranciscoD> omnidapps[m]: ah, no, on the dashboard page: https://packager-dashboard.fedoraproject.org/user/neuro-sig
13:23:52 <FranciscoD> and a text search
13:23:55 <omnidapps[m]> ah got it
13:23:57 <FranciscoD> not a query
13:24:32 <omnidapps[m]> k I'll take https://bugzilla.redhat.com/show_bug.cgi?id=1994442
13:24:38 <FranciscoD> awesome
13:24:51 <FranciscoD> #action omnidapps[m] update configupdater: rhbz 1994442
13:25:15 <FranciscoD> .fasinfo nerdsville
13:25:16 <zodbot> FranciscoD: User: nerdsville, Name: Josh Santos, Email: josh@omnidapps.com, Creation: 2014-08-01T06:40:41, IRC Nicks: omnidapps, Timezone: Asia/Bangkok, Locale: en, GPG Key IDs: None, Status: None
13:25:19 <zodbot> FranciscoD: Groups: fedora-contributor, fedorabugs, neuro-sig, packager, wikiedit
13:25:37 <omnidapps[m]> weird my GPG key isn't there
13:25:55 <MeWjOr> I'll be picking up mne-bids, just got finished with mne update :P
13:26:07 <FranciscoD> omnidapps[m]: hrm, yeh, check FAS?
13:26:13 <FranciscoD> omnidapps[m]: I've assigned the bug to you now
13:26:16 <omnidapps[m]> yeah I'll check
13:26:17 <omnidapps[m]> cool
13:26:40 <FranciscoD> #action MeWjOr update mne-bids: rhbz 1982826
13:27:01 <FranciscoD> MeWjOr: would you change the bug status to "assigned" please to let everyone know you're working on it?
13:27:07 <MeWjOr> done :D
13:27:07 <omnidapps[m]> or fedora accounts now :)
13:27:22 <FranciscoD> ++
13:27:44 <FranciscoD> Apart from that, there aren't any critical bugs. Please pick up any of these version update bugs and work on them---they should be usually quite simple ones
13:28:09 <FranciscoD> do remember to "take" the bug, and change its status to "ASSIGNED" so that everyone on the team knows you're working on it
13:28:16 <FranciscoD> music has been working on lots of packages etc. too
13:28:18 <FranciscoD> music++
13:28:21 <FranciscoD> .thank music
13:28:21 <zodbot> FranciscoD thinks music is awesome and is happy they are helping! (Please also type music++ since that is what gives them a cookie)
13:28:31 <MeWjOr> music++
13:28:31 <zodbot> MeWjOr: Karma for music changed to 2 (for the current release cycle):  https://badges.fedoraproject.org/tags/cookie/any
13:28:32 <omnidapps[m]> music++
13:28:39 <shaane[m]> music++
13:28:51 <omnidapps[m]> I can't give karma :(
13:28:52 <FranciscoD> omnidapps[m]: it won't work if your IRC nick on FAS doesn't match what you're using now
13:28:56 <FranciscoD> same for you shaane[m]
13:29:09 <shaane[m]> that makes sense rip, i'll have to change that
13:29:14 <MeWjOr> FranciscoD++
13:29:15 <omnidapps[m]> it matches, look at my fasinfo above
13:29:18 <FranciscoD> zodbot needs to know who is giving the cookie, and to whom,
13:29:30 <MeWjOr> already given karma for this release cycle I guess
13:29:36 <FranciscoD> omnidapps[m]: hrm, then maybe it doesn't work over the matrix bridge? :(
13:29:37 <shaane[m]> Yeah that tracks that tracks
13:29:49 <FranciscoD> since zodbot is here on IRC
13:29:51 <omnidapps[m]> possible, I'll try on IRC
13:29:56 <omnidapps[m]> oh right, I need to sign up on libera chat
13:29:56 <FranciscoD> I *thought* it worked, very odd
13:30:21 <FranciscoD> Any other items on the dashboard that need urgent attention?
13:30:33 <FranciscoD> #action FranciscoD fix and update arbor
13:30:57 <FranciscoD> and ITK, of course >_>
13:31:00 <FranciscoD> #chair omnidapps
13:31:00 <zodbot> Current chairs: FranciscoD MeWjOr achilleas major music omnidapps omnidapps[m] shaane[m] zbyszek_
13:31:09 <MeWjOr> lol
13:31:15 <FranciscoD> #action FranciscoD fix ITK
13:31:23 <FranciscoD> although it builds and installs, so it's fine :P
13:32:03 <omnidapps> o/
13:32:09 <omnidapps> music++
13:32:09 <zodbot> omnidapps: Karma for music changed to 3 (for the current release cycle):  https://badges.fedoraproject.org/tags/cookie/any
13:32:17 <FranciscoD> omnidapps[m]: I just realised that your matrix nick on the IRC side has a '[m]' suffix, so it's not exactly the same as what's in your FAS profile
13:32:19 <omnidapps> oh it doesn't match, has omnidapps[m]
13:32:20 <omnidapps> yeah
13:32:33 <FranciscoD> Yeh, maybe try adding the [m] version too, and then it *should* work
13:32:38 <omnidapps> just noticed that too... also IRC is much faster than matrix I noticed
13:32:42 <FranciscoD> shaane[m]: for you too ^
13:32:49 <omnidapps> that bridge must be pretty laggy
13:32:57 <FranciscoD> Yeh, it's still all being setup
13:33:25 <FranciscoD> OK, our packages are in good health then, let's move on
13:33:35 <FranciscoD> #topic Open package reviews check
13:33:53 <FranciscoD> #info All our new reviews should block the "fedora-neuro" blocker bug: https://bugzilla.redhat.com/show_bug.cgi?id=fedora-neuro
13:34:06 <FranciscoD> Look under the "depends" bit to see what new reviews are pending
13:34:29 <FranciscoD> You may need to click "Show advanced fields" on the right to see the "depends" field
13:34:53 <FranciscoD> #info Only 2 review tickets pending: sumatra and spikeextractors
13:34:55 <omnidapps> huh that's neat
13:35:23 <FranciscoD> Spikeextractors needs a few more deps---4 more to be exact. I'll start working on those so that Andy can continue with spikeextractors
13:35:51 <FranciscoD> Do feel free to pick up any of the deps---they're all relatively simple python packages
13:35:54 <FranciscoD> (or so I hope :P)
13:36:04 <FranciscoD> #info Spikeextractors needs 4 more deps: WIP
13:36:35 <shaane[m]> Wait so once all the dependencies are resolved for this bug what happens?
13:37:30 <MeWjOr> FranciscoD let us know if we can help with the reviews of those deps
13:38:23 <FranciscoD> shaane[m]: those deps are needed for its tests to run correctly
13:38:28 <FranciscoD> so until then, the review cannot proceed :/
13:38:55 <FranciscoD> (since the tests cannot currently be run)
13:39:07 <FranciscoD> MeWjOr: will do, I tend to block fedora-neuro so everyone should get a notification :D
13:39:53 <shaane[m]> Ah, okay follow up q, it mentions that this is the "central tracking bug" at the bottom of the page, what does that entail? Is it that the tests cannot currently be run or is there more to it?
13:40:22 <FranciscoD> shaane[m]: ah, you're asking about the fedora-neuro bug?
13:40:29 <FranciscoD> or the spikeextractors review bug?
13:40:47 <FranciscoD> what I said about the tests was for the spikeextractors review bug
13:40:57 <shaane[m]> 1276941 on bugzilla
13:41:09 <shaane[m]> so yeah the fedora-neuro bug i think
13:41:17 <FranciscoD> Yeh: the fedora-neuro bug is simply a tracker-bug. Whenever we package a new software for the neuro-sig, we "block" fedora-neuro
13:41:22 <omnidapps> that one is a long living bug to demonstrate blockers
13:41:23 <shaane[m]> Sorry for the ambiguity
13:41:32 <FranciscoD> and that sends a notification to everyone on the neuro-sig packager team
13:41:58 <FranciscoD> it's a "housekeeping bug"
13:42:06 <shaane[m]> Ahhhh okay okay no that makes perfect sense
13:42:10 <FranciscoD> simply for us to be able to quickly see what reviews are in progress
13:42:46 <shaane[m]> Right of course yeah I was reading too much into it i think that tracks
13:42:53 <FranciscoD> that reminds me---if you're sponsored as a packager already, please subscribe to the neuro-sig mailing list. That's where bugzilla notifications go.
13:43:05 <FranciscoD> https://lists.fedoraproject.org/admin/lists/neuro-sig.lists.fedoraproject.org/
13:43:16 <FranciscoD> unlike the discussion lists, this is a private list
13:43:27 <shaane[m]> I thought i was my bad, i'll do that now
13:43:33 <FranciscoD> because it gets bug notifications, and may receive private bug info too
13:43:54 <shaane[m]> for sure for sure
13:44:01 <FranciscoD> A private bug is one which may contain some information that the reporter only wants to share with us package maintainers, and not the public. They're rare, but they do happen.
13:44:28 <FranciscoD> #topic CompNeuro lab compose a status check for F34/F35
13:44:42 <FranciscoD> #info CompNeuro ISO compose task on Koji: https://koji.fedoraproject.org/koji/packageinfo?packageID=30691
13:44:56 <FranciscoD> #info Green tick: ISO building fine
13:45:15 <omnidapps> I found out why I haven't been getting notifications
13:45:25 <FranciscoD> This is the ISO image that will end up here each release: https://labs.fedoraproject.org/comp-neuro/
13:45:25 <omnidapps> the mailing list subscription was using a super old email I don't use anymore
13:45:30 <FranciscoD> omnidapps: ahhhh
13:45:42 <FranciscoD> you can manage all your e-mails on hyperkitty (the lists.fp.o frontend)
13:45:43 <omnidapps> it was my email from like 2014 lol
13:45:45 <FranciscoD> XD
13:46:10 <FranciscoD> if you have multiple e-mails, that often happens. I think you can select which e-mail you want to use in the hyperkitty interface---in your profile IIRC
13:46:16 <FranciscoD> oh, IIRC = if I recall correctly
13:46:37 <omnidapps> I removed the old email to be sure
13:46:47 <FranciscoD> omnidapps: for configupdater, I've assigned it to the e-mail in your FAS
13:46:55 <music> (thanks for the acknowledgment earlierโ€”I have been dropping in and out and just caught up on skimming the meeting logs)
13:47:01 <omnidapps> yup I got a notification about that one
13:47:05 <FranciscoD> omnidapps: awesome :)
13:47:19 <FranciscoD> music: no worries, thanks so much for all your help
13:47:24 <FranciscoD> and thanks for dropping by :)
13:47:36 <FranciscoD> #topic Neuroscience query of the week
13:47:50 <FranciscoD> I don't think I have any queries. Had shared a few links on the reading list
13:48:24 <FranciscoD> You can take a look at our Neuroscientists' planet to see if you find anything interesting there: https://neuroblog.fedoraproject.org/planet-neuroscientists/
13:48:43 <FranciscoD> #info thanks MeWjOr and omnidapps for migrating that to pluto from venus :)
13:48:57 <MeWjOr> :D
13:49:17 <omnidapps> #action omnidapps - reach out to fedora infra about migrating fedora main pluto as well
13:49:22 <FranciscoD> ++
13:49:38 <FranciscoD> that'll be awesome, and I'm sure they'll be happy to move
13:50:18 <FranciscoD> Oh, if you see any other neuro related blogs etc. that we don't have on the planet yet, please open a PR on this file: https://github.com/neurofedora/planet-neuroscientists/blob/master/planet.ini
13:50:42 <omnidapps> will do
13:50:56 <FranciscoD> Same for the neuroscience planet, which does journals instead of blogs: https://github.com/neurofedora/planet-neuroscience/blob/master/planet.ini
13:51:06 <omnidapps> #info Add neuroscience blogs here - https://github.com/neurofedora/planet-neuroscientists/blob/master/planet.ini
13:51:23 <omnidapps> #undo
13:51:23 <zodbot> Removing item from minutes: INFO by omnidapps at 13:51:06 : Add neuroscience blogs here - https://github.com/neurofedora/planet-neuroscientists/blob/master/planet.ini
13:51:39 <omnidapps> #info Add neuroscience blogs here https://github.com/neurofedora/planet-neuroscientists/blob/master/planet.ini and https://github.com/neurofedora/planet-neuroscience/blob/master/planet.ini
13:53:50 <omnidapps> awkward silence lol :)
13:54:12 <FranciscoD> sorry, had someone at the door XD
13:54:14 <shaane[m]> Haha o/
13:54:26 <FranciscoD> #topic Next meeting day, and chair
13:54:33 <FranciscoD> same time in 2 weeks work for everyone?
13:54:49 <omnidapps> +1
13:54:52 <FranciscoD> that is: 1300 UTC on Monday 27th September?
13:55:05 <shaane[m]> _1
13:55:07 <shaane[m]> oops
13:55:09 <shaane[m]> +1
13:55:25 <FranciscoD> I think major dropped out, but this time has worked for them
13:55:34 <FranciscoD> #agreed Next meeting in 2 weeks at 1300 UTC on Monday 27 September
13:55:41 <FranciscoD> any takers to chair? :D
13:55:55 <FranciscoD> I'm always happy to chair of course, but good if we take turns :)
13:56:28 <shaane[m]> I'd totally do it if no one else wants to
13:56:30 <omnidapps> This one I will focus on the two action items I have (and actually get them done)
13:56:55 <FranciscoD> shaane[m]: it'll be awesome if you'd like to give chairing a go.
13:57:01 <FranciscoD> we'll all be here to help, of course :)
13:57:06 <omnidapps> shaane[m]++
13:57:15 <FranciscoD> looks like you've been voted chair :P
13:57:21 <FranciscoD> #agreed shaane[m] will chair next meeting
13:57:28 <FranciscoD> #topic Open floor
13:57:34 <shaane[m]> Haha sweet thanks : ) i'll read up on those commands
13:57:36 <FranciscoD> Look at that, 3 minutes to spare :D
13:57:53 <FranciscoD> if there's anything else at all, please use the remaining time to discuss it
13:58:01 <FranciscoD> I'll close at the end of the hour otherwise
13:58:35 <shaane[m]> Oh I guess while we're here -- the autotest discovery, is that something you can configure within the .spec?
13:58:45 <FranciscoD> shaane[m]: I think that's a unittest thing
13:58:49 <shaane[m]> / how would i go about troubleshooting that
13:58:50 <FranciscoD> hold on, let me pull up the docs
13:59:04 <shaane[m]> ๐Ÿ‘๏ธ๐Ÿ‘๏ธ๐Ÿ‘๏ธ๐Ÿ‘๏ธ ty ty
13:59:12 <FranciscoD> shaane[m]: https://docs.python.org/3/library/unittest.html?highlight=unittest#unittest-test-discovery
13:59:29 <omnidapps> could be https://github.com/fedora-infra/elections/blob/develop/tox.ini
13:59:33 <omnidapps> tox.ini if using tox
13:59:46 <omnidapps> ah ok
14:00:01 <FranciscoD> Yeh, with pytest and tox, you can customise the identifier
14:00:06 <shaane[m]> Thats something the repo themselves would have to provide right? Or is this something on my end
14:00:17 <FranciscoD> by default, unittest looks for classes that end in TestCase
14:00:30 <FranciscoD> shaane[m]: yeh, that should be done by the devs, not us
14:01:00 <shaane[m]> Okay, would it be viable to submit a pr on the pyplane repo you think?
14:01:09 <omnidapps> if it isn
14:01:13 <omnidapps> if it isn't working *
14:01:15 <shaane[m]> If i can figure out that that's indeed the crux of the issue
14:01:18 <FranciscoD> shaane[m]: yeh ++
14:01:26 <FranciscoD> although i see that they have no CI at all?
14:01:32 <FranciscoD> no travis, no GH actions?
14:01:39 <shaane[m]> Yeah doesn't look like it
14:02:01 <FranciscoD> this test is.. quite basic: https://github.com/TUD-RST/pyplane/blob/master/tests/test_core.py
14:02:03 <FranciscoD> XD
14:02:11 <omnidapps> if you have time and want to make upstream PR's when you encounter issues upstream it seems it would be helpful
14:02:26 <omnidapps> lol
14:02:28 <FranciscoD> it checks if LaTeX is installed on the machine, so it isn't a unit test/integration test from the looks of it
14:02:33 <FranciscoD> shaane[m]: you can skip it tbh
14:02:39 <FranciscoD> (tbh = to be honest)
14:02:52 <FranciscoD> it doesnt' really check pyplane functionality at all.
14:02:57 <shaane[m]> Haha i hadn't looked at the test source code yet lol thats really good
14:03:26 <FranciscoD> shaane[m]: do make a note in the spec, and that'll be enough
14:03:45 <FranciscoD> OK, let me let zodbot go, and we can continue chatting
14:03:48 <shaane[m]> Alright gotcha will do
14:03:55 <FranciscoD> #action FranciscoD send out logs etc.
14:03:58 <FranciscoD> #endmeeting