neurofedora
LOGS
13:02:48 <FranciscoD> #startmeeting NeuroFedora - 2021-04-26
13:02:48 <zodbot> Meeting started Mon Apr 26 13:02:48 2021 UTC.
13:02:48 <zodbot> This meeting is logged and archived in a public location.
13:02:48 <zodbot> The chair is FranciscoD. Information about MeetBot at http://wiki.debian.org/MeetBot.
13:02:48 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
13:02:48 <zodbot> The meeting name has been set to 'neurofedora_-_2021-04-26'
13:02:53 <FranciscoD> #meetingname neurofedora
13:02:53 <zodbot> The meeting name has been set to 'neurofedora'
13:02:55 <omnidapps> Hi 🙋‍♂️ I’m here if you guys need me, but working on some stuff in the background
13:03:20 <FranciscoD> #chair achilleas bt0 bt0 omnidapps gicmo music zbyszek iztokf[m] osezer ChanServ mambang[m]
13:03:20 <zodbot> Current chairs: ChanServ FranciscoD achilleas bt0 gicmo iztokf[m] mambang[m] music omnidapps osezer zbyszek
13:03:24 <bt0> .fas bt0dotninja
13:03:24 <zodbot> bt0: bt0dotninja 'Alberto Rodriguez Sanchez' <hotgalan@gmail.com>
13:03:34 <FranciscoD> please let us know if there's anyone else so I can chair you
13:03:39 <FranciscoD> #topic Agenda
13:03:48 <FranciscoD> Agenda from here: https://neuroblog.fedoraproject.org/2021/04/26/next-open-neurofedora-meeting-26-april-1300-utc.html
13:03:58 <FranciscoD> #info New introductions and roll call
13:04:07 <FranciscoD> #info Tasks from last meeting
13:04:13 <FranciscoD> #info Open Pagure tickets
13:04:25 <FranciscoD> #info Packages health check
13:04:35 <FranciscoD> #info Open package reviews check
13:04:47 <FranciscoD> #info CompNeuro lab compose check for F34/F35
13:04:55 <FranciscoD> #info Neuroscience query of the week
13:05:18 <FranciscoD> #info Next meeting day/chair
13:05:22 <FranciscoD> #info Open floor
13:05:29 <FranciscoD> Starting with the first topic
13:05:35 <FranciscoD> #topic New intrductions and roll call
13:05:45 <FranciscoD> .hello ankursinha
13:05:46 <zodbot> FranciscoD: ankursinha 'Ankur Sinha' <sanjay.ankur@gmail.com>
13:06:11 <gicmo> .hello gicmo
13:06:12 <zodbot> gicmo: gicmo 'Christian Kellner' <ckellner@redhat.com>
13:06:13 <iztokf[m]> .fas iztokf
13:06:16 <zodbot> iztokf[m]: iztokf '' <iztok@iztok-jr-fister.eu>
13:06:32 <achilleas> .hello achilleas
13:06:33 <zodbot> achilleas: achilleas 'Achilleas Karanasios' <achilleas.karanasios@gmail.com>
13:06:43 <achilleas> oops, no, wrong one
13:06:45 <achilleas> .hello akoutsou
13:06:46 <zodbot> achilleas: akoutsou 'Achilleas Koutsou' <akoutsou@redhat.com>
13:06:48 <omnidapps> .hello nerdsville
13:06:49 <zodbot> omnidapps: nerdsville 'Josh Santos' <josh@omnidapps.com>
13:07:00 <bt0> .fas bt0dotninja
13:07:00 <osezer> .hello thunderbirdtr
13:07:00 <zodbot> bt0: bt0dotninja 'Alberto Rodriguez Sanchez' <hotgalan@gmail.com>
13:07:02 <FranciscoD> #info major sends their regrets
13:07:03 <bt0> :)
13:07:03 <zodbot> osezer: thunderbirdtr 'Onuralp SEZER' <thunderbirdtr@gmail.com>
13:07:21 <FranciscoD> thunderbirdtr++
13:07:23 <FranciscoD> :)
13:07:24 <zodbot> FranciscoD: Karma for thunderbirdtr changed to 5 (for the current release cycle):  https://badges.fedoraproject.org/tags/cookie/any
13:07:38 <osezer> FranciscoD++
13:07:39 <osezer> o/
13:07:46 <FranciscoD> more cookies from tomorrow after release, btw :)
13:07:56 <osezer> I'm waiting :)
13:08:07 <FranciscoD> i.e., so use up your cookies for the F33 release today :P
13:08:12 <gicmo> buiscuits!
13:08:15 <FranciscoD> #topic Task from last meeting
13:08:26 <FranciscoD> #info Last meeting minutes: https://meetbot.fedoraproject.org/teams/neurofedora/neurofedora.2021-04-12-13.00.html
13:08:36 <FranciscoD> #info FranciscoD e-mail -devel list for review swaps: DONE
13:08:49 <FranciscoD> #info MeWjOr file issue upstream, skip tests in spec and continue with snakemake package: WIP/PENDING
13:08:58 <FranciscoD> reassigning it to major/MeWjOr
13:09:07 <FranciscoD> #action MeWjOr file issue upstream, skip tests in spec and continue with snakemake package
13:09:17 <FranciscoD> #nick MeWjOr
13:09:38 <FranciscoD> #info bt0 send out the meeting logs and everything else: DONE
13:09:42 <FranciscoD> that's all, pretty good :D
13:09:55 <FranciscoD> #topic Open Pagure tickets
13:10:16 <FranciscoD> #info Please open tickets that you think need to be discussed in meetings on our Pagure instance here: https://pagure.io/neuro-sig/NeuroFedora/issues?status=Open&tags=S%3A+Next+meeting
13:10:39 <FranciscoD> #info Issue #421: Use pluto instead of venus for planets? https://pagure.io/neuro-sig/NeuroFedora/issue/421
13:10:47 <FranciscoD> omnidapps: this is WIP, right?
13:10:51 <FranciscoD> (low priority)
13:11:25 <FranciscoD> any updates here? Note that major isn't here, and omnidapps and major are working on the two halves of this task
13:11:58 <omnidapps> No updates yet
13:12:13 <omnidapps> I will be pushing this forward this week
13:12:22 <FranciscoD> OK, sounds good. Thanks for working on it :)
13:12:33 <FranciscoD> if there's anything we can help with, please let us know
13:12:38 <omnidapps> Will do :)
13:12:56 <FranciscoD> I customised the Venus templates initially, so if you need any info about that bit, I can help
13:13:21 <omnidapps> Great!
13:13:22 <FranciscoD> omnidapps: perhaps it's worth just testing out pluto with the list of rss feeds to see how it works?
13:13:31 <FranciscoD> and we can customise the templates next?
13:13:44 <omnidapps> Yup that’s what I’ll be doing
13:13:50 <FranciscoD> awesome, thanks
13:14:00 <FranciscoD> that's the only ticket, moving to next topic
13:14:10 <FranciscoD> #topic Packages health check
13:14:27 <FranciscoD> #info Please refer to our packager dashboard here: https://packager-dashboard.fedoraproject.org/neuro-sig
13:14:34 * FranciscoD loves the packager dashboard
13:15:33 <FranciscoD> got a few FTBFS bugs, but some of them are for F32
13:15:51 <FranciscoD> which will go EOL a month after the F34 release tomorrow. So I'd ignore the F32 bugs
13:16:27 <FranciscoD> If you click on the "gear" icon, you can deselect F32 there
13:18:03 <FranciscoD> I see a few packages from the python SIG in the list
13:18:11 <FranciscoD> do we co-maintain them??
13:18:51 <FranciscoD> ah, no, they're ours---koschei still doesn't show our full list
13:19:37 <gicmo> FranciscoD: yeah that dashboard is really cool
13:19:41 <fm-neuro> pagure.issue.comment.added -- ankursinha commented on ticket fedora-infrastructure#9664: "Koschei: not all neuro-sig packages are listed in the neuro-sig group now" https://pagure.io/fedora-infrastructure/issue/9664#comment-729500
13:19:56 <FranciscoD> #info Koschei package list sync issue: https://pagure.io/fedora-infrastructure/issue/9664
13:20:11 <bt0> I remember a ticket about stop updating the lists ..
13:20:16 <bt0> right that one
13:20:27 <FranciscoD> #action FranciscoD file new issue requesting infra to disable Koschei automatic package list sync if we don't hear back on current issue
13:20:39 <FranciscoD> bt0: yeh, but I'll file a new issue if we don't get a response on this one
13:21:11 <FranciscoD> I don't know if we can trust the FTBFS/FTI list at the moment---is probably incomplete
13:22:11 <bt0> right
13:22:30 <FranciscoD> I readded all our packages manually, please go to this page (and refresh a few times): https://koschei.fedoraproject.org/groups/neuro-sig
13:22:59 <FranciscoD> I maintain a list of our packages here now, for the time being: https://pagure.io/neuro-sig/NeuroFedora/blob/main/f/package-list/list.txt
13:23:16 <FranciscoD> #action FranciscoD update package list file
13:23:42 <FranciscoD> koschei looks OK? Nothing new there
13:23:49 <FranciscoD> anything we need to look at urgently?
13:24:06 <FranciscoD> it's odd that some packages are broken for f33, but not f34
13:25:16 <FranciscoD> some maybe failing to build, but their latest succesful builds look installable
13:25:27 <FranciscoD> https://src.fedoraproject.org/rpms/python-bokeh for example, is FTBFS in F33 according to koschei
13:26:03 <fm-neuro> pagure.issue.comment.added -- mizdebsk commented on ticket fedora-infrastructure#9664: "Koschei: not all neuro-sig packages are listed in the neuro-sig group now" https://pagure.io/fedora-infrastructure/issue/9664#comment-729502
13:26:17 <FranciscoD> there are a few update bugs---please update packages if you have the time
13:26:30 <FranciscoD> you can open PRs if you're not the main maintainer and aren't sure of the update
13:27:06 <fm-neuro> pagure.issue.comment.added -- ankursinha commented on ticket fedora-infrastructure#9664: "Koschei: not all neuro-sig packages are listed in the neuro-sig group now" https://pagure.io/fedora-infrastructure/issue/9664#comment-729503
13:27:39 <FranciscoD> OK, moving on to next topic. If any urgent package related tasks need done, please e-mail the list
13:27:43 <FranciscoD> or bump bugs etc :)
13:28:01 <FranciscoD> #topic Open package reviews check
13:28:19 <FranciscoD> #info NeuroFedora new package tracker bug is here: https://bugzilla.redhat.com/show_bug.cgi?id=fedora-neuro
13:28:32 <FranciscoD> #info All new package reviews should block this bug
13:29:36 <FranciscoD> iztokf[m]: this seems to be complete, should I close? https://bugzilla.redhat.com/show_bug.cgi?id=1945621
13:29:48 <FranciscoD> python-sport-activities-features?
13:29:51 <FranciscoD> https://src.fedoraproject.org/rpms/python-sport-activities-features
13:30:23 <FranciscoD> Also niaclass? https://src.fedoraproject.org/rpms/python-niaclass
13:31:43 <FranciscoD> I don't see any other reviews that need work at the moment. Please ping us if you need a review, and please do review other packages to help folks
13:32:04 <FranciscoD> #action FranciscoD ask iztokf[m] about closing niaclass and sport-activities-features review tickets
13:32:25 <iztokf[m]> Yes. You can close. Thanks.
13:32:30 <FranciscoD> #topic CompNeuroFedora lab image compose check
13:32:33 <FranciscoD> oo, awesome thanks iztokf[m]
13:32:43 <FranciscoD> #action FranciscoD close niaclass and sport-activities-features bugs
13:32:49 <iztokf[m]> Thanks for reviewing.
13:32:57 <FranciscoD> #info Compose status here: https://koji.fedoraproject.org/koji/packageinfo?packageID=30691
13:33:05 <FranciscoD> the rawhide build is currently failing
13:33:12 <iztokf[m]> FranciscoD++
13:34:51 <FranciscoD> hrm, is this what's causing the build failure? "ERROR: Option --old-chroot has been deprecated. Use --isolation=simple instead."
13:34:54 <FranciscoD> https://kojipkgs.fedoraproject.org//work/tasks/1722/66701722/mock_output.log
13:35:23 <FranciscoD> ah, here it is:
13:35:24 <FranciscoD> https://kojipkgs.fedoraproject.org//work/tasks/1722/66701722/anaconda-anaconda.log
13:35:32 <FranciscoD> Problem: conflicting requests
13:35:34 <FranciscoD> - package python3-scikit-image-0.18.1-3.fc35.x86_64 requires python3.9dist(networkx) >= 2, but none of the providers can be installed
13:35:36 <FranciscoD> - nothing provides (python3.9dist(decorator) < 5 with python3.9dist(decorator) >= 4.3) needed by python3-networkx-2.5.1-1.fc35.noarch
13:36:34 <FranciscoD> we don't maintain either package, so we'll wait for their maintainers to fix them
13:37:24 <FranciscoD> #action everyone check compose at next meeting and poke networkx/scikit-image maintainers to fix FTI issues if necessary
13:37:27 <FranciscoD> #nick everyone
13:37:42 <FranciscoD> F34 compose is fine, will be release tomorrow :D
13:37:49 <FranciscoD> please remember to spread the word
13:38:05 <FranciscoD> #topic Neuroscience query/topic of the week
13:38:09 <FranciscoD> Anything here?
13:39:00 * FranciscoD quickly checks the planet
13:39:05 <FranciscoD> https://neuroblog.fedoraproject.org/planet-neuroscientists/
13:39:32 <FranciscoD> Everyone is probably aware of this already: https://www.sciencenews.org/article/nasa-perseverance-rover-mars-oxygen-air
13:39:53 <gicmo> that is soo cool
13:40:08 <FranciscoD> +1 :D
13:40:17 <gicmo> did everybody see the drone take off and land too?
13:40:20 <gicmo> so amazing
13:40:36 <FranciscoD> Yeh!
13:41:14 <FranciscoD> #info Our reading list is here, please put anything you'd like to share with the community here: https://pagure.io/neuro-sig/NeuroFedora/issue/318
13:41:38 <FranciscoD> iztokf[m]: had shared this: https://www.nature.com/articles/s42256-020-00287-7 (An open source machine learning framework for efficient and transparent systematic reviews)
13:41:56 <FranciscoD> and bcotton, the Fedora Program Manager had shared this: https://funnelfiasco.com/blog/2021/04/19/balancing-incoming-tasks-in-volunteer-projects/
13:42:03 <FranciscoD> s/shared/written/
13:42:08 <FranciscoD> anything else here?
13:42:55 <iztokf[m]> Not at the moment from my side.
13:43:05 <FranciscoD> me neither
13:43:07 <iztokf[m]> I will share some interesting stuffs by the end of this week.
13:43:16 <FranciscoD> awesome, thanks very much iztokf[m]
13:43:34 <FranciscoD> #topic Next meeting day/chair
13:43:41 <FranciscoD> Same time in 2 weeks work for everyone?
13:44:01 <FranciscoD> any volunteers for chairing it?
13:44:09 <FranciscoD> gicmo: iztokf[m] bt0 ^ ?
13:44:45 <gicmo> yeah, should work
13:44:45 <iztokf[m]> I can chair after 25 June.
13:44:47 <gicmo> can do
13:44:56 <FranciscoD> great, thanks gicmo
13:45:06 <FranciscoD> #info gicmo to chair next meeting
13:45:06 <tg-fedneuro> <t​hatnerdjosh> Works for me and this time I’ll have something to share ^.^
13:45:12 <FranciscoD> awesome
13:45:33 <FranciscoD> #agreed Next meeting at same time (1300 UTC) in 2 weeks (10th May)
13:45:44 <FranciscoD> iztokf[m]: great, we look forward to you chairing too :)
13:45:56 <FranciscoD> OK, open floor then
13:45:59 <FranciscoD> #topic Open Floor
13:46:06 <FranciscoD> #action FranciscoD send out logs etc.
13:46:17 <iztokf[m]> Yeah. I will not have any other pedagogical stuffs after 25th.
13:46:24 <FranciscoD> Open floor: everything that wasn't on the agenda goes here
13:46:37 <FranciscoD> iztokf[m]: ah, I'm not teaching at all at the moment
13:46:51 <FranciscoD> will have GSoC mentoring in a bit, but that's nowhere as time consuming
13:47:07 <iztokf[m]> I will need some reviewers for quick reviews of R packages
13:47:14 <iztokf[m]> Very simple packages :)
13:47:17 <FranciscoD> sure :)
13:47:25 <iztokf[m]> I may start first review tonight.
13:47:29 <FranciscoD> oh, eclipseo has been reviewing quite a few of our packages too
13:47:34 <iztokf[m]> :)
13:47:34 <FranciscoD> eclipseo++
13:47:34 <zodbot> FranciscoD: Karma for eclipseo changed to 1 (for the current release cycle):  https://badges.fedoraproject.org/tags/cookie/any
13:47:42 <iztokf[m]> eclipseo++
13:47:49 <iztokf[m]> FranciscoD++
13:47:54 <bt0> eclipseo++
13:47:54 <zodbot> bt0: Karma for eclipseo changed to 2 (for the current release cycle):  https://badges.fedoraproject.org/tags/cookie/any
13:47:57 <FranciscoD> https://fedoraproject.org/wiki/User:Eclipseo
13:48:21 <FranciscoD> iztokf[m]: zodbot probably doesn't recognise your nick
13:48:37 <iztokf[m]> I see
13:48:38 <FranciscoD> it's been updated to use the new FAS system, where one can specify multiple nicks etc
13:48:57 <FranciscoD> I think infra are working on a new release
13:49:18 <FranciscoD> #info F34 releases tomorrow
13:49:34 <FranciscoD> plesae help seed torrents etc. and spread the word on social media (also about the CompNeuro lab)
13:49:52 <FranciscoD> https://torrent.fedoraproject.org/ should be updated soon
13:50:33 <FranciscoD> #info Please remember to register (for free!) for the Fedora 34 release party: https://communityblog.fedoraproject.org/save-the-date-fedora-linux-34-release-party/
13:50:49 <iztokf[m]> Already on the list :)
13:50:53 * FranciscoD too
13:50:56 <FranciscoD> :D
13:51:26 <FranciscoD> if there's nothing else, I'll close the meeting in 2 minutes
13:51:39 <iztokf[m]> Thanks for chairing.
13:51:44 <iztokf[m]> See you soon.
13:51:53 <FranciscoD> thanks for coming everyone
13:52:06 <FranciscoD> I hope you have a safe and constructive week
13:52:14 <FranciscoD> If there's anything we can help with, please do let us know
13:52:25 <iztokf[m]> Thanks. You too.
13:52:32 <FranciscoD> #endmeeting