neurofedora
LOGS
13:00:27 <bt0> #startmeeting NeuroFedora - 2021-02-01
13:00:27 <zodbot> Meeting started Mon Feb  1 13:00:27 2021 UTC.
13:00:27 <zodbot> This meeting is logged and archived in a public location.
13:00:27 <zodbot> The chair is bt0. Information about MeetBot at http://wiki.debian.org/MeetBot.
13:00:27 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
13:00:27 <zodbot> The meeting name has been set to 'neurofedora_-_2021-02-01'
13:00:36 <bt0> #meetingname neurofedora
13:00:36 <zodbot> The meeting name has been set to 'neurofedora'
13:00:46 <bt0> #chair FranciscoD gicmo zbyszek MeWjOr
13:00:46 <zodbot> Current chairs: FranciscoD MeWjOr bt0 gicmo zbyszek
13:01:06 <tg-fedneuro> <M​eWjOr> Coming on IRC
13:01:07 <bt0> #topic Today's Agenda
13:01:07 <bt0> #info introductions and roll call
13:01:07 <bt0> #info Tasks from last bi-week's meeting:
13:01:07 <bt0> #info Open Pagure tickets
13:01:07 <bt0> #info Open NeuroFedora bugs
13:01:07 <bt0> #info Koschei packages check
13:01:09 <bt0> #info CompNeuro lab compose status check for F33/F34
13:01:11 <bt0> #info Neuroscience query of the week
13:01:13 <bt0> #info Next meeting day, and chair
13:01:15 <bt0> #info open floor
13:01:26 <bt0> Hi compadre
13:01:40 <bt0> #topic introductions and roll call
13:01:54 <bt0> #info Alberto Rodriguez Sanchez, FAS: bt0dotninja, IRC: bt0; CommOps, NeuroFedora, Marketing, fedora-join, mindshare, etc. ; UTC -6
13:02:02 <MeWjOr> Hola!
13:02:16 <bt0> Ok I will wait a little for more quorum
13:02:34 <bt0> Hola MeWjOr
13:02:46 <MeWjOr> #info MeWjOr - Aniket Pradhan, TZ: +5:30, NeuroFedora, packaging, random chit-chat
13:02:58 <MeWjOr> \o
13:03:17 <rachitt_shah[m]> How to join the meeting? Or is it text based?
13:03:34 <bt0> text based here.
13:03:35 <MeWjOr> It's text based
13:03:39 <bt0> You are in :)
13:05:37 <bt0> If this is your first meeting introduce yourself :)
13:07:06 <MeWjOr> +1
13:07:39 <rachitt_shah[m]> <bt0 "text based here."> Oh,got confused XD
13:08:29 <bt0> This is our bi-weekly meeting, is over irc/telegram/matrix
13:08:57 <bt0> Welcome rachitt :)
13:09:18 <MeWjOr> We also pitched an idea of having video conferencing as well, along with textual meeting for the logs
13:09:28 <MeWjOr> guess we never went ahead with it
13:09:40 <bt0> well, sounds good too
13:09:52 <rachitt_shah[m]> <bt0 "If this is your first meeting in"> Hello NeuroFedora!
13:10:07 <bt0> :)
13:10:18 <bt0> ok, next topic
13:10:23 <bt0> #topic Task from the last meeting
13:10:35 <bt0> #link https://meetbot.fedoraproject.org/teams/neurofedora/neurofedora.2021-01-18-13.06.html
13:10:53 <bt0> #info bt0 review https://bugzilla.redhat.com/show_bug.cgi?id=1913491 (CompNeuro container image)
13:11:25 <bt0> #link https://bugzilla.redhat.com/show_bug.cgi?id=1913491
13:11:52 <bt0> Done and also we get this new repo:
13:11:57 <bt0> #linik https://src.fedoraproject.org/container/compneuro
13:12:07 <bt0> #link https://src.fedoraproject.org/container/compneuro
13:12:11 <MeWjOr> Ahh... that's great!
13:13:52 <bt0> yeah :)
13:14:08 <bt0> #info MeWjOr Fix the deps for python-odml
13:14:16 <MeWjOr> still pending
13:14:21 <bt0> ok,
13:14:37 <bt0> #action MeWjOr Fix the deps for python-odml
13:14:39 <bt0> :)
13:14:41 <MeWjOr> Have multiple dep requirements, and one of the dep maintainers are inactive :(
13:14:53 <MeWjOr> I'll ping them again
13:15:03 <bt0> ohh, i see :(
13:15:20 <bt0> we need more packagers
13:15:47 <bt0> #info alciregi check on python-pydicom package
13:16:02 <MeWjOr> I'll probably try to get some packages on my hands... but am unable to do so for the time being
13:16:42 <bt0> it's fine, we need to ask for help
13:17:03 * FranciscoD_ is here
13:17:05 <FranciscoD_> sorry!
13:17:07 <bt0> #action alciregi check on python-pydicom package
13:17:09 <MeWjOr> What's up with pydicom?
13:17:12 <bt0> Don't worry
13:17:29 <MeWjOr> \o FranciscoD_
13:17:43 <bt0> I see some activities from Alciregi but he is not here right now
13:17:45 <FranciscoD_> \o/
13:17:58 <bt0> o/
13:18:25 <bt0> #info FranciscoD look at escaping URL correctly for Matrix link
13:18:42 <MeWjOr> bt0, pydicom seems fine actually - https://koschei.fedoraproject.org/package/python-pydicom?
13:18:58 <bt0> awesome
13:19:44 <bt0> #undo
13:19:44 <zodbot> Removing item from minutes: INFO by bt0 at 13:18:25 : FranciscoD look at escaping URL correctly for Matrix link
13:19:47 <bt0> #undo
13:19:47 <zodbot> Removing item from minutes: ACTION by bt0 at 13:17:07 : alciregi check on python-pydicom package
13:19:52 <bt0> #info FranciscoD look at escaping URL correctly for Matrix link
13:19:58 <bt0> :)
13:20:13 <MeWjOr> :D
13:20:31 <FranciscoD_> Ooo, I'm not sure if I've done this already
13:20:52 <bt0> ok, action
13:20:53 <FranciscoD_> I remember using the correct asciidoc syntax, but not sure if I corrected this one
13:20:58 <FranciscoD_> bt0: one sec, checking
13:21:08 <FranciscoD_> Ah, yes, fixed: https://docs.fedoraproject.org/en-US/neurofedora/communicating/
13:21:18 <bt0> ok, no action :)
13:21:21 <bt0> Thanks
13:21:27 <FranciscoD_> https://pagure.io/neuro-sig/documentation/c/c32b16c86e21161ca007b3666a779def6cd789e9?branch=master
13:21:28 <FranciscoD_> :D
13:21:41 <FranciscoD_> ascidoc does link:URL[text]
13:21:51 <bt0> noted
13:22:02 <MeWjOr> ahhh... I was wondering what the issue was earlier :P
13:22:25 <bt0> :P
13:22:32 <bt0> next topic
13:22:40 <bt0> #topic Open Pagure tickets
13:22:48 <bt0> #link https://pagure.io/neuro-sig/NeuroFedora/issues?status=Open&tags=S%3A+Next+meeting
13:23:00 <bt0> #info Ticket 318 NeuroFedora reading/listening list
13:23:07 <bt0> #link https://pagure.io/neuro-sig/NeuroFedora/issue/318
13:23:21 <bt0> this is the only one
13:24:04 <bt0> #link https://alleninstitute.org/what-we-do/brain-science/events-training/open-for-neuroscience-pre-symposium-tutorials/
13:24:57 <bt0> I want to ask Do you see some optimization problems on NeuroScience?
13:25:36 <FranciscoD_> bt0: hrm, depends on what you're looking to optimise
13:25:37 <bt0> (not directly related but Optimization is my field)
13:25:49 <FranciscoD_> lots of models need to be optimised
13:26:03 <FranciscoD_> and of course, in data analysis, there's always room for optimisation
13:26:30 <bt0> yeah
13:27:14 <bt0> I will look for some papers :)
13:27:24 <FranciscoD_> Sounds good.
13:27:33 <FranciscoD_> I'll ping you when if I find anything
13:27:40 <bt0> awesome :)
13:27:52 <bt0> next topic?
13:29:28 <FranciscoD_> +1
13:29:30 <bt0> #topic Open NeuroFedora bugs
13:29:45 <bt0> #link https://tinyurl.com/neurofedora-bugs
13:31:29 <bt0> I see many updates
13:31:49 <bt0> 3 fails to build
13:32:26 <FranciscoD_> hrm,
13:33:10 <gicmo> oh man totally missed the meeting?
13:33:26 <MeWjOr> almost made it
13:33:27 <MeWjOr> :P
13:33:29 <bt0> pydeps, python-mne and arbor (arbor is not a fail)
13:33:46 <MeWjOr> python-mne fails?
13:33:48 <MeWjOr> ohh man
13:33:50 <MeWjOr> not again
13:33:52 <MeWjOr> XD
13:34:48 <bt0> yes
13:35:11 <bt0> an assertion error
13:35:12 <MeWjOr> Ahh... it's because of python 3.10... It's still alpha iirc
13:35:19 <MeWjOr> I'll report upstream
13:35:21 <FranciscoD_> Yeh,
13:35:22 <MeWjOr> ^.^
13:35:26 <bt0> :)
13:35:42 <FranciscoD_> we can't do much about py3.10 yet: we're super early and most upstreams aren't supporting it yet
13:36:07 <bt0> ok, I don't see something urgent here, do you?
13:36:34 <FranciscoD_> nah, nothing blocking f34 etc, so it's all OK :D
13:36:55 <MeWjOr> Python 3.9 was released only a few months ago... Python 3.10 will easily take 4-5 months imo
13:37:13 <bt0> ok, next topic
13:37:20 <FranciscoD_> https://www.python.org/dev/peps/pep-0619/
13:37:23 <MeWjOr> F34 is not support py3.10 right?
13:37:31 <MeWjOr> not supporting*
13:37:40 * bt0 is reading
13:37:44 <FranciscoD_> No, I wouldnt think so
13:37:58 <bt0> #topic Koschei packages check
13:38:06 <FranciscoD_> f34 was branched from rawhide already, and all the py10 things are on rawhide/main
13:38:39 <bt0> #link https://koschei.fedoraproject.org/groups/neuro-sig
13:39:20 <MeWjOr> that's F35... seems great for the schedule
13:39:28 <bt0> yeah
13:40:33 <FranciscoD_> +1
13:41:59 <bt0> mvn stands for maven (Java)?
13:42:44 <MeWjOr> Seems like it... but could be something else too... I don't use Java much
13:43:03 <bt0> good for you :P
13:43:09 <MeWjOr> XD
13:43:23 <bt0> https://koschei.fedoraproject.org/package/neurord?collection=f34
13:44:30 <bt0> it's a dependencies problem
13:44:49 <bt0> #topic CompNeuro lab compose status check for F33/F34
13:44:59 <bt0> #link https://koji.fedoraproject.org/koji/packageinfo?packageID=30691
13:45:24 <FranciscoD_> building OK I think
13:45:29 <bt0> the status of build is good :)
13:45:30 <FranciscoD_> not received a failure notification recently
13:45:32 <FranciscoD_> YAY
13:45:43 <bt0> :D
13:45:59 <bt0> #topic Neuroscience query of the week
13:46:16 <bt0> I don't have one :(
13:46:28 <FranciscoD_> no worries, it's just a placeholder :)
13:47:02 <bt0> :)
13:49:21 <bt0> #link https://bmcneurosci.biomedcentral.com/articles/10.1186/1471-2202-16-S1-P117
13:50:12 <bt0> question: this is still looking cool for neuroscientist?
13:50:52 <bt0> :)
13:50:57 <bt0> next topic
13:51:00 <FranciscoD> hold on, looking
13:51:14 <bt0> #topic Next meeting day, and chair.
13:51:15 <FranciscoD> stuff isn't loading very well here
13:51:40 <FranciscoD> bt0: oo, yes, that's very useful
13:51:45 <bt0> cool
13:51:53 <FranciscoD> not sure what the current state of the art is, though. That's from ~5 years ago?
13:52:02 <FranciscoD> worth following up to see what else has been done
13:52:48 <bt0> Ok I will check most recent papers about this
13:53:10 <FranciscoD> +1
13:53:33 <bt0> the next meeting will be February, 15 sounds good?
13:54:00 <FranciscoD> +1
13:54:31 <bt0> and we need a chair, someone want to chair the next meeting?
13:54:51 <FranciscoD> I can if not MeWjOr ?
13:55:01 <FranciscoD> rachitt_shah[m]: you up for chairing a meeting? :D
13:55:21 <MeWjOr> I most probably will be able to next week
13:55:23 <MeWjOr> :D
13:55:59 <FranciscoD> lets do that then
13:56:56 <bt0> #action FranciscoD will chair the next meeting :)
13:57:15 <bt0> #topic openfloor
13:57:21 <tg-fedneuro> <Rachitt Shah> I would love to! Just would need to get used to the CoC
13:57:43 <bt0> #undo
13:57:43 <zodbot> Removing item from minutes: <MeetBot.items.Topic object at 0x7f94a6d02150>
13:57:46 <bt0> #undo
13:57:46 <zodbot> Removing item from minutes: ACTION by bt0 at 13:56:56 : FranciscoD will chair the next meeting :)
13:57:47 <FranciscoD> rachitt_shah[m]: no worries: you can attend a few meetings first, and get used to the commands etc.
13:58:01 <bt0> ohh
13:58:12 <bt0> #action FranciscoD will chair the next meeting
13:58:20 <MeWjOr> I remember, I made a cheat-sheet the first time I chaired a meeting
13:58:43 <bt0> I have and script with jokes and commands
13:58:53 <bt0> *an
13:59:09 <bt0> #topic openfloor
13:59:17 <bt0> #action bt0 send out the meeting logs and everything else
13:59:33 <FranciscoD> Just the one item before I head out
13:59:39 <bt0> just a minute for the open floor :?
13:59:42 <FranciscoD> try: `podman pull compneuro:f33` :D
13:59:50 <FranciscoD> or `podman pull compneuro:latest`
13:59:54 <FranciscoD> the image has hit stable :D
14:00:05 <FranciscoD> #action FranciscoD add info about compneuro container image to docs
14:00:06 <MeWjOr> ooooo.... hold up
14:01:18 <bt0> works for latest (rawhide  Ithink)
14:01:40 <MeWjOr> got it... just need to learn how to run it
14:02:29 <FranciscoD> https://docs.fedoraproject.org/en-US/neurofedora/containers/
14:02:35 <FranciscoD> I've put the basic commands there already
14:02:48 <FranciscoD> f33 should also work, I'll check if it doesn't
14:03:31 <MeWjOr> ahh yesss... I'm inside the container
14:03:55 <MeWjOr> This is truly amazing
14:04:04 <bt0> yeah :)
14:04:50 <MeWjOr> I'll have to leave now... Let's meet again in the next meeting!
14:04:52 <MeWjOr> Ciao
14:04:58 <bt0> Ciao
14:05:27 <bt0> ok let me close the meeting :)
14:05:38 <bt0> #endmeeting