neurofedora
LOGS
13:03:59 <FranciscoD> #startmeeting NeuroFedora - 2020-10-19
13:03:59 <zodbot> Meeting started Mon Oct 19 13:03:59 2020 UTC.
13:03:59 <zodbot> This meeting is logged and archived in a public location.
13:03:59 <zodbot> The chair is FranciscoD. Information about MeetBot at http://wiki.debian.org/MeetBot.
13:03:59 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
13:03:59 <zodbot> The meeting name has been set to 'neurofedora_-_2020-10-19'
13:04:03 <FranciscoD> #meetingname neurofedora
13:04:03 <zodbot> The meeting name has been set to 'neurofedora'
13:04:14 <FranciscoD> #chair bt0 gicmo zbyszek
13:04:14 <zodbot> Current chairs: FranciscoD bt0 gicmo zbyszek
13:04:39 <FranciscoD> if there are folks on Telegram please join via IRC: we cannot currently chair people over the Telegram bridge
13:05:01 <FranciscoD> You can use the freenode web client: https://webchat.freenode.net/?channels=#fedora-neuro
13:05:16 <tg-fedneuro> <r​parimi> thank you for the link
13:05:44 <FranciscoD> @rparimi: hopefully it'll work. We've had some spam recently, so one may have to register with freenode to be able to access the channels
13:06:04 <FranciscoD> #topic Agenda
13:06:16 <FranciscoD> #info Announcement e-mail: https://lists.fedoraproject.org/archives/list/neurofedora@lists.fedoraproject.org/thread/L4VYMPV742CFAO2O3VWDNOVQJCBKP73Z/
13:06:23 <FranciscoD> #info New introductions and roll call
13:06:31 <FranciscoD> #info Tasks from last week's meeting:
13:06:40 <FranciscoD> #info Open Pagure tickets
13:06:42 <tg-fedneuro> <r​parimi> already registered but for some reason my nick is messed up
13:06:53 <rparimi91> hello .rparimi
13:07:00 <rparimi91> .hello rparimi
13:07:00 <FranciscoD> #chair rparimi91
13:07:00 <zodbot> Current chairs: FranciscoD bt0 gicmo rparimi91 zbyszek
13:07:00 <zodbot> rparimi91: Sorry, but you don't exist
13:07:16 <FranciscoD> rparimi91: ah, that not sorted yet? Let's take a look after the meeting
13:07:24 <FranciscoD> #info Open NeuroFedora bugs
13:07:32 <FranciscoD> #info Koschei packages check
13:07:41 <FranciscoD> #info CompNeuro lab compose status check
13:07:48 <FranciscoD> #info Neuroscience query of the week
13:07:58 <FranciscoD> #info Next meeting day, and chair
13:08:05 <FranciscoD> #info Open floor
13:08:09 <FranciscoD> First topic
13:08:20 <FranciscoD> #topic New introductions and roll call
13:09:13 <FranciscoD> #info General template: <fas>, <irc nick>, <time zone>, <interests, Fedora and otherwise>
13:09:35 <FranciscoD> #info ankursinha, FranciscoD, UTC+1, NeuroFedora, Fedora Join, Ask Fedora, packaging etc. :)
13:09:40 <FranciscoD> rparimi91: you're up :)
13:10:35 <rparimi91> Hello everyone I Ramya. Fas ramyaparimi, nick rparimi, time zone CST, want to learn packaging here in NeuroFedora.. I am sure there will be more interests along the way :)
13:11:06 <FranciscoD> nice, could you type that again, but add the info command at the start of the sentence like I'm doing?
13:11:11 <FranciscoD> that'll add it to the meeting minutes :)
13:11:32 <rparimi91> #info Hello everyone I Ramya. Fas ramyaparimi, nick rparimi, time zone CST, want to learn packaging here in NeuroFedora.. I am sure there will be more interests along the way :)
13:11:57 <FranciscoD> oops
13:12:02 <FranciscoD> anyone else here today?
13:12:08 <FranciscoD> .members neuro-sig
13:12:09 <zodbot> FranciscoD: Members of neuro-sig: alciregi @ankursinha bizdelnick blackfile bt0dotninja fangq +gicmo @ignatenkobrain ilgrad iztokf +lbazan major mhough sagitter sergiopr victortyau +zbyszek
13:12:38 <FranciscoD> right, so we don't have quorum
13:13:28 <gicmo> ah hi, I am kina here to ;)
13:13:35 <FranciscoD> hello gicmo :)
13:13:44 <gicmo> *waves*
13:13:45 <FranciscoD> I was just going to check the compose and close the meeting
13:13:49 <tg-fedneuro> <b​t0dotninja> Hi
13:13:58 <tg-fedneuro> <M​eWjOr> Heyyo
13:14:08 <tg-fedneuro> <b​t0dotninja> Hi Compadre
13:14:11 <FranciscoD> heya @MeWjOr, @bt0dotninja
13:14:28 <rparimi3> Hello everyone :)  I am new to NeuroFedora
13:14:29 <tg-fedneuro> <M​eWjOr> Hey Alberto! Sanjay!
13:14:41 <FranciscoD> should I continue with the meeting today, or if you're all busy, we can close todays and do it again in 2 weeks?
13:14:41 <tg-fedneuro> <M​eWjOr> Hey rparimi3
13:14:45 <tg-fedneuro> <M​eWjOr> Welcome
13:15:14 <tg-fedneuro> <M​eWjOr> I'm available today...
13:15:25 <rparimi3> FranciscoD did my intro get logged? right when I hit enter I had connectivity issue =L
13:15:25 <tg-fedneuro> <M​eWjOr> But, up to you all I'd say
13:15:50 <FranciscoD> rparimi3: yes, it came through, all good
13:15:53 <FranciscoD> #chair rparimi3
13:15:53 <zodbot> Current chairs: FranciscoD bt0 gicmo rparimi3 rparimi91 zbyszek
13:15:55 <tg-fedneuro> <M​eWjOr> I'll switch to irc
13:16:10 <FranciscoD> OK, let's continue then---more status check than anything today too
13:16:33 <FranciscoD> I'll wait for 2 minutes for folks to switch to IRC etc
13:16:47 <gicmo> cool cool
13:16:57 <FranciscoD> Please add your intros/roll calls too if you wish, we're still on the first topic
13:17:31 <MeWjOr> I'm here!
13:18:31 <FranciscoD> #chair MeWjOr
13:18:31 <zodbot> Current chairs: FranciscoD MeWjOr bt0 gicmo rparimi3 rparimi91 zbyszek
13:18:45 <FranciscoD> I'll move to the next topic
13:19:00 <FranciscoD> #topic Tasks from last week's meeting
13:19:13 <FranciscoD> #info Minutes from last meeting: https://meetbot-raw.fedoraproject.org/fedora-neuro/2020-10-05/%22neurofedora%22.2020-10-05-13.05.html
13:19:41 <FranciscoD> #info FranciscoD fix libneurosim: https://bugzilla.redhat.com/show_bug.cgi?id=1864029: WIP, upstream had to make a fix, reassigning
13:19:43 <FranciscoD> #action FranciscoD fix libneurosim: https://bugzilla.redhat.com/show_bug.cgi?id=1864029: WIP, upstream had to make a fix, reassigning
13:20:33 <FranciscoD> #info FranciscoD ping primary vrpn maintainer, and remove neuro-sig from package: Done, vrpn is no longer part of the neuro-sig packages: https://src.fedoraproject.org/rpms/vrpn
13:20:53 <gicmo> nice
13:21:40 <FranciscoD> #info FranciscoD orphan PEGTL: we're still maintaining it, but alakatos has agreed to be the primary maintainer since they use it
13:21:42 <FranciscoD> alakatos++
13:21:48 <FranciscoD> .thank alakatos
13:21:48 <zodbot> FranciscoD thinks alakatos is awesome and is happy they are helping! (Please also type alakatos++ since that is what gives them a cookie)
13:22:10 <FranciscoD> so that's also done in a way
13:22:42 <FranciscoD> #info FranciscoD purusharths: add koji compose link to the agenda for future meetings, PENDING, reassigning
13:22:51 <FranciscoD> #action FranciscoD purusharths: add koji compose link to the agenda for future meetings
13:23:03 <FranciscoD> Needs to be added here, FYI: https://docs.fedoraproject.org/en-US/neurofedora/communicating/#_open_meetings
13:23:18 <FranciscoD> #info purusharths send out logs to ML: DONE
13:23:23 <FranciscoD> purusharths++
13:23:25 <FranciscoD> .thank purusharths
13:23:26 <zodbot> FranciscoD thinks purusharths is awesome and is happy they are helping! (Please also type purusharths++ since that is what gives them a cookie)
13:23:45 <FranciscoD> that's all from the logs: were there any other tasks that may perhaps not have been recorded?
13:24:03 * FranciscoD waits a minute before proceeding to the next topic
13:24:30 <FranciscoD> #topic Open Pagure tickets
13:24:36 <FranciscoD> #link https://pagure.io/neuro-sig/NeuroFedora/issues?status=Open&tags=S%3A+Next+meeting
13:24:56 <FranciscoD> #into Nothing here apart from the reading/listening list
13:25:16 <FranciscoD> #info Please add interesting links to the ticket for everyone to see: https://pagure.io/neuro-sig/NeuroFedora/issue/318
13:25:30 <FranciscoD> #topic Open NeuroFedora bugs
13:25:38 <FranciscoD> #info All our open bugs: https://tinyurl.com/neurofedora-bugs
13:26:00 <MeWjOr> I actually wanted to raise a ticket... There's a new version of it, and bugzilla didn't report it
13:26:11 <MeWjOr> s/it/odml
13:26:24 <MeWjOr> I was trying it out last week and realised it
13:26:32 <FranciscoD> MeWjOr: is it set up on release-monitoring.org?
13:26:48 <MeWjOr> I'll look into it it up as soon as I get a chance
13:26:50 <FranciscoD> what's the package name? `odml`?
13:26:54 <MeWjOr> python-odml
13:27:16 <FranciscoD> OK, I'll assign that to you then
13:27:18 <MeWjOr> I'm not sure... Didn't release-monitoring.org work from the source URL of the packages?
13:27:32 <FranciscoD> MeWjOr: no, it needs to be manually set up for each package
13:27:45 <FranciscoD> #action MeWjOr check if release-monitoring.org has been set up for python-odml
13:27:50 <MeWjOr> ach... I'll add it then
13:28:08 <FranciscoD> MeWjOr: also, I see that "monitoring" is on, but not "monitoring with scratch builds": could you update that too?
13:28:28 <FranciscoD> with scratch builds, each time you push a commit, a build is triggered as part of CI to tell you if it builds correctly
13:28:58 <MeWjOr> ahh... Thats good
13:28:58 <FranciscoD> #action MeWjOr update monitoring status for python-odml to "monitoring with scratch builds"
13:29:25 <FranciscoD> On the bug list, there are a few updates, nothing urgent
13:29:30 <FranciscoD> #info Open bugs related to new releases
13:29:34 * bt0 is learning a lot :P
13:30:03 <MeWjOr> lol, same
13:30:06 <FranciscoD> #info Team: please feel free to reassign bugs to yourself and work on them if the primary maintainer has not yet started working on them
13:30:15 <FranciscoD> if you'd like, you can ping the bug to ask
13:30:29 <FranciscoD> but the idea of us maintaining packages as a team with commit access is that we can help each other out with bugs
13:30:42 <FranciscoD> so please don't limit your activities to packages where you are primary maintainer only
13:31:08 <FranciscoD> (of course, if a package is complex, you can leave it for the primary maintainer :D)
13:31:45 <FranciscoD> All package maintainers should also have subscribed to the private neuro-sig@lists.fp.o mailing list where bugzilla sends notifications
13:32:13 <FranciscoD> Moving to next topic, since there aren't any urgent bugs
13:32:27 <FranciscoD> #topic Koschei packages check
13:32:39 <FranciscoD> #info Koschei monitors all neuro-sig packages here: https://koschei.fedoraproject.org/groups/neuro-sig
13:33:07 <FranciscoD> hrm, is koschei down?
13:33:35 <FranciscoD> ah, no, it's up, was getting an error initialy
13:33:56 <FranciscoD> neurord is beyond saving, so let's skip that one
13:33:59 <bt0> #link https://status.fedoraproject.org/
13:35:02 <FranciscoD> #info python-biopython is currently failing on rawhide: https://koschei.fedoraproject.org/package/python-biopython but no bug has been filed
13:35:43 <MeWjOr> beyond saving?
13:35:46 <MeWjOr> what happened?
13:35:48 <MeWjOr> :P
13:36:10 <FranciscoD> java hell, it won't build because deps are missing etc iirc
13:36:23 <FranciscoD> (neurord)
13:36:28 <MeWjOr> ach... Java... >.<
13:36:35 <FranciscoD> it'll get retired automatically in a bit
13:37:03 <FranciscoD> #info Filed an FTBFS for python-biopython:
13:37:06 <FranciscoD> https://bugzilla.redhat.com/enter_bug.cgi?product=Fedora&component=python-biopython&version=rawhide&short_desc=python-biopython%3A+FTBFS+in+Fedora+rawhide&bug_file_loc=https%3A%2F%2Fkoschei.fedoraproject.org%2Fpackage%2Fpython-biopython&comment=Description+of+problem%3A%0APackage+python-biopython+fails+to+build+from+source+in+Fedora+rawhide.%0A%0AVersion-Release+number+of+selected+component+%
13:37:08 <FranciscoD> 28if+applicable%29%3A%0A1.78-1.fc34%0A%0ASteps+to+Reproduce%3A%0Akoji+build+--scratch+f34+python-biopython-1.78-1.fc34.src.rpm%0A%0AAdditional+info%3A%0AThis+package+is+tracked+by+Koschei.+See%3A%0Ahttps%3A%2F%2Fkoschei.fedoraproject.org%2Fpackage%2Fpython-biopython
13:37:10 <FranciscoD> uh
13:37:14 <FranciscoD> #undo
13:37:14 <zodbot> Removing item from minutes: <MeetBot.items.Link object at 0x7fccc3dd2d50>
13:37:33 <FranciscoD> #info Filed an FTBFS for python-biopython: https://bugzilla.redhat.com/show_bug.cgi?id=1889370
13:37:36 <FranciscoD> there, much better..
13:38:05 <FranciscoD> #info Koschei has a button "file FTBFS bug" to conveniently file these bugs: doens't need to be done manually
13:38:55 <FranciscoD> #info python-lfpy is currently failing too: https://koschei.fedoraproject.org/package/python-lfpy, no bug here either
13:39:09 <FranciscoD> Someone want to do the honours of filing the FTBFS bug? :D
13:39:29 <bt0> action me Please
13:39:47 <FranciscoD> #action bt0 use koschei to file an FTBFS bug for python-lfpy: https://koschei.fedoraproject.org/package/python-lfpy
13:39:51 <bt0> :)
13:39:54 <FranciscoD> thanks :D
13:40:15 <FranciscoD> #info python-mne is currently failing too: https://koschei.fedoraproject.org/package/python-mne  no bug here either
13:40:56 <FranciscoD> #action FranciscoD file FTBFS bug for python-mne using Koschei: https://koschei.fedoraproject.org/package/python-mne
13:41:07 <FranciscoD> right, that's it
13:41:23 <FranciscoD> #info 3 FTBFS packages out of 154 tracked by Koschei
13:41:27 <FranciscoD> that's pretty good!!
13:42:05 <FranciscoD> any other package related issues before I move on to the next topic?
13:42:58 <FranciscoD> #topic CompNeuro lab compose status check
13:43:29 <FranciscoD> #info https://koji.fedoraproject.org/koji/packageinfo?packageID=30691 : Rahide + 33 compose are both fine
13:43:32 <FranciscoD> YAY
13:43:55 <FranciscoD> #topic Neuroscience query of the week
13:44:11 <FranciscoD> 5 minutes here: anything folks want to discuss from a neuroscience perspective?
13:44:43 <FranciscoD> If one is interested in the "predictive coding hypothesis" about how the brain functions, this is a good read: https://www.quantamagazine.org/to-make-sense-of-the-present-brains-may-predict-the-future-20180710/
13:44:57 <FranciscoD> (shared on the reading/listening list ticket)
13:45:19 <FranciscoD> And, I ran into this COVID vaccine related thread this morning, also worth a look
13:46:06 <FranciscoD> #info Twitter thread on COVID vaccines by Florian Krammer, Professor at the Department of Microbiology Icahn School of Medicine at Mount Sinai: https://threadreaderapp.com/thread/1310372301314101250.html
13:46:43 <FranciscoD> Feel free to share other neuroscience (or just science) related bits that you found interesting
13:47:09 <FranciscoD> Also, we have a "planet neuroscientists" here that collects RSS feeds from lots of sources: https://neuroblog.fedoraproject.org/planet-neuroscientists/
13:48:00 <FranciscoD> "planet neuroscience", on the other hand, is subscribed to journals etc: https://neuroblog.fedoraproject.org/planet-neuroscience/
13:48:13 <FranciscoD> one can download the blog list to use it on their RSS feed reader
13:48:41 <MeWjOr> 10 months - 1.5 years for the covid vaccine... I still feel it will be more... :P
13:49:11 <FranciscoD> Yeh, who knows, generally takes a decade
13:49:19 <FranciscoD> Ah, another one
13:49:20 <bt0> yeah
13:49:24 <FranciscoD> #info Racial and ethnic imbalance in neuroscience reference lists and intersections with gender | bioRxiv: https://www.biorxiv.org/content/10.1101/2020.10.12.336230v1
13:50:14 <FranciscoD> I'll put this on the ticket too
13:50:33 <rparimi3> These links are quite interesting...thank you for sharing :)
13:50:41 <rparimi3> articles*
13:50:51 <FranciscoD> np
13:51:10 <FranciscoD> I've now blocked time in my calendar to be able to keep up with research work etc.
13:51:28 <FranciscoD> At the lab, we all have to monitor certain journals and point out what work may be relevant to the lab's projects
13:51:55 <fm-neuro> pagure.issue.comment.added -- ankursinha commented on ticket neuro-sig/NeuroFedora#318: "NeuroFedora reading/listening list" https://pagure.io/neuro-sig/NeuroFedora/issue/318#comment-696844
13:52:19 <FranciscoD> feel free to add to the ticket too---anything that you think is interesting for the team to read, throw it on the ticket
13:52:41 <FranciscoD> Move to next topic?
13:52:42 <rparimi3> definitely ..will do
13:53:15 <FranciscoD> Yeh, we also want to learn more while we work on NeuroFedora :)
13:53:28 <FranciscoD> #topic Next meeting day, and chair
13:53:43 <FranciscoD> Same time in 2 weeks? Any volunteers for chairing?
13:54:03 <FranciscoD> #info Chair has to send out a reminder: preferably on the Friday before the meeting, and another on the morning of the meeting
13:54:10 * FranciscoD forgot to send it out on Friday this time
13:54:23 <FranciscoD> #info Chair has to ping people before the meeting
13:54:27 <FranciscoD> #info Chair runs the meeting
13:54:33 <FranciscoD> #info Chair sends out the logs
13:54:37 <FranciscoD> #action FranciscoD send out meeting logs
13:54:47 <FranciscoD> So, any takers for the next meeting? :)
13:54:52 <FranciscoD> bt0: MeWjOr rparimi3 ?
13:54:56 <MeWjOr> o.o
13:54:58 <FranciscoD> it's quite easy, as you've seen today
13:55:17 <MeWjOr> I can
13:55:19 <MeWjOr> :D
13:55:21 <rparimi3> I think I will wait for a couple more meetings before I can chair one :)
13:55:29 <FranciscoD> sounds good
13:55:44 <FranciscoD> #info MeWjOr to chair next meeting on 02 November, 1300 UTC
13:55:50 <FranciscoD> woah, november, already?!
13:56:01 <FranciscoD> #topic Open floor
13:56:04 <MeWjOr> yeah... :(
13:56:08 <FranciscoD> We have 4 minutes for open floor
13:56:11 <MeWjOr> This year's been a mess
13:56:21 <FranciscoD> anything else that anyone wants to discuss
13:56:48 <FranciscoD> it has indeed :/
13:56:49 <rparimi3> This is my first meeting with NeuroFedora :)  very happy to be part of the team
13:57:13 <FranciscoD> we're very happy to have you here rparimi3
13:57:21 <FranciscoD> we'll get you started with packaging after the meeting :)
13:57:31 <rparimi3> yes thank you
13:57:38 <MeWjOr> Aye, rparimi3 ... we're very pleased to have you too... Please feel free to look around and see where you can help... We'd be happy to help you as well
13:57:52 <bt0> :D
13:58:24 <FranciscoD> #info FranciscoD added rparimi3 to the pagure group: https://pagure.io/group/neuro-sig
13:58:36 <FranciscoD> so you will now receive notifications and you can update tickets etc
13:58:46 <bt0> rparimi3++
13:58:57 <FranciscoD> bt0: try: ramyaparimi++
13:59:04 <MeWjOr> ramyaparimi++
13:59:04 <zodbot> MeWjOr: Karma for ramyaparimi changed to 5 (for the current release cycle):  https://badges.fedoraproject.org/tags/cookie/any
13:59:19 <FranciscoD> something off with the nick linkage on FAS: we also gotta look into that
13:59:21 <bt0> ramyaparimi++
13:59:21 <zodbot> bt0: Karma for ramyaparimi changed to 6 (for the current release cycle):  https://badges.fedoraproject.org/tags/cookie/any
13:59:44 <FranciscoD> OK, on the hour, closing meeting
14:00:02 <FranciscoD> #endmeeting