neurofedora
LOGS
13:07:05 <FranciscoD> #startmeeting NeuroFedora - 2020-09-07
13:07:05 <zodbot> Meeting started Mon Sep  7 13:07:05 2020 UTC.
13:07:05 <zodbot> This meeting is logged and archived in a public location.
13:07:05 <zodbot> The chair is FranciscoD. Information about MeetBot at http://wiki.debian.org/MeetBot.
13:07:05 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
13:07:05 <zodbot> The meeting name has been set to 'neurofedora_-_2020-09-07'
13:07:13 <FranciscoD> #meetingname neurofedora
13:07:13 <zodbot> The meeting name has been set to 'neurofedora'
13:07:25 <FranciscoD> #chair MeWjOr bt0 gicmo
13:07:25 <zodbot> Current chairs: FranciscoD MeWjOr bt0 gicmo
13:07:36 <FranciscoD> Sorry folks on Telegram: can't chair you yet
13:07:41 <tg-fedneuro> <l​bazan> .fas lbazan
13:07:44 <tg-fedneuro> <l​bazan> :-)
13:07:49 <tg-fedneuro> <l​bazan> let me change to irc
13:08:35 <FranciscoD> #topic Introductions and roll call
13:08:54 <FranciscoD> #info ankursinha, FranciscoD: Ankur Sinha UTC+1
13:09:39 <MeWjOr> #info major, MeWjOr, Aniket Pradhan, UTC+5:30
13:10:50 <bt0> #info alberto, bt0dotninja: Alberto Rodriguez UTC-5
13:10:54 <LoKoMurdoK> .fas lbazan
13:10:54 <zodbot> LoKoMurdoK: lbazan 'Luis Enrique Bazán De León' <bazanluis20@gmail.com>
13:11:25 <LoKoMurdoK> info
13:12:11 <LoKoMurdoK> .info
13:13:27 <LoKoMurdoK> #info Luis, lbazan: Luis Bazan UTC-5
13:13:38 <FranciscoD> OK, let's move on to the topics then
13:13:54 <FranciscoD> #info Agenda for today's meeting:
13:14:02 <FranciscoD> #info Tasks from last meeting: nothing here this time
13:14:16 <FranciscoD> #info Open Pagure tickets: https://pagure.io/neuro-sig/NeuroFedora/issues
13:14:35 <FranciscoD> #info CompNeuro lab compose check: seems OK, no recent failures
13:14:54 <FranciscoD> #info Open bugs on bugzilla: https://tinyurl.com/neurofedora-bugs
13:15:05 <FranciscoD> #info Neuroscience query of the week
13:15:14 <FranciscoD> #info Next meeting chair
13:15:17 <FranciscoD> #info Open floor
13:15:24 <FranciscoD> #topic Open pagure tickets
13:15:29 <FranciscoD> #info https://pagure.io/neuro-sig/NeuroFedora/issues
13:16:12 <FranciscoD> Still got a bunch of packages basically---nothing here that's super critical now.
13:16:19 <FranciscoD> Anyone working on any new packages?
13:16:31 <FranciscoD> I fixed quite a few of the simple FTBFS bugs over the weekend
13:17:18 <gicmo> cool
13:17:22 <FranciscoD> Any urgent issues here? LoKoMurdoK bt0 gicmo MeWjOr ?
13:17:34 <FranciscoD> I'm going to keep working through the comp-neuro packages
13:17:39 <MeWjOr> I saw that translation issue
13:17:45 <FranciscoD> but feel free to work on whatever you folks are interested in
13:17:49 <MeWjOr> https://pagure.io/neuro-sig/NeuroFedora/issue/391
13:17:55 <LoKoMurdoK> nop sir
13:17:57 <gicmo> FranciscoD: not that I know of
13:18:02 <FranciscoD> Yeh, gotta follow up on that one MeWjOr
13:18:37 <MeWjOr> Ahh, i see you have assigned that already
13:18:39 <MeWjOr> that's great
13:19:25 <bt0> :)
13:19:27 <MeWjOr> well, then, so far I don't think there's anything important from my end...
13:19:37 <FranciscoD> I'd already mailed the translation list about this back when we got the email from a user
13:20:21 <FranciscoD> #info E-mail to translation list about missing neurofedora bits on weblate: https://lists.fedoraproject.org/archives/list/trans@lists.fedoraproject.org/thread/MI7AMVXKGW4DVCNUKBWVHZF3UCFPOL6X/#FORNI362ZUIRZKOSHX6D3HFKZBOKEIL3
13:20:43 <FranciscoD> #info Ticket about this: https://pagure.io/fedora-websites/issue/1013
13:20:51 <FranciscoD> I guess I should ping the ticket again to see what's up?
13:20:57 <FranciscoD> #action FranciscoD ping https://pagure.io/fedora-websites/issue/1013 for updates
13:21:44 <fm-neuro> pagure.issue.comment.added -- ankursinha commented on ticket neuro-sig/NeuroFedora#391: "Check translations for NeuroFedora web pages" https://pagure.io/neuro-sig/NeuroFedora/issue/391#comment-676248
13:21:58 <FranciscoD> OK, any other tickets?
13:22:09 <FranciscoD> MeWjOr: do you want to file a ticket for fosdem already, so it's on our radar?
13:22:31 <MeWjOr> I was waiting for their devroom updates and everything
13:22:50 <MeWjOr> I'll file a ticket today, and will then update on it
13:22:54 <FranciscoD> awesome
13:23:04 <FranciscoD> #action MeWjOr file a tracker ticket for FOSDEM
13:23:44 <FranciscoD> OK, no other tickets then.
13:23:57 <FranciscoD> #info everyone continues packaging stuff that they're interested in
13:24:17 <FranciscoD> Please remember to request review swaps on the -devel list---that way the community folks are given some idea of our activity :)
13:24:29 <MeWjOr> sure sure
13:24:36 <FranciscoD> OK, next topic
13:24:45 <FranciscoD> #info F33 comp-neuro lab compose status check
13:25:04 <FranciscoD> It's going OK now. I had to remove `neurord` from the package set, since that's now FTBFS/FTI
13:25:11 <FranciscoD> because of java issues..
13:25:45 <FranciscoD> #info neurord issues: https://bugzilla.redhat.com/buglist.cgi?bug_status=__open__&classification=Fedora&component=neurord&list_id=11336434&product=Fedora&query_format=advanced
13:25:53 <FranciscoD> I don't think they're trivial to fix
13:26:09 <FranciscoD> zbyszek ^ if there's anything we can do to help with neurord, please do let us know
13:26:53 <FranciscoD> Any other notes on the F33 compose?
13:26:59 <fm-neuro> pagure.issue.new -- major opened a new ticket neuro-sig/NeuroFedora#392: "FOSDEM 2021 Tracker" https://pagure.io/neuro-sig/NeuroFedora/issue/392
13:27:25 <FranciscoD> #info ISO image composes: https://koji.fedoraproject.org/koji/builds?userID=releng&order=-build_id&type=image
13:27:37 <MeWjOr> Yes... there's Pyriemann that's sorta blocking F33
13:28:00 <FranciscoD> #info Most recent comp-neuro lab image: https://koji.fedoraproject.org/koji/buildinfo?buildID=1606917 (September 7, 1000 UTC)
13:28:15 <FranciscoD> MeWjOr: not the compose, though---it isn't on the lab image, right?
13:28:33 <MeWjOr> Ohh... I thought F33 in general and not the lab image
13:28:44 <MeWjOr> I'll talk about it when we discuss bugs
13:29:20 <FranciscoD> Let's do that now
13:29:27 <FranciscoD> #topic NeuroFedora bugs
13:29:35 <MeWjOr> lol
13:29:43 <FranciscoD> #info https://tinyurl.com/neurofedora-bugs
13:30:03 <FranciscoD> let's focus on the FTBFS/FTI bugs first
13:31:03 <MeWjOr> FTBFS python-Pyriemann: https://bugzilla.redhat.com/show_bug.cgi?id=1871604
13:31:23 <MeWjOr> So, basically Pyriemann fails because of some other library dep (python-joblib) is not working correctly with py3.9
13:31:54 <MeWjOr> Upstream has started working on it, and I hope they release a quick patch that can be used to mitigate the issue
13:33:53 <FranciscoD> OK, but this is blocked then
13:34:01 <FranciscoD> you can't do much until joblib has a fix?
13:34:25 <MeWjOr> yep
13:35:01 <FranciscoD> OK, I'd remove the needinfo and just leave it as assigned. It depends on the other bug, so that's OK
13:35:10 <MeWjOr> I wasn't sure as to what to do in this case, as the ticket was tagged as NeedInfo, and where should I provide the info
13:35:20 <MeWjOr> ohh
13:35:23 <MeWjOr> will do that
13:35:37 <FranciscoD> you just comment on the ticket saying "blocked by joblib", and tick the "im providing the info .." checkbox
13:36:00 <MeWjOr> ahh
13:36:01 <MeWjOr> okay
13:36:14 <FranciscoD> #info pyriemann FTBFS blocked by joblib bug: we're waiting for a fix
13:36:42 <FranciscoD> #info nistats to be absorved into nilearn in the next nilearn release, so not fixing it etc.
13:37:44 <FranciscoD> got pyphi, vrpn, openmeeg, libneurosim, hdfview
13:37:57 <FranciscoD> #info hdfview is also a lost cause---some java deps etc need updating and it isn't trivial iirc
13:38:14 <FranciscoD> anyone got time to look into the others? pyphi/vrpn/openmeeg/libneurosim?
13:38:34 <FranciscoD> #info Remaining FTBFS packages: pyphi, vrpn, openmeeg, libneurosim
13:38:42 <FranciscoD> I'll look at libneurosim
13:38:53 <FranciscoD> #action FranciscoD fix libneurosim
13:39:02 <FranciscoD> if you folks do have time, please take a look at the others
13:39:02 <MeWjOr> I'll try to go through some
13:39:21 <FranciscoD> LoKoMurdoK: one or two updates for you: hdfm, chaospy
13:39:33 <LoKoMurdoK> let me complete that in  this week sir
13:39:36 <FranciscoD> LoKoMurdoK: we need to be careful with hdmf and pynwb iirc---the version dependence is strict
13:39:50 <FranciscoD> so please check the requires before updating, otherwise pynwb becomes FTI
13:40:16 <FranciscoD> the autogenerated requires is good, but I see it causing more of these FTI issues now
13:40:24 <LoKoMurdoK> understood!
13:40:26 <FranciscoD> because we don't explicitly look at the requires when updating :/
13:40:38 <LoKoMurdoK> :S
13:40:44 <LoKoMurdoK> FranciscoD++
13:40:44 <zodbot> LoKoMurdoK: Karma for ankursinha changed to 13 (for the current release cycle):  https://badges.fedoraproject.org/tags/cookie/any
13:41:03 <FranciscoD> :D
13:41:05 <FranciscoD> LoKoMurdoK++
13:41:05 <zodbot> FranciscoD: Karma for lbazan changed to 3 (for the current release cycle):  https://badges.fedoraproject.org/tags/cookie/any
13:41:17 <FranciscoD> I think those are the prirotised bugs for the moment
13:41:34 <FranciscoD> we'll keep working on updates etc as usual :)
13:41:42 <FranciscoD> Any other bugs that need priority?
13:42:27 <FranciscoD> otherwise we'll proceed to the next topic
13:43:05 <FranciscoD> OK, next one then
13:43:12 <FranciscoD> #topic Neuroscience query of the week
13:43:34 <FranciscoD> Stuff like this is perhaps interesting:
13:43:41 <FranciscoD> #info Neuralink: https://www.technologyreview.com/2020/08/30/1007786/elon-musks-neuralink-demo-update-neuroscience-theater/
13:44:18 <MeWjOr> are we seriously discussing Neuralink lol
13:44:47 <FranciscoD> XD
13:45:21 <MeWjOr> I'm not sure, but it seems very very advanced for us right now
13:45:31 <MeWjOr> It could be a concept, like the Hyperloop
13:45:36 <MeWjOr> but
13:45:46 <FranciscoD> it's a mix of stuff that researchers have been doing for a long time
13:46:08 <FranciscoD> and "theatre", since there's no discussion of the issues that need to be solved to make it viable
13:46:27 <FranciscoD> but the pro is that it'll make non-academics more aware of neuroscience
13:46:29 <FranciscoD> .. in a way
13:47:14 <MeWjOr> that's a win-win I'd say
13:47:16 <MeWjOr> lol
13:47:43 <FranciscoD> :D
13:47:47 <FranciscoD> let's see how it develops
13:47:52 <FranciscoD> at the moment, it's showmanship
13:47:58 <FranciscoD> which Musk is well known for
13:48:00 <FranciscoD> :)
13:48:19 <FranciscoD> I don't have anything else that's interesting enough
13:48:22 <FranciscoD> next topic?
13:48:24 <MeWjOr> I'm not an expert, but if the stuff he claims is actually possible, then I would definitely love it
13:48:51 <FranciscoD> it's not quite there yet, from what I read on academic channels
13:48:53 * LoKoMurdoK brb
13:49:28 <FranciscoD> OK, let's go to open floor
13:49:33 <FranciscoD> #topic Open Floor
13:49:37 <FranciscoD> I have something here
13:50:01 <FranciscoD> #info join the OCNS (organization for computational neuroscience)'s tools/software/infrastructure SIG:  https://neurostars.org/t/ocns-infrastructure-software-tools-sig-meet-and-greet-initial-discussions/15560
13:50:17 <FranciscoD> there are other SIGs too, if one is interested
13:50:23 <FranciscoD> #info SIGs and more discussion: https://neurostars.org/t/cns-2020-ocns-members-meeting/15273/17
13:50:37 <FranciscoD> also, all recordings from CNS*2020 are online, and the programme is archived too
13:50:56 <FranciscoD> #info CNS*2020 Recordings: https://www.youtube.com/channel/UCqz8NIG24tV1HHCkKidA4Nw/videos
13:51:13 <FranciscoD> #info CNS*2020 programme: https://cns2020online.sched.com/
13:51:19 <FranciscoD> please watch it all at your convenience
13:51:35 <FranciscoD> This workshop is suggested: https://cns2020online.sched.com/overview/type/Workshop/W04%3A+Tools+and+resources+for+developing+and+sharing+models+in+computational+neuroscience
13:52:15 <MeWjOr> I'll make sure to go through in atleast one of the workshops
13:52:38 <FranciscoD> there're 10 of them, with multiple sessions :D
13:52:42 <FranciscoD> so take your time, see what's interesting
13:52:58 <FranciscoD> there's also the keynote on deep reinforcement learning
13:53:09 <MeWjOr> ooh nice
13:53:19 <FranciscoD> #info Matt Botvinick (Google Deep Mind)'s keynote: https://cns2020online.sched.com/event/cm0e/k1-deep-reinforcement-learning-and-its-neuroscientific-implications
13:53:34 <MeWjOr> It's the first time I am hearing of deep RL
13:54:37 <FranciscoD> Yeh, it's a new thing :D
13:55:20 * LoKoMurdoK here
13:56:18 <FranciscoD> nice
13:56:25 <FranciscoD> we're almost done here I think
13:56:32 <FranciscoD> #topic Next meeting, chair
13:56:50 <FranciscoD> next meeting, same time in 2 weeks?
13:57:13 <MeWjOr> I am fine with 2 weeks time
13:57:20 <MeWjOr> I'll be happy to chair
13:57:26 <MeWjOr> Unless....
13:57:32 <MeWjOr> someone wants to
13:58:10 <LoKoMurdoK> FranciscoD +1
13:58:20 <FranciscoD> let's mark you chair for the moment, and if someone else wants to do it, they can too
13:58:42 <FranciscoD> #info Next meeting 1300 UTC on Monday 21 September, chaired by MeWjOr  (@major)
13:59:01 <tg-fedneuro> <M​eWjOr> Nice
13:59:06 <FranciscoD> OK, it's 59 past
13:59:12 <FranciscoD> I'll close on the hour :)
13:59:20 <bt0> :)
13:59:21 <FranciscoD> #action FranciscoD send out logs
13:59:32 <LoKoMurdoK> MeWjOr++
13:59:41 <LoKoMurdoK> bt0++
14:00:03 <FranciscoD> great, closing now
14:00:08 <FranciscoD> Thanks everyone for coming
14:00:12 <FranciscoD> #endmeeting