fedora_insight
LOGS
21:19:20 <stickster> #startmeeting Fedora Insight
21:19:20 <zodbot> Meeting started Fri Apr  9 21:19:20 2010 UTC.  The chair is stickster. Information about MeetBot at http://wiki.debian.org/MeetBot.
21:19:22 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
21:19:29 <stickster> #meetingname Fedora Insight
21:19:30 <zodbot> The meeting name has been set to 'fedora_insight'
21:19:47 <stickster> #topic What we're working on
21:20:17 <pcalarco> I have to leave now too, unfortunately; getting ride now
21:20:22 <stickster> #info FI currently syncs one group membership in the following way:
21:20:27 <stickster> pcalarco: Thanks!
21:20:33 * rbergeron waves to pcalarco
21:20:45 <pcalarco> but I will close the weighting ticket as that works as expected now
21:20:59 <stickster> #info If you login with your FAS account and haven't been to the CMS before: * we create an account with username=FAS_username
21:20:59 <stickster> * we sync your membership of cmsadmin
21:20:59 <stickster> If you have been before
21:20:59 <stickster> * we check to see if you're still in cmsadmin -- if not we remove your access; * if you are and you weren't before, we add your access
21:21:06 <stickster> darn, that probably didn't work
21:21:07 <stickster> #undo
21:21:08 <pcalarco> rbergeron and stickster: thanks and I will be on later
21:21:08 <zodbot> Removing item from minutes: <MeetBot.items.Info object at 0x18ed7250>
21:21:24 <stickster> #info If you login with your FAS account and haven't been to the CMS before
21:21:35 <stickster> #info a. we create an account with username=FAS_username
21:21:40 <stickster> #info b. we sync your membership of cmsadmin
21:21:56 <stickster> #info If you have been here before, we check to see if you're still in cmsadmin
21:22:01 <stickster> #info a. If not, we remove your access
21:22:12 <stickster> #info b. If you are now and weren't before, we add your access
21:22:18 <stickster> #info We don't:
21:22:23 <stickster> #info a. sync any groups other than cmsadmin
21:22:27 <stickster> #info b. sync any group creation
21:22:39 <stickster> #info Permissioning must be set up on the Zikula/FI side.
21:22:44 <stickster> *whew*
21:22:47 <rbergeron> so: in a nutshell - we have to hardcode any link between cmseditors and editors group in zikula
21:22:57 <stickster> rbergeron: Basically
21:23:00 <rbergeron> and any link between cmsusers and users in zikula
21:23:30 <rbergeron> editors i don't think is as important - but we (hopefully) will have too many content writers to want to do all that account creation manually
21:23:36 <stickster> rogjt
21:23:41 <stickster> I mean, "right"
21:23:45 <rbergeron> or roger. :)
21:24:03 <rbergeron> but if we can add one, we should be able to add both
21:24:05 <rbergeron> if we can figure it out
21:24:21 <rbergeron> if we go down the manual road we'll never go back, and we should do it right
21:25:07 <stickster> rbergeron: Manual sucks, I agree
21:25:29 * stickster looking at the PHP code itbegins pointed us to
21:25:48 <stickster> #link /usr/share/zikula/modules/AuthFAS/pnuserapi.php <-- where comparison and work is done
21:29:44 * rbergeron reads and ohhhhhhhh boy
21:29:44 <rbergeron> :D
21:29:48 <stickster> OK, I think I see what to change
21:29:53 * rbergeron nods
21:30:39 * rbergeron would volunteer but figures we might want FI done before 2014
21:30:40 <rbergeron> ;D
21:34:27 <rbergeron> so - here's a question
21:34:44 <rbergeron> we also have the "designers" group on here - which allows designers access to themes and blocks, etc
21:34:53 <rbergeron> and an ambassadors group
21:35:01 <rbergeron> what are we doing with those?
21:35:11 <rbergeron> just bumping designers up to the admin group?
21:35:23 <rbergeron> deleting the ambassadors group? I'm not seeing what the ambassadors group is for
21:35:40 <rbergeron> i'm just wondering if those are separate other groups we need as well - or if we just want designers to have the same persmissions as cmsadmin
21:35:52 <rbergeron> not to throw more wrenches in the works or anything :)
21:35:52 <stickster> That's the only thing we can do right now -- those groups are not meaningful unless we use them, and if we want to use them with FAS, we have to have a FAS group that matters, and then the syncing function has to support syncing them
21:36:13 <stickster> The only thing Zikula currently does is figure out whether you're in FAS, and if so, are you in cmsadmin.
21:36:14 <rbergeron> well -
21:36:18 <rbergeron> you and i are the only people in designers
21:36:35 <rbergeron> so
21:36:36 <rbergeron> heh
21:36:58 <rbergeron> now that i'm actually looking at it
21:37:59 <rbergeron> well - in FAS, or signed cla
21:38:02 <rbergeron> or are those one and the same
21:38:14 <rbergeron> because i think you can still log into fas even without a signed cla
21:38:16 <rbergeron> just can't do anything
21:38:30 <stickster> rbergeron: I don't understand
21:38:34 <stickster> What are you asking?
21:38:46 <rbergeron> you said zikula figures out if you're in fas
21:38:56 <rbergeron> and i'm wondering if it figures out if you're in FAS
21:38:57 <stickster> Oh sorry, that was my kludgy warning
21:39:05 <rbergeron> or if it figures out if you've signed the cla
21:39:06 <stickster> It figures out if you're in FAS *and* have cla_done
21:39:09 <rbergeron> the script looks like cla
21:39:09 <rbergeron> ok
21:39:24 * rbergeron just making sure she's not on another planet...
21:39:41 <rbergeron> or rather, if one basically meant the other
21:39:58 * rbergeron will let stickster tinker now ;)
21:40:19 <stickster> rbergeron: Yeah, one does not mean the other automaticaaly
21:40:35 <stickster> First you have to exist in FAS, of course... but then you also have to have cla_done, which is a separate question
21:40:38 <rbergeron> right
21:40:51 * stickster looks for something with line numbering, hang on
21:40:54 * rbergeron feels a wee bit wiser for the day. :)
21:42:03 <stickster> Oh here we go
21:42:09 <stickster> OK, if you're looking at that code
21:43:07 <stickster> lines 44-59 are the checks
21:43:10 <rbergeron> line 48 has the cla_done business
21:43:11 <rbergeron> right
21:43:14 <stickster> Right
21:43:20 <stickster> And it also records a flag called $admin
21:43:34 <stickster> We would want to add flags there for other stuff like $writer and $editor
21:43:39 <stickster> Then, down to line... 151 or so
21:43:56 <rbergeron> yes... does that tie to "administrators" group in zikula?
21:43:59 <stickster> In the AuthFAS_userapi_syncgroups() area
21:44:06 <rbergeron> and if so... where does that $admin to administrator...
21:44:10 <rbergeron> oh, i bet that's where you're going
21:44:12 <stickster> rbergeron: Right
21:44:42 <stickster> It finds out first $is_users_member (are you a member of users group)
21:44:52 <stickster> then $is_admin_member (are you a member of admin group)
21:45:18 <rbergeron> stickster: yeah, that stuff in the 151-164 area is a little greyer to me
21:45:34 <rbergeron> so is the users group basically anyone who has signed cla_done?
21:45:42 <stickster> rbergeron: Correct!
21:45:53 <rbergeron> do we want to even mess with that?
21:45:58 <stickster> If you are in that group in FAS, and you haven't a user account yet on Zikula, it makes one.
21:46:06 <rbergeron> and even have a cmswriters group?
21:46:07 <stickster> Then you get authenticated and you're in
21:46:36 <stickster> rbergeron: Yes, because people who can *write* content for publishing are different from people who are users that just arrange their own content, or respond to posts, or rate them, or stuff like that
21:46:43 <rbergeron> ahhh
21:46:48 <rbergeron> good point.
21:47:04 <stickster> OK, so this isn't as bad as I was thinking
21:47:24 <stickster> I can add a few stanzas here for determining "writer" and "editor"
21:47:32 <stickster> The "writers" would use the News group on Zikula
21:47:38 <stickster> and the "editors" would use the Editors group on Zikula
21:48:14 <rbergeron> sooo - i also understood from itbegins that if we do something like
21:48:35 <rbergeron> rbergero is a member of cmswriters, cmseditors, and cmsadmin on fas
21:48:42 * stickster already backed up the PHP script... but it really needs to be changed elsewhere, repackaged, and then brought in
21:48:52 <rbergeron> then i will automatically get the highest level - cmsadmin -
21:48:55 <rbergeron> err
21:49:00 <rbergeron> $admin / administrator
21:49:02 <stickster> rbergeron: Right, the highest level of access would be compared
21:49:03 <rbergeron> in zikula, correct
21:49:17 <stickster> cmsadmin determines whether you get "Administrators" on Zikula.
21:49:24 <stickster> That's line 154 in the script
21:49:30 <rbergeron> right, i'm looking at it
21:49:31 <rbergeron> and if not -
21:49:39 <rbergeron> then i'd get dropped to whatever level below that automagically
21:49:43 <rbergeron> if i am in a level below that
21:50:03 <stickster> Yes, but that happens elsewhere in the Zikula system of course
21:50:16 <rbergeron> i just wasn't sure if when he said that - if he meant that those privelidges applied all the way down on zikula, if you're in cmsadmin
21:50:25 <rbergeron> or if it might work differently if you were in multiple groups on FAS
21:50:32 <stickster> This code here is simply determining whether to flip your "Administrators" group access in zikula on or off, based on your FAS cmsadmin membership.
21:50:46 <rbergeron> or if we need to be careful to only be in either cmseditor or cmsadmin or cmswriter in FAS
21:51:07 <stickster> Yes, careful in the sense that those aren't discrete groups -- they're additive
21:51:22 <stickster> If you're in cmsadmin, it really doesn't matter whether you're in another cms* group in FAS.
21:51:27 * rbergeron isn't trying to second guess, i promise :)
21:51:33 <stickster> Not at all!
21:51:53 <stickster> Because cmsadmin membership will make Zikula turn on your "Administrators" Zikula group access when you next login.
21:52:04 <stickster> Which means you get everything
21:52:09 <stickster> regardless of any other access you might have
21:52:16 <rbergeron> so even if i get added to cmseditor on another day
21:52:21 <rbergeron> it will still see cmsadmin and say
21:52:24 <rbergeron> "yup, she's awesome"
21:52:39 <stickster> As long as your account is still a member of cmsadmin in FAS at that time, yes, that's correct.
21:53:17 <stickster> See, what would have been a cooler module in my opinion, is to just have these groups not sync'd but simply relying on FAS altogether.
21:53:31 <stickster> But I could be way off base in whether or not Zikula can even do that, or even whether it's a good idea.
21:53:40 * rbergeron nods
21:54:09 <stickster> But I 98% understand (I think) how to change this code to figure out rights properly.
21:54:20 <rbergeron> :D
21:54:32 <rbergeron> you made a backup copy you said, right :)
21:54:39 <rbergeron> not that i doubt your amazing stickster capabilities
21:54:46 <stickster> Oh yeah
21:54:49 <stickster> Mos def
21:58:49 * stickster wonders, is DBUtil::selectObjectByID() returning the group object?
21:59:08 <stickster> Ugh, PHP is so much less readable than Python
21:59:20 * rbergeron couldn't possibly tell you
22:02:14 <stickster> Aha, got it
22:08:10 <stickster> rbergeron: Still there?
22:08:44 <rbergeron> indeed, although i'm running to the kitchen for a half-second to grab moar waterz
22:08:47 <stickster> Log out and log back in to Zikula
22:08:52 <rbergeron> k
22:09:03 <stickster> Let me know if something horrible happens
22:09:05 <rbergeron> well
22:09:08 <rbergeron> i just clicked the logout button
22:09:10 <rbergeron> Parse error: syntax error, unexpected T_STRING, expecting ']' in /usr/share/zikula/modules/AuthFAS/pnuserapi.php on line 168
22:09:56 <rbergeron> so... i cna't log out still :)
22:10:06 <stickster> Try again
22:10:53 <stickster> I found the error, missing '
22:12:21 <stickster> My fault, another one lurking, fixing now
22:13:03 <stickster> Yay!
22:15:23 <rbergeron> whee!
22:15:24 <rbergeron> works
22:15:26 <stickster> All right rbergeron check it out
22:15:29 <stickster> log out again
22:15:29 <rbergeron> ok, let me log in
22:15:33 <stickster> cool
22:15:33 <rbergeron> i just did
22:15:34 <stickster> that's fine
22:15:36 <rbergeron> without troubles
22:15:59 <rbergeron> ok - i logged in
22:16:02 <stickster> What account are you using?
22:16:08 <rbergeron> rbergero
22:17:06 <rbergeron> is that right?
22:17:53 <rbergeron> i have the "your account, administration, log out" in the upper corner
22:17:55 <stickster> Try one more time for me
22:17:56 <stickster> logout
22:17:58 <stickster> then log in
22:19:21 <stickster> rbergeron: Oops, may need to do it one more time if you already finished
22:19:30 <stickster> I think I forgot to copy the file where it needed to go :-)
22:20:03 <rbergeron> ok so - i log in
22:20:10 <rbergeron> i still have your account, administration, log out in the corner
22:20:14 <rbergeron> but at the top of the white box
22:20:21 <rbergeron> above fedora weekly news issue 220
22:20:21 <rbergeron> i have
22:20:26 <rbergeron> a red/pink box with
22:20:33 <rbergeron> Error! The action you wanted to perform was not successful for some reason, maybe because of a problem with what you input. Please check and try again.
22:20:37 <stickster> Yeah, I get that too
22:20:40 <rbergeron> is there some sort of default login page for each group?
22:20:41 <rbergeron> maybe?
22:20:46 <stickster> It's not something I did -- I think that's a separate problem.
22:20:51 <stickster> It was there earlier.
22:21:00 <rbergeron> ah
22:21:04 <rbergeron> yeah, and if you refresh the window
22:21:06 <rbergeron> it goes away
22:21:12 <stickster> Sorry to try your patience -- but log out and log in one more time for me :-)
22:21:17 <rbergeron> so it seems like it's limited to immediately when you log in
22:21:19 <stickster> heh
22:21:20 <rbergeron> np
22:21:22 <rbergeron> i'm here to test!
22:21:35 <rbergeron> since i can't code :)
22:21:50 <rbergeron> ok, logged back in
22:22:34 <stickster> Hm, my code is not working like I thought it would then. :-(
22:25:07 <stickster> rbergeron: OK, one more time!
22:26:57 <rbergeron> ok, i'm logged in
22:27:01 <stickster> Oh wait!
22:27:05 <stickster> I just found the problem
22:27:07 <stickster> I think
22:27:36 <stickster> rbergeron: One more time!
22:28:53 <rbergeron> ok
22:29:02 <stickster> YAY!
22:29:04 <stickster> I win
22:30:39 <stickster> Well... OK, not quite.
22:30:52 * rbergeron laughs
22:31:39 <stickster> I got pretty close
22:31:43 <stickster> Something in my logic is wrong
22:32:06 <stickster> It turned on your membership in News (which was correct) and your membership in Editors (which was not)
22:32:17 <stickster> And did the same thing to me, when it shouldn't have turned either on.
22:32:25 <stickster> OK, I have to order dinner, brb
22:32:26 <rbergeron> hmmmm
22:32:28 <rbergeron> ok
22:37:42 * stickster cues up some Flaming Lips
22:38:05 <stickster> "THE TEST BEGINS NOWNOWNOWNOWNOWNOWNOWNOW"
22:38:59 <stickster> Must be very boring on the other side of this log.
22:39:48 <rbergeron> lol
22:48:31 <stickster> Hm, not getting joy here.
22:54:37 <stickster> Still it's putting me in groups I shouldn't be in.
22:55:06 <stickster> brb
22:56:53 * stickster back
22:57:06 <stickster> This is apparently less of a "jog" than a "saunter"
23:05:46 <stickster> OK, no idea why this isn't working.
23:05:49 <stickster> And dinner just arrived
23:05:56 <stickster> I'll send a diff to the list and see if itbegins can help.
23:06:07 <stickster> #action stickster Send diff to list
23:06:16 <stickster> #action itbegins Help figure out what stickster did wrong
23:06:22 <stickster> #endmeeting