epel
LOGS
20:00:18 <tdawson> #startmeeting EPEL (2023-11-01)
20:00:18 <zodbot> Meeting started Wed Nov  1 20:00:18 2023 UTC.
20:00:18 <zodbot> This meeting is logged and archived in a public location.
20:00:19 <zodbot> The chair is tdawson. Information about MeetBot at https://fedoraproject.org/wiki/Zodbot#Meeting_Functions.
20:00:19 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
20:00:19 <zodbot> The meeting name has been set to 'epel_(2023-11-01)'
20:00:20 <tdawson> #meetingname epel
20:00:20 <zodbot> The meeting name has been set to 'epel'
20:00:21 <tdawson> #chair nirik tdawson pgreco carlwgeorge salimma dcavalca dherrera gotmax23 smooge
20:00:21 <zodbot> Current chairs: carlwgeorge dcavalca dherrera gotmax23 nirik pgreco salimma smooge tdawson
20:00:23 <tdawson> #topic aloha
20:00:28 <smooge> hello
20:00:30 <neil> .hi
20:00:31 <pgreco> .hi
20:00:32 <zodbot> neil: neil 'Neil Hanlon' <neil@shrug.pw>
20:00:35 <zodbot> pgreco: pgreco 'Pablo Sebastian Greco' <pablo@fliagreco.com.ar>
20:00:36 <neil> afternoon, folk
20:00:37 <nirik> morning
20:00:52 <tdawson> Hi neil and pgreco
20:00:58 <tdawson> Morning nirik
20:00:58 <jonathanspw> .hi
20:01:01 <zodbot> jonathanspw: jonathanspw 'Jonathan Wright' <jonathan@almalinux.org>
20:01:08 <tdawson> Hi jonathanspw
20:01:13 <jonathanspw> howdy tdawson
20:01:41 <carlwgeorge> .hi
20:01:41 <zodbot> carlwgeorge: carlwgeorge 'Carl George' <carl@redhat.com>
20:02:02 <tdawson> Hi carlwgeorge
20:04:12 <tdawson> That's the problem with everyone gettng here so fast ... it seems like a long time waiting for 5 minutes.
20:05:10 <tdawson> #topic End Of Life (EOL)
20:05:11 <tdawson> RHEL 7 / epel-7 will go EOL on 2024-06-30
20:05:13 <tdawson> https://endoflife.date/rhel
20:05:14 <tdawson> CentOS Stream 8 / epel-8-next goes EOL in 2024-05-31
20:05:16 <tdawson> CentOS Stream 9 / epel-9-next goes EOL in 2027-05-31
20:05:17 <tdawson> https://endoflife.date/centos-stream
20:05:30 <tdawson> #topic EPEL Issues https://pagure.io/epel/issues
20:05:32 <tdawson> https://pagure.io/epel/issues?tags=meeting&status=Open
20:06:03 <tdawson> Lets start with the new issue today
20:06:13 <tdawson> .epel 256
20:06:14 <zodbot> tdawson: Issue #256: Older epel9-next build would shadow newer epel9 build when used as dependency - epel - Pagure.io - https://pagure.io/epel/issue/256
20:06:37 <nirik> yeah, this is just the way it works... perhaps we could document it more?
20:07:04 <tdawson> Yep
20:08:02 <tdawson> I just noticed that michel-slm isn't on yet.
20:08:13 <neil> i think he said he couldn't make it today
20:08:31 <pgreco> I think we should emphasize to untag and not retire, right? in case the "next" is needed in the future
20:08:35 <tdawson> I'm trying to think were to document it best.
20:08:47 <neil> yep -- "Unfortunately I'd have to miss today's meeting - need to take my kid to an appointment "
20:08:55 <tdawson> pgreco: Oh yes ... if you retire something, it's a pain to use it again.
20:10:02 <tdawson> I was thinking of putting something in the FAQ ... cuz I'm not seeing it anyplace.
20:10:30 <carlwgeorge> this came up in the office hours earlier today, and tdawson brought up an important detail.  can regular packagers untag their own builds, or does that require special koji permissions?
20:10:45 <nirik> any regular packager can
20:10:51 <tdawson> neil: Ah, ok.  I thought he was talking about the Office Hours meeting.
20:11:28 <carlwgeorge> nice, so documenting the command to do that is certainly the right path forward
20:11:41 <tdawson> nirik: If any packager can, then I think it might go in a "best practices" area. ... Like carlwgeorge said.
20:11:51 <nirik> and just wait silently until we can retire the next stuff. ;)
20:11:57 <nirik> sure.
20:12:28 <carlwgeorge> we could just stick it at the end of the workflow
20:12:30 <carlwgeorge> https://docs.fedoraproject.org/en-US/epel/epel-about-next/#example_workflow
20:12:34 <nirik> actually tho...
20:12:57 <nirik> it's just got no permission requirement, so anyone can untag... which might be wider than we want...
20:13:15 <tdawson> carlwgeorge: Oh, that's a good place to put it.
20:13:46 <pgreco> nirik: I think anyone can untag their own, not anything, right?
20:13:48 <tdawson> nirik: So ... that means I'm not special. :( ... or yipes ... whichever is the case.
20:14:18 <nirik> anyone can untag anything I think...
20:14:30 <nirik> but perhaps it is owner, would have to dig.
20:14:36 <Son_Goku> .hello ngompa
20:14:37 <zodbot> Son_Goku: ngompa 'Neal Gompa' <ngompa13@gmail.com>
20:14:39 <tdawson> Well ... we won't put that in the documentation .... but we'll just say to untag your own.
20:14:45 <tdawson> Hello Son_Goku
20:15:04 <Son_Goku> i'm pretty sure only releng can untag
20:15:04 <smooge> let the untag wars begin
20:15:08 <rsc> .hello robert
20:15:08 <zodbot> rsc: robert 'Robert Scheck' <redhat@linuxnetz.de>
20:15:19 <Son_Goku> at least I don't think I've been unable to untag before
20:15:22 <rsc> (sorry, I didn't remember that this is not bound to daylight saving)
20:15:33 <Son_Goku> I don't think I've been able to untag before, I mean
20:15:44 <Son_Goku> though I haven't tried recently....
20:15:58 <tdawson> Son_Goku: I'm not in releng, and I do an untagging of all old packages in *-next every six months.
20:16:17 <Son_Goku> don't you own the epel-next tag?
20:16:20 <tdawson> I know I can't do regular epel packages, just -next
20:16:31 <tdawson> Son_Goku: That's sorta what I thought.
20:16:41 <Son_Goku> I'm pretty sure it's tag owner only
20:16:49 <nirik> it per tag permissions...
20:16:52 <Son_Goku> for all tags that's releng, and some tags have other owners
20:17:04 <nirik> you cannot untag things from base fedora tags for example... but... epel9-next was setup more open
20:18:21 <tdawson> Well, I'll just document it as if people can only untag their own.
20:18:41 <tdawson> If it becomes a problem because it's too open ... we'
20:18:49 <tdawson> we'll deal with it then.
20:19:14 <carlwgeorge> the epel10 model can't get here fast enough
20:19:36 <tdawson> I am so looking forward to that.
20:19:55 <neil> hiya rsc, Son_Goku
20:20:21 <tdawson> I'm volunteering to write the documentation for this.
20:21:04 <tdawson> Any other questions and/or comments for this issue?
20:21:41 <tdawson> Moving on to the next issue.
20:21:45 <tdawson> .epel 242
20:21:46 <zodbot> tdawson: Issue #242: Formalizing the EPEL Steering Committee voting process - epel - Pagure.io - https://pagure.io/epel/issue/242
20:22:35 <tdawson> I believe we're just saying ya or commenting on carlwgeorge's pull request ... correct?
20:22:45 <tdawson> https://pagure.io/epel/pull-request/254
20:22:45 <carlwgeorge> seems ready to merge, anyone disagree?
20:22:59 <pgreco> I acked it, I'm good with it
20:23:19 * nirik nods. sure.
20:23:26 <jonathanspw> +1
20:23:37 <tdawson> +1 from me as well.
20:23:59 <smooge> ≠1
20:24:14 <smooge> not sure how I did that
20:24:34 <tdawson> smooge: First, I didn't know that was a thing .... oh ...
20:24:54 <neil> +1 from me, only comment being that i might say, with respect to asking for a pre-meeting vote, that Steering members would _do their best_ to vote, but not explicitly require it.
20:24:56 <smooge> second I can't vote :)
20:24:59 <neil> probably a nit :)
20:25:43 <tdawson> _64.rpm
20:25:45 <tdawson> Resolving www.gamat.io (www.gamat.io)... 13.32.151.96, 13.32.151
20:26:02 <tdawson> OK ... well ... I don't know what that wan
20:26:06 <neil> lol
20:26:22 <jonathanspw> tdawson: you alright?
20:26:32 <tdawson> Sorry ... I was trying to do what smooge did ... but ... as we all know, nobody can duplicate smooge
20:26:58 <neil> :D
20:26:58 <pgreco> no idea how he did that...
20:27:08 <neil> ≠ i did it
20:27:09 <pgreco> I tried almost every combination I could think of  :D
20:27:17 <neil> (copy and paste ;) )
20:27:26 <pgreco> that's cheating!
20:27:28 <smooge> it comes from using a macos box for the meeting.
20:27:41 <smooge> and a wireless PC keyboard
20:28:48 <nirik> ∭1
20:28:48 <neil> apparently if you type 'option + =' on mac, that's what you get. the more you know
20:28:56 <neil> nirik: don't you bring that evil on me
20:29:13 <smooge> triple integrals..
20:29:29 <smooge> anyway.. back to the meeting
20:29:31 <pgreco> ok, in mac is easy
20:29:32 <smooge> and voting
20:29:54 <nirik> This one is even better: ⧤
20:30:06 <tdawson> That's for bringing us back ... it sounds like everyone is good with it.
20:30:32 <neil> yea, i think so tdawson
20:30:59 <tdawson> neil does have a good point ... but I'm thinking it might be best to get this up, and clarify that part with another pull request.
20:31:10 <neil> agreed.
20:31:21 <neil> (that it can wait, not that I have a good point.. i'm not _that_ vain)
20:32:19 <tdawson> #agreed Everyone (both committee members and non-committee members) agreed on carlwgeorge's pull request - https://pagure.io/epel/pull-request/254
20:32:45 <tdawson> carlwgeorge: Thank you for getting that written up, and for the proposal in general.
20:32:47 <carlwgeorge> yipee
20:33:14 <tdawson> Moving on to ...
20:33:24 <tdawson> #topic Old Business
20:33:40 <tdawson> Does anyone have any old business they would like to bring up?
20:34:15 <neil> carlwgeorge++
20:34:36 <carlwgeorge> making progress on my compat devel conflicts pr, keep an eye out for that this week to provide feedback
20:34:40 <tdawson> Are you trying to say that carlwgeorge is old?
20:35:01 <neil> now tdawson's trying to start a fight! i love the chaotic energy
20:35:11 <neil> (and, yes, i was. :) )
20:35:18 <carlwgeorge> hey I don't turn 40 for another two years, then I'll officially be old
20:35:31 <pgreco> oh, shut up!! :D
20:35:45 <tdawson> If that's old ...
20:35:51 <carlwgeorge> hehe
20:36:13 <tdawson> carlwgeorge: Thanks for working on the compat devel stuff also ... I'm glad you had brought it up too.
20:36:14 * neil pats pgreco on the head
20:36:40 <tdawson> Looks like the only old business is old folk ...
20:37:11 * jonathanspw waits for "EPEL7 was retired" to be old business.
20:37:11 <rsc> Is having a new question for EL-7/8 old business?
20:37:20 <tdawson> I noticed the really old people didn't say how old they were ... either it's real restraint, or ...
20:37:29 <pgreco> tail end of 40s here
20:37:33 <tdawson> rsc: How about I just move to Open Floor
20:37:36 <jonathanspw> early 30s here :D
20:37:42 <nirik> all you young folks...sheesh
20:37:45 <tdawson> #topic General Issues / Open Floor
20:37:48 <jonathanspw> but i'm already falling apart physically so...
20:38:05 <smooge> man you all hit all the old jokes without me
20:38:17 <tdawson> rsc: Go for it.
20:38:27 <neil> smooge: that's one, no?
20:38:31 <nirik> I had one small item to note. can go after rsc.
20:38:49 <pgreco> I crashed my ibus trying key combinations, now my keyboard does not type apostrophes anymore....
20:38:59 <smooge> ouch
20:39:09 <rsc> I maintain unrealircd in EPEL (and Fedora). Unfortunately, the latest update depends on a newer pcre version than in RHEL 7 and 8 (requires PCRE2_MATCH_INVALID_UTF). Upstream offers (by default) bundling pcre - is that acceptable for EPEL 7 and 8 in this case?
20:39:47 <jonathanspw> I would think so, that's good justification to bundle IMO
20:39:49 <rsc> (the Fedora guideline says if it can be unbundled, unbundle it)
20:40:09 <rsc> A compat pcre wouldn't work, because of same soname version ;-(
20:40:34 <pgreco> so even unbundlign means special location
20:40:46 <nirik> same soname? :( ugh
20:41:16 <rsc> nirik: pcre2 is lovely. They introduce new features without soname version bumps.
20:41:30 <rsc> Technically not really wrong, but not helpful.
20:42:03 <nirik> :(
20:42:03 <rsc> Okay, but if there are no objections, I'll use the bundled version.
20:42:28 <pgreco> Seems better than the alternative
20:42:29 <nirik> make sure you document in the spec and Provides: bundled() =
20:42:50 <rsc> Indeed.
20:43:19 <tdawson> rsc: Done ?
20:43:22 <rsc> Done, yes.
20:43:25 <rsc> Thank you :)
20:43:28 <tdawson> nirik: Go for it.
20:43:33 <carlwgeorge> i agree that would be good justification for bundling
20:43:38 <neil> makes sense to me rsc
20:43:53 <carlwgeorge> i've actually been contemplating adding some stuff to the epel packaging guidelines that says our stance on bundling is slightly more lenient than fedora's anyways, but it isn't even needed in this case
20:44:09 <nirik> Just a quick note that epel7 in koji was a bit out of date due to some script/content issues. It should be up to date now...
20:44:43 <tdawson> nirik: Meaning the packages in it's buildroot ?
20:45:02 <nirik> yeah. The optional/ha/whatever repos were not updating
20:45:35 <nirik> because a tboot package has contol characters in it, so createrepo_c barfed, and the script didn't do the right thing after that
20:46:01 <tdawson> Someone putting emoji's in package names again?
20:46:04 <nirik> ( https://pagure.io/releng/issue/11751 )
20:46:23 <neil> ask not why some packages have emoji, instead ask why more don't!
20:47:08 <rsc> Looks more like an accident in a description? Because it's a control char?
20:47:13 <nirik> It's a ^S apparently.
20:47:27 <neil> oh, yeah.. i do that sometimes
20:47:48 <neil> ^S in insert mode
20:47:50 <rsc> Maybe RPM should catch that by itself during rpmbuild already?
20:48:02 <neil> decent idea
20:48:20 <rsc> neil: what's the hex code of ^S? Then I would file an issue (except you want)
20:48:21 <nirik> rpm doesn't care.
20:48:27 <tdawson> That, combined with smooge's wierd character ... I'm begining to think I'm missing out on some wierd typing.
20:48:28 <nirik> createrepo_c errors on it.
20:48:36 <neil> 023
20:48:44 <nirik> I asked them about that and they said erroring is all they can do...
20:49:06 <neil> i gues.. rpmlint could care?
20:49:09 <rsc> nirik: yes, that's why I think that future versions of RPM should fail already (during rpmbuild)
20:49:29 <nirik> https://github.com/rpm-software-management/createrepo_c/issues/327
20:49:38 <nirik> sure, might be worth proposing
20:49:43 <pgreco> the thing is that any change in rpm means years until it can be trusted in epel
20:49:47 <smooge> well the issue was that the ^S appeared in a package from 2018
20:49:54 <carlwgeorge> the last tboot rhel7 update was several years ago, odd that it just now caused an issue
20:50:05 <nirik> 2014 actually.
20:50:06 <smooge> because we download the repository from the CDN, that old version was sitting there in the tree
20:50:32 <smooge> so the ^S is in all the later version of the package.
20:50:33 <nirik> anyhow, it should all be working now
20:51:32 <nirik> they actually removed it from the ones after...
20:51:40 <smooge> ah sorry
20:51:49 <smooge> I said that in my head but typed the opposite
20:52:08 * smooge puts his fingers in timeout
20:52:11 <pgreco> For those who are curious on how smooge managed to derail the whole meeting, Ctrl+Shift+U (for unicode char), 2260 <enter>
20:52:12 <carlwgeorge> i wonder if the character was intentional or an unlucky typo
20:52:13 <nirik> anyhow, yeah, I would support erroring on such things.
20:52:13 * smooge typing with nose
20:52:35 <neil> ^S and ^Q are software flow control, iirc
20:52:40 <nirik> it's worse in fedora when autochangelog is in use. ;) Then it really is forever unless you force push
20:53:00 * neil stares at autochangelog
20:53:14 <neil> smooge: don't sneeze
20:53:26 <pgreco> that is a usual problem with automatic changelogs and linters
20:53:36 <pgreco> they end up in an eternal fight
20:54:06 <neil> not to derail this any further, but I suggest we ask rpm team to add support for emoji and deprecate non-emoji package names
20:54:49 <tdawson> I believe emoji is already allowed in package names.
20:55:25 <tdawson> Anyone have anything else before I let this be derailed for the rest of the time?
20:55:54 <carlwgeorge> going off the rails, on a crazy train...
20:56:03 <neil> i have a couple packages that i will be filing stalled epel requests for this week; that's it from me
20:56:06 <pgreco> I think we did as much as we could to use the whole allotted time for today
20:56:17 <nirik> 🚅
20:57:57 <tdawson> Thank you all for comming and thank you for the great discussions.
20:58:11 <neil> thank you for putting up with us (read: me), tdawson
20:58:21 <tdawson> I'll talk to ya'll next week, if not sooner.
20:58:46 <tdawson> neil: Don't worry, I'm hoping by next week you're done with your Halloween candy and settled down a bit. :)
20:59:05 <tdawson> #endmeeting