fedora-server
LOGS
17:00:33 <pboy> #startmeeting fedora-server
17:00:33 <zodbot> Meeting started Wed Sep  6 17:00:33 2023 UTC.
17:00:33 <zodbot> This meeting is logged and archived in a public location.
17:00:33 <zodbot> The chair is pboy. Information about MeetBot at https://fedoraproject.org/wiki/Zodbot#Meeting_Functions.
17:00:33 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
17:00:33 <zodbot> The meeting name has been set to 'fedora-server'
17:00:46 <pboy> #topic Welcome / roll call
17:00:57 <pboy> Welcome to our Server WG IRC meeting today!
17:01:10 <pboy> „Same procedure as every year“ We'll give a few minutes for folks to show up
17:01:36 <eseyman> hello, everybody !
17:01:42 <eseyman> .hello2 eseyman
17:01:43 <zodbot> eseyman: eseyman 'Emmanuel Seyman' <emmanuel@seyman.fr>
17:01:58 <ab> .hello2 abbra
17:01:59 <zodbot> ab: Sorry, but user 'ab' does not exist
17:02:15 <ab> .hello
17:02:15 <zodbot> ab: (hello <an alias, 1 argument>) -- Alias for "hellomynameis $1".
17:02:22 <ab> weird
17:02:24 <jdubby> .hello2 jdubby
17:02:25 <zodbot> jdubby: Sorry, but user 'jdubby' does not exist
17:02:27 <ab> anyway, hello
17:02:37 <jdubby> .hello
17:02:37 <zodbot> jdubby: (hello <an alias, 1 argument>) -- Alias for "hellomynameis $1".
17:02:58 <jdubby> .hello jdubby
17:02:58 <zodbot> jdubby: Sorry, but user 'jdubby' does not exist
17:04:03 <pboy> Zodbot seems to be recalcitrant today.
17:04:09 <pboy> :-)
17:04:52 <pboy> Hello everybody and a big welcome.
17:05:50 <pboy> I had already feared, after the non-regular 3 week break, many would have overlooked this date.
17:05:59 <pboy> OK, thew Agenda
17:06:10 <pboy> #topic Agenda
17:06:23 <pboy> #info  Follow up actions
17:06:35 <pboy> #info  F39 Work Project: Fedora Server on (ARM) SBC
17:06:35 <pboy> #info  Work Project: Using Ansible to install and configure Wildfly
17:06:35 <pboy> #info  Fedora release 39 test planning
17:06:35 <pboy> #info  F39/40 Work Project: Fedora Server in a virtualized runtime environment
17:06:35 <pboy> #info  Open floor
17:06:47 <pboy> Any topic to add?
17:07:16 <pboy> obviously none
17:07:25 <pboy> #topic 1. Follow up actions
17:07:33 <pboy> #action pboy will write a info about changing the timeout value and nirik will review – still work in progress
17:07:42 <pboy> That's finally a running gag. But, good things come to those who wait.
17:08:05 <pboy> Anything to ask or to announce here?
17:08:38 <pboy> OK, next topic
17:08:47 <pboy> #topic 2.  F39 Work Project: Fedora Server on (ARM) SBC
17:08:58 <pboy> #link https://pagure.io/fedora-server/issue/108
17:09:19 <pboy> I had send a summary previously:
17:09:29 <pboy> #link https://lists.fedoraproject.org/archives/list/server@lists.fedoraproject.org/message/B275Q5GOX5FIBDQ464CGSGJXWWEY7NXQ/
17:10:07 <eseyman> I suspect it's time we went to the ARM SIG and asked 'What do you feel comfortable supporting the install on?'
17:10:27 <jdubby> Lots of SBC's with more power than Rpi hitting the market now.  Unfortunately almost none are completely FOSS.
17:11:48 <pboy> jdubby yeah, but a lot of capable alternatives already exist. e.g. by pine64
17:13:14 <pboy> We have a list at
17:13:17 <jdubby> When I get done remodeling a rental property that I own, I will look at purchasing a pine64 or something like that.  The VIM4 looks promising, but not yet supported.
17:13:18 <pboy> #link https://docs.stg.fedoraproject.org/en-US/fedora-server/server-on-sbc/reference-list/
17:14:42 <pboy> eseyman Do you have access to the vim1 you spoke about some weeks ago?
17:15:01 <eseyman> yes, it's still on my 'tech' shelf
17:15:32 <pboy> So you could perform some tests? And provide an installation report / remark?
17:15:42 <eseyman> oh yes
17:16:02 <eseyman> I Can try to do this by next meeting
17:16:05 <pboy> Very good!
17:16:49 <pboy> Propably you can fill in the first line of the table in our stg docs? I have put in all questions marks for now.
17:17:31 <eseyman> yes
17:17:57 <pboy> jdubby ypu may consider  Libre Computer mdel  Roc RK 3399 PC, either original or by firefly
17:18:10 <pboy> It has some advantages over the pine64
17:18:45 <pboy> Pine64 is most interesting with the big case to include to hard disks and to build a home server.
17:18:46 <jdubby> pboy: Thanks
17:19:02 <pboy> to hard -> two hard...
17:19:44 <pboy> It is an ideal candidate for a follow up project "a power efficient home server appliance".
17:20:02 <jdubby> pboy: What is the difference between +1 and +2 in your ARM SBC Devices Rererence List?
17:20:55 <pboy> +2 is "best rated". +1 "Good with some inconveniences"
17:21:05 <jdubby> pboy: Thx
17:22:51 <pboy> The idea is, to comment on the inconveniences in an additional, short profile below the table. See the comments about the Rock Pi 4
17:23:23 <pboy> Well, what to do next?
17:23:38 <pboy> In my email I specified 3 tasks:
17:23:49 <jdubby> If we can find more that are supported, then this looks like a great format.
17:23:52 <pboy> 1.  checking the power consumpption argument
17:23:52 <pboy> 2.  Checking the performance argument:
17:24:05 <pboy> .  checking price argument
17:24:05 <pboy> i.e. make a small market analysis on recommended manufacturer pricing (or large reseller).
17:24:49 <pboy> Can we split this between us?
17:25:09 <pboy> E.G. 2. performance
17:25:12 <eseyman> I really think we need the ARM SIG's input on this
17:25:36 <pboy> eseyman: Yes, probably.
17:26:14 <eseyman> I really can't see us supporting anything they're not OK with
17:26:20 <pboy> eseyman: when I finish my intro text, could you organize to contact ARM Sig?
17:26:30 <eseyman> yes, I can do that
17:26:40 <pboy> eseyman: Out table only consists of device they fully support.
17:27:03 <pboy> Fully support was an initial criteria
17:27:35 <pboy> Well,  so we agree with
17:27:49 <pboy> a) pboy completes the intro text
17:28:06 <pboy> b) eseyman will take over an contact ARM Sig
17:28:15 <pboy> Any onjection?
17:29:04 <pboy> #action pboy will complete the intro text about Fedora Server and ARM SBC
17:29:24 <pboy> #action eseyman will then take over and contact ARM SIG
17:29:49 <pboy> Anything else at the moment?
17:30:16 <eseyman> no, that looks good
17:30:20 <pboy> OK, next topic
17:30:41 <pboy> #topic 3. Work Project: Using Ansible to install and configure Wildfly
17:30:50 <pboy> #link https://pagure.io/fedora-server/issue/60
17:31:01 <pboy> I'm a little uncertain about the state of things. If I remember correctly, it's now about an nginx proxy and the Ansible playbook.
17:31:19 <pboy> Isn't it?
17:31:44 <eseyman> yes
17:32:04 <pboy> ab arn't you involved in the Java app server as tomcat, tomee, etc?
17:32:07 <eseyman> this used to be a hard requirement, I'm not so sure it is these days
17:32:47 <ab> pboy: as a user of Dogtag but I don't do configuration of tomcat there
17:33:15 <ab> dogtag configures tomcat for us
17:34:24 <pboy> Could it help with wildfly, too? (Unfortunately, I don't know dogtag)
17:34:40 <jdubby> Sorry, I had to step away for a moment.
17:34:53 <ab> unlikely, unless you'd extract that logic from dogtag's installer code
17:35:06 <jdubby> If you want to access Wildfly vi port 80, then you need a proxy in front of it.
17:35:30 <ab> yep, in FreeIPA we proxy from apache to dogtag on higher ports
17:36:38 <jdubby> From  an architectural standpoint, do you want the proxy (NGINX) to run on the same host as Wildfly or on a separate host?
17:37:19 <jdubby> Also, can deployments of JEE applications occur from hosts other than local to Wildfly?
17:37:25 <eseyman> in a SOHO or homelab setting, it probably makes sense to run both on the same host
17:38:19 <jdubby> The clients such as JBOSS plugin for maven, JBOSS-CLI, etc ass assume they can address Wildfly via localhost.
17:38:20 <pboy> jdubby ad the former: We should support both
17:39:06 <pboy> Ad the latter: With tomcat you need local access. Im not sure with wildfly
17:39:27 <pboy> I think Wilsdfly's admin supports remote access.
17:39:38 <jdubby> I need to do some more research on how to co configure JBOSS plugin to use something other than localhost.
17:39:43 <pboy> But I'm not sure at the moment. I always use local.
17:40:39 <pboy> Can we determine what to do next?
17:40:54 <jdubby> Wildfly does support remote admin, but I'm not sure what config files need changing to support maven driven app deployments.  I suspect the issue will be the same with Gradle.
17:41:32 <jdubby> I will try to deploy some of the quickstarts via localhost and report at our next meeting.
17:41:47 <pboy> jdubby OK
17:42:24 <pboy> #action jdubby will deploy some of the wildfly quickstarts via localhost and report at our next meeting.
17:42:52 <pboy> Just a question: Is the nginx proxy currently working?
17:44:25 <jdubby> yes
17:44:41 <pboy> OK, thanks.
17:44:53 <pboy> Anything else here?
17:45:32 <pboy> Obviously not, next topic.
17:45:48 <pboy> #topic 4.  Fedora release 39 test planning
17:46:00 <pboy> Change Set: https://fedoraproject.org/wiki/Releases/39/ChangeSet
17:46:12 <pboy> Overview:   https://docs.fedoraproject.org/en-US/releases/f39/
17:46:21 <pboy> No issue created yet.
17:46:32 <pboy> In the short term, I think we need someone to investigate whether any of the changes might affect servers in a way that we need to specifically address.
17:46:44 <ab> We plan a test day for passkey integration in SSSD and FreeIPA in two weeks
17:46:44 <pboy> In the long term, we need someone to look at whether and how we want to systematize beta testing, e.g. with a test week and the corresponding work structures (e.g. https://testdays.fedoraproject.org/events/131 or https://testdays.fedoraproject.org/events/132
17:46:57 <ab> #link https://pagure.io/fedora-qa/issue/747
17:47:36 <ab> test cases are being prepared and all the material for that as well
17:49:02 <jdubby> I seem to recall a discuss on one of the Fedora Mailing Lists about booting and xfs partitions early in the boot/grub phases.  Would that affect us?
17:49:04 <pboy> Oh, interesting!" I hadn't thought of that before!
17:49:29 <pboy> I mean  issue 747
17:50:42 <pboy> ab I guess (hope) you take care ot this?
17:50:56 <pboy> And can we do something?
17:51:19 <ab> this is mostly informational, you are very welcome to participate. At the moment we don't need any help
17:51:45 <pboy> OK, that's good!
17:52:11 <ab> we have all stuff working but I know people tend to find interesting ways of break things ;)
17:52:31 <pboy> Unfortunately, I have a lot Fedora related on my todo list. But I'm interested and will try.
17:54:21 <pboy> ab According to your knowledge, is that the only item  that can affect us? Is there anything else we should be concerned about?
17:55:46 <ab> NetworkManager's profile migration might be disruptive
17:56:21 <pboy> That's another one I didn't notice yet.
17:56:22 <ab> since it affects upgrades (servers are tend to be upgraded from previous Fedora releases) and also ifcfg format is something often used by servers
17:57:39 <ab> there is also fwupda-refresh.timer by default for server edition
17:57:39 <pboy> Is there a 2nd step now? A first step away from sysconfig/network-scripts was with F37 or so. Wasn't it?
17:58:47 <pboy> OK, I see, we should urgently open a mail thread about this!
17:59:05 <pboy> Our time is nearly up, therefore
17:59:26 <pboy> #action pboy will open a mailing list thread about F39 change set.
17:59:35 <ab> I think an action item would be to review changes and come up with a list of those that affect server edition
17:59:44 <ab> exactly
18:00:23 <pboy> #undo
18:00:23 <zodbot> Removing item from minutes: ACTION by pboy at 17:59:26 : pboy will open a mailing list thread about F39 change set.
18:01:01 <pboy> #action pboy will open a mailing list thread about F39 change set to review changes and come up with a list of those that affect server edition
18:01:20 <pboy> ab thanks!
18:01:44 <eseyman> pboy: did you solve your NFS issues?
18:02:17 <pboy> eseyman. unfortunately not, it is still on my todo list.
18:02:32 <pboy> But I could resolve the Perl issue. :-)
18:02:33 <eseyman> ok
18:02:56 <pboy> I skip to Open Floor
18:03:17 <pboy> #topic  5. Open Floor
18:03:36 <pboy> the floor is open. anything to discuss here?
18:04:26 <eseyman> ah, fixing the Perl issue is a good thing. :-)
18:04:38 <eseyman> I'm all topic-ed out
18:05:46 <pboy> OK I think I can close with 5 mins overdraft
18:06:25 <pboy> Thanks everyone for coming!
18:06:35 <pboy> #endmeeting