fedora-server
LOGS
17:00:06 <pboy> #startmeeting fedora-server
17:00:06 <zodbot> Meeting started Wed Aug 16 17:00:06 2023 UTC.
17:00:06 <zodbot> This meeting is logged and archived in a public location.
17:00:06 <zodbot> The chair is pboy. Information about MeetBot at https://fedoraproject.org/wiki/Zodbot#Meeting_Functions.
17:00:06 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
17:00:06 <zodbot> The meeting name has been set to 'fedora-server'
17:00:18 <pboy> #topic Welcome / roll call
17:00:30 <pboy> Welcome to our Server WG IRC meeting today!
17:00:30 <pboy> We have several apologies for today. I guess our group is quite small today. Let's see.
17:00:41 <pboy> „Same procedure as every year“ We'll give a few minutes for folks to show up
17:00:41 <pboy> Please, everybody who is lurking, say either .hello2 or .hello <fasname>
17:01:59 <tflink> .hello2
17:02:00 <zodbot> tflink: tflink 'Tim Flink' <tflink@tirfa.com>
17:02:22 <pboy> Welcome tflink!
17:02:35 * tflink is lurking for a bit, have a conflict at half past
17:02:54 <pboy> Welsome nevertheless!
17:03:11 * nirik is doing some updates, but lurking also
17:03:43 <jwhimpel> .hello2
17:03:44 <zodbot> jwhimpel: jwhimpel 'John Himpel' <john@jlhimpel.net>
17:03:45 <pboy> Seems as if most of our regular members are on vacation or otherwise busy.
17:03:58 <pboy> Hi john!
17:04:48 <jwhimpel> pboy: Greetings!
17:05:09 * pboy wink win
17:05:56 <pboy> I think we should start, nevertheless. Mayb e, swe can talk about what to do.
17:06:12 <pboy> #topic Agenda
17:06:19 <pboy> #info  Follow up actions
17:06:32 <pboy> #info  F39 Work Project: Fedora Server on (ARM) SBC
17:06:32 <pboy> #info  Work Project: Using Ansible to install and configure Wildfly
17:06:32 <pboy> #info  Fedora release 39 test planning
17:06:32 <pboy> #info  F39/40 Work Project: Fedora Server in a virtualized runtime environment
17:06:32 <pboy> #info  Open floor
17:06:43 <pboy> #topic 1. Follow up actions
17:06:56 <pboy> An upcomming running gag here:
17:07:05 <pboy> #action pboy will write a info about changing the timeout value and nirik will review – still work in progress
17:07:20 <nirik> ha.
17:07:28 <pboy> May be I can do that after F39 release. :-)
17:07:39 <pboy> Anythink else here?
17:07:59 <pboy> OK
17:08:01 <pboy> #topic 2.  F39 Work Project: Fedora Server on (ARM) SBC
17:08:32 <pboy> F39 release is approching. We must make some progress here soon.
17:08:44 <pboy> I wrote an email today about it
17:08:53 <pboy> #link https://lists.fedoraproject.org/archives/list/server@lists.fedoraproject.org/message/B275Q5GOX5FIBDQ464CGSGJXWWEY7NXQ/
17:09:23 <pboy> Any comment here today. it is a bit a short notice, yes.
17:09:34 <pboy> But I couldn't do it earlier.
17:10:41 <pboy> jwhimpel>
17:10:43 <jwhimpel> Was there any discussion of SBC servers at Flock?
17:11:10 <pboy> Yes, a short one. Several people were quite interested.
17:11:47 <pboy> I think, you have some experience mit the phronix test sweet.
17:12:05 <pboy> Could yopu take a look into the article I mentioned in my mail?
17:12:18 <pboy> Can we ujse some it it?
17:12:44 <pboy> Would be interesting to replicate an earlier study, even in a short way.
17:13:19 <pboy> the test may be sweet, but I mean suite. :-)
17:13:21 <jwhimpel> I used it quite a while back.  Unfortunately all of my SBC stuff is running Debian because many of the ARM vendors require propriotary modules or patches.
17:13:50 <jwhimpel> I dont have any SBC's that currently run Fedora.
17:13:59 <pboy> What a pitty.
17:14:24 <jwhimpel> I read that the supply of Raspberry Pi's is improving.  But they are not quite powerful enough for what I need.
17:14:52 <pboy> But probbly you can look at the test results in the article and if they are useful und if we can use them?
17:14:53 <jwhimpel> I saw your email regarding VIM4.  But I haven't seen any response yet.
17:15:14 <pboy> jwhimpel unfortunately I got none.
17:15:26 <jwhimpel> I'll look at the article this weekend and let you know late Sunday evening (my time).
17:15:33 <pboy> Usually Peter Robinson is very quick.
17:15:42 <pboy> jwhimpel thanks!
17:16:10 <pboy> Welll, I think we should discuss details on mailing list.
17:16:40 <pboy> I'll write a first draft of a text that describes our intention and findings so far.
17:16:49 <pboy> Should be ready next week, too,
17:16:50 <pboy> .
17:16:57 <jwhimpel> Okay, I'll send my comments there.
17:17:15 <pboy> Good. I' switch
17:17:27 <pboy> #topic 3. Work Project: Using Ansible to install and configure Wildfly
17:18:11 <pboy> tflink I guess, you have to leave soon. Can we answer some questions of yours or provide some information?
17:18:35 <jwhimpel> I've made some progress working with Zuma Farah (T/L at Redhat for JBOSS).
17:18:48 <pboy> Very good!
17:19:01 <jwhimpel> We found that I was not processing some hidden files correctly.
17:19:02 <tflink> I was mostly curious about the SBC plans and where you wanted to go with the testing you mentioned in your email today
17:20:15 <jwhimpel> we fixed those issues, Now it seems as though a wildfly service is not UP.  Will continue to work with Zume to try and resolve.
17:20:56 <pboy> tflink the text will be about our planning. I hore we will publish it in Fedora Magazine and in our Doku. And it is the base of some apps, e.g. a ready tu use clusger monitor, and some other apps, where the SBC is really useful.
17:21:41 <pboy> We will discuss this now regularly on our meetings.
17:22:09 <pboy> And I'll publish the text on my fedora people site and inform on mailing list.
17:22:37 <pboy> Wold be good, it you could tell us your opinion and maybe proposals
17:22:58 <jwhimpel> Paul Whalen seems to run the ARM meetings on IRC.  Perhaps he could give us some suggestions for suitable ARM SBC's to use as a server.
17:24:11 <pboy> jwhimpel yes, Peter Robinson already offered help. But I wanted to gather some information first and start too "stupid". :-)
17:25:06 <jwhimpel> Sounds like you already have a plan.  Let's go with you plan.
17:25:15 <tflink> I don't have much on the SBCs, the ones I've dealt with in the (relatively distant) past have been nothing but a source of frustration so I've avoided them. I keep hoping to find a SBC that doesn't have the usual problems of binary blobs and/or custom kernel patch requirements
17:26:18 <pboy> tflink Icurrently use Radxa Rock Pi 4 and Pine64 RockPro. Both are working fine with Fedora.
17:27:28 <pboy> We have some Doku about it on our doks site
17:27:30 <jwhimpel> Since IBM has acquired Red Hat and now there is a lot of turmoil inside RedHat with people being laid off and people being reassigned and some product support/development being curtailed, I don't feel so good about Fedora support of ARM SBC's.
17:27:34 <pboy> #link https://docs.stg.fedoraproject.org/en-US/fedora-server/server-on-sbc/
17:27:47 <tflink> hopefully things have gotten better. my previous experience was: buy a board, get fedora to run on it, wait a release or two, nobody cares about the board anymore and its no longer supported. but that's pretty unrelated to Fedora Server :)
17:28:53 <eseyman> tflink: that's the default way of doing things in the mobile market (which is mostly ARM), I'm afraid
17:28:58 <pboy> tflink yeah, my experience is if you choose a board where the make is OSS friendly, the support of the board is lasting long.
17:29:28 <pboy> Hi eseyman!
17:29:44 <eseyman> hello, all. I'm here but not here at the same time
17:29:59 <pboy> Well, we are a bit chaotic at the moment. :-)
17:30:22 <pboy> not chaotic, Spontaneous of course
17:30:44 <pboy> how should we proceed?
17:31:08 <pboy> I think, regarding wildfly we have to wait, until the app is working?
17:31:34 <pboy> jwhimnpel maybe we can make a matrix meeting when it works?
17:31:51 <jwhimpel> That would be great!
17:31:52 <pboy> And discuss, how to proceed further abnd how I can hekp?
17:32:13 <pboy> OK. we coordinate as previously.
17:32:39 <pboy> Something about the SBC topic, at the moment?
17:32:55 <pboy> It is the most urgent. F39 is approaching fast.
17:33:22 <pboy> And surprisingly, like every release
17:33:50 <eseyman> Banana Pi seems to be the vendor with the most compatibility, imho
17:34:23 <pboy> Another one is Pine64
17:34:47 <jwhimpel> Can you get "out of the box" Fedora to run on Banana Pi or Pine64?
17:35:04 <pboy> On a Pint64 yes!
17:35:40 <jwhimpel> Does the pine 64 support external disk drives?
17:36:19 <eseyman> the pro board has a PCI slot allowing you to add SATA ports
17:36:24 <pboy> Yes. It has a standard PCI Interface and you cann add a standard board.
17:36:49 <pboy> And the have a box to accomodate disk and board.
17:36:53 <jwhimpel> I'll have to do some research and perhaps spend some money.
17:37:12 <pboy> jwhimpel ++
17:37:22 <jwhimpel> Do either of you have a preferred US vendor?
17:37:39 <pboy> Well, I*m living in Germany. :-)
17:37:44 <eseyman> no (I'm in France)
17:38:27 <jwhimpel> Guess it's time to update my Google Search foo!
17:38:58 <pboy> yes always a dood idea. ;-)
17:39:04 <pboy> Well, i suppose we are done with these topics
17:39:26 <jwhimpel> It's time for me to leave now anyway.  BYE
17:39:34 <eseyman> see you next time, jwhimpel
17:39:44 <pboy> Bye bye jwhimpel
17:39:53 <pboy> #topic 4.  Fedora release 39 test planning
17:40:18 <pboy> I think, we have to check the change proposals as every release.
17:40:39 <pboy> eseyman did you watch  all the proposals?
17:41:40 <eseyman> no
17:42:03 <pboy> From my vague recollection, I don't think there's anything specifically critical.
17:42:32 <pboy> So we should start a discussion on mailing list.
17:43:04 <pboy> OK, next topic
17:43:08 <pboy> topic 5. F39/40 Work Project: Fedora Server in a virtualized runtime environment
17:43:44 <pboy> I had some questions about that on Flock. Many people were looking forward what we will do.
17:44:18 <pboy> But at the moment I made no specific progress.
17:44:54 <pboy> The upcoming task is to prepare a questionaire for our users about it.
17:45:21 <pboy> I hope I can prepare something for our next meeting.
17:46:10 <pboy> I see no futher comment
17:46:24 <pboy> #topic  5. Open Floor
17:46:38 <pboy> Something to discuss here?
17:46:57 <eseyman> I'm good
17:47:21 <pboy> eseyman If I remeber correctly, you are familiar with Perl?
17:47:27 <eseyman> yes, I am
17:47:55 <pboy> I'm struggeling to recover and making work an older Perl bases Website.
17:48:09 <pboy> Can I ask you some questions ny mail in the next days?
17:48:14 <eseyman> of course
17:48:36 <pboy> Thanks! My Pearlö knowledge is quiet doemant
17:49:20 <pboy> If we have nothing else, should we close erarly (first time since I'm a member)
17:50:17 <eseyman> I'm off, regardless. Dinner awaits
17:50:36 <pboy> OK. Thanks to all for coming!
17:50:40 <pboy> #endmeeting