fedora-server
LOGS
17:00:02 <pboy> #startmeeting fedora-server
17:00:02 <zodbot> Meeting started Wed Jun  7 17:00:02 2023 UTC.
17:00:02 <zodbot> This meeting is logged and archived in a public location.
17:00:02 <zodbot> The chair is pboy. Information about MeetBot at https://fedoraproject.org/wiki/Zodbot#Meeting_Functions.
17:00:02 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
17:00:02 <zodbot> The meeting name has been set to 'fedora-server'
17:00:15 <pboy> #topic Welcome / roll call
17:00:21 <eseyman> hello, all
17:00:25 <pboy> Welcome to our Server WG IRC meeting today!
17:00:25 <eseyman> .hello2
17:00:26 <zodbot> eseyman: eseyman 'Emmanuel Seyman' <emmanuel@seyman.fr>
17:00:47 <pboy> Please, everybody who is lurking, say either .hello2 or .hello <fasname>
17:01:07 <pboy> I’ll post the agenda in 4 minutes.
17:01:36 <jwhimpel> .hello2
17:01:37 <zodbot> jwhimpel: jwhimpel 'John Himpel' <john@jlhimpel.net>
17:01:38 <cooltshirtguy> .hello2
17:01:41 <zodbot> cooltshirtguy: cooltshirtguy 'Jason Beard' <jas_beard@hotmail.com>
17:02:57 <cooltshirtguy> lurking. lol I'm on a customer meeting so I might be slower than normal
17:03:42 <pboy> I've a new equipment and it is still a bit uncomfortable. So, welcome. :-)
17:04:07 <pboy> Great, our permanent members almost complete.
17:04:15 <pboy> So legt's start.
17:04:27 <pboy> #topic Agenda
17:04:36 <pboy> #info  Follow up actions
17:04:46 <pboy> #info  F39 Work Project: Fedora Server on (ARM) SBC
17:05:02 <pboy> #info  Using Ansible to install and configure Wildfly
17:05:13 <pboy> #info  F39/40 Work Project: Fedora Server in a virtualized runtime environment
17:05:22 <pboy> #info  Open floor
17:05:29 <pboy> Any additions?
17:05:54 <pboy> Ok, none. next
17:06:02 <eseyman> honestly, that's already an hour's worth of disc.
17:06:14 <pboy> indeed.
17:06:15 <pboy> #topic 1. Follow up actions
17:06:24 <pboy> info ACTION: pboy will write a info about changing the timeout value and nirik will review – still work in progress
17:06:31 <pboy> #info ACTION: pboy will write a info about changing the timeout value and nirik will review – still work in progress
17:06:48 <pboy> #info otherwise no open actions.
17:07:13 <pboy> But some annopuncdements today
17:07:33 <pboy> 1. This year we'll have a in-person Flock again, after 3 years.
17:07:43 <pboy> #link https://flocktofedora.org
17:07:51 <pboy> Aug. 2 - 4 in Cork Ireland.
17:08:01 <pboy> I'll attend, and I hope someone else from us.
17:08:12 <pboy> And wie should consider how to contribute.
17:08:25 <pboy> Any ideas?
17:09:05 <pboy> I think, we should discuss on mailing list and it should be one topic next meeting.
17:09:15 <pboy> 2. I prepared and document how to setup a nfs service.
17:09:24 <pboy> #link https://docs.stg.fedoraproject.org/en-US/fedora-server/services/filesharing-nfs-installation/
17:09:39 <pboy> Unfortunately, it doesn't work as expected, And I don't find my mistake.
17:09:56 <pboy> Therefore, help welcome!
17:10:09 <pboy> Can someone have a look at it?
17:10:46 <eseyman> I can do that
17:10:48 <cooltshirtguy> i'll take a look
17:11:02 <pboy> Thanks, both of you!
17:11:08 <pboy> Next topic
17:11:22 <pboy> #topic 2. F39 Work Project: Fedora Server on (ARM) SBC
17:11:24 <eseyman> sadly, I'm just learning about Flock and I've already planned my vacation trip
17:11:47 <pboy> eseyman freally
17:11:53 <pboy> really a pitty
17:12:11 <pboy> (I still struggle with the keyboard and mouse
17:12:20 <pboy> #link https://pagure.io/fedora-server/issue/108
17:12:25 <eseyman> let me give it some thought about how I can make it work
17:12:46 <pboy> Would be great!!
17:12:58 <pboy> Back to SBC
17:13:14 <pboy> Topics we have to deal with
17:13:14 <pboy> - Discussion of the working plan
17:13:24 <pboy> * For reference list:
17:13:25 <pboy> - What other SBC equipment do we have available
17:13:25 <pboy> - Discussion of the criteria
17:13:34 <pboy> * Evaluation study
17:13:34 <pboy> - Discussion of the content plan
17:13:34 <pboy> - Who can contribute to which section
17:13:50 <pboy> Let's start with the first. (working plan)
17:15:03 <eseyman> select a list of SBC that will be vetted
17:15:15 <eseyman> RPi4 should be on the list
17:15:41 <jwhimpel> I see the CEO is promising the supply chain issues with Rpi 4 will ease significantly this fall and be a thing of the past by 4Q 2023.
17:15:53 <eseyman> yes, saw that too
17:15:55 <cooltshirtguy> I dont't have anything else except Pi's
17:16:15 <jwhimpel> I think detailed installation instructions and list of supported H/W would be a good start.
17:17:16 <eseyman> both the Banana Pi and the Vim are more appealing than RPi to me but YMVV
17:17:22 <pboy> Yes, when we have agreed about the reference list project, we should as the ARM Sig for proposal and comments.
17:17:54 <pboy> eseyman Yeah, the RPi is missing a fast internal disk.
17:18:25 <pboy> Neverthe less, the RPi is important. It has the role of a reference device
17:19:26 <pboy> And, BTW I made contact to several makers. Hopefully, we get 1 or 2 test devices.
17:19:28 <eseyman> agreed
17:21:11 <jwhimpel> The VIM stuff looks promising.  Do you have detailed installation instructions for them?
17:21:46 <pboy> jwhimpel no, not yet. they are quite expensive in Germany
17:21:55 <pboy> But it is one of my contacts.
17:21:58 <eseyman> jwhimpel: https://forum.khadas.com/t/how-to-install-fedora-linux-for-any-khadas-sbc/13323
17:22:24 <jwhimpel> esseyman: How about you for detailed install instructions?
17:22:28 <pboy> eseyman ++1  Didn't found that yet
17:23:16 <jwhimpel> esseyman: Thanks
17:23:27 <eseyman> I'm waiting on a VIM 3. Once I have it, I'm installing Fedora on my VIM 1
17:23:58 <pboy> The relative silence I interpret that we agree on the part 1 (reference list)?
17:24:08 <pboy> Objections?
17:24:35 <eseyman> nope
17:24:53 <pboy> OK, then:
17:24:56 <jwhimpel> No objections here.
17:25:19 <pboy> #agreed The WG agrees on part 1 of the plan in issue 108 and will create a reference list.
17:25:53 <pboy> I'll start a comment with a list, who has what device available.
17:26:24 <pboy> And as soon as I get positive feedback from a maker, I'll contact our group via email.
17:26:34 <eseyman> I've sent my list to the ml
17:26:51 <pboy> s/feddback/decision/
17:27:01 <pboy> eseyman. yes.
17:27:38 <pboy> OK, next part, the evaluation.
17:28:24 <pboy> Any comment?
17:28:53 <eseyman> I'm more worried about the criteria, TBH
17:29:19 <pboy> which criteria? freference list or evaluation?
17:29:35 <eseyman> the evaluation criteria
17:30:36 <pboy> Yeah. I think the 3 basic assumptions are quite virulent, aren't they?
17:30:54 <pboy> But empirical evidence is sparse
17:31:30 <pboy> Do you think of something else or additional? or replace?
17:32:14 <eseyman> performance is subjectif; economy of power is hard to measure, ...
17:32:51 <pboy> eseyman agreed, but everybody talks about it, nevertheless
17:33:06 <eseyman> yeah, I know...
17:33:56 <pboy> Regarding performance, instead of artifical numeric indices we could compare 1-3 typical server tasks.
17:34:14 <pboy> That would not be representative, and not scientifical.
17:34:45 <pboy> but maybe interesting and meaningful
17:35:24 <jwhimpel> Phoronix has a pretty extensive test suite that is open-source.  I know many tests are video oriented, but a bunch are apropos for server tasks.
17:35:39 <eseyman> Sorry, I need to think about it
17:35:58 <pboy> jwhimpel great! could you post a link on ml?
17:36:12 <jwhimpel> pboy: sure
17:36:24 <pboy> eseyman no problem. it is not easy, and we should carefully think about it.
17:36:46 <pboy> But: we need to pick the next topic!
17:37:01 <pboy> Let's try the ml regarding the evaluation.
17:37:29 <pboy> eseyman: maybe you can write some (temptative) ideas?
17:37:46 <eseyman> I'll give it a shot
17:37:53 <pboy> Thanks!
17:38:25 <pboy> In any case, the topic is generating a lot of interest. It is therefore worthwhile.
17:38:38 <pboy> Let's swith to next topic
17:38:54 <pboy> #topic 3. Using Ansible to install and configure Wildfly
17:39:05 <pboy> #link https://pagure.io/fedora-server/issue/60
17:39:54 <pboy> As far as I know we have a working Wildfly and at least a part of Ansible scripts.
17:40:12 <pboy> jwhimpel: Could you provide some info?
17:40:23 <pboy> Would is the next reaquired step?
17:40:31 <jwhimpel> I have been consumed by a higher priority task, so I haven't made much progress.  I think I found a network config error that prevented me from getting SSL working when communicating with Wildfly.  Hope to get back to this in July.
17:41:08 <pboy> OK. Do you propse to postpone until July?
17:41:19 <pboy> Would be no prob I think
17:41:44 <jwhimpel> If anyone want to help see: https://developer.jboss.org/people/fjuma/blog/2018/08/31/obtaining-certificates-from-lets-encrypt-using-the-wildfly-cli
17:42:34 <jwhimpel> We have the working Wildfly instance on the VM that pboy created for us.  You can use that for testing purposes.
17:42:36 <jwhimpel> I
17:42:49 <jwhimpel> I'm find with a postponement.
17:42:57 <jwhimpel> s/find/fine/
17:43:18 <pboy> OK. I'll check the blog entry.
17:43:32 <pboy> Question: Can I find the Ansiblescript anywhere in
17:43:37 <pboy> on the server?
17:44:54 <jwhimpel> I think the M/L has a pointer to the ansible stuff.  You should be able to find the reference in the M/L archives.  If not, ping me.
17:45:08 <pboy> OK thanks.
17:45:32 <eseyman> this, maybe : https://gitlab.com/jwhimpel/wildfly-ansible ?
17:45:48 <pboy> I'll ask my trustworthy search tengine. :-)
17:46:06 <pboy> Yeah thanks, I'll have a look.
17:46:26 <pboy> So, let's switch to the next topic.
17:46:43 <pboy> #topic 4. F39/40 Work Project: Fedora Server in a virtualized runtime environment
17:46:53 <pboy> #link https://pagure.io/fedora-server/issue/110
17:46:56 <jwhimpel> That url looks right.  I'm away from my workstation right now, so cannot verify.
17:47:18 <pboy> This plan got some attention, too
17:47:35 <pboy> jwhimnpol thanks. I'll try or ask you by mail.
17:47:47 <pboy> Sorry, again a typo
17:48:30 <pboy> We should discuss the provisional working plan, here
17:49:14 <eseyman> I don't use a VPS/VDS so I don't think I'll be able to contribute
17:49:29 <eseyman> I'm going to focus on the backup plan
17:49:56 <pboy> eseyman OK
17:50:09 <jwhimpel> Is the only difference between this effort and Fedora Cloud, the packages that are included?
17:51:14 <pboy> There are several difference with the preinstalled packages, the file system, and the purpose of the use, I think
17:51:57 <pboy> I had several discussions with several people on ask.fedora and discussion.
17:52:01 <pboy> May
17:52:20 <jwhimpel> Certainly, the difference is purpose of use.  I just was wondering if we could generate appropriate images using their tooling with a different package list?
17:53:18 <pboy> My first idea is, tp pick our KVM image and add some hoster specific configuration / packages, etc
17:53:47 <pboy> One isue is abviously the first boot
17:55:12 <pboy> Our time is running up.
17:55:16 <cooltshirtguy> I have fedora-server running on a computer utilizing KVM and run mutliple VM's. does that meet the requirements? or help?
17:56:35 <pboy> cooltshirtguy  not directly. Your case seems to be the same as mine. :-). The people I discussed don't have a machine of their own on the internet.
17:56:55 <cooltshirtguy> ahh ok.
17:57:02 <cooltshirtguy> wasn't sure of the direction here
17:57:36 <pboy> They are looking for a  affordable machine, to kind of "simulate" their own machine using the hosting provider as "hardware"
17:58:03 <cooltshirtguy> ahh. so cloud stuff
17:58:11 <pboy> So it is intended to be permanent and with fixed resources.
17:58:33 <jwhimpel> Does the provider have a pre-installed O/S when a new VPS is created or is that up the purchaser of the VPS?
17:58:51 <pboy> Well. cloud is a bit ambigious
17:59:26 <pboy> jwhimpel several options. Some provide just a empty pre-installed VM, Other accept a 'custom image'
17:59:50 <pboy> and the latter is the particulary interesting case here
18:00:28 <jwhimpel> Have to leave now.
18:01:02 <pboy> Regarding cloud statt:  That means originally "resources on demand". You don't have fixed resources and pay, but that<#s vafriable and you just pay what you use.
18:01:39 <pboy> and he cloud system interacts with the cloud instances to make it work.
18:02:17 <pboy> But some people use cloud for anything that is not running on their own hardware
18:02:31 <cooltshirtguy> interesting. I've vaguely heard of it but never looked into it
18:02:46 <pboy> Well time is up.
18:03:23 <pboy> For practical reason: Any objection to perform the community survey as discussed on mailing list?
18:03:57 <cooltshirtguy> nope
18:04:02 <pboy> OK
18:04:28 <pboy> #agreed WG will perform the community survey as proposed in #110
18:04:44 <pboy> So, let's continue on mailing list.
18:05:00 <pboy> Thanks everybody for coming!
18:05:16 <pboy> See you in 2 weeks.
18:05:23 <eseyman> bye, folks
18:05:42 <pboy> #endmeeting