eln
LOGS
17:02:30 <sgallagh> #startmeeting ELN (2023-03-10)
17:02:30 <zodbot> Meeting started Fri Mar 10 17:02:30 2023 UTC.
17:02:30 <zodbot> This meeting is logged and archived in a public location.
17:02:30 <zodbot> The chair is sgallagh. Information about MeetBot at https://fedoraproject.org/wiki/Zodbot#Meeting_Functions.
17:02:30 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
17:02:30 <zodbot> The meeting name has been set to 'eln_(2023-03-10)'
17:02:30 <sgallagh> #meetingname eln
17:02:30 <zodbot> The meeting name has been set to 'eln'
17:02:30 <sgallagh> #topic init process
17:02:30 <sgallagh> .hi
17:02:31 <zodbot> sgallagh: sgallagh 'Stephen Gallagher' <sgallagh@redhat.com>
17:03:15 <jforbes> morning
17:03:29 <bstinson> .hello bstinson
17:03:30 <zodbot> bstinson: bstinson 'Brian Stinson' <brian@bstinson.com>
17:04:30 <tdawson> Hello
17:06:51 <sgallagh> #topic Agenda
17:07:21 <sgallagh> I have one item for the agenda today: x86_64-v3 as the architecture baseline for RHEL 10
17:07:21 <sgallagh> Does anyone else have a topic they'd like to discuss today?
17:07:35 <davide> Michel and I are at SCALE
17:08:50 <sgallagh> Davide Cavalca: Is that a topic, or just a statement?
17:09:54 <sgallagh> I'll assume the latter, then
17:09:59 <bstinson> sgallagh mentioned that my announcement might have gone to moderation on fedora-devel
17:10:11 <bstinson> while i work on fixing that, we also cross-posted to centos-devel: https://lists.centos.org/pipermail/centos-devel/2023-March/142814.html
17:10:17 <sgallagh> #topic x86_64-v3 as the architecture baseline for RHEL 10
17:11:00 <davide> Just a heads up that we'll be sporadic
17:11:06 <sgallagh> Roger, got it
17:11:35 <sgallagh> So, this is more of an announcement than it is a discussion topic.
17:11:38 <jforbes> The new baseline shouldn't be too problematic
17:12:38 <tdawson> I understand this will impact installations.  But will it also impact some package builds at all?
17:12:43 <sgallagh> Essentially, Red Hat has decided that v3 will be the baseline for RHEL 10, so in order to remain in sync with them, ELN will be making this switch soon.
17:13:06 <sgallagh> tdawson: There are only two ways that could happen:
17:13:30 <sgallagh> 1) There's a compiler bug, which we report and have fixed by the tools team.
17:13:53 <sgallagh> 2) We attempt to build on incompatible hardware.
17:14:25 <sgallagh> I'm pretty sure we've already confirmed that all of the Koji builders are running v3-compatible processors, so 2) should not be a concern.
17:14:26 <tdawson> I believe I saw conversations about checking the hardware.  So I assume we're good on that part?
17:14:41 <fweimer> 3) some code gets selected by the changed build flags that hasn't been built before and it has bugs.
17:15:00 <fweimer> Hardware is good, unless it's been downgraded recently.
17:15:02 <bstinson> the infrastructure is ready for this baseline
17:15:09 <tdawson> So, it sounds like, unless there are bugs, it shouldn't affect package builds.
17:15:15 * nirik checked. all x86_64 builders are fine... even with v4. ;)
17:15:24 <sgallagh> fweimer: Ah, I didn't consider that. Thanks.
17:15:48 <smooge> I was going to say 'go to v4, go to v4.. get ahead of the game'
17:16:08 <sgallagh> NO
17:16:22 <AhmedA> Is 4 not supported by many apps yet?
17:16:54 <bstinson> v4 is not on our radar at all for this cycle
17:16:59 <sgallagh> #link https://src.fedoraproject.org/rpms/redhat-rpm-config/pull-request/247
17:17:18 <sgallagh> FYI, ^^ is the merge request to change that baseline
17:18:09 <jforbes> If it is really worthwhile, V4 could be supported by hwcaps
17:18:28 <sgallagh> So we have two questions to answer here today.
17:18:55 <sgallagh> 1) The ELN SIG needs to formally approve this baseline and record the decision so we can land that merge request.
17:19:41 <sgallagh> 2) We need to decide if we want to do a mass-rebuild to pick up the changes or wait until the F39 mass-rebuild does it in the meantime.
17:19:52 <sgallagh> s/)/./, s/in the meantime//
17:20:23 <sgallagh> The first question is basically a rubber-stamp, since this decision isn't really ours.
17:20:47 <tdawson> I'll give it a +1 though, so there is some type of vote.
17:20:49 <jforbes> I don't know that an additional mass rebuild is needed. F39 will force it
17:20:50 <sgallagh> Does anyone want to go on record that this is a terrible, horrible, no-good, very bad idea?
17:21:17 <jforbes> I am all for it. +1 from me
17:21:17 <smooge> this is a good idea
17:21:33 <smooge> i for one welcome our new v3 masters
17:21:34 <AhmedA> I think mass rebuild can wait to F39
17:22:15 <sgallagh> fweimer: I assume that there's no issue with a mixture of v2 and v3 in the repo for a time?
17:22:19 <AhmedA> My hardware supports x86-64v3 and v4
17:22:21 <tdawson> I agree that mass rebuild can wait.   I would want a small rebuild, like the compilers and such, but I suspect they will get rebuild plenty before then anyway.
17:22:30 <fweimer> sgallagh: No, absolutely not.  Not even a performance issue.
17:22:39 <sgallagh> Perfect
17:22:41 <AhmedA> So I think it is okay
17:22:43 <fweimer> (except bugs of course)
17:22:54 <danpb> FYI,  QEMU upstream has had a bunch of work to close the emulation gaps, so QEMU 8.0 TCG should work with x86_64-v3
17:22:57 <smooge> I was wondering.. is there a way to have koschei do scratch builds of all the ELN packages before an official mass-rebuild to see if something blows up
17:23:11 <sgallagh> danpb: That's good to hear
17:23:30 <danpb> in fact qemu 7.2 should work too modolo some small bugs that need patching
17:24:28 <sgallagh> That's emulation, not virtualization, correct?
17:24:41 <danpb> yep
17:24:52 <sgallagh> Virtualization should be fine with CPU pass-through
17:25:09 <danpb> if you're using KVM you merely need suitably new hardware
17:25:36 <sgallagh> Right
17:25:37 <danpb> but some apps (notably libguestfs) do run tests in koji with QEMU emulation
17:25:50 <danpb> so its important for emulation to support it too
17:25:57 <sgallagh> OK, that's going to be something to watch out for, then
17:26:03 <sgallagh> Thanks for the heads-up
17:26:54 <sgallagh> #info QEMU 7.2+ should be able to emulate x86_64-v3 hardware, but may have bugs to watch out for. Some packages like libguestfs have tests that rely on emulated CPUs and may be affected by this change.
17:26:59 <sgallagh> (Accurate?)
17:27:40 <fweimer> sgallagh: Seems about right.
17:27:51 <sgallagh> OK
17:28:12 <fweimer> We even rebuilt Fedora with x86-64-v3 flags and booted it with QEMU TCG.
17:28:35 <sgallagh> #agreed The ELN SIG approves the change of baseline to x86_65-v3
17:28:46 <sgallagh> And I think we have consensus that we don't need to perform a mass-rebuild for this.
17:29:13 <sgallagh> Anyone want to disagree?
17:29:19 <smooge> not i
17:29:36 <sgallagh> OK, anyone want to dsagree?
17:30:16 <smooge> nt i
17:30:29 <bstinson> i'm happy
17:30:36 <sgallagh> #agreed No mass-rebuild is required immediately for this change. It can wait until the Fedora 39 scheduled rebuild.
17:30:59 <sgallagh> #topic Open Floor
17:31:21 <sgallagh> That was the only item on the agenda. Does anyone have additional thoughts?
17:31:50 <sgallagh> Oh, actually I have one thing.
17:32:00 <smooge> steve jobs moment?
17:32:25 <sgallagh> I'm going to be unavailable for the 2023-03-24 meeting. Would someone else be willing to volunteer to chair the meeting in my absence?
17:33:41 <sgallagh> OK, I'll take that as "let's cancel" then
17:34:00 <sgallagh> #info There will be no meeting on 2023-03-24
17:34:17 <sgallagh> fweimer: Shall we plan to land the redhat-rpm-config change on Monday?
17:34:29 <sgallagh> I'll respond to the MR with the official decision by the SIG
17:35:03 <fweimer> sgallagh: Yes, sounds good.
17:35:06 <smooge> sorry i usually have a conflicting meeting or I would do so
17:35:28 <fweimer> sgallagh: Somewhere I've got a companion patch for gcc.
17:36:06 <sgallagh> #action sgallagh and fweimer to land the baseline change on Monday, 2023-03-13.
17:36:06 <fweimer> We should also consider rebuilding a few packages early, e.g., libtool.
17:36:11 <sgallagh> ack
17:36:12 <fweimer> Because they embed the build flags.
17:37:01 <sgallagh> Python as well, IIRC
17:37:01 <sgallagh> (for native modules)
17:38:53 <sgallagh> Alright, I think we're done here. Thanks for coming, folks!
17:39:23 <sgallagh> #endmeeting